source: projects/specs/branches/6/g/gnuplot/gnuplot-vl.spec @ 3714

Revision 3714, 6.5 KB checked in by inagaki, 13 years ago (diff)

update: gnuplot

Line 
1%define gpmainver 4.4
2%define gpver %{gpmainver}.3
3
4Summary: A program for plotting mathematical expressions and data.
5Summary(ja):  数学系の関数やデータのプロット・プログラム
6Name: gnuplot
7Version: %{gpver}
8Release: 1%{?_dist_release}
9
10License: gnuplot and GPLv2
11Group: Applications/Engineering
12URL: http://gnuplot.sourceforge.net/
13
14Source: http://prdownloads.sourceforge.net/gnuplot/gnuplot-%{version}.tar.gz
15
16BuildRoot: %{_tmppath}/%{name}-root
17BuildRequires: gd-devel >= 2.0.27, libpng-devel, zlib-devel
18BuildRequires: libX11-devel, libXt-devel, wx-gtk2-devel
19BuildRequires: readline-devel
20BuildRequires: lua-devel cairo-devel pango-devel
21
22BuildRequires: texlive
23BuildRequires: texlive-collection-latexextra
24BuildRequires: texinfo, emacsen
25Requires(post): install-info
26Requires(preun): install-info
27
28Vendor: Project Vine
29Distribution: Vine Linux
30Packager: daisuke, inagaki
31
32%description
33Gnuplot is a command-line driven, interactive function plotting
34program especially suited for scientific data representation.  Gnuplot
35can be used to plot functions and data points in both two and three
36dimensions and in many different formats.
37
38Install gnuplot if you need a graphics package for scientific data
39representation.
40
41%description -l ja
42Gnuplotはとりわけ科学データ・プレゼンテーションに適した、コマンド
43操作によるインタラクティブな関数プロット・プログラムです。
44Gnuplotは関数や座標データを同時にプロットしたり、3次元化やさまざ
45まな形式で表現するのに利用することができます。
46
47科学データプレゼンテーション用のグラフィック・パッケージが必要な
48場合、gnuplotをインストールしてください。
49
50%prep
51%setup -q
52
53%build
54#autoreconf -f -i
55%ifarch alpha
56%define optflags -O0
57%endif
58%configure --with-readline=gnu --with-png --without-linux-vga --enable-history-file
59
60make %{?_smp_mflags}
61
62
63%install
64rm -rf $RPM_BUILD_ROOT
65make install DESTDIR=$RPM_BUILD_ROOT
66
67rm -f demo/Makefile* tutorial/Makefile*
68
69# move app-dafaults to %%_datadir
70#mv $RPM_BUILD_ROOT%{_libdir}/X11 $RPM_BUILD_ROOT%{_datadir}/
71
72# move texmf config
73mv $RPM_BUILD_ROOT%{_datadir}/texmf-local $RPM_BUILD_ROOT%{_datadir}/texmf
74
75# remove unneeded files
76rm -f $RPM_BUILD_ROOT%{_infodir}/dir
77
78%clean
79rm -rf $RPM_BUILD_ROOT
80
81%post
82/sbin/install-info --quiet --info-dir=%{_infodir} %{_infodir}/gnuplot.info.gz
83
84%preun
85if [ $1 = 0 ]; then
86    /sbin/install-info --quiet --info-dir=%{_infodir} \
87        --delete %{_infodir}/gnuplot.info.gz
88fi
89
90%files
91%defattr(-,root,root)
92%doc demo tutorial
93%doc README README.1ST INSTALL Copyright TODO
94%doc PATCHLEVEL VERSION BUGS ChangeLog
95%{_bindir}/gnuplot
96%{_libexecdir}/gnuplot/%{gpmainver}/*
97%{_datadir}/gnuplot/%{gpmainver}/*
98#{_datadir}/X11/app-defaults/Gnuplot
99%{_datadir}/texmf/tex/latex/gnuplot
100%{_datadir}/emacs/site-lisp/*
101%{_infodir}/gnuplot.info*
102%{_mandir}/man1/gnuplot.*
103
104%changelog
105* Sat Apr 16 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.3-1
106- update to gnuplot-4.4.3
107- use BR: texlive instead of tetex
108
109* Sun May 31 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 4.2.5-1
110- update to gnuplot-4.2.5
111- drop plus patch (merged in upstream)
112- update URL: to new upstream homepage
113- fix License:
114- build with wxGTK
115- add BR: libX11-devel, libXt-devel, wx-gtk2-devel
116
117* Sat Aug 16 2008 Shu KONNO <owa@bg.wakwak.com> 4.0.0-1vl5
118- applied new versioning policy, spec in utf-8
119
120* Tue Aug 22 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 4.0.0-0vl6
121- add BuildRequires: texinfo, emacsen
122
123* Sun Mar 19 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 4.0.0-0vl5
124- rebuild with readline-5.1
125
126* Wed Jun 15 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 4.0.0-0vl4
127- update Patch0 to fix 'Invalid char in eps file'
128  (thanks to HANAWA Toshihiro)
129- add BuildRequires: autoconf, automake
130
131* Sat Nov 20 2004 Satoshi MACHINO <machino@vinelinux.org> 4.0.0-0vl2
132- enabled history-file
133
134* Wed Jul 14 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 4.0.0-0vl1
135- source update
136
137* Wed Jul 14 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 3.8k.3-0vl1
138- source update
139- patch update and modified
140- add info
141
142* Wed Mar 10 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 3.7.3-2vl3
143- rebuild
144- fix license
145- remove -DUSE_SYSTEM_TIME ([VinePlus:01805])
146
147* Wed Apr 02 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 3.7.3-2vl2
148- rebuild with readline-4.3
149
150* Thu Feb 20 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 3.7.3-2vl1
151- syncd with RH 3.7.3-2
152- modified Yamaga-san's gnuplot3.7.2+1.2.0rc2.patch for 3.7.3
153
154* Fri Jan 25 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 16vl1
155- added pathes (patch1,2) from RH
156
157* Sat Aug 25 2001 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 12vl1
158- syncd rawhide
159- updated to 3.7.1-1.2.0
160
161* Mon Jun  5 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
162- updated to 3.7.1
163- updated gnuplot+ patch to 1.1.9 for gnuplot 3.7.1.
164- remake SPEC from rawhide.
165
166* Fri May 19 2000 Nalin Dahyabhai <nalin@redhat.com>
167- rebuild with new gd, changing gif terminal to jpeg terminal (release 7)
168
169* Mon May 08 2000 Preston Brown <pbrown@redhat.com>
170- build for 7.0
171
172* Thu Apr  6 2000 Bill Nottingham <notting@redhat.com>
173- use gnu readline, not built-in version
174
175* Mon Apr  3 2000 Bill Nottingham <notting@redhat.com>
176- add latex tutorial, demo files, other docs (#10508)
177
178* Wed Mar  1 2000 Bill Nottingham <notting@redhat.com>
179- update to 3.7.1. Oops.
180
181* Thu Feb  3 2000 Bill Nottingham <notting@redhat.com>
182- handle compressed man pages
183
184* Thu Nov  4 1999 Bill Nottingham <notting@redhat.com>
185- update to 3.7.1
186
187* Mon Oct 11 1999 Bill Nottingham <notting@redhat.com>
188- ship some docs.
189
190* Wed Aug 18 1999 Bill Nottingham <notting@redhat.com>
191- add a patch to fix postscript output from Bernd Kischnick
192 (kisch@die-herrmanns.de)
193
194* Fri Jul 30 1999 Bill Nottingham <notting@redhat.com>
195- fix license
196
197* Thu Jul 15 1999 Bill Nottingham <notting@redhat.com>
198- rebuild without svgalib
199
200* Tue Jun 15 1999 Bill Nottingham <notting@redhat.com>
201- update to 3.7.0.1
202
203* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
204- auto rebuild in the new build environment (release 2)
205
206* Tue Feb  2 1999 Jeff Johnson <jbj@redhat.com>
207- update to 3.7.
208
209* Thu Dec 17 1998 Michael Maher <mike@redhat.com>
210- built package for 6.0
211
212* Fri Sep 11 1998 Jeff Johnson <jbj@redhat.com>
213- update to 2.6beta347
214
215* Sat Aug 15 1998 Jeff Johnson <jbj@redhat.com>
216- build root
217
218* Thu May 07 1998 Prospector System <bugs@redhat.com>
219- translations modified for de, fr, tr
220
221* Mon Oct 20 1997 Donnie Barnes <djb@redhat.com>
222- spec file cleanups
223
224* Thu Jul 10 1997 Erik Troan <ewt@redhat.com>
225- built against glibc
Note: See TracBrowser for help on using the repository browser.