source: projects/specs/branches/6/g/gnupg/gnupg-vl.spec @ 8027

Revision 8027, 9.4 KB checked in by iwamoto, 11 years ago (diff)

gnupg: security fixes

Line 
1Summary: A GNU utility for secure communication and data storage.
2Summary(ja): GNU 版の RFC2440 (OpenPGP) 公開鍵暗号プログラム
3Name: gnupg
4Version: 1.4.15
5Release: 2%{?_dist_release}
6License: GPL
7Group: Applications/System
8Source0: ftp://ftp.gnupg.org/gcrypt/gnupg/gnupg-%{version}.tar.bz2
9Source1: ftp://ftp.gnupg.org/gcrypt/gnupg/gnupg-%{version}.tar.bz2.sig
10Source2: gnupg-1.4.11-1_ja.po
11
12URL: http://www.gnupg.org/
13
14Vendor: Project Vine
15Distribution: Vine Linux
16Packager: daisuke, iwaim, shaolin
17
18BuildRoot: %{_tmppath}/%{name}-%{version}-root
19
20Provides: gpg, openpgp
21Requires(post): install-info
22Requires(preun): install-info
23
24BuildRequires: autoconf
25BuildRequires: zlib-devel, bzip2-devel
26BuildRequires: openldap-devel
27BuildRequires: libusb-devel
28BuildRequires: readline-devel
29
30%description
31GnuPG (GNU Privacy Guard) is a GNU utility for encrypting data and
32creating digital signatures. GnuPG has advanced key management
33capabilities and is compliant with the proposed OpenPGP Internet
34standard described in RFC2440. Since GnuPG does not use any patented
35algorithm, it is not compatible with any version of PGP2 (PGP2.x uses
36only IDEA for symmetric-key encryption, which is patented worldwide).
37
38%description -l ja
39GnuPG (GNU プライバシーガード) は、データを暗号化したりデジタル署名を
40作成したりする GNU ユーティリティです。GnuPG は優れた鍵管理機能を有し、
41RFC2440 に規定された OpenPGP 規格に準拠しています。GnuPG は特許化された
42アルゴリズムを一切用いていないので、何の制限もなく使用することが出来ま
43すが、全てのバージョンの PGP2 とは互換性がありません。(PGP2.x は世界
44中で特許化されている IDEA を対称暗合鍵のために用います。)
45
46%prep
47%setup -q
48
49mv po/ja.po po/ja.po.orig
50cp -f %{SOURCE2} po/ja.po
51autoreconf
52
53%build
54%configure --enable-shared \
55           --enable-ldap --disable-mailto \
56           --without-libcurl \
57           --program-transform-name='' \
58           --program-prefix='' \
59           --program-suffix='' \
60           --libexecdir=%{_libdir}
61
62make %{?_smp_mflags}
63(cd po; make ja.gmo)
64make check
65
66%install
67rm -rf $RPM_BUILD_ROOT
68%makeinstall libexecdir=%{buildroot}%{_libdir}
69# install -m644 doc/gpg.info doc/gpgv.info $RPM_BUILD_ROOT/%{_infodir}
70install -m644 doc/gnupg1.info $RPM_BUILD_ROOT/%{_infodir}
71sed 's^\.\./g[0-9\.]*/^^g' tools/lspgpot > lspgpot
72install -m755 lspgpot $RPM_BUILD_ROOT%{_bindir}/lspgpot
73rm -f $RPM_BUILD_ROOT/%{_infodir}/dir
74%find_lang %name
75
76%clean
77rm -rf $RPM_BUILD_ROOT
78
79
80%post
81if test -s %{_infodir}/gnupg1.info.gz ; then
82    /sbin/install-info %{_infodir}/gnupg1.info.gz %{_infodir}/dir 2> /dev/null
83fi
84if ! test -s %{_infodir}/gpg.info.gz ; then
85    /sbin/install-info --delete %{_infodir}/gpg.info.gz %{_infodir}/dir 2> /dev/null
86fi
87if ! test -s %{_infodir}/gpgv.info.gz ; then
88    /sbin/install-info --delete %{_infodir}/gpgv.info.gz %{_infodir}/dir 2> /dev/null
89fi
90exit 0
91
92%preun
93if [ $1 = 0 ]; then
94    /sbin/install-info --delete %{_infodir}/gpgv.info.gz %{_infodir}/dir
95    /sbin/install-info --delete %{_infodir}/gpg.info.gz %{_infodir}/dir
96fi
97
98
99%files -f %{name}.lang
100%defattr(-,root,root)
101%doc AUTHORS BUGS COPYING ChangeLog INSTALL NEWS PROJECTS README THANKS TODO
102%doc doc/DETAILS doc/HACKING doc/OpenPGP doc/samplekeys.asc
103%{_bindir}/*
104%dir %{_datadir}/%{name}
105%{_datadir}/%{name}/FAQ
106%{_datadir}/%{name}/options.skel
107%{_libdir}/%{name}
108%{_infodir}/*
109%{_mandir}/man1/*
110%{_mandir}/man7/*
111
112
113%changelog
114* Tue Oct  8 2013 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.4.15-2
115- drop patch1 (Thanks to Shaolin-san's help)
116
117* Tue Oct  8 2013 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.4.15-1
118- new upstream release with security fix (CVE-2013-4402)
119- add patch1 to stop git access
120
121* Mon Aug 05 2013 Toshiahru Kudoh <toshi.kd2@gmail.com> 1.4.11-3
122- added patch101 for fix CVE-2013-4242
123
124* Mon Jan  7 2013 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.4.11-2
125- add patch100 for fix CVE-2012-6085 (importing public key)
126- add smp flag in make section
127
128* Mon Apr  4 2011 IWAI, Masaharu <iwai@alib.jp> 1.4.11-1
129- new upstream release
130- update ja.po (Source2)
131- drop dir patch (Patch3): upstream merged
132- drop faq.html in %%files: upstream deleted
133
134* Sat Jul 17 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.10-1
135- new upstream release
136- add --enable-ldap
137- add BR: bzip2-devel, openldap-devel, libusb-devel, readline-devel
138- use Requires(post,preun) instead of PreReq
139
140* Tue Jul 14 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.4.9-1
141- new upstream release
142
143* Fri Aug 15 2008 Shu KONNO <owa@bg.wakwak.com> 1.4.6-1vl5
144- applied new versioning policy, spec in utf-8
145
146* Sun May 20 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.4.6-0vl4
147- add --without-libcurl option for configure,
148  instead of "rebuilding without curl" as shown below
149
150* Mon May 14 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.4.6-0vl3
151- rebuild without curl
152
153* Mon Dec 25 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.6-0vl2
154- rebuilt for VineSeed
155
156* Sat Dec 09 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.4.6-0vl1
157- new upstream release incorporating fixes for CVE-2006-6169, 6235
158- drop Patch100 (included in new upstream)
159- add patch3 from redhat
160
161* Sat Dec 02 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.4.5-0vl1.1
162- add patch100 for fix CVE-2006-6169
163
164* Mon Sep  4 2006 IWAI, Masaharu <iwai@alib.jp> 1.4.5-0vl1
165- new upstream release
166- update ja.po ( but, it has many fuzzy )
167
168* Sun May  7 2006 IWAI, Masaharu <iwai@alib.jp> 1.4.3-0vl1
169- drop CVE-2006-0455 ( Patch10 ) and CVE-2006-0049 ( Patch11 ) patches
170    - upstream fixed
171- update ja.po ( but, it has many fuzzy )
172- drop unnecessary libexec patch ( Patch0 )
173
174* Sun Apr  9 2006 IWAI, Masaharu <iwai@alib.jp> 1.2.6-0vl5
175- build for VineSeed
176
177* Sun Mar 19 2006 IKEDA Katsumi <ikeda@webmasters.gr.jp> 1.2.6-0vl4
178- added a security patch for CVE-2006-0049.
179
180* Mon Feb 20 2006 IKEDA Katsumi <ikeda@webmasters.gr.jp> 1.2.6-0vl3
181- added a security patch for CVE-2006-0455.
182
183* Sat Oct 30 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.6-0vl2
184- update ja.po
185
186* Thu Oct 28 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.6-0vl1
187- new upstream release
188
189* Mon Dec 29 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.4-0vl2
190- rebuilt
191
192* Mon Dec 29 2003 IWAI, Masaharu <iwai@alib.jp> 1.2.4-0vl1
193- new upstream release
194
195* Sun Aug 30 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.3-0vl1
196- new upstream release
197
198* Tue May  6 2003 IWAI Masaharu <iwai@alib.jp> 1.2.2-0vl1
199- upstream releace
200- update libexec.patch (Patch0)
201- drop trustfix.patch (Patch10)
202
203* Tue May  6 2003 IWAI Masaharu <iwai@alib.jp> 1.2.1-3vl3
204- SECURITY FIX - Key validity bug
205    - http://lists.gnupg.org/pipermail/gnupg-announce/2003q2/000268.html
206    - add trustfix.patch (Patch10) from Vine-2.6 updates 1.0.7-6vl2.1
207
208* Fri Mar  7 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.1-3vl2
209- update ja.po
210
211* Fri Mar  7 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.1-3vl1
212- new upstream release
213- merged with rawhide version 1.2.1-3
214  * Fri Feb  7 2003 Nalin Dahyabhai <nalin@redhat.com> 1.2.1-3
215  - modify g10defs to look for helpers in libexecdir, because that's where they
216    get installed, per gnupg-users
217  - actually drop updates for 1.0.7 which are no longer needed for 1.2.1
218  * Mon Oct 28 2002 Nalin Dahyabhai <nalin@redhat.com> 1.2.1-1
219  - update to 1.2.1
220  * Tue Sep 24 2002 Nalin Dahyabhai <nalin@redhat.com> 1.2.0-1
221  - update to 1.2.0
222  - stop stripping files manually, let the buildroot policies handle it
223  - add translations updates ca and fr
224
225* Tue Oct  1 2002 IWAI Masaharu <iwai@alib.jp> 1.0.7-6vl2
226- added --disable-{ldap,mailto} options for configure script
227- added zlib in Requires tag
228- added zlib-devel in BuildRequires tag
229
230* Mon Sep 23 2002 IWAI Masaharu <iwai@alib.jp> 1.0.7-6vl1
231- sync with Rawhide gnupg-1.0.7-6
232    - added --program-{transform-name,prefix,suffix} options for configure script
233    - added Source1(signature for the GnuPG 1.0.7 tarball)
234    - added BUGS and doc/samplekeys.asc in %%doc
235    - eliminated g*/OPTIONS and g*/pubring.asc in %%doc
236    - stopped patching Patch0(codeset.patch)
237    -
238- droped Source3(ja.po)
239- added Patch1 (gnupg-1.0.7-ja.po.patch)
240
241* Fri Jan 25 2002 Toru Sagami <sagami@vinelinux.org> 1.0.6-3vl1
242- sync with 1.0.6-3
243  * set message output encoding to match the message encoding, based on a
244    patch by goeran@uddeborg.pp.se (#49182)
245- fixed ja.po
246
247* Thu Jun 07 2001 <sagami@vinelinux.org>
248- update to 1.0.6: follow up with RHSA's 1.0.5 package
249- changed Group/Description
250- stop replacing/overriding man page (new one is out there)
251
252* Thu May 24 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.5-0vl2
253- fixed typo in spec file.
254
255* Thu May 24 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.5-0vl1
256- update to 1.0.5
257- update ja.po.
258
259* Mon Oct 23 2000 KAJIKI Yoshihiro <kajiki@ylug.org>
260- update to 1.0.4 for a security reason
261- add Japanese summary and description
262
263* Thu Aug 17 2000 KAJIKI Yoshihiro <kajiki@ylug.org>
264- rebuild for Vine-2.0/VineSeed
265
266* Sun Jul 23 2000 Nalin Dahyabhai <nalin@redhat.com>
267- update to 1.0.2
268
269* Wed Jul 19 2000 Jakub Jelinek <jakub@redhat.com>
270- rebuild to cope with glibc locale binary incompatibility
271
272* Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
273- automatic rebuild
274
275* Wed Jul 12 2000 Nalin Dahyabhai <nalin@redhat.com>
276- include lspgpot (#13772)
277
278* Mon Jun  5 2000 Nalin Dahyabhai <nalin@redhat.com>
279- rebuild in new build environment
280
281* Fri Feb 18 2000 Bill Nottingham <notting@redhat.com>
282- build of 1.0.1
283
284* Fri Sep 10 1999 Cristian Gafton <gafton@redhat.com>
285- version 1.0.0 build for 6.1us
Note: See TracBrowser for help on using the repository browser.