source: projects/specs/branches/6/g/gnome-vfs/gnome-vfs-vl.spec @ 521

Revision 521, 4.9 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1# Note that this is NOT a relocatable package
2%define name    gnome-vfs
3%define ver     1.0.5
4%define rel     13vl4
5
6Summary:        The GNOME virtual file-system libraries
7Name:           gnome-vfs
8Version:        1.0.5
9Release:        14%{?_dist_release}
10License:        LGPL
11Group:          System Environment/Libraries
12Source:         ftp://ftp.gnome.org/pub/GNOME/sources/%{name}/1.0/%{name}-%{ver}.tar.gz
13Source2:        macros.tar.gz
14Source3:        gnome-vfs-pofiles.tar.gz
15
16Patch1: gnome-vfs-1.0.5-charset-and-rpmsave.patch
17Patch2: gnome-vfs-1.0.5-lib64.patch
18Patch3: gnome-vfs-1.0.5-mimesniffcrash-backport.patch
19Patch4: gnome-vfs-1.0.5-compilation-fix.patch
20
21Patch100: gnome-vfs-1.0.5-configure.patch
22
23URL:            http://www.gnome.org/
24BuildRoot:      %{_tmppath}/%{name}-%{version}-root
25Requires:       glib >= 1.2.4
26Requires:       GConf >= 0.9
27Requires:       oaf >= 0.3.0
28Requires:       gnome-mime-data
29BuildRequires: GConf-devel, oaf-devel, glib-devel, libxml-devel, zlib-devel
30BuildRequires: popt-devel, bzip2-devel, ORBit-devel, libX11-devel
31BuildRequires: gnome-libs-devel, pkgconfig, intltool, gettext, openjade
32BuildRequires: gnome-mime-data
33BuildRequires: automake14
34
35%description
36GNOME VFS is the GNOME virtual file system. It is the foundation of the
37Nautilus file manager. It provides a modular architecture and ships with
38several modules that implement support for file systems, http, ftp and others.
39It provides a URI-based API, a backend supporting asynchronous file operations,
40a MIME type manipulation library and other features.
41
42
43%package devel
44Summary: Libraries and include files for developing GNOME VFS applications.
45Group: Development/Libraries
46Requires: %{name} = %{version}
47Requires: GConf-devel
48Requires: oaf-devel
49
50
51%description devel
52This package provides the necessary development libraries for writing
53GNOME VFS modules and applications that use the GNOME VFS APIs.
54
55
56%prep
57%setup -q
58
59%patch1 -p1 -b .charset-and-rpmsave
60
61if [ "%{_lib}" == "lib64" ] ; then
62%patch2 -p1 -b .lib64
63fi
64%patch3 -p1 -b .mimecrash
65%patch4 -p1 -b .compilation-fix
66
67tar zxf %{SOURCE2}
68
69# unpack translations
70tar zxf %{SOURCE3}
71
72%patch100 -p1 -b .configure
73
74
75# workaround glibc21.m4 being installed
76mkdir tmp-macros
77cp libgnomevfs/libcharset/*.m4 tmp-macros
78rm tmp-macros/glibc21.m4
79
80# for patch 1
81aclocal-1.4 -I macros -I tmp-macros
82automake-1.4
83autoheader
84autoconf
85
86%build
87if pkg-config openssl ; then
88        CPPFLAGS=`pkg-config --cflags openssl`; export CPPFLAGS
89        LDFLAGS=`pkg-config --libs-only-L openssl`; export LDFLAGS
90fi
91
92%configure --disable-gtk-doc
93export tagname=CC
94make LIBTOOL=/usr/bin/libtool
95
96%install
97rm -rf %{buildroot}
98
99export tagname=CC
100%makeinstall LIBTOOL=/usr/bin/libtool
101
102%find_lang %{name}
103
104# Remove files which we won't include in this package.
105rm -f $RPM_BUILD_ROOT/%{_libdir}/*.la
106rm -f $RPM_BUILD_ROOT/%{_libdir}/libgnomevfs-pthread.a
107rm -f $RPM_BUILD_ROOT/%{_libdir}/vfs/modules/*.la
108rm -f $RPM_BUILD_ROOT/%{_libdir}/vfs/modules/*.a
109
110%clean
111rm -rf %{buildroot}
112
113
114%post -p /sbin/ldconfig
115
116
117%postun -p /sbin/ldconfig
118
119
120%files -f %{name}.lang
121%defattr(-, root, root)
122
123%doc AUTHORS COPYING ChangeLog NEWS README
124%dir %{_sysconfdir}/vfs
125%dir %{_sysconfdir}/vfs/modules
126%config %{_sysconfdir}/vfs/modules/*.conf
127%{_libdir}/lib*.so.*
128%{_libdir}/libgnomevfs-pthread.so
129%{_libdir}/vfs/extfs/*
130%{_libdir}/vfs/modules/*.so
131#{_datadir}/gtk-doc/html/*
132
133
134%files devel
135%defattr(-, root, root)
136%{_bindir}/gnome-vfs-config
137%{_includedir}/gnome-vfs-1.0
138%{_libdir}/gnome-vfs-1.0
139%{_libdir}/lib*.a
140%{_libdir}/lib*.so
141%{_libdir}/*.sh
142#{_libdir}/vfs/modules/*.a
143
144
145%changelog
146* Sat Oct 25 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.5-14vl5
147- applied new versioning policy
148
149* Sat Jul 28 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.5-13vl4
150- rebuild with new toolchain
151- added Patch100
152
153* Sun Apr 25 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.5-13vl3
154- rebuild with openssl-0.9.7d
155- s/Copyright/License/
156- added BuildRequires gettext
157
158* Sun Apr 13 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.0.5-13vl2
159- added BuildRequires intltool
160
161* Sat Apr 12 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.0.5-13vl1
162- synced with Rawhide
163
164* Sun Dec 15 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.5-0vl1
165- new upstream release
166- split mime stuff to gnome-mime-data.
167
168* Fri Nov 23 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.0.3-0vl1
169- updated to the new upstream release
170
171* Fri May 18 2001 Akira TAGOH <tagoh@gnome.gr.jp> 1.0.1-0vl2
172- Added mime of .ttc
173
174* Wed May  9 2001 Akira TAGOH <tagoh@gnome.gr.jp> 1.0.1-0vl1
175- New upstream release.
176
177* Thu Apr 12 2001 Akira TAGOH <tagoh@gnome.gr.jp> 1.0-0vl3
178- Include the API documents.
179
180* Mon Apr  9 2001 Akira TAGOH <tagoh@gnome.gr.jp> 1.0-0vl2
181- Added some build depends.
182- Fixed relative config.
183
184* Tue Apr  3 2001 Akira TAGOH <tagoh@gnome.gr.jp> 1.0-0vl1
185- New upstream release.
186- Use find_lang macro.
187
188* Fri Mar  9 2001 Akira TAGOH <tagoh@gnome.gr.jp> 0.6.2-0vl1
189- New upstream release.
190
191* Wed Dec 27 2000 Akira TAGOH <tagoh@gnome.gr.jp> 0.4.2-0vl1
192- Build for Vine
193
194* Tue Feb 22 2000 Ross Golder <rossigee@bigfoot.com>
195- Integrate into source tree
196
Note: See TracBrowser for help on using the repository browser.