source: projects/specs/branches/6/g/gnome-python-desktop/gnome-python-desktop-vl.spec @ 2041

Revision 2041, 13.8 KB checked in by Takemikaduchi, 14 years ago (diff)

update to GNOME-2.32.0

Line 
1%{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
2
3%define glib_version 2.26.0
4%define gtk_version 2.22.0
5%define pygtk_version 2.22.0
6%define gnome_python_version 2.28.0
7%define libgnome_keyring_version 2.32.0
8%define gnome_panel_version 2.32.0
9%define gnome_desktop_version 2.32.0
10%define gtksourceview2_version 2.10.5
11%define libgtop_version 2.28.2
12%define gnome_media_version 2.32.0
13%define metacity_version 2.30.3
14%define librsvg2_version 2.32.0
15%define totem_version 2.32.0
16%define libwnck_version 2.30.5
17%define bug_buddy_version 2.32.0
18%define evolution_data_server_version 2.32.0
19
20### Abstract ###
21
22Name: gnome-python-desktop
23Version: 2.32.0
24Release: 1%{?_dist_release}
25License: GPL/LGPL
26Group: Development/Libraries
27Summary: The sources for additional PyGNOME Python extension modules
28BuildRoot: %{_tmppath}/%{name}-%{version}-root
29Source: gnome-python-desktop-%{version}.tar.bz2
30
31### Dependencies ###
32
33Requires: gnome-python >= %{gnome_python_version}
34
35### Build Dependencies ###
36
37BuildRequires: glib2-devel >= %{glib_version}
38BuildRequires: gtk2-devel >= %{gtk_version}
39BuildRequires: python >= 2.6
40BuildRequires: pygtk2-devel >= %{pygtk_version}
41BuildRequires: gnome-python-devel >= %{gnome_python_version}
42BuildRequires: libgnome-keyring-devel >= %{libgnome_keyring_version}
43BuildRequires: gnome-panel-devel >= %{gnome_panel_version}
44BuildRequires: gnome-desktop-devel >= %{gnome_desktop_version}
45BuildRequires: libgnomeprint-devel
46BuildRequires: libgnomeprintui-devel
47BuildRequires: evince-devel
48BuildRequires: evolution-data-server >= %{evolution_data_server_version}
49BuildRequires: gtksourceview-devel >= %{gtksourceview_version}
50BuildRequires: libgtop2-devel >= %{libgtop_version}
51BuildRequires: gnome-media-devel >= %{gnome_media_version}
52BuildRequires: metacity-devel >= %{metacity_version}
53BuildRequires: brasero-devel
54BuildRequires: librsvg2-devel >= %{librsvg2_version}
55BuildRequires: pycairo-devel
56BuildRequires: totem-pl-parser-devel >= %{totem_version}
57BuildRequires: totem >= %{totem_version}
58BuildRequires: libwnck-devel >= %{libwnck_version}
59BuildRequires: bug-buddy >= %{bug_buddy_version}
60BuildRequires: libSM-devel
61
62%description
63The gnome-python-desktop package contains the source packages for additional
64Python bindings for GNOME. It should be used together with gnome-python.
65
66%package -n gnome-python-applet
67Summary: Python bindings for GNOME Panel applets.
68Group: Development/Libraries
69Requires: %{name} = %{version}-%{release}
70# applets from GNOME 1.4 are no longer supported - we only have 1 panel
71Obsoletes: pygnome-applet
72
73%description -n gnome-python-applet
74This module contains a wrapper that allows GNOME Panel applets to be
75written in Python.
76
77%package -n gnome-python-bugbuddy
78Summary: Python bindings for interacting with bug-buddy
79Group: Development/Libraries
80Requires: %{name} = %{version}-%{release}
81Requires: bug-buddy >= %{bug_buddy_version}
82
83%description -n gnome-python-bugbuddy
84This module contains a wrapper that allows the use of bug-buddy via
85Python.
86
87%package -n gnome-python-evolution
88Summary: Python bindings for interacting with evolution
89Group: Development/Libraries
90Requires: %{name} = %{version}-%{release}
91Requires: evolution-data-server >= %{evolution_data_server_version}
92
93%description -n gnome-python-evolution
94This module contains a wrapper that allows the use of evolution via
95Python.
96
97%package -n gnome-python-gnomeprint
98Summary: Python bindings for interacting with libgnomeprint
99Group: Development/Libraries
100Requires: %{name} = %{version}-%{release}
101Requires: libgnomeprint
102Requires: libgnomeprintui
103
104%description -n gnome-python-gnomeprint
105This module contains a wrapper that allows the use of libgnomeprint via
106Python.
107
108%package -n gnome-python-gtksourceview
109Summary: Python bindings for interacting with the gtksourceview library
110Group: Development/Libraries
111Requires: %{name} = %{version}-%{release}
112Requires: gtksourceview >= %{gtksourceview_version}
113Requires: gnome-python-gnomeprint
114
115%description -n gnome-python-gtksourceview
116This module contains a wrapper that allows the use of gtksourceview via
117Python.
118
119%package -n gnome-python-libwnck
120Summary: Python bindings for interacting with libwnck
121Group: Development/Libraries
122Requires: libwnck >= %{libwnck_version}
123
124%description -n gnome-python-libwnck
125This module contains a wrapper that allows the use of libwnck via
126Python.
127
128%package -n gnome-python-libgtop2
129Summary: Python bindings for interacting with libgtop
130Group: Development/Libraries
131Requires: %{name} = %{version}-%{release}
132Requires: libgtop2 >= %{libgtop_version}
133
134%description -n gnome-python-libgtop2
135This module contains a wrapper that allows the use of libgtop via
136Python.
137
138%package -n gnome-python-brasero
139Summary: Python bindings for interacting with brasero
140Group: Development/Libraries
141Requires: %{name} = %{version}-%{release}
142Requires: brasero-libs
143
144%description -n gnome-python-brasero
145This module contains a wrapper that allows the use of brasero
146via Python.
147
148%package -n gnome-python-metacity
149Summary: Python bindings for interacting with metacity
150Group: Development/Libraries
151Requires: %{name} = %{version}-%{release}
152Requires: metacity >= %{metacity_version}
153
154%description -n gnome-python-metacity
155This module contains a wrapper that allows the use of metacity
156via Python.
157
158%package -n gnome-python-totem
159Summary: Python bindings for interacting with totem
160Group: Development/Libraries
161Requires: %{name} = %{version}-%{release}
162Requires: totem >= %{totem_version}
163
164%description -n gnome-python-totem
165This module contains a wrapper that allows the use of totem
166via Python.
167
168%package -n gnome-python-rsvg
169Summary: Python bindings for interacting with librsvg
170Group: Development/Libraries
171Requires: librsvg2 >= %{librsvg2_version}
172Requires: pycairo
173
174%description -n gnome-python-rsvg
175This module contains a wrapper that allows the use of librsvg
176via Python.
177
178%package -n gnome-python-gnomedesktop
179Summary: Python bindings for interacting with gnome-desktop
180Group: Development/Libraries
181Requires: %{name} = %{version}-%{release}
182Requires: gnome-desktop >= %{gnome_desktop_version}
183
184%description -n gnome-python-gnomedesktop
185This module contains a wrapper that allows the use of gnome-desktop
186via Python.
187
188%package -n gnome-python-gnomekeyring
189Summary: Python bindings for interacting with gnome-keyring
190Group: Development/Libraries
191Requires: %{name} = %{version}-%{release}
192Requires: libgnome-keyring >= %{libgnome_keyring_version}
193
194%description -n gnome-python-gnomekeyring
195This module contains a wrapper that allows the use of gnome-keyring
196via Python.
197
198%package -n gnome-python-evince
199Summary: Python bindings for interacting with evince
200Group: Development/Libraries
201Requires: %{name} = %{version}-%{release}
202Requires: evince
203
204%description -n gnome-python-evince
205This module contains a wrapper that allows the use of evince
206via Python.
207
208%prep
209%setup -q -n gnome-python-desktop-%{version}
210
211%build
212./waf configure --prefix=%{_prefix} --libdir=%{_libdir} --enable-metacity
213./waf build %{?_smp_mflags}
214
215%install
216rm -rf $RPM_BUILD_ROOT
217./waf install --destdir=$RPM_BUILD_ROOT
218
219find $RPM_BUILD_ROOT -name '*.la' -exec rm {} \;
220
221rm -rf $RPM_BUILD_ROOT/%{_libdir}/python*/site-packages/gtk-2.0/gksu
222
223%clean
224rm -rf $RPM_BUILD_ROOT
225
226%files
227%defattr(-,root,root,-)
228%doc AUTHORS ChangeLog NEWS
229%{_libdir}/pkgconfig/gnome-python-desktop-2.0.pc
230%{_datadir}/pygtk
231
232%files -n gnome-python-applet
233%defattr(-,root,root,-)
234%{python_sitearch}/gtk-2.0/gnomeapplet.so
235%defattr(644,root,root,755)
236%doc ../gnome-python-desktop-%{version}/examples/applet/*
237
238%files -n gnome-python-bugbuddy
239%defattr(-,root,root,-)
240%{python_sitearch}/gtk-2.0/bugbuddy.py*
241
242%files -n gnome-python-evolution
243%defattr(-,root,root,-)
244%dir %{python_sitearch}/gtk-2.0/evolution/
245%{python_sitearch}/gtk-2.0/evolution/*
246
247%files -n gnome-python-gnomeprint
248%defattr(-,root,root,-)
249%{python_sitearch}/gtk-2.0/gnomeprint/
250%{_datadir}/gtk-doc/html/pygnomeprint
251%{_datadir}/gtk-doc/html/pygnomeprintui
252%defattr(644,root,root,755)
253%doc ../gnome-python-desktop-%{version}/examples/gnomeprint/*
254
255%files -n gnome-python-gtksourceview
256%defattr(-,root,root,-)
257%{python_sitearch}/gtk-2.0/gtksourceview.so
258%{_datadir}/gtk-doc/html/pygtksourceview
259%defattr(644,root,root,755)
260%doc ../gnome-python-desktop-%{version}/examples/gtksourceview/*
261
262%files -n gnome-python-libwnck
263%defattr(-,root,root,-)
264%{python_sitearch}/gtk-2.0/wnck.so
265%defattr(644,root,root,755)
266%doc ../gnome-python-desktop-%{version}/examples/wnck_example.py
267
268%files -n gnome-python-libgtop2
269%defattr(-,root,root,-)
270%{python_sitearch}/gtk-2.0/gtop.so
271
272%files -n gnome-python-brasero
273%defattr(-,root,root,-)
274%{python_sitearch}/gtk-2.0/braseroburn.so
275%{python_sitearch}/gtk-2.0/braseromedia.so
276%defattr(644,root,root,755)
277%doc ../gnome-python-desktop-%{version}/examples/braseroburn/*
278%doc ../gnome-python-desktop-%{version}/examples/braseromedia/*
279
280%files -n gnome-python-metacity
281%defattr(-,root,root,-)
282%{python_sitearch}/gtk-2.0/metacity.so
283
284%files -n gnome-python-totem
285%defattr(-,root,root,-)
286%{python_sitearch}/gtk-2.0/mediaprofiles.so
287%{python_sitearch}/gtk-2.0/totem
288
289%files -n gnome-python-rsvg
290%{python_sitearch}/gtk-2.0/rsvg.so
291%defattr(644,root,root,755)
292%doc ../gnome-python-desktop-%{version}/examples/rsvg/*
293
294%files -n gnome-python-gnomedesktop
295%{python_sitearch}/gtk-2.0/gnomedesktop
296
297%files -n gnome-python-gnomekeyring
298%{python_sitearch}/gtk-2.0/gnomekeyring.so
299%defattr(644,root,root,755)
300%doc ../gnome-python-desktop-%{version}/examples/keyring*.py
301
302%files -n gnome-python-evince
303%{python_sitearch}/gtk-2.0/evince.so
304
305%changelog
306* Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0-1
307- new upstream release
308
309* Sat Sep 25 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.2-2
310- rebuild with rpm-4.8.1 for pkg-config file
311- change BuildRequires: gnome-panel-devel instead of gnome-panel
312- change BuildRequires: gnome-media-devel instead of gnome-media
313- add BuildRequires: libSM-devel
314
315* Mon Jun 21 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.2-1
316- new upstream release
317
318* Sat Apr 10 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
319- new upstream release
320- add BuildRequires: totem
321- change BuildRequires: gnome-keyring-devel -> libgnome-keyring-devel
322
323* Tue Feb 02 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.28.0-2
324- rebuild for python-2.6
325
326* Sat Nov  7 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.0-1
327- new upstream release
328- added gnome-python-brasero, gnome-python-evince package
329- remove gnome-python-nautilus-cd-burner package
330- used waf instead of configure script
331
332* Mon Mar 23 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
333- new upstream release
334
335* Sat Oct 18 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.24.0-1
336- new upstream release
337- added BuildRequires: pycairo-devel
338
339* Wed Jul 23 2008 Shu KONNO <owa@bg.wakwak.com> - 2.20.0-3
340- rebuilt with python-2.5.2
341
342* Wed Apr 16 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.20.0-2
343- re-enable BuildRequires: gnome-python-devel
344
345* Mon Apr  7 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.22.0-1vl5
346- new upstream release
347- added gnome-python-evolution subpackage
348
349* Wed Jan  9 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.20.0-0vl1
350- new upstream release
351
352* Sun Jul 08 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.18.0-1vl2
353- add BuildRequires: gnome-media
354
355* Sat Jul  7 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.18.0-1vl1
356- initial build for Vine Linux
357
358* Mon Mar 12 2007 Matthew Barnes <mbarnes@redhat.com> - 2.18.0-1.fc7
359- Update to 2.18.0
360
361* Wed Feb 28 2007 Matthias Clasen <mclasen@redhat.com> - 2.17.93-1
362- Update to 2.17.93
363
364* Sun Feb 25 2007 Matthew Barnes <mbarnes@redhat.com> - 2.17.92-1.fc7
365- Update to 2.17.92
366- Remove patch for GNOME bug #401760 (fixed upstream).
367
368* Mon Feb 05 2007 Matthew Barnes <mbarnes@redhat.com> - 2.17.3-3.fc7
369- Add patch for GNOME bug #401760 (plparser fails to build).
370
371* Mon Feb 05 2007 Matthew Barnes <mbarnes@redhat.com> - 2.17.3-2.fc7
372- Rename spec file to gnome-python2-desktop.spec (RH bug #225832).
373
374* Mon Jan 08 2007 Matthew Barnes <mbarnes@redhat.com> - 2.17.3-1
375- Update to 2.17.3
376
377* Sun Jan 07 2007 Matthew Barnes <mbarnes@redhat.com> - 2.17.2-1
378- Update to 2.17.2
379- New gnome-python2-bugbuddy subpackage.
380- Update version requirements to match configure.ac.
381- Use python_sitearch macro for installing libraries.
382
383* Thu Dec  7 2006 Jeremy Katz <katzj@redhat.com> - 2.17.1-2
384- rebuild for python 2.5
385- BR gnome-python2-devel
386
387* Sat Oct 21 2006 Matthias Clasen <mclasen@redhat.com> - 2.17.1-1
388- Update to 2.17.1
389
390* Tue Sep  5 2006 Matthias Clasen <mclasen@redhat.com> - 2.16.0-1.fc6
391- Update to 2.16.0
392
393* Tue Aug 22 2006 Dan Williams <dcbw@redhat.com> - 2.15.90-2.fc6
394- Remove unecessary dependencies on gnome-python2-desktop from
395    -libwnck and -rsvg subpackages (OLPC)
396
397* Fri Aug  4 2006 Matthias Clasen <mclasen@redhat.com> - 2.15.90-1.fc6
398- Update to 2.15.90
399
400* Thu Jul 20 2006 Matthias Clasen <mclasen@redhat.com> - 2.15.4-2
401- Rebuild against dbus
402
403* Thu Jul 13 2006 Matthias Clasen <mclasen@redhat.com> - 2.15.4-1
404- Update to 2.15.4
405
406* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 2.15.3-4.1
407- rebuild
408
409* Thu Jun 15 2006 Jesse Keating <jkeating@redhat.com> - 2.15.3-4
410- Create gnomekeyring subpackage
411- block out the nautilus-cd stuff
412
413* Thu Jun 15 2006 Jesse Keating <jkeating@redhat.com> - 2.15.3-2
414- Bump for new nautilus-cd-burner
415
416* Tue Jun 13 2006 Matthias Clasen <mclasen@redhat.com> - 2.15.3-1
417- Update to 2.15.3
418
419* Tue May 30 2006 Matthias Clasen <mclasen@redhat.com> - 2.15.2-1
420- Update to 2.15.2
421- Add subpackages gnome-python2-rsvg and gnome-python2-gnomedesktop
422
423* Wed May 24 2006 John (J5) Palmieri <johnp@redhat.com> - 2.14.0-2
424- Add pygtk2 BR
425
426* Mon Mar 13 2006 Ray Strode <rstrode@redhat.de> 2.14.0-1
427- Update to 2.14.0
428
429* Tue Feb 28 2006 Karsten Hopp <karsten@redhat.de> 2.13.3-2
430- Buildrequires: python-devel
431
432* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 2.13.3-1.1
433- bump again for double-long bug on ppc(64)
434
435* Mon Feb  6 2006 John (J5) Palmieri <johnp@redhat.com> - 2.13.3-1
436- Initial build.
437
Note: See TracBrowser for help on using the repository browser.