source: projects/specs/branches/6/g/gnome-print/gnome-print-vl.spec @ 5569

Revision 5569, 9.3 KB checked in by Takemikaduchi, 12 years ago (diff)

rebuild packages

Line 
1# Note that this is NOT a relocatable package
2%define ver     0.37
3%define rel     4%{?_dist_release}
4%define name    gnome-print
5%define sover   15
6
7Summary:        Gnome Print - Printing libraries for GNOME.
8Summary(ja):    Gnome Print - GNOME用印刷ライブラリ
9Name:           %{name}
10Version:        %{ver}
11Release:        %{rel}
12License:        LGPL
13Group:          Applications/Publishing
14Source:         ftp://ftp.gnome.org/pub/GNOME/stable/sources/%{name}/%{name}-%{ver}.tar.bz2
15BuildRoot:      %{_tmppath}/%{name}-%{version}-root
16BuildRequires:  gnome-libs-devel >= 1.4.2-2vl5
17BuildRequires:  libxml-devel
18BuildRequires:  libSM-devel
19BuildRequires:  gdk-pixbuf-devel
20BuildRequires:  freetype2-devel
21BuildRequires:  automake14, autoconf213
22Requires:       libgnomeprint%{sover} = %{version}
23Requires:       urw-fonts ghostscript-fonts
24#Prereq:                libxml urw-fonts ghostscript-fonts
25Requires:               libxml urw-fonts ghostscript-fonts
26
27Obsoletes:      gnome-print-beta < 0.26, gnome-print-bin < 0.26, gnome-print-beta-bin < 0.26, gnome-print-data < 0.26
28
29# RH patches
30Patch2:         gnome-print-0.30-nofontmaps.patch
31
32# for Vine
33Patch50:        gnome-print-0.34-fallback.patch
34Patch51:        gnome-print-0.35-dynamicfallback.patch
35Patch52:        gnome-print-0.37-ft2build.patch
36
37Patch60: gnome-print-0.37-config.patch
38Patch61: gnome-print-0.37-parseTT.patch
39
40%description
41GNOME (GNU Network Object Model Environment) is a user-friendly set of
42applications and desktop tools to be used in conjunction with a window
43manager for the X Window System.  GNOME is similar in purpose and scope
44to CDE and KDE, but GNOME is based completely on free software.
45The gnome-print package contains libraries and fonts that are needed by
46GNOME applications wanting to print.
47
48You should install the gnome-print package if you intend on using any of
49the GNOME applications that can print. If you would like to develop GNOME
50applications that can print you will also need to install the gnome-print
51devel package.
52
53%description -l ja
54印刷できるGNOMEアプリケーションを使いたいなら、gnome-printパッケージを
55インストールする必要があります。もし印刷できるGNOMEアプリケーションを
56開発したいなら、gnome-print-develパッケージをインストールする必要が
57あります。
58
59%package -n libgnomeprint%{sover}
60Summary:        Printing libraries for GNOME
61Summary(ja):    GNOME用印刷ライブラリ
62Group:          System Environment/Libraries
63Obsoletes:      gnome-print-beta < 0.26
64
65%description -n libgnomeprint%{sover}
66This package contains the printing apparatus for GNOME, the complete
67graphical desktop environment based entirely on free software.
68
69%package devel
70Summary:        Libraries and include files for developing GNOME applications.
71Summary(ja):    GNOME用印刷アプリケーション開発用ライブラリとヘッダファイル
72Group:          Development/Libraries
73Obsoletes:      gnome-print-beta-devel < 0.26
74Requires:       %{name} = %{version}
75Requires:       libgnomeprint%{sover} = %{version}
76Requires:       gdk-pixbuf-devel
77
78%description devel
79GNOME (GNU Network Object Model Environment) is a user-friendly set of
80applications and desktop tools to be used in conjunction with a window
81manager for the X Window System.  GNOME is similar in purpose and scope
82to CDE and KDE, but GNOME is based completely on free software.
83The gnome-print-devel package includes the libraries and include files that
84you will need when developing applications that use the GNOME printing
85facilities.
86
87You should install the gnome-print-devel package if you would like to
88develop GNOME applications that will use the GNOME printing facilities.
89You don't need to install the gnome-print-devel package if you just want
90to use the GNOME desktop enviornment.
91
92%prep
93%setup -q
94%patch2 -p1 -b .nofontmaps
95%patch50 -p1 -b .fallback
96%patch51 -p1 -b .dynamic
97%patch52 -p1 -b .ft2build
98
99%patch60 -p0 -b .config
100%patch61 -p0 -b .parseTT
101
102%build
103libtoolize --copy --force
104autoheader-2.13
105automake-1.4
106autoconf-2.13
107%configure --disable-static
108make LIBTOOL=/usr/bin/libtool
109%install
110[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
111%makeinstall LIBTOOL=/usr/bin/libtool
112./mkinstalldirs $RPM_BUILD_ROOT%{_datadir}/gnome-print/fonts
113./mkinstalldirs $RPM_BUILD_ROOT%{_sysconfdir}/gnome/fonts
114install -c fonts/*.font $RPM_BUILD_ROOT%{_datadir}/gnome-print/fonts
115
116cat > $RPM_BUILD_ROOT%{_bindir}/vine-update-gnome-font-install <<__EOF__
117#! /bin/sh
118%{_bindir}/gnome-font-install --clean \
119        --aliases=%{_datadir}/gnome-print/fonts/adobe-urw.font \
120        --target=%{_sysconfdir}/gnome/fonts/gnome-print-rpm.fontmap \
121        --recursive \
122        %{_prefix}/X11R6/lib/X11/fonts \
123        %{_datadir}/fonts
124__EOF__
125chmod a+x $RPM_BUILD_ROOT%{_bindir}/vine-update-gnome-font-install
126
127%find_lang %{name}
128
129## remove unuse files
130rm -rf $RPM_BUILD_ROOT%{_libdir}/*.la
131
132%clean
133[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
134
135%post -p %{_bindir}/vine-update-gnome-font-install
136
137%post -n libgnomeprint%{sover} -p /sbin/ldconfig
138
139%postun -n libgnomeprint%{sover} -p /sbin/ldconfig
140
141
142%files -f %{name}.lang
143%defattr(-, root, root)
144%doc AUTHORS COPYING ChangeLog NEWS README
145%dir %{_datadir}/gnome-print
146%dir %{_datadir}/gnome-print/profiles
147%dir %{_sysconfdir}/gnome/fonts
148%{_datadir}/gnome-print/profiles/*
149%{_bindir}/*
150%{_datadir}/fonts/afms/adobe/*
151%{_datadir}/gnome-print/fonts
152
153%files -n libgnomeprint%{sover}
154%defattr(-, root, root)
155%{_libdir}/*.so.%{sover}.*
156%{_libdir}/*.so.%{sover}
157
158%files devel
159%defattr(-, root, root)
160%{_libdir}/*.so
161#{_libdir}/*.a
162#{_libdir}/*.la
163%{_libdir}/*.sh
164%{_includedir}/*
165
166%changelog
167* Fri Feb 03 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.37-4
168- rebuild with Vine6 environment
169- add BuildRequires: libSM-devel
170
171* Mon Sep 27 2010 Shu KONNO <owa@bg.wakwak.com> 0.37-3
172- added Patch60: gnome-print-0.37-config.patch
173- added Patch61: gnome-print-0.37-parseTT.patch
174
175* Sat May  2 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.37-2
176- rebuilt with gnome-libs-1.4.2-2vl5 (linking with db-4.6.21)
177- removed *.a
178
179* Sat Sep 20 2008 Shu KONNO <owa@bg.wakwak.com> 0.37-1vl5
180- applied new versioning policy, spec in utf-8
181- removed *.la
182
183* Sat Jun 16 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.37-0vl2
184- rebuilt with db4-4.3.29
185
186* Mon Oct 25 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.37-0vl1
187- updated to 0.37
188- rebuilt with db4-4.2.52
189- added Patch52 to build with freetype2
190- s/Copyright/License/
191- fixed %post, %postun section
192
193* Fri Jan 17 2003 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.35-0vl2
194- rebuilt with db4 environment
195- added BuildPreReq: automake14, autoconf213
196
197* Wed Mar 20 2002 Akira TAGOH <tagoh@gnome.gr.jp> 0.35-0vl1
198- New upstream release.
199- vine-update-gnome-font-install: added a wrapper script for generating
200  gnome-print's fontmap. it will helps us if font packages will calls it
201  with %%post and %%postun.
202- %%post: changed calling vine-update-gnome-font-install.
203- gnome-print-0.35-dynamicfallback.patch:
204  generate hash using NAMES file.
205
206* Fri Dec 28 2001 Akira TAGOH <tagoh@gnome.gr.jp> 0.34-0vl3
207- Fixed fontmap generation.
208  Note: don't remove --clean option. when gnome-font-install regenerate
209  fontmap, it don't add the fonts which already exists.
210
211* Wed Dec 26 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.34-0vl2
212- added PreReq: freetype2 for gnome-font-install invoked from %%post section
213- commented out Requires: %%{name} >= %%{ver} from libgnomeprint15
214
215* Tue Dec 18 2001 Akira TAGOH <tagoh@gnome.gr.jp> 0.34-0vl1
216- New upstream release.
217
218* Sun Apr  1 2001 Akira TAGOH <tagoh@gnome.gr.jp> 0.26-0vl3
219- Added Obsolates to libgnomeprint11.
220- Added some build requires.
221
222* Mon Mar 12 2001 Akira TAGOH <tagoh@gnome.gr.jp> 0.26-0vl2
223- New upstream release.
224
225* Tue Jan 23 2001 Akira TAGOH <tagoh@gnome.gr.jp> 0.20-0vl6
226- Fixed -devel conflicts.
227
228* Tue Jan  9 2001 Akira TAGOH <tagoh@gnome.gr.jp> 0.20-0vl5
229- Added Conflicts: line in -devel.
230
231* Wed Dec 27 2000 Akira TAGOH <tagoh@gnome.gr.jp> 0.20-0vl4
232- separated binary and data packages.
233
234* Fri Sep 15 2000 Jun Nishii <jun@vinelinux.org>
235- added prereq urw-fonts
236
237* Wed May 31 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
238- modified jahack pach to fix threshold value of MB_CUR_MAX for glibc 2.1.3.
239
240* Mon May 30 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
241- updated to 0.20
242
243* Mon May 29 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
244- modified jahack patch for satbility of memory allocation.
245- modified jahack patch to fix text alignment.
246
247* Sat May 20 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
248- modified jahack patch for preview.
249- added i18n_fix for nls.
250- added orignal ja.po.
251
252* Tue May 16 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
253- updated to 0.19
254
255* Mon May  1 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
256- updated to 0.18
257
258* Wed Feb 23 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
259- updated to 0.12
260
261* Mon Jan 17 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
262- added "quick hacked" ja patch.
263
264* Tue Nov 23 1999 Norihito Ohmori <ohmori@flatotu.org>
265- add Provides: libgnomeprint.so.2
266
267* Sat Oct 13 1999 Kazuhito Nishi <nishi@imasy.or.jp>
268- Added Prereq: zlib
269
270* Sun Aug 01 1999 Gregory McLean <gregm@comstar.net>
271- Undo my draconian uninstall stuff.
272
273* Tue Jul 20 1999 Gregory McLean <gregm@comstar.net>
274- Stab at cleaning up properly when we uninstall.
275
276* Fri Jul 16 1999 Herbert Valerio Riedel <hvr@hvrlab.dhs.org>
277- fixed typo in spec
278
279* Wed Jul 14 1999 Gregory McLean <gregm@comstar.net>
280- Added fonts to the spec.
281
282* Mon Jul 05 1999 Gregory McLean <gregm@comstar.net>
283- Fleshed out the descriptions.
Note: See TracBrowser for help on using the repository browser.