source: projects/specs/branches/6/g/gnome-power-manager/gnome-power-manager-vl.spec @ 2118

Revision 2118, 12.0 KB checked in by Takemikaduchi, 13 years ago (diff)

fix ja.po

Line 
1%define dbus_version 1.4.0
2%define dbus_glib_version 0.88
3%define gnome_panel_version 2.32.0
4
5Summary: GNOME power management service
6Summary(ja): GNOME 電源管理ツール
7Name: gnome-power-manager
8Version: 2.32.0
9Release: 2%{?_dist_release}
10License: GPLv2+ and GFDL
11Group: Applications/System
12URL: http://projects.gnome.org/gnome-power-manager/
13
14Source0: http://download.gnome.org/sources/gnome-power-manager/2.32/gnome-power-manager-%{version}.tar.bz2
15# ja.po from l10n
16Source101: gnome-power-manager.gnome-2-32.ja.po
17
18# for Vine Linux
19Patch10: gnome-power-manager-2.28.2-warningflags.patch
20Patch11: gnome-power-manager-2.28.2-math.patch
21
22BuildRoot: %{_tmppath}/%{name}-%{version}-root
23BuildRequires: autoconf >= 2.65
24BuildRequires: libgnomeui-devel
25BuildRequires: libglade2-devel
26BuildRequires: libwnck-devel
27BuildRequires: dbus-devel >= %{dbus_version}
28BuildRequires: libnotify-devel
29BuildRequires: gnome-panel-devel >= %{gnome_panel_version}
30BuildRequires: scrollkeeper
31BuildRequires: gnome-doc-utils >= 0.3.2
32BuildRequires: desktop-file-utils
33BuildRequires: gettext
34BuildRequires: libtool
35BuildRequires: cairo-devel
36BuildRequires: libcanberra-devel >= 0.10
37BuildRequires: unique-devel >= 1.1.6
38## BuildRequires: DeviceKit-power-devel >= 008
39BuildRequires: upower-devel >= 0.9.0
40BuildRequires: intltool
41BuildRequires: docbook-utils
42Requires: gtk2 >= 2.10.0
43Requires: gnome-mime-data
44Requires: gnome-icon-theme
45Requires: libnotify >= 0.4.3
46Requires: dbus-glib >= %{dbus_glib_version}
47Requires: dbus-x11 >= %{dbus_version}
48Requires: libcanberra-gtk2 >= 0.10
49Requires: unique >= 1.1.6
50Requires: upower >= 0.9.0
51Requires(post,postun): scrollkeeper
52Requires(post,pre,preun): GConf2
53
54Vendor:       Project Vine
55Distribution: Vine Linux
56Packager:     daisuke, Takemikaduchi
57
58%description
59GNOME Power Manager uses the information and facilities provided by HAL
60displaying icons and handling user callbacks in an interactive GNOME session.
61GNOME Power Preferences allows authorised users to set policy and
62change preferences.
63
64%package extra
65Summary: GNOME Power Manager extra utility programs
66Group: Applications/System
67Requires: %{name} = %{version}-%{release}
68
69%description extra
70Extra GNOME power management applications that are not normally needed.
71
72%prep
73%setup -q
74#%setup -q -n %{?name}-%{?version}-%{?alphatag}
75## %patch10 -p1 -b .warnings
76## %patch11 -p1 -b .math
77
78# copy ja.po
79cp -f %{SOURCE101} po/ja.po
80
81autoreconf -i
82
83%build
84%configure \
85        --disable-scrollkeeper
86make
87
88# strip unneeded translations from .mo files
89# ideally intltool (ha!) would do that for us
90# http://bugzilla.gnome.org/show_bug.cgi?id=474987
91cd po
92grep -v ".*[.]desktop[.]in[.]in$\|.*[.]server[.]in[.]in$" POTFILES.in > POTFILES.keep
93mv POTFILES.keep POTFILES.in
94intltool-update --pot
95for p in *.po; do
96  msgmerge $p %{name}.pot > $p.out
97  msgfmt -o `basename $p .po`.gmo $p.out
98done
99
100%install
101rm -rf $RPM_BUILD_ROOT
102export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
103make install DESTDIR=$RPM_BUILD_ROOT
104unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
105
106desktop-file-install --vendor gnome --delete-original                   \
107  --dir $RPM_BUILD_ROOT%{_sysconfdir}/xdg/autostart                     \
108  $RPM_BUILD_ROOT%{_sysconfdir}/xdg/autostart/gnome-power-manager.desktop
109
110# save space by linking identical images in translated docs
111helpdir=$RPM_BUILD_ROOT%{_datadir}/gnome/help/%{name}
112for f in $helpdir/C/figures/*.png; do
113  b="$(basename $f)"
114  for d in $helpdir/*; do
115    if [ -d "$d" -a "$d" != "$helpdir/C" ]; then
116      g="$d/figures/$b"
117      if [ -f "$g" ]; then
118        if cmp -s $f $g; then
119          rm "$g"; ln -s "../../C/figures/$b" "$g"
120        fi
121      fi
122    fi
123  done
124done
125
126%find_lang %name --with-gnome
127
128%clean
129rm -rf $RPM_BUILD_ROOT
130
131%post
132export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
133gconftool-2 --makefile-install-rule \
134        %{_sysconfdir}/gconf/schemas/gnome-power-manager.schemas >/dev/null || :
135scrollkeeper-update -q &> /dev/null || :
136touch --no-create %{_datadir}/icons/hicolor
137if [ -x /usr/bin/gtk-update-icon-cache ]; then
138    gtk-update-icon-cache -q %{_datadir}/icons/hicolor
139fi
140
141%pre
142if [ "$1" -gt 1 ]; then
143    export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
144    gconftool-2 --makefile-uninstall-rule \
145      %{_sysconfdir}/gconf/schemas/gnome-power-manager.schemas > /dev/null || :
146fi
147
148%preun
149if [ "$1" -eq 0 ]; then
150    export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
151    gconftool-2 --makefile-uninstall-rule \
152      %{_sysconfdir}/gconf/schemas/gnome-power-manager.schemas > /dev/null || :
153fi
154
155%postun
156scrollkeeper-update -q &> /dev/null || :
157touch --no-create %{_datadir}/icons/hicolor
158if [ -x /usr/bin/gtk-update-icon-cache ]; then
159    gtk-update-icon-cache -q %{_datadir}/icons/hicolor &> /dev/null || :
160fi
161
162%files -f %{name}.lang
163%defattr(-,root,root)
164%doc AUTHORS COPYING README
165%{_bindir}/gnome-power-bugreport.sh
166%{_bindir}/gnome-power-manager
167%{_bindir}/gnome-power-preferences
168%{_sbindir}/gnome-power-backlight-helper
169%dir %{_datadir}/gnome-power-manager
170%{_datadir}/gnome-power-manager/acme.ui
171%{_datadir}/gnome-power-manager/gpm-prefs.ui
172%{_datadir}/gnome-power-manager/gpm-feedback-widget.ui
173%{_mandir}/man1/gnome-power-manager.1.gz
174%{_mandir}/man1/gnome-power-preferences.1.gz
175%{_sysconfdir}/gconf/schemas/*.schemas
176%{_datadir}/dbus-1/services/gnome-power-manager.service
177#%{_datadir}/omf/gnome-power-manager
178%{_sysconfdir}/xdg/autostart/*.desktop
179%{_datadir}/gnome-power-manager/icons/hicolor/*/*/*.*
180%{_datadir}/icons/hicolor/*/apps/gnome-power-manager.*
181%{_datadir}/applications/gnome-power-preferences.desktop
182%{_libexecdir}/gnome-brightness-applet
183%{_libdir}/bonobo/servers/GNOME_BrightnessApplet.server
184%{_datadir}/gnome-2.0/ui/GNOME_BrightnessApplet.xml
185%{_datadir}/icons/hicolor/*/apps/gnome-brightness-applet.*
186%{_datadir}/polkit-1/actions/org.gnome.power.policy
187
188%files extra
189%defattr(-,root,root,-)
190%doc AUTHORS COPYING NEWS README
191%{_bindir}/gnome-power-statistics
192%{_mandir}/man1/gnome-power-statistics.1.gz
193%{_datadir}/gnome-power-manager/gpm-statistics.ui
194%{_datadir}/applications/gnome-power-statistics.desktop
195%{_datadir}/icons/hicolor/*/apps/gnome-power-statistics.*
196%{_libexecdir}/gnome-inhibit-applet
197%{_libdir}/bonobo/servers/GNOME_InhibitApplet.server
198%{_datadir}/gnome-2.0/ui/GNOME_InhibitApplet.xml
199%{_datadir}/icons/hicolor/*/apps/gnome-inhibit-applet.*
200
201%changelog
202* Sat Oct 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0-2
203- add Source101(gnome-power-manager.gnome-2-32.ja.po)
204
205* Tue Oct 05 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0-1
206- new upstream release
207- change BuildRequires: gnome-panel-devel instead of gnome-panel
208- fix %files
209
210* Sat May 01 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-1
211- new upstream release
212
213* Sat Apr 10 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
214- new upstream release
215- remove Patch1, Patch2, Patch3
216- change BuildRequires: DeviceKit-power-devel -> upower-devel
217- change Requires: DeviceKit-power -> upower
218
219* Sun Feb 28 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.3-1
220- new upstream release
221- change BuildRequires: xmlto -> docbook-utils
222- remove BuildReuiqres: hal-devel
223
224* Sun Feb 28 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.3-1
225- new upstream release
226
227* Tue Dec 29 2009 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.2-1
228- merge spec file from FC package
229- add Patch1, Patch2 and Patch3 from FC package
230- add Patch10 and Patch11 for Vine Linux
231- remove configure option --enable-policykit
232- add new package (extra)
233
234* Sun Apr 26 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.4-1
235- new upstream release
236
237* Wed Oct 28 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.1-1
238- new upstream release
239
240* Thu Sep 25 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
241- new upstream release
242
243* Sun Apr 13 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1-1vl5
244- new upstream release
245
246* Sun Jan 12 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.20.2-0vl1
247- new upstream release
248
249* Fri May 11 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.2-0vl2
250- rebuild with new environment/toolchain
251
252* Sat Apr 28 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.2-0vl1
253- new upstream release
254- drop Patch10 to enable suspend-to-ram.
255
256* Thu Sep 07 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.16.0-0vl1
257- new upstream release
258
259* Tue Aug 08 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.91-0vl1
260- new upstream release
261
262* Mon Jul 24 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.90-0vl1
263- new upstream release
264
265* Wed Jun 21 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.3-0vl1
266- new upstream release
267
268* Wed May 31 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.2-0vl1
269- new upstream release
270
271* Wed Apr 26 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.1-0vl1
272- new upstream release
273
274* Mon Apr 17 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.0-0vl1
275- new upstream release
276
277* Mon Apr 10 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl1
278- new upstream release
279
280* Thu Mar 30 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl3
281- add Patch10 to disable suspend-to-ram by default.
282
283* Thu Mar 30 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl2
284- update ja.po from CVS head.
285
286* Thu Mar 23 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl1
287- new upstream release
288
289* Sun Mar 12 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.93-0vl1
290- initial build for Vine Linux based on FC package
291
292* Mon Mar  6 2006 Ray Strode <rstrode@redhat.com> - 2.13.93-4
293- fix the fix in -2 and -3
294
295* Mon Mar  6 2006 Ray Strode <rstrode@redhat.com> - 2.13.93-3
296- fix the fix in -2
297
298* Mon Mar  6 2006 Ray Strode <rstrode@redhat.com> - 2.13.93-2
299- fix icon in bubbles (bug 184192).
300
301* Fri Mar  3 2006 Ray Strode <rstrode@redhat.com> - 2.13.93-1
302- Update to 2.13.93
303- ignore d-bus timeout errors
304
305* Thu Mar  2 2006 Ray Strode <rstrode@redhat.com> - 2.13.92-3
306- Add patch from Richard Hughes to potentially fix a
307  crasher bug (bug 183127)
308
309* Tue Feb 28 2006 Karsten Hopp <karsten@redhat.de> 2.13.92-2
310- Buildrequires: gnome-doc-utils
311
312* Sun Feb 26 2006 Ray Strode <rstrode@redhat.com> - 2.13.92-1
313- Update to 2.13.92
314
315* Tue Feb 21 2006 Matthias Clasen <mclasen@redhat.com> - 2.13.91-1
316- Update to 2.13.91
317- Drop upstreamed patch
318
319* Wed Feb 15 2006 Matthias Clasen <mclasen@redhat.com> - 2.13.90-1
320- Update to 2.13.90
321- Require dbus-x11 (#176656)
322
323* Sun Feb 13 2006 Ray Strode <rstrode@redhat.com> - 2.13.5.0.20060207-2
324- remove Hibernate and Suspend from menus as part of
325  panel/g-p-m integration effort
326
327* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 2.13.5.0.20060207-1.1
328- bump again for double-long bug on ppc(64)
329
330* Tue Feb  7 2006 Ray Strode <rstrode@redhat.com> - 2.13.5.0.20060207-1
331- pull cvs snapshot from HEAD and drop the patches caillon
332  just added
333
334* Tue Feb  7 2006 Christopher Aillon <caillon@redhat.com> - 2.13.5-3
335- Install into the autostart directory
336- Don't suspend on lid close while on AC power
337
338* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 2.13.5-2.1
339- rebuilt for new gcc4.1 snapshot and glibc changes
340
341* Tue Jan 31 2006 Matthias Clasen <mclasen@redhat.com> - 2.13.5-2
342- rebuild
343
344* Thu Jan 26 2006 Ray Strode <rstrode@redhat.com> - 2.13.5-1
345- packaging tweaks
346
347* Thu Jan 26 2006 Christopher Aillon <caillon@redhat.com> 2.13.5-1
348- Update to 2.13.5
349
350* Tue Jan 24 2006 Christopher Aillon <caillon@redhat.com> - 0.3.4-2
351- Left clicking on the applet should bring up the menu
352
353* Tue Jan 17 2006 Ray Strode <rstrode@redhat.com> - 0.3.4-1
354- update to 0.3.4
355- disable updating scrollkeeper database in buildroot
356  (move to %%post)
357
358* Fri Jan  6 2006 Jeremy Katz <katzj@redhat.com> - 0.3.3-0.cvs.20060106
359- update to a cvs snap so that it works with hal cvs snap
360- make sure we use libnotify
361
362* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com> - 0.3.1-2.1
363- rebuilt
364
365* Thu Dec 01 2005 John (J5) Palmieri <johnp@redhat.com> - 0.3.1-2
366- rebuild for new dbus
367
368* Mon Nov 28 2005 Christopher Aillon <caillon@redhat.com> 0.3.1-1
369- Update to 0.3.1
370
371* Fri Nov 25 2005 Christopher Aillon <caillon@redhat.com> 0.3.0-1
372- Update to 0.3.0
373
374* Wed Oct 19 2005 Ray Strode <rstrode@redhat.com> 0.2.8-1
375- update to 0.2.8
376
377* Wed Oct  3 2005 Ray Strode <rstrode@redhat.com> 0.2.6-1
378- update to 0.2.6
379
380* Wed Sep 28 2005 Ray Strode <rstrode@redhat.com> 0.2.4-1
381- update to 0.2.4
382
383* Fri Sep 02 2005 David Zeuthen <davidz@redhat.com> 0.2.3.1-1
384- Initial import based on an SRPM from Richard Hughes
385
Note: See TracBrowser for help on using the repository browser.