source: projects/specs/branches/6/g/gnome-phone-manager/gnome-phone-manager-vl.spec @ 2170

Revision 2170, 8.2 KB checked in by Takemikaduchi, 13 years ago (diff)

bluez,obexd:new upstream release, others:fix issue that package could not be installed

Line 
1Name:           gnome-phone-manager
2Summary:        Gnome Phone Manager
3Summary(ja): Gnome Phone マネージャー
4Version:        0.65
5Release:        2%{?_dist_release}
6License:        GPLv2+
7Group:          Applications/System
8Source:         http://ftp.gnome.org/pub/GNOME/sources/gnome-phone-manager/%{version}/%{name}-%{version}.tar.bz2
9URL:            http://usefulinc.com/software/phonemgr/
10#----------------------------------------------------------------------------
11
12BuildRoot:      %{_tmppath}/%{name}-%{version}-root
13
14#----------------------------------------------------------------------------
15
16BuildRequires:  gtk2-devel
17BuildRequires:  libgnomeui-devel
18BuildRequires:  libgnome-devel
19BuildRequires:  gnome-bluetooth-devel
20BuildRequires:  libbtctl-devel
21BuildRequires:  bluez-libs-devel
22
23BuildRequires:  gnokii-devel
24
25BuildRequires:  gstreamer-devel >= 0.10
26BuildRequires:  gnome-icon-theme >= 2.19.1
27# For libebook (evolution address book)
28BuildRequires:  evolution-data-server-devel
29BuildRequires:  gtkspell-devel
30BuildRequires:  telepathy-glib-devel
31BuildRequires:  libcanberra-devel
32
33# search telepathy
34# empathy - GNOME インスタントメッセージクラアイント
35# libtelepathy - Telepathy クライアントを簡単に記述するための GLibライブラリ
36# libtelepathy-devel - Development files for libtelepathy
37# telepathy-filesystem - Telepathy ファイルシステムレイアウト
38# telepathy-gabble - Jabber/XMPP 接続マネージャ
39# telepathy-glib - Telepathy の GLib バインディング
40# telepathy-glib-devel - Development files for telepathy-glib
41# telepathy-haze - マルチプロトコル Libpurple 接続マネージャ
42# telepathy-mission-control - Central control for Telepathy connection manager
43# telepathy-mission-control-devel - Development files for telepathy-mission-control
44# telepathy-salut - Link-local XMPP telepathy 接続マネージャ
45# telepathy-stream-engine - メディアストリーミングを扱うための Telepathy クライア ント
46
47BuildRequires:  perl(XML::Parser)
48BuildRequires:  gettext
49BuildRequires:  desktop-file-utils
50
51
52# https://bugzilla.redhat.com/show_bug.cgi?id=436773
53Patch0:         gpm-telepathy-workaround.patch
54
55#----------------------------------------------------------------------------
56%description
57This program will connect to your mobile phone over a serial port,
58either via a cable, infrared (IrDA) or Bluetooth connection.
59
60For example it listens for text messages, and when they arrive,
61displays them on the desktop. A visual indicator is displayed in
62the notification area, if one is presently added to the panel.
63
64#----------------------------------------------------------------------------
65%package telepathy
66Summary: Telepathy connection manager to send and receive SMSes
67Group: Applications/System
68
69%description telepathy
70This program will connect to your mobile phone over a serial port,
71either via a cable, infrared (IrDA) or Bluetooth connection.
72
73This plugin to Telepathy allows you to send and receive messages using any
74Instant Messaging application that uses Telepathy, such as Empathy.
75
76#----------------------------------------------------------------------------
77%prep
78%setup -q
79## %patch0 -p0
80
81%build
82%configure
83make %{?_smp_mflags}
84
85#----------------------------------------------------------------------------
86%install
87%{__rm} -rf $RPM_BUILD_ROOT
88make DESTDIR=$RPM_BUILD_ROOT install
89
90# This should be in empathy instead
91install -m0644 -D telepathy/sms.profile $RPM_BUILD_ROOT%{_datadir}/mission-control/profiles/sms.profile
92
93%find_lang %{name}
94desktop-file-install \
95  --delete-original \
96  --dir $RPM_BUILD_ROOT%{_datadir}/applications \
97  --add-category X-VineLinux \
98  $RPM_BUILD_ROOT%{_datadir}/applications/gnome-phone-manager.desktop
99
100%post
101export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
102gconftool-2 --makefile-install-rule \
103        %{_sysconfdir}/gconf/schemas/gnome-phone-manager.schemas        \
104        >& /dev/null || :
105
106%pre
107if [ "$1" -gt 1 ]; then
108    export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
109    gconftool-2 --makefile-uninstall-rule                               \
110        %{_sysconfdir}/gconf/schemas/gnome-phone-manager.schemas        \
111        >& /dev/null || :
112fi
113
114%preun
115if [ "$1" -eq 0 ]; then
116    export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
117    gconftool-2 --makefile-uninstall-rule                               \
118        %{_sysconfdir}/gconf/schemas/gnome-phone-manager.schemas        \
119        >& /dev/null || :
120fi
121
122%clean
123%{__rm} -rf $RPM_BUILD_ROOT
124
125%files -f %{name}.lang
126%defattr(-, root, root, -)
127%doc AUTHORS COPYING ChangeLog NEWS README TODO
128%{_sysconfdir}/gconf/schemas/gnome-phone-manager.schemas
129%{_bindir}/gnome-phone-manager
130%{_datadir}/applications/*.desktop
131%{_datadir}/gnome-phone-manager/
132%{_mandir}/man1/gnome-phone-manager.1.gz
133
134%files telepathy
135%{_libexecdir}/telepathy-phoney
136%{_datadir}/telepathy/managers/*
137%{_datadir}/dbus-1/services/*
138%{_datadir}/mission-control/profiles/*
139
140#----------------------------------------------------------------------------
141# Maintainers: babasaki@mindgear.org
142#
143#----------------------------------------------------------------------------
144%changelog
145* Wed Nov 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.65-2
146- rebuils with evolution-data-server-2.32.0 and gnome-bluetooth-2.32.0
147
148* Sat Jul 24 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.65-1
149- new upstream release
150- add BuildRequires: libcanberra-devel
151- drop Patch0
152
153* Mon Oct 27 2008 Seiichirou Babasaki - 0.60-4
154- Import gnome-phone-manager - Packager: Babasaki
155- Updated specfile
156
157#----------------------------------------------------------------------------
158* Tue Oct 07 2008 - Bastien Nocera <bnocera@redhat.com> - 0.60-3
159- Rebuild for new libgnokii
160
161* Thu Sep 11 2008  Matthias Clasen  <mclasen@redhat.com>
162- Rebuild
163
164* Wed Jun 11 2008 - Bastien Nocera <bnocera@redhat.com> - 0.60-1
165- Update to 0.60
166- Remove vendor from desktop file
167
168* Wed May 14 2008 - Bastien Nocera <bnocera@redhat.com> - 0.51-2
169- Rebuild
170
171* Fri Mar 21 2008 - Bastien Nocera <bnocera@redhat.com> - 0.51-1
172- Update to 0.51
173
174* Fri Mar 14 2008 - Bastien Nocera <bnocera@redhat.com> - 0.50-3
175- Add a patch from upstream to fix connection to serial devices (#356861)
176
177* Mon Mar 10 2008 - Bastien Nocera <bnocera@redhat.com> - 0.50-2
178- Work-around for telepathy brokeness
179
180* Mon Mar 10 2008 - Bastien Nocera <bnocera@redhat.com> - 0.50-1
181- Update to 0.50
182
183* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.40-3
184- Autorebuild for GCC 4.3
185
186* Wed Dec 12 2007 - Bastien Nocera <bnocera@redhat.com> - 0.40-2
187- Rebuild against new release of gnokii
188
189* Wed Nov 14 2007 - Bastien Nocera <bnocera@redhat.com> - 0.40-1
190- Update to 0.40
191- Add experimental telepathy backend in a subpackage
192
193* Mon Oct 29 2007 - Bastien Nocera <bnocera@redhat.com> - 0.30-1
194- Update to 0.30
195- Fix sending non-ASCII texts (for real)
196- Add debugging improvements
197
198* Wed Oct 17 2007 - Bastien Nocera <bnocera@redhat.com> - 0.20-1
199- Update to 0.20
200
201* Sun Aug 19 2007 - Bastien Nocera <bnocera@redhat.com> - 0.10-1
202- Update to 0.10 (#253400)
203- Remove obsolete work-arounds and dependencies
204- Update BRs
205- Add GConf scriptlets
206
207* Fri Aug 17 2007 Linus Walleij <triad@df.lth.se> 0.8-6
208- Update license field from GPL to GPLv2+
209
210* Sun Nov 15 2006 Linus Walleij <triad@df.lth.se> 0.8-5
211- Rebuild to pick up libbtctl i/f bump.
212
213* Sun Oct 29 2006 Linus Walleij <triad@df.lth.se> 0.8-4
214- Rebuild to pick up libedataserver i/f bump.
215
216* Sun Oct 8 2006 Linus Walleij <triad@df.lth.se> 0.8-3
217- Pick up intltool.
218
219* Sun Oct 8 2006 Linus Walleij <triad@df.lth.se> 0.8-2
220- Pick up libtool.
221
222* Sun Oct 8 2006 Linus Walleij <triad@df.lth.se> 0.8-1
223- New upstream version including patch.
224- The icon is an an even weirder place now!
225- Have to run som autotools on this one to get it working.
226
227* Tue Sep 5 2006 Linus Walleij <triad@df.lth.se> 0.7-5
228- Patch to compile with new version of E-D-S.
229
230* Thu Aug 10 2006 Linus Walleij <triad@df.lth.se> 0.7-4
231- Missing BR
232
233* Thu Aug 3 2006 Linus Walleij <triad@df.lth.se> 0.7-3
234- Updated after feedback from Chris Weyl
235- Bogus problem with cellphone.png icon image
236
237* Sat Jul 29 2006 Linus Walleij <triad@df.lth.se> 0.7-2
238- Updated after feedback from Parag and Paul
239
240* Tue Jun 27 2006 Linus Walleij <triad@df.lth.se> 0.7-1
241- 0.7 Release
242- Took Matthews nrpm package and Fedora Extrasificated it
243
244* Fri Sep 09 2005 Matthew Hall <matt@nrpms.net> 0.6-1
245- 0.6 Release
246
247* Mon Jun 20 2005 Matthew Hall <matt@nrpms.net> 0.4-1
248- 0.4 Release
Note: See TracBrowser for help on using the repository browser.