source: projects/specs/branches/6/g/gnome-mplayer/gnome-mplayer-vl.spec @ 7876

Revision 7876, 16.2 KB checked in by munepi, 11 years ago (diff)

new upstream release; added gmtk

Line 
1#TODO: Nautilus extention
2%global with_nautilus 0
3%global with_my_japo 0
4#% global svnrevision 2411
5#% global rcversion 1
6%global pretestversion a
7
8Name:           gnome-mplayer
9Version:        1.0.9
10Release:        1%{?pretestversion:.%pretestversion}%{?svnrevision:.svn%svnrevision}%{?_dist_release}
11Summary:        An MPlayer GUI, a full-featured binary
12Summary(ja):    高機能な MPlayer のグラフィカルユーザーインターフェース
13Group:          Applications/Multimedia
14License:        GPLv2+
15URL:            http://kdekorte.googlepages.com/gnomemplayer
16Source0:        http://gnome-mplayer.googlecode.com/files/%{name}-%{version}%{?pretestversion:%pretestversion}%{?svnrevision:.svn%svnrevision}%{?rcversion:.rc%rcversion}.tar.%{?svnrevision:xz}%{!?svnrevision:gz}
17Source10:       gnome-mplayer-snapshot.sh
18
19## vine
20%if %{with_my_japo}
21Source100:      gnome-mplayer-1.0.8a.svn2411-ja.po
22%endif
23
24BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
25
26BuildRequires:  gmtk-devel >= 1.0.7
27BuildRequires:  alsa-lib-devel
28BuildRequires:  pulseaudio-libs-devel
29BuildRequires:  dbus-glib-devel
30BuildRequires:  desktop-file-utils
31BuildRequires:  GConf2-devel
32BuildRequires:  gettext
33BuildRequires:  glib2-devel
34%if %{?_dist_release} == "vl7"
35BuildRequires:  gtk3-devel
36%else
37%if %{?_dist_release} == "vl6"
38BuildRequires:  gtk2-devel
39%endif
40%endif
41#BuildRequires:  libcurl-devel
42BuildRequires:  curl-devel
43BuildRequires:  libgpod-devel
44%if %{?_dist_release} != "vl5"
45BuildRequires:  libmusicbrainz3-devel
46%endif
47#BuildRequires:  libmusicbrainz-devel
48BuildRequires:  libnotify-devel
49BuildRequires:  libXScrnSaver-devel
50BuildRequires:  gnome-power-manager
51
52Requires:       gvfs-fuse
53Requires:       gnome-power-manager
54#Requires:       mencoder
55#Requires:       self-build-mplayer
56
57Requires(pre):  GConf2
58Requires(post): GConf2
59Requires(preun): GConf2
60
61Distribution:   Vine Linux
62Vendor:         Project Vine
63Packager:       munepi
64
65
66%description
67GNOME MPlayer is a simple GUI for MPlayer. It is intended to be a nice tight
68player and provide a simple and clean interface to MPlayer. GNOME MPlayer has
69a rich API that is exposed via DBus. Using DBus you can control a single or
70multiple instances of GNOME MPlayer from a single command.
71
72%description -l ja
73GNOME MPlayer は MPlayer のための簡単なグラフィカルユーザー
74インターフェースです。とても引き締まったていて,
75MPlayer への簡単でかつ明確なインターフェースを提供します.
76GNOME MPlayer は DBus 経由で公開されている豊富な API を持っています。
77DBus を使って,あなたは1つのコマンドから単一のあるいは複数の
78GNOME MPlayer のインスタンスを制御できます.
79
80gnome-mplayer を使うためには,mplayer が必要です.
81
82
83%if %{with_nautilus}
84%package nautilus
85Summary:        A Nautilus extention of %{name}
86Summary(ja):    %{name} の Nautilus 拡張
87Group:          Applications/Multimedia
88Requires:       %{name} = %{version}-%{release}
89Requires:       nautilus-extensions
90
91%description nautilus
92GNOME MPlayer is a simple GUI for MPlayer. It is intended to be a nice tight
93player and provide a simple and clean interface to MPlayer. GNOME MPlayer has
94a rich API that is exposed via DBus. Using DBus you can control a single or
95multiple instances of GNOME MPlayer from a single command.
96
97This package provides a nautilus extension, which shows properties of audio and
98video files in the properties dialogue.
99
100%description nautilus -l ja
101GNOME MPlayer は MPlayer のための簡単なグラフィカルユーザー
102インターフェースです。とても引き締まったていて,
103MPlayer への簡単でかつ明確なインターフェースを提供します.
104GNOME MPlayer は DBus 経由で公開されている豊富な API を持っています。
105DBus を使って,あなたは1つのコマンドから単一のあるいは複数の
106GNOME MPlayer のインスタンスを制御できます.
107
108このパッケージはプロパティダイアログ内でオーディオやビデオファイルの
109プロパティを示すに Nautilus 拡張を提供します.
110%endif
111
112%prep
113#% setup -q %{?rcversion:-n %{name}-%{version}.rc%{rcversion}}
114%setup -q %{?pretestversion:-n %{name}-%{version}%pretestversion}
115
116## vine
117%if %{with_my_japo}
118%__install -m644 %{SOURCE100} po/ja.po
119%endif
120
121
122%build
123%configure \
124    %if %{?_dist_release} == "vl7"
125    --enable-gtk3 \
126    %endif
127    %if !%{with_nautilus}
128    --disable-nautilus \
129    %endif
130    --disable-schemas-compile \
131    \
132    --with-dbus \
133    --with-alsa \
134    --with-pulseaudio \
135    --with-libnotify \
136    --with-libgpod \
137    %if %{?_dist_release} != "vl5"
138    --with-libmusicbrainz3 \
139    %endif
140    ;
141%__make %{?_smp_mflags}
142
143
144%install
145%__rm -rf $RPM_BUILD_ROOT
146
147export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
148%__make install DESTDIR=$RPM_BUILD_ROOT
149
150desktop-file-install --vendor=vine \
151       --delete-original --dir $RPM_BUILD_ROOT%{_datadir}/applications \
152       $RPM_BUILD_ROOT%{_datadir}/applications/%{name}.desktop
153
154%find_lang %{name}
155
156# remove intrusive docs
157%__rm -rf $RPM_BUILD_ROOT%{_docdir}/gnome-mplayer
158
159# remove unpackaged files
160find $RPM_BUILD_ROOT -name *.la -exec %__rm -f {} \;
161
162
163# %pre
164# if [ "$1" -gt 1 ]; then
165#     export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
166#     gconftool-2 --makefile-uninstall-rule \
167#       %{_sysconfdir}/gconf/schemas/gnome-mplayer.schemas >/dev/null || :
168#     # If the schema file has ever been renamed::
169#     #gconftool-2 --makefile-uninstall-rule \
170#     #  %{_sysconfdir}/gconf/schemas/[OLDNAME].schemas > /dev/null || :
171# fi
172
173
174%post
175touch --no-create %{_datadir}/icons/hicolor
176if [ -x %{_bindir}/gtk-update-icon-cache ]; then
177  %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
178fi
179update-desktop-database &> /dev/null || :
180
181# export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
182# gconftool-2 --makefile-install-rule \
183#   %{_sysconfdir}/gconf/schemas/gnome-mplayer.schemas > /dev/null || :
184
185%posttrans
186glib-compile-schemas %{_datadir}/glib-2.0/schemas &> /dev/null || :
187# update-desktop-database %{_datadir}/applications/
188
189# %preun
190# if [ "$1" -eq 0 ]; then
191#     export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
192#     gconftool-2 --makefile-uninstall-rule \
193#       %{_sysconfdir}/gconf/schemas/gnome-mplayer.schemas > /dev/null || :
194# fi
195
196%postun
197if [ $1 -eq 0 ]; then
198  glib-compile-schemas %{_datadir}/glib-2.0/schemas &> /dev/null || :
199  update-desktop-database %{_datadir}/applications/
200fi
201
202touch --no-create %{_datadir}/icons/hicolor
203if [ -x %{_bindir}/gtk-update-icon-cache ]; then
204  %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
205fi
206update-desktop-database &> /dev/null || :
207
208
209%clean
210%__rm -rf $RPM_BUILD_ROOT
211
212
213%files -f %{name}.lang
214%defattr(-,root,root,-)
215%{_bindir}/gnome-mplayer
216%{_datadir}/applications/*-gnome-mplayer.desktop
217%{_datadir}/gnome-control-center/default-apps/gnome-mplayer.xml
218%doc AUTHORS COPYING ChangeLog INSTALL NEWS README DOCS/* DOCS/tech/*
219# %{_sysconfdir}/gconf/schemas/gnome-mplayer.schemas
220%{_datadir}/glib-2.0/schemas/apps.gecko-mediaplayer.preferences.gschema.xml
221%{_datadir}/glib-2.0/schemas/apps.gnome-mplayer.preferences.enums.xml
222%{_datadir}/glib-2.0/schemas/apps.gnome-mplayer.preferences.gschema.xml
223%{_datadir}/icons/hicolor/*/apps/gnome-mplayer.*
224%{_mandir}/man1/gnome-mplayer.1.gz
225
226%if %{with_nautilus}
227%files nautilus
228%{_libdir}/nautilus/extensions-2.0/*.so.*
229%{_libdir}/nautilus/extensions-2.0/*.so
230%endif
231
232
233%changelog
234* Tue Sep 17 2013 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.9-1.a
235- updated to 1.0.9a; this is first alpha version
236
237* Thu Mar  7 2013 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.8-4
238- new upstream release
239
240* Wed Feb 20 2013 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.8-3.b
241- updated to 1.0.8b (beta)
242
243* Sun Feb 17 2013 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.8-2.a.svn2411
244- update to svn2411
245- updated ja.po: gnome-mplayer-1.0.8a.svn2411-ja.po
246
247* Fri Feb  1 2013 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.8-1.a.svn2398
248- update to svn2398
249- updated ja.po: gnome-mplayer-1.0.8a.svn2398-ja.po
250
251* Thu Nov  1 2012 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.7-1
252- new upstream release
253
254* Sat May 26 2012 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.6-4
255- dropped a wrapper of /usr/bin/gnome-mplayer
256
257* Mon Apr 16 2012 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.6-3
258- new upstream release
259
260* Thu Apr  5 2012 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.6-2.b1.svn2227
261- source 1.0.6b1 svn2227
262- updated ja.po
263
264* Sat Mar 24 2012 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.6-1.b1
265- new upstream release
266
267* Tue Feb 28 2012 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.5-3
268- updated ja.po
269
270* Sat Feb 25 2012 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.5-2
271- updated ja.po
272
273* Fri Dec 30 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.5-1
274- new upstream release
275
276* Sat Oct 15 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.5-1.b1.svn2180
277- source 1.0.5b1
278- updated ja.po
279- added BuildRequires: gmtk-devel >= 1.0.5
280  - dropped --disable-static from %%configure
281- enable gtk3 for vl7
282  - added BuildRequires: gtk3-devel
283  - added --enable-gtk3 in %%configure
284
285* Sun Sep 25 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.4-4
286- rebuilt with libnotify-0.7.4
287
288* Mon Jul 04 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.4-3
289- new upstream release
290
291* Fri Jun 10 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.4-2.b2
292- source 1.0.4b2
293
294* Sun Jun 05 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.4-1.b1.svn2124
295- source snapshot 1.0.4b1 r2124
296- use gsettings
297
298* Fri Apr 22 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.3-3
299- new upstream release
300
301* Tue Apr 19 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.3-2.beta.svn1992
302- source snapshot 1.0.3beta r1992
303
304* Sun Apr 17 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.3-1.beta.svn1989
305- source snapshot 1.0.3beta r1989
306  - added --disable-schemas-compile in configure options
307  - use GSettings (%%posttrans, %%postun)
308- updated Japanese translation (gnome-mplayer-1.0.3beta.svn1989-ja.po)
309
310* Tue Mar 08 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.1-2
311- new upstream release
312
313* Wed Mar 02 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.1-1.b1.svn1912
314- source snapshot 1.0.1b1 r1912
315
316* Thu Feb 24 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.1-1.b1.svn1892
317- source snapshot 1.0.1b1 r1892
318- added BuildRequires: pulseaudio-libs-devel
319
320* Sat Nov 06 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.0-1
321- new upstream release
322- added BuildRequires:
323  - libmusicbrainz3-devel (only vl6)
324  - gnome-power-manager
325- added Requires: gnome-power-manager
326
327* Tue Oct 12 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.9.99-2.rc3
328- source 0.9.99.rc3
329
330* Fri Aug 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.9.99-1.rc1
331- source 0.9.99.rc1
332  - applied gnome-mplayer-0.9.99.rc1-ja.po
333  - entry ja in gnome-mplayer.desktop
334
335* Mon Jun 28 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.9.9.2-5.svn1729
336- source snapshot r1729
337
338* Sat Apr 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.9.9.2-4.svn1685
339- fixed gnome-mplayer.sh.in
340
341* Sat Apr 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.9.9.2-3.svn1685
342- source snapshot r1685
343- added gnome-mplayer.sh.in
344  - this script is a wrapper to check MPlayer binary existance
345
346* Tue Mar 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.9.9.2-2.svn1673
347- source snapshot r1673
348  - Rework vdpau codec selection and deinterlace (r1673)
349
350* Thu Mar 04 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.9.9.2-1
351- new upstream release
352
353* Sat Feb 06 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.9.9-4
354- new upstream release
355- added gnome-mplayer-snapshot.sh
356
357* Sat Jan 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.9.9-2.svn1619
358- source snapshot r1619
359- added gnome-mplayer-0.9.9.svn1619-ja.po
360
361* Mon Dec 14 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.9.9-1.svn1599
362- source snapshot r1599
363- added BuildRequires: libXScrnSaver-devel
364
365* Sun Nov 01 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.9.9-1.svn1583
366- source snapshot r1583
367- dropped gnome-mplayer-0.9.8-fix-hidden-cursor-over-menus.patch
368
369* Sun Nov 01 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.9.8-4
370- applied gnome-mplayer-0.9.8-fix-hidden-cursor-over-menus.patch
371  - fix hidden cursor over menus (r1576)
372
373* Sat Sep 19 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.9.8-3
374- new upstream release
375
376* Tue Sep 15 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.9.8-2.svn1540
377- source snapshot r1540
378
379* Mon Sep 14 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.9.8-1.svn1538
380- source snapshot r1538
381  - updated the latest up-to-date ja.po
382
383* Sat Aug 22 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.9.7-3
384- new upstream release
385
386* Fri Aug 07 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.9.7-2.svn1493
387- source snapshot r1493
388
389* Fri Aug 07 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.9.7-1.svn1486
390- source snapshot r1486
391  - updated the latest up-to-date ja.po
392- added gtk-update-icon-cache actions in %%post, %%postun
393
394* Wed Jun 10 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6-2
395- rebuild with libgpod-0.7.2
396- gconf uninstall rule in %%preun, not %%postun
397
398* Sat Jun 06 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.9.6-1
399- new upstream release
400
401* Thu May 27 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.9.5-4.svn1298
402- source snapshot r1298
403  - updated the latest up-to-date ja.po
404
405* Sat Apr 25 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.9.5-3.svn1236
406- dropped Requires: self-build-mplayer
407
408* Sat Mar 28 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.9.5-2.svn1236
409- source snapshot r1236
410- updated the latest up-to-date ja.po
411
412* Sun Mar 15 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.9.5-1
413- new upstream release
414
415* Fri Mar 06 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.9.4-4.r1184
416- dropped a Nautilus plugin once
417
418* Fri Mar 06 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.9.4-3.r1184
419- source snapshot r1184
420- dropped gnome-mplayer-0.9.4-ja.patch
421  - committed Japanese translation
422- applied gnome-mplayer-0.9.4.r1184-ja.po
423  - update the latest up-to-date ja.po
424
425* Fri Feb 06 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.9.4-2
426- added Summary(ja), %%description -l ja
427- updated gnome-mplayer-0.9.4-ja.patch
428
429* Fri Feb 06 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.9.4-1
430- new upstream release
431- updated gnome-mplayer-0.9.4-ja.patch
432- updated gnome-mplayer-0.9.4-ja.po
433- updated the URL tag
434
435* Sun Feb 01 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.9.3-1
436- initial build
437- added ja.po
438
439* Thu Jan  8 2009 Julian Sikorski <belegdol[at]gmail[dot]com> - 0.9.3-2
440- Added patch fixing rpmfusion bug #238 from SVN
441- Made the dependencies between packages stricter (%%{version} → %%{version}-%%{release})
442
443* Sat Jan  3 2009 Julian Sikorski <belegdol[at]gmail[dot]com> - 0.9.3-1
444- Updated to 0.9.3
445
446* Mon Nov 24 2008 Julian Sikorski <belegdol[at]gmail[dot]com> - 0.9.2-2
447- Refactored the spec to allow building both minimal and full-featured versions
448- s/gnome-mplayer-core-functionality/gnome-mplayer-binary
449
450* Sat Nov 22 2008 Julian Sikorski <belegdol[at]gmail[dot]com> - 0.9.2-1
451- Updated to 0.9.2
452- Added libcurl-devel, libgpod-devel and libmusicbrainz3-devel to BuildRequires
453- Provide gnome-mplayer-core-functionality
454
455* Sun Nov  2 2008 Julian Sikorski <belegdol[at]gmail[dot]com> - 0.9.1-1
456- Updated to 0.9.1
457
458* Fri Oct 31 2008 Julian Sikorski <belegdol[at]gmail[dot]com> - 0.9.0-1
459- Updated to 0.9.0
460- Added libnotify-devel to BuildRequires
461- Added gvfs-fuse to Requires
462
463* Mon Sep 29 2008 Julian Sikorski <belegdol[at]gmail[dot]com> - 0.8.0-1.1
464- Updated to 0.8.0
465
466* Sat Sep  6 2008 Julian Sikorski <belegdol[at]gmail[dot]com> - 0.7.0-2.1
467- Added alsa-lib-devel to BuildRequires (livna bug #2084)
468
469* Sun Aug 17 2008 Julian Sikorski <belegdol[at]gmail[dot]com> - 0.7.0-1.1
470- Updated to 0.7.0
471
472* Wed Jul 30 2008 Thorsten Leemhuis <fedora [AT] leemhuis [DOT] info - 0.6.3-2
473- rebuild for buildsys cflags issue
474
475* Sun Jul  6 2008 Julian Sikorski <belegdol[at]gmail[dot]com> - 0.6.3-1
476- Updated to 0.6.3
477
478* Tue Jun 10 2008 Julian Sikorski <belegdol[at]gmail[dot]com> - 0.6.2-2
479- Added mencoder to Requires (bug #1991)
480
481* Wed May 28 2008 Julian Sikorski <belegdol[at]gmail[dot]com> - 0.6.2-1
482- Updated to 0.6.2
483
484* Thu Apr 17 2008 Julian Sikorski <belegdol[at]gmail[dot]com> - 0.6.1-1
485- Updated to 0.6.1
486- Updated URL and Source0
487
488* Wed Feb 13 2008 Julian Sikorski <belegdol[at]gmail[dot]com> - 0.6.0-1
489- Initial rpmfusion release
Note: See TracBrowser for help on using the repository browser.