source: projects/specs/branches/6/g/gnome-media/gnome-media-vl.spec @ 2041

Revision 2041, 14.2 KB checked in by Takemikaduchi, 13 years ago (diff)

update to GNOME-2.32.0

Line 
1%define glib2_version 2.26.0
2%define pango_version 1.28.3
3%define gtk2_version 2.22.0
4%define gconf2_version 2.32.0
5%define pa_version 0.9.15
6%define canberra_version 0.25
7%define gstreamer_version 0.10.30
8%define unique_version 1.0.0
9%define desktop_file_utils_version 0.16
10%define gnome_doc_utils_version 0.3.2
11
12%define gettext_package gnome-media-2.0
13
14Summary:        GNOME media programs.
15Name:           gnome-media
16Version:        2.32.0
17Release:        1%{?_dist_release}
18License:        GPL
19Group:          Applications/Multimedia
20Source:         ftp://ftp.gnome.org/pub/GNOME/sources/gnome-media/2.32/gnome-media-%{version}.tar.bz2
21
22BuildRoot:      %{_tmppath}/%{name}-%{version}-root
23Obsoletes:      gnome
24URL:            http://www.gnome.org
25
26Requires(post,postun): scrollkeeper >= 0.1.4
27Requires(post,pre,preun): GConf2 >= 2.14
28BuildRequires:  intltool
29BuildRequires:  glib2-devel >= %{glib2_version}
30BuildRequires:  pango-devel >= %{pango_version}
31BuildRequires:  gtk2-devel >= %{gtk2_version}
32BuildRequires:  GConf2-devel >= %{gconf2_version}
33BuildRequires:  pulseaudio-libs-devel >= %{pa_version}
34BuildRequires:  libcanberra-devel >= %{canberra_version}
35BuildRequires:  gstreamer-devel >= %{gstreamer_version}
36BuildRequires:  gstreamer-plugins-base-devel >= %{gstreamer_version}
37BuildRequires:  unique-devel >= %{unique_version}
38BuildRequires:  desktop-file-utils >= %{desktop_file_utils_version}
39BuildRequires:  gnome-doc-utils >= %{gnome_doc_utils_version}
40
41%description
42GNOME (GNU Network Object Model Environment) is a user-friendly set of
43GUI applications and desktop tools to be used in conjunction with a
44window manager for the X Window System. The gnome-media package will
45install media features like the GNOME CD player.
46
47Install gnome-media if you want to use GNOME's multimedia
48capabilities.
49
50%package        devel
51Summary:        Development tools for gnome-media applications.
52Summary(ja):    gnome-media アプリケーションの開発用ファイル
53Group:          Development/Libraries
54Requires:       %{name} = %{version}-%{release}
55Requires:       pkgconfig
56Requires:       GConf2-devel
57Requires:       gtk2-devel
58
59%description devel
60Header files and libraries for building a extension library for the gnome-media.
61
62%prep
63%setup -q
64
65%build
66/usr/bin/gst-inspect-0.10 --print-all > /dev/null
67%configure \
68  --disable-schemas-install --disable-scrollkeeper
69make %{?_smp_mflags}
70
71%install
72rm -rf $RPM_BUILD_ROOT
73
74%makeinstall
75
76## show in all
77desktop-file-install --vendor "" --delete-original       \
78  --dir $RPM_BUILD_ROOT%{_datadir}/applications             \
79  $RPM_BUILD_ROOT%{_datadir}/applications/gstreamer-properties.desktop
80
81desktop-file-install --vendor gnome --delete-original       \
82  --dir $RPM_BUILD_ROOT%{_datadir}/applications             \
83  $RPM_BUILD_ROOT%{_datadir}/applications/gnome-sound-recorder.desktop
84 
85rm -f $RPM_BUILD_ROOT%{_datadir}/applications/vumeter.desktop
86rm -f $RPM_BUILD_ROOT%{_datadir}/applications/reclevel.desktop
87rm -f $RPM_BUILD_ROOT%{_bindir}/vumeter
88
89rm -rf $RPM_BUILD_ROOT%{_libdir}/lib*.*a
90rm -rf $RPM_BUILD_ROOT/var/scrollkeeper
91rm -rf $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/icon-theme.cache
92
93%find_lang %{gettext_package} --all-name --with-gnome
94
95# save space by linking identical images in translated docs
96for helpdir in $RPM_BUILD_ROOT%{_datadir}/gnome/help/*; do
97  for f in $helpdir/C/figures/*.png; do
98    b="$(basename $f)"
99    for d in $helpdir/*; do
100      if [ -d "$d" -a "$d" != "$helpdir/C" ]; then
101        g="$d/figures/$b"
102        if [ -f "$g" ]; then
103          if cmp -s $f $g; then
104            rm "$g"; ln -s "../../C/figures/$b" "$g"
105          fi
106        fi
107      fi
108    done
109  done
110done
111
112%clean
113rm -rf $RPM_BUILD_ROOT
114
115%post
116scrollkeeper-update > /dev/null 2>&1 || :
117export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
118gconftool-2 --makefile-install-rule \
119    %{_sysconfdir}/gconf/schemas/gnome-audio-profiles.schemas \
120    %{_sysconfdir}/gconf/schemas/gnome-sound-recorder.schemas \
121    > /dev/null || :
122/sbin/ldconfig
123touch --no-create %{_datadir}/icons/hicolor
124if [ -x /usr/bin/gtk-update-icon-cache ]; then
125  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
126fi
127 
128%pre
129if [ "$1" -gt 1 ]; then
130  export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
131  if [ -f %{_sysconfdir}/gconf/schemas/gnome-cd.schemas ] ; then
132    gconftool-2 --makefile-uninstall-rule \
133      %{_sysconfdir}/gconf/schemas/gnome-cd.schemas \
134      %{_sysconfdir}/gconf/schemas/CDDB-Slave2.schemas \
135      > /dev/null || :
136  fi
137  if [ -f %{_sysconfdir}/gconf/schemas/gnome-sound-recorder.schemas ] ; then
138    gconftool-2 --makefile-uninstall-rule \
139      %{_sysconfdir}/gconf/schemas/gnome-sound-recorder.schemas \
140      > /dev/null || :
141  fi
142  if [ -f %{_sysconfdir}/gconf/schemas/gnome-volume-control.schemas ] ; then
143    gconftool-2 --makefile-uninstall-rule \
144      %{_sysconfdir}/gconf/schemas/gnome-volume-control.schemas \
145      > /dev/null || :
146  fi
147  gconftool-2 --makefile-uninstall-rule \
148    %{_sysconfdir}/gconf/schemas/gnome-audio-profiles.schemas \
149    > /dev/null || :
150fi
151
152%preun
153if [ "$1" -eq 0 ]; then
154  export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
155  if [ -f %{_sysconfdir}/gconf/schemas/gnome-cd.schemas ] ; then
156    gconftool-2 --makefile-uninstall-rule \
157      %{_sysconfdir}/gconf/schemas/gnome-cd.schemas \
158      %{_sysconfdir}/gconf/schemas/CDDB-Slave2.schemas \
159      > /dev/null || :
160  fi
161  if [ -f %{_sysconfdir}/gconf/schemas/gnome-sound-recorder.schemas ] ; then
162    gconftool-2 --makefile-uninstall-rule \
163      %{_sysconfdir}/gconf/schemas/gnome-sound-recorder.schemas \
164      > /dev/null || :
165  fi
166  if [ -f %{_sysconfdir}/gconf/schemas/gnome-volume-control.schemas ] ; then
167    gconftool-2 --makefile-uninstall-rule \
168      %{_sysconfdir}/gconf/schemas/gnome-volume-control.schemas \
169      > /dev/null || :
170  fi
171  gconftool-2 --makefile-uninstall-rule \
172    %{_sysconfdir}/gconf/schemas/gnome-audio-profiles.schemas \
173    > /dev/null || :
174fi
175
176%postun
177scrollkeeper-update -q || :
178/sbin/ldconfig
179touch --no-create %{_datadir}/icons/hicolor
180if [ -x /usr/bin/gtk-update-icon-cache ]; then
181  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
182fi
183 
184
185%files -f %{gettext_package}.lang
186%defattr(-, root, root)
187%doc AUTHORS COPYING* NEWS README
188
189%{_sysconfdir}/gconf/schemas/*.schemas
190%{_sysconfdir}/xdg/autostart/gnome-volume-control-applet.desktop
191
192%{_datadir}/applications/*
193%{_datadir}/gnome-media
194%{_datadir}/gnome-sound-recorder
195%{_datadir}/gstreamer-properties
196%{_datadir}/icons/hicolor/*/apps/*
197%{_datadir}/sounds/gnome/default/alerts/*
198
199%{_libdir}/*.so.*
200%{_bindir}/*
201
202%files devel
203%{_includedir}/*
204%{_libdir}/*.so
205%{_libdir}/pkgconfig/*
206
207%changelog
208* Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0-1
209- new upstream release
210- remove BuildRequires: libgnomeui-devel
211
212* Thu Sep 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-3
213- rebuild with rpm-4.8.1 for pkg-config file
214
215* Sun Aug 29 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-2
216- add gnome-media-devel package
217
218* Wed Mar 31 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
219- new upstream release
220- remove BuildRequires: libglade2-deveL
221
222* Sun Feb 28 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.5-1
223- new upstream release
224- add BuildRequires: gnome-doc-utils
225
226* Sun Nov  1 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.1-1
227- new upstream release
228
229* Tue Mar 24 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-3
230- fix %%post/%%pre/%%preun
231  - gnome-volume-control is removed
232
233* Mon Mar 23 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.26.0-2
234- add BuildRequires: unique-devel
235
236* Sun Mar 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
237- new upstream release
238
239* Thu Sep 25 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0.1-1
240- new upstream release
241- drop gnome-cd
242- add gnome-sound-recorder
243
244* Sun Apr  6 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.0-1vl5
245- new upstream release
246- dropped Patch1 (merged into upstream)
247
248* Mon Jan 14 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.20.1-0vl1
249- new upstream release
250- added Patch0 and 1 from Fedora
251  * Wed Oct 17 2007 - Bastien Nocera <bnocera@redhat.com> - 2.20.1-3
252  - Show the "Front" track by default (#335121)
253  * Wed Oct 10 2007 - Bastien Nocera <bnocera@redhat.com> - 2.20.1-2
254  - Install the schema for the mixer properly (#186791)
255
256* Sat Apr 28 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.0-0vl1
257- new upstream release
258
259* Sat Dec 23 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.14.2-0vl2
260- add Requires: gstreamer-plugins-base instead of libgstcdparanoia.so
261
262* Sun Jun 04 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.2-0vl1
263- new upstream release
264
265* Tue Mar 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl1
266- new upstream release
267
268* Tue Mar 07 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.93-0vl1
269- new upstream release
270
271* Mon Sep 19 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.0-0vl1
272- new upstream release
273
274* Wed May 11 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.10.2-0vl2
275- added Requires: libgstcdparanoia.so
276
277* Sun May  8 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.10.2-0vl1
278- new upstream release
279- added BuildRequires: gstreamer-plugins-devel
280
281* Mon Apr 11 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.1-0vl1
282- new upstream release
283
284* Mon Mar 21 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl1
285- new upstream version
286
287* Thu Nov 11 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.0-0vl1
288- new upstream release
289
290* Tue Dec  9 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.4.1.1-0vl1
291- new upstream release
292- s/Copyright/License/
293
294* Thu Sep 11 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl1
295- new upstream release
296
297* Thu Sep 04 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.90-0vl1
298- new upstream release
299
300* Tue Jun 10 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.3-0vl1
301- new upstream release
302
303* Sat Feb 22 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.1.1-0vl1
304- new upstream release
305
306* Sat Jan 25 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl1
307- new upstream release
308
309* Fri Jan 24 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl2
310- rebuild with gstreamer-0.5.2
311
312* Sat Jan 18 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl1
313- new upstream release
314- build for Vine Linux
315
316* Tue Aug 27 2002 Owen Taylor <otaylor@redhat.com>
317- Fix bug with changing device in preferences (#72465)
318- Make the operation of --unique per-device
319
320* Fri Aug 23 2002 Owen Taylor <otaylor@redhat.com>
321- Add --unique option to allow starting only one CD player
322  per display. (#39208)
323
324* Wed Aug 21 2002 Havoc Pennington <hp@redhat.com>
325- remove gnome-reclevel.desktop that was another alias for vumeter #71916
326
327* Wed Aug 14 2002 Havoc Pennington <hp@redhat.com>
328- remove vumeter, #67140
329
330* Mon Jul 29 2002 Havoc Pennington <hp@redhat.com>
331- rebuild with new gail
332
333* Thu Jul 25 2002 Havoc Pennington <hp@redhat.com>
334- put translations in, makes it rebuild #69404
335
336* Sun Jun 16 2002 Havoc Pennington <hp@redhat.com>
337- 2.0.0
338- install capplet control center file, though I may
339  take it out again since it sucks
340- use desktop-file-install
341- add omf to file list
342
343* Fri Jun 07 2002 Havoc Pennington <hp@redhat.com>
344- rebuild in different environment
345
346* Wed Jun  5 2002 Havoc Pennington <hp@redhat.com>
347- add post/postun ldconfig
348- rebuild with latest libs
349
350* Tue May 21 2002 Havoc Pennington <hp@redhat.com>
351- rebuild in different environment
352
353* Tue May 21 2002 Havoc Pennington <hp@redhat.com>
354- rebuild in different environment
355- buildrequire gail
356
357* Tue May 21 2002 Havoc Pennington <hp@redhat.com>
358- 1.547.0
359
360* Fri May 03 2002 Havoc Pennington <hp@redhat.com>
361- rebuild with new libs
362
363* Thu Apr 25 2002 Havoc Pennington <hp@redhat.com>
364- GNOME 2 version 1.520.2
365
366* Wed Aug 22 2001 Owen Taylor <otaylor@redhat.com>
367- Force regeneration of .po files (#52326)
368
369* Thu Jul 19 2001 Havoc Pennington <hp@redhat.com>
370- build requires gnome-libs-devel
371- fix rpmlint's utterly crack-smoking request that we not
372  run /bin/sh in post/postun
373
374* Tue Jul 03 2001 Owen Taylor <otaylor@redhat.com>
375- Update to 1.2.3
376
377* Sun Jun 24 2001 Elliot Lee <sopwith@redhat.com>
378- Bump release + rebuild.
379
380* Wed May  9 2001 Owen Taylor <otaylor@redhat.com>
381- Version 1.2.2
382- Fix bogus scrollkeeper version in dependency
383
384* Fri Feb 23 2001 Trond Eivind Glomsr藷?<teg@redhat.com>
385- langify
386- move changelog to end of file
387- don't use and define "ver" at the top of the spec file
388
389* Tue Feb 07 2001 Than Ngo <than@redhat.com>
390- fixed non-standard dir perm (Bug #26264)
391
392* Wed Jan 31 2001 Elliot Lee <sopwith@redhat.com> 1.2.0-10
393- Fix bug #17713, grecord internals (Patch10)
394
395* Tue Jan 30 2001 Elliot Lee <sopwith@redhat.com> 1.2.0-9
396- Fix bug #21488, include cddb-submit-methods in file list
397
398* Thu Jan 18 2001 Akira TAGOH <tagoh@redhat.com>
399- Added Japanese patch.
400
401* Fri Aug 11 2000 Jonathan Blandford <jrb@redhat.com>
402- Update Epoch
403
404* Sat Aug 05 2000 Havoc Pennington <hp@redhat.com>
405- Find "sox", bug 15472, patch from Alan
406
407* Fri Aug 04 2000 Havoc Pennington <hp@redhat.com>
408- Add docs for gtcd, bug 14558
409
410* Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
411- automatic rebuild
412
413* Sat Jul 8 2000 Havoc Pennington <hp@redhat.com>
414- Remove docdir
415
416* Thu Jun 15 2000 Havoc Pennington <hp@redhat.com>
417- 1.2.0
418- use %%makeinstall
419
420* Tue Sep 21 1999 Havoc Pennington <hp@redhat.com>
421- Fixed gtcd so it works without corba-gtcd
422- add DrMike's no-g_error() patch
423
424* Mon Sep 20 1999 Elliot Lee <sopwith@redhat.com>
425- Update to 1.0.40
426
427* Fri Sep 17 1999 Owen Taylor <otaylor@redhat.com>
428- Don't keep device open in gtcd
429
430* Thu Sep 9 1999 Owen Taylor <otaylor@redhat.com>
431- Fixed warnings with previous
432
433* Wed Sep 8 1999 Owen Taylor <otaylor@redhat.com>
434- added --play option to gtcd
435
436* Mon Aug 16 1999 Michael Fulbright <drmike@redhat.com>
437- version 1.0.9.1
438
439* Fri Mar 19 1999 Michael Fulbright <drmike@redhat.com>
440- strip binaries
441
442* Mon Feb 15 1999 Michael Fulbright <drmike@redhat.com>
443- version 0.99.8
444
445* Tue Jan 19 1999 Michael Fulbright <drmike@redhat.com>
446- fixed building on sparc and RH 5.2 - seems to get confused into thinking
447  we have cd changer support when we don't
448
449* Wed Jan 06 1999 Michael Fulbright <drmike@redhat.com>
450- updated to 0.99.1
451
452* Wed Dec 16 1998 Michael Fulbright <drmike@redhat.com>
453- updated for GNOME freeze
454
455* Sat Nov 21 1998 Pablo Saratxaga <srtxg@chanae.alphanet.ch>
456- added spanish and french translations for rpm
457
458* Wed Sep 23 1998 Michael Fulbright <msf@redhat.com>
459- Updated to 0.30 release
460
461* Mon Mar 16 1998 Marc Ewing <marc@redhat.com>
462- Integrate into gnome-media CVS source tree
Note: See TracBrowser for help on using the repository browser.