source: projects/specs/branches/6/g/gnome-keyring/gnome-keyring-vl.spec @ 2219

Revision 2219, 9.0 KB checked in by Takemikaduchi, 13 years ago (diff)

new upstream release

Line 
1%define gtk2_version 2.22.0
2%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
3
4Summary: A framework for managing user passwords and other secrets
5Summary(ja): ユーザのパスワードや秘匿情報を管理するためのフレームワーク
6Name: gnome-keyring
7Version: 2.32.1
8Release: 1%{?_dist_release}
9License: GPL/LGPL
10Group: System Environment/Libraries
11Source: gnome-keyring-%{version}.tar.bz2
12URL: http://www.gnome.org
13BuildRoot: %{_tmppath}/%{name}-%{version}-root
14Requires: gtk2 >= %{gtk2_version}
15Requires(post,pre,preun): GConf2
16BuildRequires: gtk2-devel >= %{gtk2_version}
17BuildRequires: GConf2-devel >= 1.0
18BuildRequires: dbus-devel >= 1.0
19BuildRequires: gettext
20BuildRequires: libgcrypt-devel
21BuildRequires: libtasn1-devel
22BuildRequires: pam-devel
23BuildRequires: autoconf, automake, libtool
24BuildRequires: intltool
25BuildRequires: perl(XML::Parser)
26
27# http://bugzilla.gnome.org/show_bug.cgi?id=484612
28Patch0:    gnome-keyring-2.20-selinux-pam.patch
29
30# autounlock does not currently work, see
31# https://bugzilla.redhat.com/show_bug.cgi?id=250147
32Patch1: no-autounlock.patch
33
34# patch for vine linux
35Patch2: %{name}-2.31.91-configure-vine.patch
36
37%description
38gnome-keyring manages passwords and other types of secrets
39for the user, storing them encrypted with a main password.
40Applications can use the gnome-keyring library to integrate
41with the keyring.
42
43%package devel
44Summary: The files needed for gnome-keyring application development.
45Group: Development/Libraries
46Requires: %{name} = %{version}-%{release}
47Requires: glib2-devel
48
49%description devel
50The gnome-keyring-devel package contains the libraries and
51include files that you can use to develop applications that
52use gnome-keyring.
53
54%package pam
55Summary: A pam module for unlocking keyrings at login time
56License: LGPLv2+
57Group: System Environment/Libraries
58Requires: %{name} = %{version}-%{release}
59# for /lib/security
60Requires: pam
61
62%description pam
63The gnome-keyring-pam package contains a pam module that can
64automatically unlock the "login" keyring when the user logs in
65and start the keyring daemon.
66
67# compat32
68%package -n compat32-%{name}
69Summary: A framework for managing user passwords and other secrets
70Summary(ja): ユーザのパスワードや秘匿情報を管理するためのフレームワーク
71Group: System Environment/Libraries
72Requires: %{name} = %{version}-%{release}
73
74%description -n compat32-%{name}
75gnome-keyring manages passwords and other types of secrets
76for the user, storing them encrypted with a main password.
77Applications can use the gnome-keyring library to integrate
78with the keyring.
79
80%package -n compat32-%{name}-devel
81Summary: The files needed for gnome-keyring application development.
82Group: Development/Libraries
83Requires: %{name}-devel = %{version}-%{release}
84Requires: compat32-%{name} = %{version}-%{release}
85Requires: compat32-glib2-devel
86
87%description -n compat32-%{name}-devel
88The gnome-keyring-devel package contains the libraries and
89include files that you can use to develop applications that
90use gnome-keyring.
91
92%package -n compat32-%{name}-pam
93Summary: A pam module for unlocking keyrings at login time
94License: LGPLv2+
95Group: System Environment/Libraries
96Requires: %{name}-pam = %{version}-%{release}
97Requires: compat32-%{name} = %{version}-%{release}
98# for /lib/security
99Requires: compat32-pam
100
101%description -n compat32-%{name}-pam
102The gnome-keyring-pam package contains a pam module that can
103automatically unlock the "login" keyring when the user logs in
104and start the keyring daemon.
105
106%prep
107%setup -q -n gnome-keyring-%{version}
108
109#patch0 -p1 -b .selinux_pam
110#patch1 -p1 -b .no-autounlock
111%patch2 -p1 -b .vine
112
113%build
114%configure --disable-gtk-doc --enable-pam --with-pam-dir=/%{_lib}/security
115make %{?_smp_mflags}
116
117%install
118rm -rf $RPM_BUILD_ROOT
119make install install-pam DESTDIR=$RPM_BUILD_ROOT
120
121rm -f $RPM_BUILD_ROOT%{_libdir}/pam_gnome_keyring.so
122
123%find_lang %{name}
124
125rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
126rm -f $RPM_BUILD_ROOT%{_libdir}/gnome-keyring/*.la
127rm -f $RPM_BUILD_ROOT%{_libdir}/gnome-keyring/*/*.la
128rm -f $RPM_BUILD_ROOT/%{_lib}/security/*.la
129
130%clean
131rm -rf $RPM_BUILD_ROOT
132
133%post -p /sbin/ldconfig
134
135%postun
136/sbin/ldconfig
137if [ $1 -eq 0 ]; then
138       glib-compile-schemas %{_datadir}/glib-2.0/schemas
139fi
140
141%posttrans
142glib-compile-schemas %{_datadir}/glib-2.0/schemas
143
144%post -n compat32-%{name} -p /sbin/ldconfig
145
146%postun -n compat32-%{name} -p /sbin/ldconfig
147
148%files -f %{name}.lang
149%defattr(-, root, root)
150%doc AUTHORS NEWS README COPYING COPYING.LIB
151%{_sysconfdir}/xdg/autostart/gnome-keyring-pkcs11.desktop
152%{_sysconfdir}/xdg/autostart/gnome-keyring-secrets.desktop
153%{_sysconfdir}/xdg/autostart/gnome-keyring-ssh.desktop
154%{_sysconfdir}/xdg/autostart/gnome-keyring-gpg.desktop
155%{_bindir}/*
156%{_libdir}/lib*.so.*
157%dir %{_libdir}/gnome-keyring
158%{_libdir}/gnome-keyring/*.so
159%{_libdir}/gnome-keyring/devel/*.so
160%{_libdir}/gnome-keyring/standalone/*.so
161%{_libexecdir}/*
162%{_datadir}/dbus-1/services/*
163%{_datadir}/gnome-keyring
164%dir %{_datadir}/gcr
165%{_datadir}/gcr/ui/*.ui
166%{_datadir}/GConf/gsettings/*
167%{_datadir}/glib-2.0/schemas/*
168
169%files devel
170%defattr(-, root, root)
171%{_libdir}/lib*.so
172%{_libdir}/pkgconfig/*
173%{_includedir}/*
174## %{_datadir}/gtk-doc/html/gnome-keyring
175%{_datadir}/gtk-doc/html/gp11
176%{_datadir}/gtk-doc/html/gcr-0
177
178%files pam
179%defattr(-, root, root)
180/%{_lib}/security/*.so
181
182# compat32
183%if %{build_compat32}
184%files -n compat32-%{name}
185%defattr(-, root, root)
186%{_libdir}/lib*.so.*
187%dir %{_libdir}/gnome-keyring
188%{_libdir}/gnome-keyring/*.so
189%{_libdir}/gnome-keyring/devel/*.so
190%{_libdir}/gnome-keyring/standalone/*.so
191
192%files -n compat32-%{name}-devel
193%defattr(-, root, root)
194%{_libdir}/lib*.so
195%{_libdir}/pkgconfig/*
196
197%files -n compat32-%{name}-pam
198%defattr(-, root, root)
199/%{_lib}/security/*.so
200%endif
201
202%changelog
203* Sat Nov 20 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.1-1
204- new upstream release
205
206* Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0-1
207- new upstream release
208- add configure option (--enable-pam)
209- remove configure option (--disable-schemas-install)
210- add Patch2 (%{name}-2.31.91-configure-vine.patch)
211
212* Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 2.30.3-2
213- build with rpm-4.8.1-1 for pkg-config file
214
215* Sat Jun 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.3-1
216- new upstream release
217
218* Sat May 01 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-1
219- new upstream release
220
221* Wed Mar 31 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
222- new upstream release
223- remove BuildRequires: hal-devel
224
225* Sun Mar 14 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.2-1
226- new upstream release
227- add BuildRequires: GConf2-devel
228
229* Sat Oct 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.1-1
230- new upstream release
231
232* Sun Jul 12 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.26.3-2
233- added compat32 package for x86_64 arch support
234
235* Sat Jul 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.3-1
236- new upstream release
237
238* Sat Apr 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.1-1
239- new upstream release
240
241* Mon Mar 23 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
242- new upstream release
243
244* Wed Oct 28 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.1-1
245- new upstream release
246
247* Tue Sep 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
248- new upstream release
249
250* Sat May 31 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.2-1
251- new upstream release
252
253* Wed Apr  9 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1-1vl5
254- new upstream release
255
256* Sat Mar 22 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.0-1vl5
257- new upstream release
258- added BuildRequires: libtasn1-devel
259
260* Tue Dec 11 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.20.2-0vl1
261- new upstream release
262- added a pam subpackage
263
264* Fri Apr 27 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.1-0vl1
265- new upstream release
266
267* Tue May 16 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.9-0vl1
268- new upstream release
269
270* Mon Mar 06 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.8-0vl1
271- new upstream release
272
273* Sat Oct 08 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.5-0vl1
274- new upstream release
275
276* Wed Sep 21 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.4-0vl1
277- new upstream release
278
279* Fri Mar 25 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.2-0vl1
280- new upstream version
281
282* Sun Dec 12 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.4.0-0vl1
283- new upstream release
284
285* Sun Aug 01 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.3.2-0vl1
286- initial build for Vine Linux based on fedora's spec file.
287
288* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
289- rebuilt
290
291* Thu Apr  1 2004 Alex Larsson <alexl@redhat.com> 0.2.0-1
292- update to 0.2.0
293
294* Wed Mar 10 2004 Alexander Larsson <alexl@redhat.com> 0.1.90-1
295- update to 0.1.90
296
297* Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
298- rebuilt
299
300* Tue Feb 24 2004 Alexander Larsson <alexl@redhat.com> 0.1.4-1
301- update to 0.1.4
302
303* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
304- rebuilt
305
306* Fri Jan 30 2004 Alexander Larsson <alexl@redhat.com> 0.1.3-1
307- update to 0.1.3
308
309* Mon Jan 26 2004 Bill Nottingham <notting@redhat.com>
310- tweak summary
311
312* Mon Jan 26 2004 Alexander Larsson <alexl@redhat.com> 0.1.2-2
313- devel package only needs glib2-devel, not gtk2-devel
314
315* Fri Jan 23 2004 Alexander Larsson <alexl@redhat.com> 0.1.2-1
316- First version
Note: See TracBrowser for help on using the repository browser.