source: projects/specs/branches/6/g/gnome-do/gnome-do-vl.spec @ 4204

Revision 4204, 9.5 KB checked in by kazutaka, 13 years ago (diff)

cmigemo 対応を追加

Line 
1%define mainver         0.8.4
2%define build_vine5     %( [ "%{?_dist_release}" == "vl5" ] && echo 1 || echo 0)
3
4Name:           gnome-do
5Version:        0.8.4
6Release:        3%{?_dist_release}
7Summary:        An intelligent launcher tool for Gnome
8Summary(ja):    Gnome 用の高機能ランチャー
9License:        GPLv3+
10Group:          Applications/Accessories       
11URL:            http://do.davebsd.com/
12Source0:        http://edge.launchpad.net/do/0.8/%{mainver}/+download/gnome-do-%{version}.tar.gz
13Source1:        gnome-do.desktop
14# Taken from cmigemo
15Source2:        Migemo.cs.utf8
16# https://bugs.launchpad.net/do/+bug/634556
17#Patch0:                gnome-do-0.8.3.1-mono-2.8.patch
18#Patch1:                gnome-do-0.8.3.1-gdk-build-fix.patch
19# https://bugs.launchpad.net/do/+bug/634550
20Patch2:         gnome-do-0.8.4-cs0200.patch
21# http://d.hatena.ne.jp/kiwanami/20110612/1307897291
22# https://gist.github.com/1021707, but modified for gnome-do-0.8,4
23Patch3:         gnome-do-0.8.4-cmigemo.patch
24BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
25
26# Various Mono dependencies are not available for ppc64; see bug 241850.
27ExcludeArch:    ppc64
28
29Requires:       cmigemo
30BuildRequires:  mono-devel, mono-addins
31BuildRequires:  desktop-file-utils
32BuildRequires:  ndesk-dbus
33BuildRequires:  ndesk-dbus-glib
34BuildRequires:  gtk-sharp2
35BuildRequires:  notify-sharp-devel
36BuildRequires:  gnome-sharp2, gnome-desktop-sharp2 >= 2.26
37BuildRequires:  gnome-keyring-sharp-devel
38BuildRequires:  gettext
39BuildRequires:  perl-XML-Parser
40BuildRequires:  intltool
41BuildRequires:  gtk2-devel
42BuildRequires:  desktop-file-utils
43BuildRequires:  wnck-sharp
44BuildRequires:  gconf-sharp2
45BuildRequires:  rsvg2-sharp
46
47Requires(pre):  GConf2
48Requires(post): GConf2
49Requires(preun):GConf2
50
51Requires:       gnome-keyring-sharp, gnome-desktop-sharp2
52Requires:       pkgconfig
53
54Packager:       kazutaka
55
56%description
57GNOME Do (Do) is an intelligent launcher tool that makes performing
58common tasks on your computer simple and efficient. Do not only
59allows you to search for items in your desktop environment
60(e.g. applications, contacts, bookmarks, files, music), it also
61allows you to specify actions to perform on search results
62(e.g. run, open, email, chat, play).
63
64%description -l ja
65GNOME Do (Do) は高機能なランチャーツールです。 PC を使った一
66般的なタスクをシンプルかつ効率的に実行できるようにします。Do
67はデスクトップ環境の様々なアイテム(例えばアプリケーションや
68連絡先、ブックマーク、ファイル、音楽等)の検索だけでなく、検索
69した結果をどう操作するのか(例えば開く、メールに添付、チャット、
70再生する等)を指定することができます。
71
72%package devel
73Summary:                Development files for GNOME Do
74Summary(ja):               GNOME Do の開発用ファイル
75Group:                  Development/Libraries
76Requires:               %{name} = %{version}-%{release}
77Requires:               pkgconfig
78
79%description devel
80Development files for GNOME Do
81
82%description devel -l ja
83GNOME Do の開発用ファイルです。
84
85%prep
86%setup -q
87#%if !%{build_vine5}
88#%patch0 -p0 -b .mono28-fix
89#%patch1 -p1 -b .gdkbuild-fix
90#%endif
91%patch2 -p0 -b .cs0200
92
93# apply cmigemo patch
94%{__cp} %{SOURCE2} Do.Platform/src/Do.Platform/Migemo.cs
95%patch3 -p1 -b .cmigemo
96
97
98%build
99%configure
100make %{?_smp_mflags}
101
102
103%install
104rm -rf ${RPM_BUILD_ROOT}
105export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
106make install DESTDIR=${RPM_BUILD_ROOT}
107
108desktop-file-install \
109        --dir ${RPM_BUILD_ROOT}%{_sysconfdir}/xdg/autostart     \
110        --add-only-show-in=GNOME                                \
111        %{SOURCE1}
112desktop-file-install \
113        --dir ${RPM_BUILD_ROOT}%{_datadir}/applications   \
114        --remove-category Application \
115        %{SOURCE1}
116
117
118#own this dir:
119mkdir -p ${RPM_BUILD_ROOT}%{_datadir}/%{name}
120
121%find_lang %{name}
122
123%pre
124if [ "$1" -gt 1 ]; then
125    export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
126    gconftool-2 --makefile-uninstall-rule \
127      %{_sysconfdir}/gconf/schemas/%{name}.schemas >/dev/null || :
128fi
129
130%post
131export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
132gconftool-2 --makefile-install-rule \
133  %{_sysconfdir}/gconf/schemas/%{name}.schemas > /dev/null || :
134
135touch --no-create %{_datadir}/icons/hicolor
136if [ -x %{_bindir}/gtk-update-icon-cache ] ; then
137  %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
138fi
139
140%preun
141if [ "$1" -eq 0 ]; then
142    export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
143    gconftool-2 --makefile-uninstall-rule \
144      %{_sysconfdir}/gconf/schemas/%{name}.schemas > /dev/null || :
145fi
146
147%postun
148touch --no-create %{_datadir}/icons/hicolor
149if [ -x %{_bindir}/gtk-update-icon-cache ] ; then
150  %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
151fi
152
153%clean
154rm -rf ${RPM_BUILD_ROOT}
155
156%files -f %{name}.lang
157%defattr(-,root,root,-)
158%doc AUTHORS COPYING COPYRIGHT
159%{_bindir}/gnome-do/
160%{_libdir}/gnome-do/
161%{_datadir}/gnome-do/
162%config(noreplace) %{_sysconfdir}/xdg/autostart/gnome-do.desktop
163%config(noreplace) %{_sysconfdir}/gconf/schemas/*
164%{_datadir}/icons/hicolor/*/apps/gnome-do.*
165%{_datadir}/applications/*
166
167%files devel
168%defattr(-,root,root,-)
169%{_libdir}/pkgconfig/*
170
171%changelog
172* Thu Jun 23 2011 Kazutaka HARADA <kazutaka@vinelinux.org> 0.8.4-3
173- update Patch2 to fix Bad quantifier error of regex
174
175* Wed Jun 22 2011 Kazutaka HARADA <kazutaka@vinelinux.org> 0.8.4-2
176- add Source1 and Patch2: add cmigemo support
177
178* Thu Jan 13 2011 Kazutaka HARADA <kazutaka@vinelinux.org> 0.8.4-1
179- new upstream release
180- drop Patch0 & 1
181- add Patch2: fix compilation error (cs0200)
182- add Source1: temporary fix for desktop-file-install failure.
183               (Comment[kk] contains a bogus linebreak)
184
185* Sat Nov 06 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 0.8.3.1-4
186- add Patch0 & 1 to fix compilation error (Seed only)
187
188* Sat Sep 25 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.3.1-3
189- rebuild with rpm-4.8.1 for pkg-config file
190- add BuildRequires: gconf-sharp2, rsvg2-sharp
191
192* Mon Jul 26 2010 Shu KONNO <owa@bg.wakwak.com> 0.8.3.1-2
193- rebuilt with mono-addins-0.5
194
195* Sun Jan 10 2010 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.8.3.1-1
196- new upstream release
197
198* Fri Jul 10 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.8.2-1
199- new upstream release
200- drop Patch0 (merged in upstream)
201
202* Fri Jun 12 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.8.1.3-3
203- change Group to Applications/Accessories
204
205* Fri Jun 12 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.8.1.3-2
206- add BuildRequires: wnck-sharp
207
208* Thu Jun 11 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.8.1.3-1
209- initial build for Vine Linux based on fedora development
210
211* Fri Apr 10 2009 Sindre Pedersen Bj淡rdal <sindrepb@fedoraproject.org> - 0.8.1.3-5
212- Fix .desktop issue, install in both autostart and applications
213- Rebuild for new gnome-desktop-sharp
214- Add missing gnome-desktop-sharp requires
215- Fix Ndesk-dbus Requires
216
217* Wed Apr 01 2009 Sindre Pedersen Bj淡rdal <sindrepb@fedoraproject.org> - 0.8.1.3-3
218- Add patch to fix issue where applications wasn't being indexed
219
220* Tue Mar 17 2009 Sindre Pedersen Bj淡rdal <sindrepb@fedoraproject.org> - 0.8.1.3-2
221- New upstream release
222
223* Tue Mar 3 2009 Sindre Pedersen Bj淡rdal <sindrepb@fedoraproject.org> - 0.8.0-4
224- Own _datadir/gnome-do
225* Tue Feb 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.8.0-3
226- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
227
228* Sat Feb  7 2009 Michel Salim <salimma@fedoraproject.org> - 0.8.0-2
229- Rebuild against new mono-addins
230
231* Fri Jan 30 2009 Sindre Pedersen Bj淡rdal <sindrepb@fedoraproject.org> - 0.8.0-1
232- New upstream release
233
234* Thu Jan 29 2009 Michel Salim <salimma@fedoraproject.org> - 0.6.1.0-3
235- Remove Tomboy dependency (bz #481183)
236- Updated description, from Do
237
238* Mon Oct 27 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 0.6.1.0-2
239- rebuild against new gnome-sharp
240
241* Wed Oct 08 2008 Sindre Pedersen Bj淡rdal <sindrepb@fedoraproject.org> - 0.6.1.0-1
242- New Upstream Release
243
244* Fri Oct 03 2008 Sindre Pedersen Bj淡rdal <sindrepb@fedoraproject.org> - 0.6.0.1-1
245- New upstream release
246
247* Wed Jun 11 2008 Sindre Pedersen Bj淡rdal <sindrepb@fedoraproject.org> - 0.6.0.0-1
248- New upstream release
249
250* Wed Jun 11 2008 Sindre Pedersen Bj淡rdal <sindrepb@fedoraproject.org> - 0.5.0.1-4
251- New upstream release
252- Add gnome-desktop-sharp dependency
253
254* Wed Jun 04 2008 Caol叩n McNamara <caolanm@redhat.com> - 0.4.2.0-2
255- rebuild for dependancies
256
257* Tue Apr 22 2008 Sindre Pedersen Bj淡rdal <sindrepb@fedoraproject.org> - 0.4.2.0-1
258- New upstream release
259
260* Tue Apr 01 2008 David Nielsen <gnomeuser@gmail.com> - 0.4.0.1-2
261- #439793 - correct URL
262
263* Sat Mar 29 2008 David Nielsen <gnomeuser@gmail.com> - 0.4.0.1-1
264- Bump to 0.4.0.1
265- Hopefully bring an end to the endless dups of 432201
266
267* Thu Feb 21 2008 David Nielsen <david@lovesunix.net> - 0.3.1-2
268- Fix 432201
269
270* Thu Feb 21 2008 David Nielsen <david@lovesunix.net> - 0.3.1-1
271- Bump to 0.3.1
272
273* Wed Feb 06 2008 David Nielsen <david@lovesunix.net> - 0.3.0.1-5
274- #431589 - Force runtime dependency on ndesk-dbus(-glib)
275
276* Mon Feb 04 2008 David Nielsen <david@lovesunix.net> - 0.3.0.1-4
277- #431462 - Correctly pull in Tomboy runtime dependency
278
279* Fri Jan 25 2008 David Nielsen <david@lovesunix.net> - 0.3.0.1-3
280- autostart gnome-do in quiet mode with the user session
281- to invoke gnome-do use super+space
282
283* Tue Jan 22 2008 David Nielsen <david@lovesunix.net> - 0.3.0.1-2
284- Fix BuildRequires
285
286* Tue Jan 22 2008 David Nielsen <david@lovesunix.net> - 0.3.0.1-1
287- bump to 0.3.0.1
288- update patches
289
290* Sat Nov 17 2007 David Nielsen <david@lovesunix.net> - 0.0.2-2
291- updated libdir patch
292- cleaned up desktop-file-install invocation
293- correct BuildRequires
294
295* Mon Nov 12 2007 David Nielsen <david@lovesunix.net> - 0.0.2-1
296- Initial package
Note: See TracBrowser for help on using the repository browser.