source: projects/specs/branches/6/g/gnome-color-manager/gnome-color-manager-vl.spec @ 4619

Revision 4619, 5.9 KB checked in by Takemikaduchi, 13 years ago (diff)

add colord (Vine6), new upstream release (Vine7)

Line 
1%{!?python_sitelib: %define python_sitelib %(python -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
2
3Summary:   Color management tools for GNOME
4Name:      gnome-color-manager
5Version:   2.32.0
6Release:   2%{?_dist_release}
7License:   GPLv2+
8Group:     Applications/System
9URL:       http://projects.gnome.org/gnome-color-manager/
10Source0:   http://download.gnome.org/sources/gnome-color-manager/2.32/%{name}-%{version}.tar.bz2
11
12Requires:  colord
13Requires:  gnome-icon-theme
14Requires:  shared-mime-info
15Requires:  shared-color-profiles
16Requires(pre):    GConf2
17Requires(post):   GConf2
18Requires(preun):  GConf2
19
20BuildRequires: gtk2-devel >= 2.16.0
21BuildRequires: scrollkeeper
22BuildRequires: gnome-doc-utils >= 0.3.2
23BuildRequires: desktop-file-utils
24BuildRequires: gettext
25BuildRequires: libtool
26BuildRequires: vte-devel
27BuildRequires: gnome-doc-utils
28BuildRequires: unique-devel >= 1.0.0
29BuildRequires: intltool
30BuildRequires: libgudev1-devel
31BuildRequires: dbus-glib-devel >= 0.73
32BuildRequires: libXxf86vm-devel
33BuildRequires: libXrandr-devel
34BuildRequires: gnome-desktop-devel
35BuildRequires: lcms-devel
36BuildRequires: cups-devel
37BuildRequires: sane-devel
38BuildRequires: libtiff-devel
39BuildRequires: libcanberra-devel
40BuildRequires: libnotify-devel
41BuildRequires: GConf2
42
43%description
44gnome-color-manager is a session framework that makes it easy to manage, install
45and generate color profiles in the GNOME desktop.
46
47%prep
48%setup -q
49
50%build
51%configure --disable-scrollkeeper --disable-schemas-install
52make %{?_smp_mflags}
53
54%install
55make install DESTDIR=$RPM_BUILD_ROOT
56
57for i in gcm-prefs gcm-import ; do
58  desktop-file-install --delete-original                                \
59    --dir=$RPM_BUILD_ROOT%{_datadir}/applications/                      \
60    $RPM_BUILD_ROOT%{_datadir}/applications/$i.desktop
61done
62
63%find_lang %name --with-gnome
64
65%post
66export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
67gconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/gnome-color-manager.schemas > /dev/null
68
69touch --no-create %{_datadir}/icons/hicolor &> /dev/null || :
70update-desktop-database %{_datadir}/applications &> /dev/null || :
71update-mime-database %{_datadir}/mime &> /dev/null || :
72
73%pre
74if [ "$1" -gt 1 ]; then
75    export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
76    gconftool-2 --makefile-uninstall-rule %{_sysconfdir}/gconf/schemas/gnome-color-manager.schemas > /dev/null
77fi
78
79%preun
80if [ "$1" -eq 0 ]; then
81    export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
82    gconftool-2 --makefile-uninstall-rule %{_sysconfdir}/gconf/schemas/gnome-color-manager.schemas > /dev/null
83fi
84
85
86%postun
87if [ $1 -eq 0 ]; then
88    touch --no-create %{_datadir}/icons/hicolor &> /dev/null || :
89    gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
90fi
91update-desktop-database %{_datadir}/applications &> /dev/null || :
92update-mime-database %{_datadir}/mime &> /dev/null || :
93
94%posttrans
95gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
96
97%files -f %{name}.lang
98%defattr(-,root,root,-)
99%doc AUTHORS COPYING NEWS README
100/lib/udev/rules.d/*.rules
101%{_bindir}/gcm-*
102%dir %{_datadir}/gnome-color-manager
103%{_datadir}/gnome-color-manager/gcm-*.ui
104%dir %{_datadir}/gnome-color-manager/targets
105%dir %{_datadir}/gnome-color-manager/icons
106%{_datadir}/gnome-color-manager/targets/*.png
107%{_datadir}/gnome-color-manager/icons/*.svg
108%{_datadir}/man/man1/*.1.gz
109%{_datadir}/icons/hicolor/*/*/*.png
110%{_datadir}/icons/hicolor/scalable/*/*.svg*
111%config(noreplace) %{_sysconfdir}/gconf/schemas/*.schemas
112%{_datadir}/applications/gcm-prefs.desktop
113%{_datadir}/applications/gcm-import.desktop
114%{_sysconfdir}/xdg/autostart/*.desktop
115%{_datadir}/dbus-1/services/org.gnome.ColorManager.service
116%{_sbindir}/gcm-install-system-wide
117%{_datadir}/polkit-1/actions/org.gnome.color.policy
118
119# this is probably better in a shared package
120%dir %{_localstatedir}/lib/color
121
122%changelog
123* Fri Aug 19 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0-2
124- add Requires: colord
125
126* Mon Oct 04 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0-1
127- new upstream release
128
129* Mon Jun 21 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.2-1
130- new upstream release
131
132* Sat May 15 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-1
133- Initial build for Vine Linux
134
135
136* Fri Apr  2 2010 Matthias Clasen <mclasen@redhat.com> 2.30.0-4
137- BR GConf to make the macros work
138- Modernize icon cache handling
139
140* Wed Mar 31 2010 Richard Hughes <richard@hughsie.com> 2.30.0-3
141- Fix up a scriptlet problem.
142- Resolves: #578611
143
144* Mon Mar 29 2010 Richard Hughes <richard@hughsie.com> 2.30.0-2
145- Add libnotify BR.
146
147* Mon Mar 29 2010 Richard Hughes <richard@hughsie.com> 2.30.0-1
148- New upstream release.
149
150* Tue Mar 09 2010 Richard Hughes <richard@hughsie.com> 2.29.4-2
151- Update to the latest version of the Fedora Packaging Guidelines
152- Remove the custom BuildRoot
153- Do not clean the buildroot before install
154- Use the gconf_schema defines for the GConf schemas
155- Remove some over-zealous Requires that are already picked up by rpm.
156- Resolves #571658
157
158* Mon Mar 01 2010 Richard Hughes <richard@hughsie.com> 2.29.4-1
159- New upstream release.
160
161* Mon Feb 22 2010 Richard Hughes <richard@hughsie.com> 2.29.4-0.1.20100222
162- Another new snapshot from upstream with lots of bugs fixed from the Fedora
163  test day.
164
165* Wed Feb 18 2010 Richard Hughes <richard@hughsie.com> 2.29.4-0.1.20100218
166- Another new snapshot from upstream for the Fedora test day.
167
168* Wed Feb 17 2010 Richard Hughes <richard@hughsie.com> 2.29.4-0.1.20100217
169- New snapshot from upstream for the Fedora test day.
170
171* Mon Feb 01 2010 Richard Hughes <richard@hughsie.com> 2.29.3-1
172- New upstream release.
173
174* Mon Jan 18 2010 Matthias Clasen <mclasen@redhat.com> 2.29.2-3
175- Rebuild against new gnome-desktop
176
177* Mon Jan 04 2010 Richard Hughes <richard@hughsie.com> 2.29.2-2
178- Rebuild, hopefully koji has now a working glibc.
179
180* Mon Jan 04 2010 Richard Hughes <richard@hughsie.com> 2.29.2-1
181- New upstream release.
182
183* Fri Dec 04 2009 Richard Hughes <richard@hughsie.com> 2.29.1-1
184- Initial spec for review.
185
Note: See TracBrowser for help on using the repository browser.