source: projects/specs/branches/6/g/gnome-bluetooth/gnome-bluetooth-vl.spec @ 2041

Revision 2041, 13.4 KB checked in by Takemikaduchi, 14 years ago (diff)

update to GNOME-2.32.0

Line 
1Summary: GNOME Bluetooth Subsystem
2Summary(ja): GNOME Bluetooth サブシステム
3Name: gnome-bluetooth
4Version: 2.32.0
5Release: 1%{?_dist_release}
6License: GPLv2+
7Group: System Environment/Libraries
8URL: http://live.gnome.org/GnomeBluetooth
9Source0: http://ftp.gnome.org/pub/gnome/sources/gnome-bluetooth/2.32/%{name}-%{version}.tar.bz2
10Source1: 61-gnome-bluetooth-rfkill.rules
11#----------------------------------------------------------------------------
12BuildRoot:      %{_tmppath}/%{name}-%{version}-root
13
14#----------------------------------------------------------------------------
15#BuildRequires: autoconf >= 2.57
16BuildRequires: bluez-libs-devel >= 2.8
17#BuildRequires: bluez-utils
18BuildRequires: libbonobo-devel >= 2.32.0
19BuildRequires: libbonoboui-devel >= 2.24.4
20BuildRequires: GConf2-devel >= 2.32
21BuildRequires: hal-devel
22BuildRequires: unique-devel
23BuildRequires: libnotify-devel
24BuildRequires: gnome-doc-utils
25
26BuildRequires: intltool, automake, libtool, gettext
27Requires: %{name}-libs = %{version}-%{release}
28Requires(pre): GConf2
29Requires(post): GConf2
30Requires(preun): GConf2
31Requires: bluez >= 4.42
32Requires: obexd
33Requires(post): desktop-file-utils
34Requires(postun): desktop-file-utils
35ExcludeArch: s390 s390x
36
37## Patch1: gnome-bluetooth-0.8.0-desktop.patch
38
39#----------------------------------------------------------------------------
40%description
41This package contains a library with widgets for Bluetooth applications.
42
43%description -l ja
44このパッケージには、 Bluetooth アプリケーションのためのウィジェットと
45ライブラリが含まれます。
46
47#----------------------------------------------------------------------------
48%package libs
49Summary: Libraries for applications, which use gnome-bluetooth
50Summary(ja):Gnome-bluetooth を使用するアプリケーション用ライブラリ
51Group: Development/Libraries
52
53%description libs
54This package contains the libraries for applications,
55which use gnome-bluetooth.
56
57%description libs -l ja
58このパッケージには Gnome-bluetoothを使用するアプリケーション用の
59ライブラリが含まれています。
60
61#----------------------------------------------------------------------------
62%package devel
63Summary: Files for the development of applications, which use gnome-bluetooth
64Summary(ja): Gnome-bluetoothを使用するアプリケーション開発用ファイル
65Group:          Development/Libraries
66License:        LGPLv2+
67Requires:       %{name}-libs = %{version}-%{release}
68Requires:       gtk-doc pkgconfig
69Requires:       glib2-devel
70Requires:       libbtctl-devel
71
72
73%description devel
74This package contains the files for the development of applications,
75which will use gnome-bluetooth.
76
77%description devel -l ja
78このパッケージにはGnome-bluetoothを使用するアプリケーションを
79開発するためのヘッダーファイルなどが含まれています(develパッケージ)
80
81#----------------------------------------------------------------------------
82
83%prep
84%setup -q -n gnome-bluetooth-%{version}
85
86## %patch1 -p1 -b .dfix
87
88%build
89%configure --disable-desktop-update --disable-icon-update --disable-nautilus-sendto --enable-introspection=yes
90make %{?_smp_mflags}
91
92#----------------------------------------------------------------------------
93%install
94rm -rf $RPM_BUILD_ROOT
95export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
96make DESTDIR=$RPM_BUILD_ROOT install
97
98# we do not want .la files
99rm -f $RPM_BUILD_ROOT%{_libdir}/gnome-vfs-2.0/modules/libbluetooth.*a
100rm -f $RPM_BUILD_ROOT%{_libdir}/libgnome-bluetooth.la
101rm -f $RPM_BUILD_ROOT/%{_libdir}/gnome-bluetooth/plugins/*.la
102rm -f $RPM_BUILD_ROOT/%{_libdir}/nautilus-sendto/plugins/*.la
103
104install -m0644 -D %{SOURCE1} $RPM_BUILD_ROOT/lib/udev/rules.d/61-gnome-bluetooth-rfkill.rules
105
106# Remove the gnome-obex-server
107# rm -rf $RPM_BUILD_ROOT%{_bindir}/ $RPM_BUILD_ROOT%{_datadir}/applications/ $RPM_BUILD_ROOT%{_sysconfdir}/
108
109%find_lang gnome-bluetooth2
110%find_lang %{name} --with-gnome
111cat %{name}.lang >> gnome-bluetooth2.lang
112
113# save space by linking identical images in translated docs
114helpdir=$RPM_BUILD_ROOT%{_datadir}/gnome/help/%{name}
115for f in $helpdir/C/figures/*.png; do
116  b="$(basename $f)"
117  for d in $helpdir/*; do
118    if [ -d "$d" -a "$d" != "$helpdir/C" ]; then
119      g="$d/figures/$b"
120      if [ -f "$g" ]; then
121        if cmp -s $f $g; then
122          rm "$g"; ln -s "../../C/figures/$b" "$g"
123        fi
124      fi
125    fi
126  done
127done
128
129%clean
130rm -rf $RPM_BUILD_ROOT
131
132%pre
133#if [ "$1" -gt 1 ]; then
134#    export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
135#    if [ -f %{_sysconfdir}/gconf/schemas/gnome-obex-server.schemas ] ; then
136#      gconftool-2 --makefile-uninstall-rule \
137#        %{_sysconfdir}/gconf/schemas/gnome-obex-server.schemas >/dev/null || :
138#    fi
139#fi
140if [ "$1" -gt 1 ]; then
141        export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
142        if [ -f %{_sysconfdir}/gconf/schemas/gnome-obex-server.schemas ] ; then
143                gconftool-2 --makefile-uninstall-rule \
144                %{_sysconfdir}/gconf/schemas/gnome-obex-server.schemas >/dev/null || :
145        fi
146        if [ -f %{_sysconfdir}/gconf/schemas/bluetooth-manager.schemas ] ; then
147                gconftool-2 --makefile-uninstall-rule                           \
148                %{_sysconfdir}/gconf/schemas/bluetooth-manager.schemas          \
149                >& /dev/null || :
150        fi
151fi
152
153%post
154update-desktop-database -q
155
156%posttrans
157glib-compile-schemas %{_datadir}/glib-2.0/schemas || :
158
159%preun
160#if [ "$1" -eq 0 ]; then
161#    export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
162#    if [ -f %{_sysconfdir}/gconf/schemas/gnome-obex-server.schemas ] ; then
163#      gconftool-2 --makefile-uninstall-rule \
164#        %{_sysconfdir}/gconf/schemas/gnome-obex-server.schemas > /dev/null || :
165#    fi
166#fi
167if [ "$1" -eq 0 ]; then
168        export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
169        if [ -f %{_sysconfdir}/gconf/schemas/gnome-obex-server.schemas ] ; then
170                gconftool-2 --makefile-uninstall-rule \
171                %{_sysconfdir}/gconf/schemas/gnome-obex-server.schemas > /dev/null || :
172        fi
173        if [ -f %{_sysconfdir}/gconf/schemas/bluetooth-manager.schemas ] ; then
174                gconftool-2 --makefile-uninstall-rule                           \
175                %{_sysconfdir}/gconf/schemas/bluetooth-manager.schemas          \
176                >& /dev/null || :
177        fi
178fi
179
180%postun
181update-desktop-database -q
182glib-compile-schemas %{_datadir}/glib-2.0/schemas || :
183if [ $1 -eq 0 ] ; then
184        touch --no-create %{_datadir}/icons/hicolor &>/dev/null
185        gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
186fi
187
188%post libs
189/sbin/ldconfig
190touch --no-create %{_datadir}/icons/hicolor &>/dev/null || :
191
192%posttrans libs
193gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
194
195%postun libs
196/sbin/ldconfig
197if [ $1 -eq 0 ] ; then
198        touch --no-create %{_datadir}/icons/hicolor &>/dev/null
199        gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
200fi
201
202#----------------------------------------------------------------------------
203%files -f %{name}.lang
204%defattr(-, root, root)
205%doc README NEWS COPYING
206%{_sysconfdir}/xdg/autostart/bluetooth-applet.desktop
207%{_bindir}/bluetooth-*
208%{_libdir}/gnome-bluetooth/
209%{_datadir}/applications/*.desktop
210%{_datadir}/gnome-bluetooth/
211%{_datadir}/locale/*
212%{_datadir}/GConf/gsettings/gnome-bluetooth
213%{_datadir}/glib-2.0/schemas/org.gnome.Bluetooth.gschema.xml
214%{_mandir}/man1/*
215/lib/udev/rules.d/61-gnome-bluetooth-rfkill.rules
216
217%files libs
218%defattr(-,root,root,-)
219%doc COPYING.LIB
220%{_libdir}/libgnome-bluetooth.so.*
221%{_libdir}/girepository-1.0/GnomeBluetooth-1.0.typelib
222%{_datadir}/icons/hicolor/*/apps/*
223%{_datadir}/icons/hicolor/*/status/*
224
225%files devel
226%defattr(-,root,root,-)
227%{_includedir}/gnome-bluetooth/
228%{_libdir}/libgnome-bluetooth.so
229%{_libdir}/pkgconfig/gnome-bluetooth-1.0.pc
230%{_datadir}/gir-1.0/GnomeBluetooth-1.0.gir
231%{_datadir}/gtk-doc/html/gnome-bluetooth/
232
233#----------------------------------------------------------------------------
234# Maintainers: babasaki@mindgear.org
235#
236#----------------------------------------------------------------------------
237%changelog
238* Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0-1
239- new upstream release
240- remove BuildRequires: gir-repository-devel
241- add Requires(post) and Requires(postun): desktop-file-utils
242
243* Sat Sep 25 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-2
244- rebuild with rpm-4.8.1 for pkg-config file
245
246* Wed Apr 21 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
247- new upstream release
248- add BuildRequires: gir-repository-devel
249- add configure option (--disable-nautilus-sendto)
250
251* Wed Dec 30 2009 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.6-1
252- new upstream release
253- merge spec file from FC package
254
255* Fri Oct 24  2008 Seiichirou Babasaki 0.11.0-6
256- Update to 0.11.0 (VineSeed)
257- added "# Maintainers: " comments.
258- changed UTF-8 encode at gnome-bluetooth.vsc.spec
259- FedoraCore - LOGS
260-- 0.11.0-5
261-- Rebuild against new bluez-libs
262-- 0.11.0-4
263-- Changed name of icon file(#444811)
264-- 0.11.0-3
265-- Remove gnome-obex-server, we should use gnome-user-share now
266-- 0.11.0-1
267-- gcc43 rebuild
268-- 0.11.0 - Update to 0.11.0
269-- 0.10.0 - Update to 0.10.0
270-- 0.9.1-4
271-- marked gnome-obex-server.schemas as config file
272-- changed upstream URL
273-- 0.9.1-3
274-- fixed wrong source URL
275-- 0.9.1-2
276-- rebuilt for F8
277-- changed license tag to GPLv2 and LGPLv2+
278-- 0.9.1-1
279-- Upgrade to 0.9.1 to fix a crasher in the server
280-- 0.9.0-1
281-- Update for 0.9.0
282-- Fix installation of the python bindings
283-- 0.8.0-4
284-- Remove unncessary gconfd killing from scripts (#224561)
285-- 0.8.0-3
286-- corrected BuildRoot
287-- smp flags added
288-- specfile cleanup
289-- fixed desktop file
290- Updated specfile
291
292* Fri Sep 26 2008 Seiichirou Babasaki 0.8.0-2
293- Updated specfile
294
295* Wed Jan 16 2008 Seiichirou Babasaki 0.8.0-1
296- Import gnome-bluetooth - Packager: Babasaki
297- Updated specfile (downgrade -> 0.8.0-0vl1)
298
299#----------------------------------------------------------------------------
300* Mon Nov 13 2006 Harald Hoyer <harald@redhat.com> - 0.8.0-1
301- version 0.8.0
302
303* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 0.7.0-10.1
304- rebuild
305
306* Wed Jun 14 2006 Harald Hoyer <harald@redhat.com> - 0.7.0-10
307- bump for new openobex
308
309* Sun Jun 11 2006 Jesse Keating <jkeating@redhat.com> - 0.7.0-9
310- Missing automake, libtool, gettext BR
311
312* Sun Jun 11 2006 Jesse Keating <jkeating@redhat.com> - 0.7.0-6
313- Bump for new libbluetooth
314
315* Wed May 31 2006 Harald Hoyer <harald@redhat.com> - 0.7.0-6
316- add dependency on bluez-utils, cosmetic tweaks (bug #190280)
317
318* Tue May 30 2006 Harald Hoyer <harald@redhat.com> - 0.7.0-5
319- install schemata correctly (bug #193518)
320
321* Mon May 29 2006 Harald Hoyer <harald@redhat.com> - 0.7.0-3
322- more build requires (bug #193374)
323
324* Mon Feb 27 2006 Harald Hoyer <harald@redhat.com> - 0.7.0-2
325- pydir fixes for lib64
326
327* Thu Feb 16 2006 Harald Hoyer <harald@redhat.com> - 0.7.0-1
328- version 0.7.0
329
330* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 0.6.0-2.2.1
331- bump again for double-long bug on ppc(64)
332
333* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 0.6.0-2.2
334- rebuilt for new gcc4.1 snapshot and glibc changes
335
336* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
337- rebuilt
338
339* Fri Oct 07 2005 Harald Hoyer <harald@redhat.com> - 0.6.0-2
340- Fix relative path for the icons in desktop files which no longer works
341  with the icon cache.
342
343* Wed Sep 28 2005 Harald Hoyer <harald@redhat.com> - 0.6.0-1
344- new version 0.6.0
345
346* Tue Aug 16 2005 Warren Togami <wtogami@redhat.com> 0.5.1-14
347- rebuild for new cairo
348
349* Thu Jul  7 2005 Matthias Saou <http://freshrpms.net/> 0.5.1-13
350- Minor spec file cleanups.
351- Fix relative path for the icons in desktop files which no longer works
352  with the icon cache.
353- Remove useless zero epochs.
354- Remove explicit python abi requirement, it's automatic for FC4 and up.
355
356* Thu Mar 31 2005 Harald Hoyer <harald@redhat.com> - 0.5.1-12
357- removed base requirement from libs
358
359* Tue Mar 29 2005 Warren Togami <wtogami@redhat.com> - 0.5.1-11
360- devel req glib2-devel libbtctl-devel for pkgconfig (#152488)
361
362* Wed Mar 02 2005 Harald Hoyer <harald@redhat.com>
363- rebuilt
364
365* Mon Feb 21 2005 Harald Hoyer <harald@redhat.com> - 0.5.1-9
366- added gnome hbox patch for bug rh#149215
367
368* Tue Dec 07 2004 Harald Hoyer <harald@redhat.com> - 0.5.1-8
369- added requires for python-abi
370
371* Tue Dec 07 2004 Harald Hoyer <harald@redhat.com> - 0.5.1-7
372- split package into app, libs and devel
373
374* Mon Oct 25 2004 Harald Hoyer <harald@redhat.com> - 0.5.1-6
375- fixed again gnome-bluetooth-manager script for 64bit (bug 134864)
376
377* Fri Oct 08 2004 Harald Hoyer <harald@redhat.com> - 0.5.1-5
378- buildrequire pygtk2-devel (bug 135032)
379- fixed gnome-bluetooth-manager script for 64bit (bug 134864)
380- fixed segfault on file receive (bug 133041)
381
382* Mon Sep 27 2004 Harald Hoyer <harald@redhat.com> - 0.5.1-4
383- buildrequire libbtctl-devel
384- buildrequire openobex-devel >= 1.0.1
385- pythondir -> pyexecdir
386
387* Wed Jul 28 2004 Harald Hoyer <harald@redhat.com> - 0.5.1-3
388- added build dependency for librsvg2-devel
389
390* Tue Jul 27 2004 Harald Hoyer <harald@redhat.com> - 0.5.1-2
391- added pydir patch
392
393* Thu Jul 22 2004 Harald Hoyer <harald@redhat.com> - 0.5.1-1
394- version 0.5.1
395
396* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
397- rebuilt
398
399* Tue May 25 2004 Harald Hoyer <harald@redhat.com> - 0.4.1-8
400- corrected BuildRequires
401
402* Wed Mar 10 2004 Harald Hoyer <harald@redhat.com> - 0.4.1-7
403- added EggToolBar patch for gcc34
404
405* Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
406- rebuilt
407
408* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
409- rebuilt
410
411* Mon Jan 26 2004 Harald Hoyer <harald@redhat.de> 0.4.1-4
412- added autofoo patch
413
414* Thu Aug 28 2003 Harald Hoyer <harald@redhat.de> 0.4.1-3
415- add .so to gnome-vfs module, if libtool does not!
416
417* Thu Aug 07 2003 Harald Hoyer <harald@redhat.de> 0.4.1-2
418- call libtool finish
419
420* Wed Aug  6 2003 Harald Hoyer <harald@redhat.de> 0.4.1-1
421- new version 0.4.1
422
423* Wed Jun  5 2003 Harald Hoyer <harald@redhat.de> 0.4-1
424- initial RPM
425
426
Note: See TracBrowser for help on using the repository browser.