source: projects/specs/branches/6/g/gnokii/gnokii-vl.spec @ 3751

Revision 3751, 15.3 KB checked in by Takemikaduchi, 13 years ago (diff)

fix BuildRequires?

Line 
1# TODO: merge patches upstream where applicable
2
3Name:           gnokii
4Version:        0.6.27
5Release:        7%{?_dist_release}
6Summary:        Linux/Unix tool suite for various mobile phones
7Summary(ja): Linux/Unix tool suite for various mobile phones
8
9Group:          Applications/Communications
10License:        GPLv2+
11URL:            http://www.gnokii.org/
12Source0:        http://www.gnokii.org/download/gnokii/%{name}-%{version}.tar.bz2
13#----------------------------------------------------------------------------
14
15Source2:        gnokii-smsd.init
16Source3:        gnokii-smsd.sysconfig
17Source4:        gnokii-smsd.logrotate
18Source5:        gnokii-smsd2mail.sh
19Source6:        gnokii-smsd-README.smsd2mail
20
21# Patch to make gnokii use "htmlview" instead of "mozilla" as default browser
22Patch0:         gnokii-htmlview.patch
23# Patch to remove port locking and apply the system-wide /usr/sbin directory
24# to the path instead of the default /usr/local
25Patch1:         gnokii-config.patch
26
27#----------------------------------------------------------------------------
28
29BuildRoot:      %{_tmppath}/%{name}-%{version}-root
30
31#----------------------------------------------------------------------------
32
33BuildRequires:  flex
34BuildRequires:  gettext
35BuildRequires:  gtk2-devel
36BuildRequires:  desktop-file-utils
37BuildRequires:  ImageMagick
38BuildRequires:  postgresql-devel
39BuildRequires:  mysql-devel
40BuildRequires:  zlib-devel
41BuildRequires:  bluez-libs-devel
42BuildRequires:  libusb-devel
43BuildRequires:  readline-devel
44
45BuildRequires:  libical-devel >= 0.24
46
47# VineSeed
48BuildRequires:  libXt-devel
49BuildRequires:  libXpm-devel
50## VineLinux-4.x
51## BuildRequires: XOrg, XOrg-libs, XOrg-sdk
52
53BuildRequires:  perl(XML::Parser)
54Requires(pre):  %{_sbindir}/groupadd
55
56#----------------------------------------------------------------------------
57%description
58Gnokii provides tools and a user space driver for use with mobile
59phones under Linux, various unices and Win32. With gnokii you can do
60such things as make data calls, update your address book, change
61calendar entries, send and receive SMS messages and load ring tones
62depending on the phone you have.
63
64#----------------------------------------------------------------------------
65%package     -n xgnokii
66Summary:        Graphical Linux/Unix tool suite for various mobile phones
67Group:          Applications/Communications
68Requires:       %{name} = %{version}-%{release}
69
70%description -n xgnokii
71Xgnokii is graphical Linux/Unix tool suite for various mobile
72phones. It allows you to edit your contacts book, send/read SMS's
73from/in computer and more other features.
74
75#----------------------------------------------------------------------------
76%package        smsd
77Summary:        Gnokii SMS daemon
78Group:          System Environment/Daemons
79Requires:       %{name} = %{version}-%{release}
80Requires(pre):  %{_sbindir}/useradd
81Requires(post): /sbin/chkconfig
82Requires(preun): /sbin/chkconfig
83
84%description    smsd
85The Gnokii SMS daemon receives and sends SMS messages.
86
87#----------------------------------------------------------------------------
88%package        smsd-pgsql
89Summary:        PostgreSQL support for Gnokii SMS daemon
90Group:          System Environment/Daemons
91Requires:       %{name}-smsd = %{version}-%{release}
92Obsoletes:      %{name}-smsd-postgresql < 0.6.4-0.lvn.2
93
94%description    smsd-pgsql
95%{summary}.
96
97#----------------------------------------------------------------------------
98%package        smsd-mysql
99Summary:        MySQL support for Gnokii SMS daemon
100Group:          System Environment/Daemons
101Requires:       %{name}-smsd = %{version}-%{release}
102
103%description    smsd-mysql
104%{summary}.
105
106#----------------------------------------------------------------------------
107%package        devel
108Summary:        Gnokii development files
109Group:          Development/Libraries
110Requires:       %{name} = %{version}-%{release}
111Requires:       pkgconfig
112
113%description    devel
114%{summary}.
115
116
117#----------------------------------------------------------------------------
118%prep
119%setup -q
120%patch0 -p0
121%patch1 -p0
122install -pm 644 %{SOURCE5} smsd2mail.sh
123install -pm 644 %{SOURCE6} README.smsd2mail
124
125%build
126%configure --enable-security --disable-rpath --disable-static \
127                --enable-libical
128make %{?_smp_mflags}
129
130
131#----------------------------------------------------------------------------
132%install
133make install DESTDIR=$RPM_BUILD_ROOT
134
135# Rename smsd to gnokii-smsd
136mv $RPM_BUILD_ROOT%{_bindir}/{,gnokii-}smsd
137mv $RPM_BUILD_ROOT%{_mandir}/man8/{,gnokii-}smsd.8
138sed -i 's,smsd ,gnokii-smsd ,' $RPM_BUILD_ROOT%{_mandir}/man8/gnokii-smsd.8
139sed -i 's,smsd.,gnokii-smsd.,' $RPM_BUILD_ROOT%{_mandir}/man8/gnokii-smsd.8
140
141# Remove libtool droppings
142rm $RPM_BUILD_ROOT%{_libdir}{,/smsd}/lib*.la
143
144# Fix up the default desktop file
145desktop-file-install \
146  --delete-original \
147  --vendor "" \
148  --dir $RPM_BUILD_ROOT%{_datadir}/applications \
149  --mode 644 \
150  --add-category X-VineLinux \
151  $RPM_BUILD_ROOT%{_datadir}/applications/xgnokii.desktop
152
153# Convert the default icons to PNG
154install -dm 755 $RPM_BUILD_ROOT%{_datadir}/pixmaps
155convert Docs/sample/logo/gnokii.xpm \
156  $RPM_BUILD_ROOT%{_datadir}/pixmaps/xgnokii.png
157chmod 644 $RPM_BUILD_ROOT%{_datadir}/pixmaps/xgnokii.png
158
159# Install the configuration files
160install -Dpm 755 %{SOURCE2} $RPM_BUILD_ROOT%{_initrddir}/gnokii-smsd
161install -Dpm 640 %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/gnokii-smsd
162install -Dpm 644 %{SOURCE4} \
163  $RPM_BUILD_ROOT%{_sysconfdir}/logrotate.d/gnokii-smsd
164cp -a Docs/sample/gnokiirc $RPM_BUILD_ROOT%{_sysconfdir}/
165
166# Install the docs
167mkdir -p temporary-gnokii-docs/
168mv $RPM_BUILD_ROOT%{_datadir}/doc/gnokii/ temporary-gnokii-docs/
169
170%find_lang %{name}
171
172
173%clean
174rm -rf $RPM_BUILD_ROOT
175
176
177#----------------------------------------------------------------------------
178%pre
179%{_sbindir}/groupadd -r gnokii >/dev/null 2>&1 || :
180
181%pre smsd
182%{_sbindir}/useradd -r -M -d / -g gnokii \
183  -s /sbin/nologin -c "Gnokii system user" gnokii >/dev/null 2>&1 || :
184
185%post -p /sbin/ldconfig
186
187%postun -p /sbin/ldconfig
188
189%post smsd
190/sbin/chkconfig --add gnokii-smsd
191
192%preun smsd
193if [ $1 -eq 0 ] ; then
194  %{_initrddir}/gnokii-smsd stop >/dev/null 2>&1 || :
195  /sbin/chkconfig --del gnokii-smsd
196fi
197
198%postun smsd
199if [ $1 -ge 1 ] ; then
200  %{_initrddir}/gnokii-smsd try-restart >/dev/null 2>&1 || :
201fi
202
203
204#----------------------------------------------------------------------------
205%files -f %{name}.lang
206%defattr(-,root,root,-)
207%doc ChangeLog COPY* MAINTAINERS TODO temporary-gnokii-docs/*
208%config(noreplace) %{_sysconfdir}/gnokiirc
209%attr(4750,root,gnokii) %{_sbindir}/mgnokiidev
210%{_bindir}/gnokii
211%{_bindir}/sendsms
212%{_bindir}/gnokiid
213%{_libdir}/libgnokii.so.*
214%{_mandir}/man1/gnokii.1*
215%{_mandir}/man1/sendsms.1*
216%{_mandir}/man8/gnokiid.8*
217%{_mandir}/man8/mgnokiidev.8*
218
219%files -n xgnokii
220%defattr(-,root,root,-)
221%doc xgnokii/ChangeLog xgnokii/README.vcard
222%{_bindir}/xgnokii
223%{_datadir}/pixmaps/xgnokii.png
224%{_datadir}/applications/*xgnokii.desktop
225%{_mandir}/man1/xgnokii.1*
226%{_prefix}/share/xgnokii/
227
228%files smsd
229%defattr(-,root,root,-)
230%doc smsd/action smsd/ChangeLog smsd/README README.smsd2mail smsd2mail.sh
231%attr(-,gnokii,gnokii) %config(noreplace) %{_sysconfdir}/sysconfig/gnokii-smsd
232%config(noreplace) %{_sysconfdir}/logrotate.d/gnokii-smsd
233%{_initrddir}/gnokii-smsd
234%{_bindir}/gnokii-smsd
235%{_mandir}/man8/gnokii-smsd.8*
236%dir %{_libdir}/smsd/
237%{_libdir}/smsd/libsmsd_file.so
238
239%files smsd-pgsql
240%defattr(-,root,root,-)
241%doc smsd/sms.tables.pq.sql
242%{_libdir}/smsd/libsmsd_pq.so
243
244%files smsd-mysql
245%defattr(-,root,root,-)
246%doc smsd/sms.tables.mysql.sql
247%{_libdir}/smsd/libsmsd_mysql.so
248
249%files devel
250%defattr(-,root,root,-)
251%{_includedir}/gnokii*
252%{_libdir}/libgnokii.so
253%{_libdir}/pkgconfig/gnokii.pc
254%{_libdir}/pkgconfig/xgnokii.pc
255
256#----------------------------------------------------------------------------
257# Maintainers: babasaki@mindgear.org
258#
259#----------------------------------------------------------------------------
260%changelog
261* Sun May 01 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.6.27-7
262- add BuildRequires: readline-devel
263
264* Tue Apr 12 2011 Shu KONNO <owa@bg.wakwak.com> 0.6.27-6
265- rebuilt with postgresql-9.0.3
266
267* Sun Oct 03 2010 Shu KONNO <owa@bg.wakwak.com> 0.6.27-5
268- rebuilt with rpm-4.8.1 for pkg-config
269
270* Fri May 22 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 0.6.27-4
271- rebuilt with MySQL-5.1.34.
272
273* Mon Oct 27 2008 Seiichirou Babasaki - 0.6.27-3
274- Import gnokii - Packager: Babasaki
275- Updated specfile
276
277#----------------------------------------------------------------------------
278* Mon Oct 06 2008 - Bastien Nocera <bnocera@redhat.com> - 0.6.27-2
279- Fix htmlview patch
280
281* Mon Oct 06 2008 - Bastien Nocera <bnocera@redhat.com> - 0.6.27-1
282- Update to 0.6.27
283
284* Thu Sep 11 2008 - Bastien Nocera <bnocera@redhat.com> - 0.6.26-3
285- Rebuild
286
287* Thu Jun 19 2008 - Bastien Nocera <bnocera@redhat.com> - 0.6.26-2
288- Rebuild with libical support
289
290* Wed Jun 11 2008 - Bastien Nocera <bnocera@redhat.com> - 0.6.26-1
291- Update to 0.6.26
292
293* Fri May 23 2008 Robert Scheck <robert@fedoraproject.org> 0.6.25-2
294- Set empty --vendor rather none for using desktop-file-install
295- Fixed initscript as gnokii-smsd stays in /usr/bin not /usr/sbin
296
297* Mon May 19 2008 - Bastien Nocera <bnocera@redhat.com> - 0.6.25-1
298- Update to 0.6.25
299
300* Thu Mar 20 2008 - Bastien Nocera <bnocera@redhat.com> - 0.6.24-1
301- Update to 0.6.24
302
303* Mon Feb 11 2008 - Linus Walleij <triad@df.lth.se> - 0.6.22-3
304- Rebuild for GCC 4.3.
305
306* Thu Dec 6 2007 - Linus Walleij <triad@df.lth.se> - 0.6.22-2
307- Pick up new libssl .solib version dependency.
308
309* Thu Nov 29 2007 - Bastien Nocera <bnocera@redhat.com> - 0.6.22-1
310- Update to 0.6.22
311
312* Thu Nov 01 2007 - Bastien Nocera <bnocera@redhat.com> - 0.6.20-1
313- Update to 0.6.20
314
315* Sun Oct 28 2007 Jeremy Katz <katzj@redhat.com> - 0.6.18-3
316- Even better multilib fixing (#335161)
317
318* Tue Oct 23 2007 - Jeremy Katz <katzj@redhat.com> - 0.6.18-2
319- Quick fix to multilib conflict (#335161)
320
321* Fri Aug 17 2007 - Linus Walleij <triad@df.lth.se> - 0.6.18-1
322- New upstream release
323
324* Fri Aug 17 2007 - Linus Walleij <triad@df.lth.se> - 0.6.17-2
325- Update license field from GPL to GPLv2+
326
327* Wed Jul 04 2007 - Bastien Nocera <bnocera@redhat.com> - 0.6.17-1
328- New upstream release
329
330* Mon Jul 02 2007 - Bastien Nocera <bnocera@redhat.com> - 0.6.16-1
331- New upstream release
332- Update smsd name change patch
333- ppm2nokia, waitcall and todologo have moved to gnokii-extras, as per
334  upstream
335
336* Wed Dec 06 2006 Linus Walleij <triad@df.lth.se> - 0.6.14-3
337- Rebuild to pick up new libpq IF
338
339* Thu Oct 05 2006 Christian Iseli <Christian.Iseli@licr.org> 0.6.14-2
340 - rebuilt for unwind info generation, broken in gcc-4.1.1-21
341
342* Sat Sep 23 2006 Linus Walleij <triad@df.lth.se> - 0.6.14-1
343- New upstream release.
344
345* Tue Aug 29 2006 Linus Walleij <triad@df.lth.se> - 0.6.13-3
346- Rebuild for Fedora Extras 6.
347
348* Fri Aug 11 2006 Linus Walleij <triad@df.lth.se> - 0.6.13-2
349- Bump because tagged before committing sources and I just
350  dont know how the f* you delete a tag in CVS at the moment
351  and it does seem like a too big endavour to find out just
352  in order to have a nice release tag.
353
354* Thu Aug 10 2006 Linus Walleij <triad@df.lth.se> - 0.6.13-1
355- New upstream release.
356- New dependency on libusb for USB serial, DKU no longer needed/wanted
357  so now we have that troublesome issue resolved once and for all.
358- Remove patches to SQL files: these are now fixed upstream!
359
360* Mon Jun 12 2006 Linus Walleij <triad@df.lth.se> - 0.6.12-4
361- Rebuilding due to changed interface on libbluetooth.
362
363* Sun Apr 2 2006 Linus Walleij <triad@df.lth.se> - 0.6.12-4
364- Goofed up. Fixit it...
365
366* Sun Apr 2 2006 Linus Walleij <triad@df.lth.se> - 0.6.12-3
367- Post-import updates.
368
369* Thu Mar 31 2006 Linus Walleij <triad@df.lth.se> - 0.6.12-2
370- Updated after comments from Ville.
371
372* Thu Mar 16 2006 Linus Walleij <triad@df.lth.se> - 0.6.12-1
373- New upstream tarball
374
375* Wed Mar 8 2006 Linus Walleij <triad@df.lth.se> - 0.6.11-2
376- Updated after comments from Ville.
377
378* Sun Mar 5 2006 Linus Walleij <triad@df.lth.se> - 0.6.11-1
379- 0.6.11
380- Modified to drop into the Fedora Extras as the nice package it now is
381- Based work off Ville's good olde package
382
383* Sun Nov 13 2005 Ville Skyttä <ville.skytta at iki.fi> - 0.6.10-0.lvn.1
384- 0.6.10.
385- Clean up pkgconfig file and -devel dependencies from bits needed only
386  for static libs.
387
388* Thu Nov  3 2005 Ville Skyttä <ville.skytta at iki.fi> - 0.6.9-0.lvn.1
389- 0.6.9, desktop entry file included upstream.
390- Drop zero Epochs.
391
392* Sat Aug  6 2005 Ville Skyttä <ville.skytta at iki.fi> - 0:0.6.8-0.lvn.1
393- 0.6.8.
394- Don't ship static libraries.
395- Rename smsd to gnokii-smsd to avoid conflicts with smstools.
396- Remove not included files instead of using %%exclude.
397
398* Sat Jun  4 2005 Ville Skyttä <ville.skytta at iki.fi> - 0:0.6.7-0.lvn.2
399- BuildRequire openssl-devel to work around https://bugzilla.redhat.com/159569
400
401* Thu Jun  2 2005 Ville Skyttä <ville.skytta at iki.fi> - 0:0.6.7-0.lvn.1
402- 0.6.7.
403- Build unconditionally with bluetooth support.
404
405* Mon May  2 2005 Ville Skyttä <ville.skytta at iki.fi> - 0:0.6.5-0.lvn.1
406- 0.6.5.
407
408* Fri Nov  5 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:0.6.4-0.lvn.2
409- Rename -smsd-postgresql to -smsd-pgsql for consistency with other similar
410  packages in FC/Extras.
411
412* Fri Oct 22 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:0.6.4-0.lvn.1
413- Update to 0.6.4, perms and pgsql patches applied upstream.
414- Xgnokii help locale symlink hack no longer necessary.
415- Don't remove user/group on last erase, move smsd user to -smsd subpackage.
416- Add libical support (disabled), rebuild with "--with libical" to enable.
417
418* Mon Jul  5 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:0.6.3-0.lvn.1
419- Update to 0.6.3.
420
421* Sun Jun 20 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:0.6.1-0.lvn.4
422- Improve Xgnokii desktop entry according to GNOME HIG.
423
424* Sun Jun 13 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:0.6.1-0.lvn.3
425- Remove duplicate gettext build dependency (bug 95).
426
427* Sun Jun  6 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:0.6.1-0.lvn.2
428- Fix chown syntax in smsd init script.
429- Summary and description improvements.
430- Trim $RPM_OPT_FLAGS out from gnokii.pc.
431- Make -devel require XFree86-devel.
432
433* Sun Apr 18 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:0.6.1-0.lvn.1
434- Update to 0.6.1.
435
436* Thu Mar 18 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:0.6.0-0.lvn.2
437- Make -devel require pkgconfig.
438
439* Mon Feb 23 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:0.6.0-0.lvn.1
440- Update to 0.6.0.
441
442* Mon Feb  2 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:0.5.10-0.lvn.1
443- Update to 0.5.10.
444
445* Tue Jan 27 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:0.5.9-0.lvn.1
446- Update to 0.5.9.
447- Specfile cleanups, small init script enhancements.
448
449* Sat Dec 27 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:0.5.7-0.lvn.1
450- Update to 0.5.7.
451- Move smsd man page into -smsd subpackage.
452
453* Sat Nov 15 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:0.5.6-0.lvn.1
454- Update to 0.5.6.
455- Include sample action script for forwarding SMSD messages to mail.
456- s/fedora/livna/.
457- Specfile and init script cleanups.
458
459* Sat Jul 19 2003 Warren Togami <warren@togami.com> - 0:0.5.2-0.fdr.2
460- Disable smp flags to prevent build failure
461
462* Sun Jun 15 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:0.5.2-0.fdr.1
463- Update to 0.5.2.
464
465* Thu May 29 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:0.5.1-0.fdr.1
466- Update to 0.5.1.
467- Include init script, sysconfig and logrotate config for smsd.
468
469* Tue May 27 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:0.5.0-0.fdr.1
470- Update to 0.5.0.
471
472* Sun Nov  3 2002 Ville Skyttä <ville.skytta at iki.fi> 0.4.3-1cr
473- RedHat'ified PLD version.
Note: See TracBrowser for help on using the repository browser.