source: projects/specs/branches/6/g/glib/glib-vl.spec @ 1892

Revision 1892, 8.3 KB checked in by Takemikaduchi, 14 years ago (diff)

rebuild with rpm-4.8.1

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2# overwrite configure macro (remove --target option)
3%define configure CFLAGS="${CFLAGS:-%optflags}" ; export CFLAGS ; CXXFLAGS="${CXXFLAGS:-%optflags}" ; export CXXFLAGS ; FFLAGS="${FFLAGS:-%optflags}" ; export FFLAGS ; ./configure --host=%{_host} --build=%{_build} --program-prefix=%{?_program_prefix} --prefix=%{_prefix} --exec-prefix=%{_exec_prefix} --bindir=%{_bindir} --sbindir=%{_sbindir} --sysconfdir=%{_sysconfdir} --datadir=%{_datadir} --includedir=%{_includedir} --libdir=%{_libdir} --libexecdir=%{_libexecdir} --localstatedir=%{_localstatedir} --sharedstatedir=%{_sharedstatedir} --mandir=%{_mandir} --infodir=%{_infodir}
4
5# Note that this is NOT a relocatable package
6%define debug    on
7
8Summary:        A library of handy utility functions.
9Summary(ja):    便利なユーティリティ関数ライブラリ
10Name:           glib
11Version:        1.2.10
12Release:        4%{?_dist_release}
13License:        LGPL
14Group:          System Environment/Libraries
15URL:            http://www.gtk.org
16Source:         ftp://ftp.gimp.org/pub/gtk/v1.2/%{name}-%{version}.tar.gz
17Patch1:         glib-1.2.10-isowarning.patch
18Patch2:         glib-1.2.10-gcc34.patch
19Patch3:         glib-1.2.10-config.sub-x86_64.patch
20BuildRoot:      %{_tmppath}/%{name}-%{version}-root
21
22%description
23Glib is a handy library of utility functions. This C
24library is designed to solve some portability problems
25and provide other useful functionality which most
26programs require.
27
28Glib is used by GDK, GTK+ and many applications.
29You should install Glib because many of your applications
30will depend on this library.
31
32This package rebuilds binaries with debug option.
33
34%description -l ja
35Glib は便利なユーティリティ関数ライブラリです。この C
36ライブラリはいくつかのよく遭遇する問題を解決し、多くの
37プログラムで必要な有用な機能を提供するために作られました。
38
39このパッケージでは debug option 付きで binary を 作成します。
40
41
42%package devel
43Summary: Libraries and header files for glib development
44Group: Development/Libraries
45Requires(post,preun): /sbin/install-info
46
47%description devel
48Static libraries and header files for the support library for the GIMP's X
49libraries, which are available as public libraries.  GLIB includes generally
50useful data structures.
51
52%description devel -l ja
53GIMP の X ライブラリをサポートする静的関数およびヘッダファイルです。
54GLIB には使いやすいデータストラクチャーも含まれています。
55
56## to build compat32 for x86_64 architecture support
57%package -n compat32-%{name}
58Summary:        A library of handy utility functions.
59Group:          System Environment/Libraries
60Requires:       %{name} = %{version}
61%description -n compat32-%{name}
62Glib is a handy library of utility functions. This C
63library is designed to solve some portability problems
64and provide other useful functionality which most
65programs require.
66
67%package -n compat32-%{name}-devel
68Summary: Libraries and header files for glib development
69Group: Development/Libraries
70Requires:       compat32-%{name} = %{version}
71%description -n compat32-%{name}-devel
72Static libraries and header files for the support library for the GIMP's X
73libraries, which are available as public libraries.  GLIB includes generally
74useful data structures.
75
76
77%prep
78%setup -q
79%patch1 -p1 -b .isowarning
80%patch2 -p1 -b .gcc34
81%patch3 -p1 -b .config.sub
82
83
84%build
85if [ %{debug} = "on" ] ; then
86  export CFLAGS="$RPM_OPT_FLAGS -g"
87else
88  export CFLAGS="$RPM_OPT_FLAGS"
89fi
90
91%configure
92%__make
93
94
95%install
96[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
97
98%makeinstall
99
100rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.la
101rm -f $RPM_BUILD_ROOT%{_infodir}/dir
102
103#%find_lang %{name}
104
105%clean
106[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
107
108
109%post -p /sbin/ldconfig
110
111%postun -p /sbin/ldconfig
112
113
114%post devel
115/sbin/install-info %{_infodir}/glib.info* %{_infodir}/dir
116
117%preun devel
118if [ "$1" = 0 ]; then
119  /sbin/install-info --delete %{_infodir}/glib.info* %{_infodir}/dir
120fi
121
122%post -n compat32-%{name} -p /sbin/ldconfig
123
124%postun -n compat32-%{name} -p /sbin/ldconfig
125
126
127%files
128%defattr(-, root, root)
129%doc AUTHORS COPYING ChangeLog NEWS README
130%{_libdir}/libglib-1.2.so.*
131%{_libdir}/libgthread-1.2.so.*
132%{_libdir}/libgmodule-1.2.so.*
133
134%files devel
135%defattr(-, root, root)
136%{_bindir}/*
137%{_libdir}/lib*.so
138%{_libdir}/lib*.a
139%{_libdir}/glib
140%{_libdir}/pkgconfig/*
141%{_includedir}/*
142%{_datadir}/aclocal/*
143%{_infodir}/*
144%{_mandir}/man1/*
145
146## to build compat32 for x86_64 architecture support
147%if %{build_compat32}
148%files -n compat32-%{name}
149%defattr(-, root, root)
150%{_libdir}/libglib-1.2.so.*
151%{_libdir}/libgthread-1.2.so.*
152%{_libdir}/libgmodule-1.2.so.*
153
154%files -n compat32-%{name}-devel
155%defattr(-, root, root)
156%{_libdir}/lib*.so
157%{_libdir}/lib*.a
158%{_libdir}/glib
159%{_libdir}/pkgconfig/*
160%endif
161
162%changelog
163* Sat Sep 25 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.10-4
164- rebuild with rpm-4.8.1 for pkg-config file
165
166* Mon May 25 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.10-3
167- spec in UTF-8
168
169* Sat May 10 2008 NAKAMURA Kenta <kenta@vinelinux.org> 1.2.10-2
170- updated %%if %%{build_compat32} case related statements
171
172* Tue May  6 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.10-1
173- applied new versioning policy
174- moved Requires(post,preun): /sbin/install-info to devel package
175
176* Fri Feb 10 2006 Shu KONNO <owa@bg.wakwak.com> 1.2.10-0vl7
177- added compat32-* packages for x86_64 architecture support
178- added glib-1.2.10-config.sub-x86_64.patch
179
180* Tue Feb 07 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.2.10-0vl6
181- rebuild
182- disable %%find_lang macro
183- refine %%configure macro
184- add PreReq: ldconfig, install-info instead of /sbin/install-info
185
186* Wed Jul 07 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.2.10-0vl5
187- rebuilt
188- change from Copyright to License
189- add patch2
190- remove info/dir
191
192* Wed Dec 25 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.2.10-0vl4
193- rebuilt with new toolchain
194- TODO: we better remove info files when glib2 be ready to ship...
195
196* Thu Oct 11 2001 Akira TAGOH <tagoh@gnome.gr.jp> 1.2.10-0vl3
197- Applied RH patch (glib-1.2.10-isowarning.patch)
198  * Sat Jul 21 2001 Owen Taylor <otaylor@redhat.com>
199  - Add #pragma GCC system_header to supress warnings when in -pedantic
200    mode. (41271)
201- Added %%{_libdir}/pkgconfig to devel file list.
202
203* Sat Jul 14 2001 <sagami@vinelinux.org>
204- 1.2.10-0vl2: put %%patch0 at %%setup, not %%build. But already applied:-)
205
206* Tue Apr  3 2001 Akira TAGOH <tagoh@gnome.gr.jp> 1.2.10-0vl1
207- New upstream release.
208
209* Wed Mar  7 2001 Akira TAGOH <tagoh@gnome.gr.jp> 1.2.9-0vl1
210- New upstream release.
211
212* Mon Feb 05 2001 Lisa Sagami <czs14350@mb.infoweb.ne.jp>
213- 1.2.8-0vl2
214- fixed files section so as not to own mandir itself
215- use better macros
216
217* Mon May 29 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
218- updated to 1.2.8
219
220* Thu Feb 17 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
221- [glib-1.2.7-0vl1]
222
223* Mon Sep 27 1999 Jun Nishii <jun@flatout.org>
224- [glib-1.2.6-1]
225
226* Mon Sep 27 1999 Jun Nishii <jun@flatout.org>
227- [glib-1.2.5-1]
228
229* Fri Sep 7 1999 Yasuhide OOMORI <dasen@typhoon.co.jp>
230  [glib-1.2.4-2.1]
231- added debug option to CFLAG.
232
233* Fri Sep 6 1999 Yasuhide OOMORI <dasen@typhoon.co.jp>
234  [glib-1.2.4-2]
235- gzip info.
236
237* Fri Sep 3 1999 Yasuhide OOMORI <dasen@typhoon.co.jp>
238  [glib-1.2.4-1]
239- version 1.2.4.
240- bzip2 source.
241- info is installed in glib-devel.
242
243* Sat Aug 21 1999 Jun Nishii <jun@flatout.org>
244- added Japanese summary and description
245- build for Vine-1.9
246
247* Mon Jun 7 1999 Owen Taylor <otaylor@redhat.com>
248- version 1.2.3
249
250* Thu Mar 25 1999 Michael Fulbright <drmike@redhat.com>
251- version 1.2.1
252
253* Fri Feb 26 1999 Michael Fulbright <drmike@redhat.com>
254- Version 1.2
255
256* Thu Feb 25 1999 Michael Fulbright <drmike@redhat.com>
257- version 1.2.0pre1
258
259* Tue Feb 23 1999 Cristian Gafton <gafton@redhat.com>
260- new description tags
261
262* Sun Feb 21 1999 Michael Fulbright <drmike@redhat.com>
263- removed libtoolize from %build
264
265* Thu Feb 11 1999 Michael Fulbright <drmike@redhat.com>
266- added libgthread to file list
267
268* Fri Feb 05 1999 Michael Fulbright <drmike@redhat.com>
269- version 1.1.15
270
271* Wed Feb 03 1999 Michael Fulbright <drmike@redhat.com>
272- version 1.1.14
273
274* Mon Jan 18 1999 Michael Fulbright <drmike@redhat.com>
275- version 1.1.13
276
277* Wed Jan 06 1999 Michael Fulbright <drmike@redhat.com>
278- version 1.1.12
279
280* Wed Dec 16 1998 Michael Fulbright <drmike@redhat.com>
281- updated in preparation for the GNOME freeze
282
283* Mon Apr 13 1998 Marc Ewing <marc@redhat.com>
284- Split out glib package
285
Note: See TracBrowser for help on using the repository browser.