source: projects/specs/branches/6/g/glade3/glade3-vl.spec @ 1897

Revision 1897, 6.1 KB checked in by Takemikaduchi, 14 years ago (diff)

rebuild with rpm-4.8.1

Line 
1%define helpdir glade3
2
3Version: 3.6.7
4Release: 4%{?_dist_release}
5
6Summary: A user interface builder for the GTK+ toolkit and GNOME
7Summary(ja): GTK+ツールキット及びGNOME向けのユーザインターフェースビルダー
8Name: glade3
9License: GPL
10Group: Applications/Development
11URL: http://glade.gnome.org/
12Source0: http://ftp.gnome.org/pub/GNOME/sources/glade3/3.6/%{name}-%{version}.tar.bz2
13
14BuildRoot: %{_tmppath}/%{name}-%{version}-root
15BuildRequires: gtk2-devel >= 2.14.0
16BuildRequires: libxml2-devel >= 2.4.0
17BuildRequires: libbonoboui-devel
18BuildRequires: libgnomeui-devel
19BuildRequires: libSM-devel
20#BuildRequires(install): desktop-file-utils
21BuildRequires: gnome-doc-utils
22
23Requires: gtk2 >= 2.14.0
24Requires: libxml2 >= 2.4.0
25Requires: libbonoboui
26Requires: libgnomeui
27Requires: devhelp
28Prereq: scrollkeeper
29
30Vendor: Project Vine
31Distribution: Vine Linux
32
33%description
34Glade is a RAD tool to enable quick & easy development of user interfaces
35for the Gtk+ toolkit and the GNOME desktop environment.
36The user interfaces designed in Glade are stored in XML format,
37enabling easy integration with external tools.
38In particular libglade can load the XML files and create the interfaces
39at runtime. The DTD for the XML files is included with libglade, and is
40also at http://glade.gnome.org/glade-2.0.dtd.
41Other tools are available which can turn the XML files into source code
42in languages such as C++, Perl and Python.
43
44%description -l ja
45Gladeは、GTK+ツールキットやGNOME向けのユーザインターフェースを素早く簡単に開
46発する事が可能なRADツールです。
47Gladeでデザインされたユーザインターフェースは外部ツールに用意に統合可能なXML
48フォーマットで保存されます。
49特にlibgladeは、XMLファイルを読み込み、ランタイムにインターフェースを生成す
50ることが出来ます。このXMLファイルのDTDは、libgladeに含まれており、
51http://glade.gnome.org/glade-2.0.dtdにもあります。
52このXMLファイルをC++、PerlやPythonといった言語のソースコードに変換する他のツー
53ルも利用可能です。
54
55%package devel
56Summary:        the Glade UI Builder core library
57Group:          Development/Libraries
58Requires:       %{name} = %{version}-%{release}
59Requires:       gtk2-devel >= 2.12.0
60Requires:       libxml2-devel >= 2.4.0
61Requires:       libbonoboui-devel
62Requires:       libgnomeui-devel
63
64%description devel
65the Glade UI Builder core library to integrate Glade into your application
66and integrate your custom (GTK+ based) widget toolkit into the Glade
67UI Builder.
68
69%prep
70%setup -q
71pushd src
72## change gnome help directory
73mv glade-window.c glade-window.c.orig
74sed "s|GLADE_GNOMEHELPDIR, \"glade\"|GLADE_GNOMEHELPDIR, \"%{helpdir}\"|" \
75        glade-window.c.orig > glade-window.c
76popd
77
78
79%build
80%configure --disable-scrollkeeper --disable-static
81%__make %{_smp_mflags}
82
83
84%install
85rm -rf $RPM_BUILD_ROOT
86%makeinstall
87
88#desktop-file-install \
89#       --vendor gnome \
90#       --delete-original \
91#       --dir $RPM_BUILD_ROOT%{_datadir}/applications \
92#       $RPM_BUILD_ROOT%{_datadir}/applications/*
93
94rm -rf $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/icon-theme.cache
95rm -f $RPM_BUILD_ROOT%{_libdir}/glade3/modules/*.la
96rm -f $RPM_BUILD_ROOT%{_libdir}/libgladeui-1.la
97
98## change gnome help directory
99mv $RPM_BUILD_ROOT%{_datadir}/gnome/help/glade $RPM_BUILD_ROOT%{_datadir}/gnome/help/%{helpdir}
100mv $RPM_BUILD_ROOT%{_datadir}/omf/glade $RPM_BUILD_ROOT%{_datadir}/omf/%{helpdir}
101pushd $RPM_BUILD_ROOT%{_datadir}/omf/%{helpdir}
102files=`ls *.omf`
103for omf in $files; do
104        mv $omf $omf.orig
105        sed "s|help/glade/|help/%{helpdir}/|g" $omf.orig > $omf
106        rm $omf.orig
107done
108popd
109     
110%find_lang %{name}
111
112%clean
113rm -rf $RPM_BUILD_ROOT
114
115%post
116/sbin/ldconfig
117scrollkeeper-update -p /var/lib/scrollkeeper -o %{_datadir}/omf/%{helpdir}
118touch --no-create %{_datadir}/icons/hicolor
119if [ -x /usr/bin/gtk-update-icon-cache ]; then
120  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
121fi
122
123%postun
124/sbin/ldconfig
125scrollkeeper-update > /dev/null 2>&1 || :
126touch --no-create %{_datadir}/icons/hicolor
127if [ -x /usr/bin/gtk-update-icon-cache ]; then
128  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
129fi
130
131%files -f %{name}.lang
132%defattr(-,root,root)
133%{_bindir}/glade-3
134%{_libdir}/libgladeui-1.so.*
135%{_libdir}/glade3/modules/*.so
136%{_datadir}/applications/*
137%{_datadir}/glade3
138%{_datadir}/gtk-doc/html/gladeui
139%{_datadir}/gnome/help/%{helpdir}
140%{_datadir}/icons/hicolor/*/apps/glade-3.png
141%{_datadir}/icons/hicolor/scalable/apps/glade-3.svg
142%{_datadir}/omf/%{helpdir}
143
144%files  devel
145%defattr(-,root,root)
146%{_includedir}/libgladeui-1.0/gladeui/*
147%{_libdir}/pkgconfig/*.pc
148%{_libdir}/libgladeui-1.so
149
150%changelog
151* Sat Sep 25 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.7-4
152- rebuild with rpm-4.8.1 for pkg-config file
153- add BuildRequires: libSM-devel
154
155* Fri Nov 06 2009 Yasumichi Akahoshi <yasumichi@vinelinux.org> 3.6.7-3
156- add gnome-doc-utils to BR
157- comment out desktop-file-install
158
159* Tue Nov 03 2009 Yasumichi Akahoshi <yasumichi@vinelinux.org> 3.6.7-2
160- rebuild with gtk2-2.18.2
161
162* Sat Aug 01 2009 Yasumichi Akahoshi <yasumichi@vinelinux.org> 3.6.7-1
163- new upstream release
164- care ld and icon cache
165- define helpdir
166
167* Sun May 17 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.6.3-1
168- new upstream release
169- spec in utf-8 (fixed)
170
171* Fri May 01 2009 Shu KONNO <owa@bg.wakwak.com> 3.6.2-2
172- spec in utf-8
173
174* Sun Apr 19 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.6.2-1
175- new upstream release
176
177* Sat Jul 26 2008 Shu KONNO <owa@bg.wakwak.com> 3.5.2-1
178- new upstream version.
179
180* Tue May 13 2008 Yasumichi Akahoshi <yasumichi@vinelinux.org> 3.4.5-1
181- new upstream version.
182- update Requires.
183- update description.
184
185* Tue May 13 2008 Yasumichi Akahoshi <yasumichi@vinelinux.org> 3.4.1-2vl5
186- use macro for release
187
188* Fri May 09 2008 Yasumichi Akahoshi <yasumichi@vinelinux.org> 3.4.1-1vl5
189- apply new virsioning policy.
190- remove *.la
191
192* Fri Jan 04 2008 Shu KONNO <owa@bg.wakwak.com> 3.4.1-0vl
193- new upstream version
194- added Requires: devhelp
195- added Prereq: scrollkeeper
196- added disable-scrollkeeper to configure
197- added scrollkeeper-update in %%post and %%postun sections
198- changed gnome help directory temporarily
199
200* Sun Dec 17 2006 Yasumichi Akahoshi <yasumichi@vinelinux.org> 3.0.3-0vl
201- build for VineSeed
202
Note: See TracBrowser for help on using the repository browser.