source: projects/specs/branches/6/g/giflib/giflib-vl.spec @ 3525

Revision 3525, 10.3 KB checked in by owa, 13 years ago (diff)

rebuilt

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Summary:     A library for manipulating GIF format image files.
4Summary(ja): GIF 形式の画像ファイルを扱うライブラリ
5Name: giflib
6Version: 4.1.6
7Release: 4%{_dist_release}
8License: MIT
9URL: http://sourceforge.net/projects/giflib/
10Source: http://jaist.dl.sourceforge.net/sourceforge/giflib/%{name}-%{version}.tar.bz2
11Group: System Environment/Libraries
12BuildRoot: %{_tmppath}/%{name}-%{version}-root
13
14Obsoletes: libungif < 4.1.6-1
15Provides:  libungif = %{version}-%{release}
16
17
18%description
19The giflib package contains a shared library of functions for
20loading and saving GIF format image files. It is API and ABI compatible
21with libungif, the library which supported uncompressed GIFs while the
22Unisys LZW patent was in effect.
23
24Install the giflib package if you need to write programs that use GIF files.
25You should also install the giflib-utils package if you need some simple
26utilities to manipulate GIFs.
27
28%description -l ja
29giflib パッケージには GIF 形式の画像ファイルを読み書きするために必要な
30共有ライブラリが収録されています。この giflib は、Unisys LZW 特許が有効で
31あった時期に、非圧縮形式の GIF ファイルを扱うために使われていたライブラリで
32ある libungif と API / ABI 互換性があります。
33
34GIF ファイルを扱うプログラムを作成される場合は giflib パッケージを
35インストールして下さい。また、GIF ファイルを操作する簡単なユーティリティが
36必要な場合には giflib-utils パッケージも一緒にインストールする必要があります。
37
38
39%package devel
40Summary: Development tools for programs which will use the giflib library.
41Summary(ja): giflib ライブラリを使うプログラム用開発ツール
42Group: Development/Libraries
43Requires: %{name} = %{version}-%{release}
44Obsoletes: libungif-devel < 4.1.6-1
45Provides:  libungif-devel = %{version}-%{release}
46
47%description devel
48This package contains the static libraries, header files and
49documentation necessary for development of programs that will use the
50giflib library to load and save GIF format image files.
51
52You should install this package if you need to develop programs which
53will use libungif library functions.  You'll also need to install the
54giflib package.
55
56%description devel -l ja
57このパッケージには giflib ライブラリを使って GIF 形式の画像ファイルを
58読み書きするプログラムの開発に必要なスタティックライブラリ、ヘッダファイル
59そしてドキュメントが収められています。
60
61giflib ライブラリ関数を使うプログラム開発を行う場合は
62このパッケージをインストールする必要があります。
63giflib パッケージも同時にインストールして下さい。
64
65
66%package utils
67Summary: Programs for manipulating GIF format image files.
68Summary(ja): GIF 形式の画像ファイルを扱うプログラム
69Group: Applications/Graphics
70Requires: %{name} = %{version}-%{release}
71Obsoletes: libungif-progs < 4.1.6-1
72
73%description utils
74The giflib-utils package contains various programs for manipulating
75GIF format image files.
76
77Install this package if you need to manipulate GIF format image files.
78You'll also need to install the giflib package.
79
80%description utils -l ja
81giflib-utils パッケージには GIF 形式の画像ファイルを扱う
82様々なプログラムが収められています。
83
84GIF 形式の画像ファイルを扱う必要があるならこのパッケージを
85インストールして下さい。giflib パッケージも同時にインストールする
86必要があります。
87
88
89## to build compat32 for x86_64 architecture support
90%package -n compat32-%{name}
91Summary:     A library for manipulating GIF format image files.
92Summary(ja): GIF 形式の画像ファイルを扱うライブラリ
93Group: System Environment/Libraries
94Obsoletes: compat32-libungif <= %{version}-%{release}
95Provides: compat32-libungif = %{version}-%{release}
96
97%description -n compat32-%{name}
98The giflib package contains a shared library of functions for
99loading and saving GIF format image files. It is API and ABI compatible
100with libungif, the library which supported uncompressed GIFs while the
101Unisys LZW patent was in effect.
102
103Install the giflib package if you need to write programs that use GIF files.
104You should also install the giflib-utils package if you need some simple
105utilities to manipulate GIFs.
106
107
108%package -n compat32-%{name}-devel
109Summary: Development tools for programs which will use the giflib library.
110Summary(ja): giflib ライブラリを使うプログラム用開発ツール
111Group: Development/Libraries
112Obsoletes: compat32-libungif-devel < 4.1.6-1
113Provides: compat32-libungif-devel = %{version}-%{release}
114
115%description -n compat32-%{name}-devel
116This package contains the static libraries, header files and
117documentation necessary for development of programs that will use the
118giflib library to load and save GIF format image files.
119
120You should install this package if you need to develop programs which
121will use giflib library functions.  You'll also need to install the
122giflib package.
123
124
125%prep
126%setup -q -n %{name}-%{version}
127
128
129%build
130%configure
131make all
132
133MAJOR=`echo '%{version}' | sed 's/\([0-9]\+\)\..*/\1/'`
134%{__cc} $RPM_OPT_FLAGS -shared -Wl,-soname,libungif.so.$MAJOR -Llib/.libs -lgif -o libungif.so.%{version}
135
136
137%install
138rm -rf $RPM_BUILD_ROOT
139
140%makeinstall
141install -m 0755 -p libungif.so.%{version} $RPM_BUILD_ROOT%{_libdir}
142ln -sf libungif.so.%{version} ${RPM_BUILD_ROOT}%{_libdir}/libungif.so.4
143ln -sf libungif.so.4 ${RPM_BUILD_ROOT}%{_libdir}/libungif.so
144
145chmod 755 $RPM_BUILD_ROOT%{_libdir}/*.so*
146chmod 644 $RPM_BUILD_ROOT%{_libdir}/*.a
147chmod 644 COPYING README NEWS ONEWS
148chmod 644 ChangeLog TODO BUGS AUTHORS
149chmod 644 doc/* util/giffiltr.c util/gifspnge.c
150
151## remove unuse files
152rm -rf $RPM_BUILD_ROOT%{_libdir}/*.{a,la}
153
154
155%post -p /sbin/ldconfig
156
157
158%postun -p /sbin/ldconfig
159
160
161%if %{build_compat32}
162%post -n compat32-%{name} -p /sbin/ldconfig
163%postun -n compat32-%{name} -p /sbin/ldconfig
164%endif
165
166
167%clean
168rm -rf $RPM_BUILD_ROOT
169
170
171%files
172%defattr(-,root,root)
173%doc COPYING README NEWS ONEWS
174%doc ChangeLog TODO BUGS AUTHORS
175%{_libdir}/lib*.so.*
176
177%files devel
178%defattr(-,root,root)
179%doc doc/* util/giffiltr.c util/gifspnge.c
180%{_libdir}/lib*.so
181%{_includedir}/*.h
182
183%files utils
184%defattr(-,root,root)
185%{_bindir}/*
186
187## to build compat32 for x86_64 architecture support
188%if %{build_compat32}
189%files -n compat32-%{name}
190%defattr(-,root,root)
191%{_libdir}/lib*.so.*
192
193%files -n compat32-%{name}-devel
194%defattr(-,root,root)
195%{_libdir}/lib*.so
196%endif
197
198
199%changelog
200* Sun Apr 17 2011 Shu KONNO <owa@bg.wakwak.com> 4.1.6-4
201- rebuilt with rpm-4.8.1-3
202
203* Sat Feb 13 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 4.1.6-3
204- rebuild with new environment
205- remove static lib
206
207* Thu Aug 20 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 4.1.6-2
208- Obsolete specific version of libungif
209
210* Sun Jan 11 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 4.1.6-1
211- switch from the obsoleted libungif to the ongoing giflib
212  due to LZW's patent expiration which happend a few years ago
213
214* Fri Sep 26 2008 Shu KONNO <owa@bg.wakwak.com> 4.1.4-2vl5
215- removed *.la
216- spec in utf-8
217
218* Sat Apr 19 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.1.4-1vl5
219- applied new versioning policy
220- updated URL
221
222* Sun Feb 11 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.1.4-0vl1
223- new upstream release
224
225* Sat Sep 16 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.1.3-3vl3
226- changed libungif-progs Group to Applications/Graphics
227
228* Wed Feb 15 2006 Shu KONNO <owa@bg.wakwak.com> 4.1.3-3vl2
229- added compat32-* packages for x86_64 architecture support
230
231* Tue May 10 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.1.3-3vl1
232- new upstream release
233- not generate libungif.so.3* any more
234- fixed spec file based on 4.1.3-3 from Fedora development
235- s/Copyright/License/
236- updated URL
237
238* Fri Dec 13 2002 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.1.0-13vl1
239- based on 4.1.0-13 from Rawhide
240  - Clean up spec file
241  - Fix build with current auto* tools
242
243* Sat Jul 14 2001 <sagami@vinelinux.org>
244- 4.1.0-9vl1
245- follow up with 4.1.0-9 which has a fix to build against new libtool
246
247* Mon Feb 19 2001 Jun Nishii <jun@vinelinux.org>
248- 4.1.0-7vl2
249- build with netpbm
250
251* Fri Jan 12 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
252- 4.1.0-7vl1
253- based on 4.1.0-7 from Rawhide
254- added Japanese summary and description
255
256* Thu Jul 27 2000 Bernhard Rosenkraenzer <bero@redhat.com>
257- Make the subpackages require the base package (Bug #14697)
258- update URL
259- add fixes from the homepage
260
261* Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
262- automatic rebuild
263
264* Sat Jun  3 2000 Nalin Dahyabhai <nalin@redhat.com>
265- FHS adjustments (release 5)
266
267* Mon Feb 14 2000 Elliot Lee <sopwith@redhat.com> 4.1.0-4
268- Add giflibcvs-small2crash.patch, which changes lib/dgif_lib.c to be
269  whatever is currently in the libungif CVS, thus fixing bug number 9315.
270
271* Sat Feb  5 2000 Bernhard Rosenkraenzer <bero@redhat.com>
272- strip libraries
273- update URL
274- some specfile tweaks
275
276* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
277- auto rebuild in the new build environment (release 2)
278
279* Sun Mar 14 1999 Preston Brown <pbrown@redhat.com>
280- include libungif 4.1.0 as standard library, with 3.1.0 backwards compat.
281
282* Mon Jan 11 1999 Cristian Gafton <gafton@redhat.com>
283- build for 6.0
284- call libtoolize to make sure it will build on the arm
285
286* Sat Oct 31 1998 Jeff Johnson <jbj@redhat.com>
287- package for RH 5.2.
288
289* Mon Sep 14 1998 Arne Coucheron <arneco@online.no>
290  [3.1.0-3]
291- major cleanups and changes to the spec file
292
293* Mon Sep 7 1998 Toshio Kuratomi <badger@prtr-13.ucsc.edu>
294- Upgrade to version 3.1.0 (which incorporates the patches in 3.0-4)
295- Updated Source: and URL: to reflect change in directories/pages.
296
297* Tue May 26 1998 Dick Porter <dick@cymru.net>
298- Fixed some "warning: cast to pointer from integer of different size" on Alpha
299
300* Tue May 5 1998 Marc Ewing <marc@redhat.com>
301- Made it obsolete giflib and provide libgif.so and giflib (previous
302  giflib packages were built incorrectly and packages built against
303  it require libgif.so but work fine with this package)
304- cleaned buildroot
305- Removed Toshio as packager so he doesn't get yelled at when Red Hat
306  breaks it :-)
307
308* Fri Apr 24 1998 Toshio Kuratomi <badger@prtr-13.ucsc.edu>
309- Initial revision of libungif, a giflib derivative modified to not use LZW
310  compression.
Note: See TracBrowser for help on using the repository browser.