source: projects/specs/branches/6/g/gedit-plugins/gedit-plugins-vl.spec @ 2041

Revision 2041, 6.5 KB checked in by Takemikaduchi, 14 years ago (diff)

update to GNOME-2.32.0

Line 
1Name:           gedit-plugins
2Version:        2.32.0
3Release:        1%{?_dist_release}
4Summary:        A collection Official Plugins for gedit
5Summary:        gedit の公式プラグイン集
6
7Group:          Applications/Editors
8License:        GPLv2+
9URL:            http://live.gnome.org/GeditPlugins
10Source0:        ftp://ftp.gnome.org/pub/gnome/sources/gedit-plugins/2.32/%{name}-%{version}.tar.bz2
11
12BuildRoot:      %{_tmppath}/%{name}-%{version}-root
13BuildRequires:  intltool >= 0.35.0
14BuildRequires:  perl >= 5.8.1
15BuildRequires:  perl-XML-Parser
16BuildRequires:  gettext
17BuildRequires:  glib2-devel >= 2.24.0
18BuildRequires:  gtk2-devel >= 2.20.0
19BuildRequires:  GConf2-devel
20BuildRequires:  gtksourceview2-devel >= 2.5.1
21BuildRequires:  gedit-devel >= 2.30.0
22BuildRequires:  gucharmap-devel >= 2.30.0
23BuildRequires:  gnome-doc-utils
24BuildRequires:  vte-devel
25BuildRequires:  pygtk2-devel >= 2.12.0
26BuildRequires:  pygtksourceview-devel >= 2.2.0
27BuildRequires:  pygobject-devel >= 2.15.4
28BuildRequires:  python-devel
29Requires:       gedit
30Requires:       pygtk2
31Requires:       pygtksourceview
32Requires:       pygobject
33Requires(pre): GConf2
34Requires(post): GConf2
35Requires(preun): GConf2
36
37
38%description
39A collection of Official plugins for gedit.
40
41 * Bookmarks: Easy document navigation with bookmarks
42 * Bracket Completion: Automatically adds closing brackets.
43 * Character Map: Insert special characters just by clicking on them.
44 * Code comment: Comment out or uncomment a selected block of code.
45 * Color Picker: Pick a color from a dialog and insert its hexadecimal representation.
46 * Draw Spaces: Draw Spaces and Tabs
47 * Join/Split Lines: Join several lines or split long ones
48 * Session Saver: Save and restore your working sessions
49 * Show/Hide Tabbar: Add a menu entry to show/hide the tabbar.
50 * Smart Spaces: Forget you're not using tabulations.
51 * Embedded Terminal: Embed a terminal in the bottom pane.
52
53
54%description -l ja
55gedit の公式プラグイン集です。
56
57 * ブックマーク: ブックマークを使って簡単にドキュメントを閲覧できるようにします。
58 * 括弧の補完: 対応する閉じ括弧を自動的に追加します。
59 * 文字マップ: 特殊な文字をクリックしながら挿入していきます。
60 * コードのコメント: 選択した範囲をコメントアウトしたり解除します。
61 * 色の取得: 色選択ダイアログから色を取得して 16進形式の文字列として挿入します。
62 * 空白文字の表示: 空白やタブ文字を描画します。
63 * 行の結合・分割: 複数の行と結合したり一行を分割したりします。
64 * セッションの保存: 現在、作業中のセッションを保存したりリストアします。
65 * タブバーの表示/非表示: タブバーの表示切り替えエントリをメニューに追加します。
66 * スマート・スペース: 作表を使っていないことを忘れて下さい。
67 * 埋め込み式の端末: ボトム・ペインに端末を埋め込みます。
68
69
70%prep
71%setup -q
72grep '"import vte' configure && sed \
73    -i "s!import vte!import imp; imp.find_module('vte')!" configure
74
75%build
76%configure --disable-schemas-install --enable-python
77#--with-plugins=bracketcompletion,charmap,codecomment,colorpicker,drawspaces,joinlines,showtabbar,smartspaces,terminal,bookmarks
78make %{?_smp_mflags}
79
80
81%install
82rm -rf $RPM_BUILD_ROOT
83make install DESTDIR=$RPM_BUILD_ROOT
84%find_lang %{name}
85find $RPM_BUILD_ROOT/%{_libdir}/gedit-2/plugins -name "*.la" -exec rm {} \;
86
87
88%clean
89rm -rf $RPM_BUILD_ROOT
90
91
92%pre
93if [ "$1" -gt 1 ]; then
94    export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
95    gconftool-2 --makefile-uninstall-rule \
96      %{_sysconfdir}/gconf/schemas/gedit-show-tabbar-plugin.schemas >/dev/null || :
97fi
98
99
100%post
101export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
102gconftool-2 --makefile-install-rule \
103  %{_sysconfdir}/gconf/schemas/gedit-show-tabbar-plugin.schemas > /dev/null || :
104
105
106
107%preun
108if [ "$1" -eq 0 ]; then
109    export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
110    gconftool-2 --makefile-uninstall-rule \
111      %{_sysconfdir}/gconf/schemas/gedit-show-tabbar-plugin.schemas > /dev/null || :
112fi
113
114%check
115[ -f ${RPM_BUILD_ROOT}%{_libdir}/gedit-2/plugins/terminal.py ]
116
117
118%files -f %{name}.lang
119%defattr(-,root,root,-)
120%doc README NEWS AUTHORS COPYING
121%config(noreplace) %{_sysconfdir}/gconf/schemas/*.schemas
122%{_libdir}/gedit-2/plugins/*
123%{_datadir}/gedit-2/plugins/*
124
125
126%changelog
127* Tue Oct 05 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.32.0-1
128- new upstream release
129
130* Sun Apr 18 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.30.0-1
131- new upstream release
132- add BuildRequires: python-devel
133
134* Tue Dec  1 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.28.0-2
135- added BuildRequires: gedit-devel
136
137* Tue Nov  3 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.28.0-1
138- new upstream release
139
140* Sun Aug  2 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 2.26.3-1
141- Update to upstream release
142
143* Fri Jun  5 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 2.26.2-1
144- Update to upstream release
145
146* Tue May 19 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 2.26.1-1
147- initial build for VineSeed
148
149* Sat Apr 11 2009 Dodji Seketeli <dodji@redhat.org> - 2.26.1-1
150- Update to upstream release 2..26.1
151- Fixes GNOME bugzilla bug #576766 - Crash when Configuring "Draw Spaces"
152- Make sure to remove all *.la files
153- Remove BuildRequire libgnomeui-devel as needless now
154
155* Fri Apr 10 2009 Dodji Seketeli <dodji@redhat.org> - 2.26.0-1
156- Update to upstream release (2.26.1)
157- Add plugin files from %%{_datadir}
158- Don't check for vte anymore, the package checks it pkg-config
159- Add 'bookmarks' to the plugin set
160
161* Tue Feb 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.22.3-4
162- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
163
164* Mon Dec 01 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 2.22.3-3
165- Rebuild for Python 2.6
166
167* Mon Sep 29 2008 Rakesh Pandit <rakesh@fedoraproject.org> - 2.22.3-2
168- Fixed buildrequires
169
170* Mon Sep 29 2008 Rakesh Pandit <rakesh@fedoraproject.org> - 2.22.3-1
171- Updated to 2.22.3
172
173* Mon Sep 29 2008 Rakesh Pandit <rakesh@fedoraproject.org> - 2.22.0-2
174- rebuild to pick latest gucharmap
175
176* Tue Mar 18 2008 Trond Danielsen <trond.danielsen@gmail.com> - 2.22.0-1
177- Updated.
178
179* Mon Apr 30 2007 Trond Danielsen <trond.danielsen@gmail.com> - 2.18.0-2
180- Disable buggy session saver plugin.
181- Removed static libraries.
182
183* Sun Apr 01 2007 Trond Danielsen <trond.danielsen@gmail.com> - 2.18.0-1
184- Initial version.
Note: See TracBrowser for help on using the repository browser.