source: projects/specs/branches/6/g/geany/geany-vl.spec @ 2462

Revision 2462, 5.7 KB checked in by kudoh, 13 years ago (diff)
Line 
1Summary:       A fast and lightweight IDE using GTK2
2Summary(ja):       GTK2 を用いた高速・軽量な統合開発環境 (IDE)
3Name:          geany
4Version:       0.20
5Release: 1%{?_dist_release}
6License:       GPL2+
7Group:         Applications/Development
8Source:   http://download.geany.org/%{name}-%{version}.tar.bz2
9URL:           http://geany.uvena.de/
10BuildRoot:     %{_tmppath}/%{name}-%{version}-root
11
12BuildRequires: glib2-devel, gtk2-devel, pango-devel
13BuildRequires: desktop-file-utils
14BuildRequires: gettext, intltool
15BuildRequires: perl-XML-Parser
16
17Requires: glib2, pango
18Requires: gtk2 >= 2.8
19Requires: vte
20
21%description
22Geany is a small and fast editor with basic features
23of an integrated development environment.
24
25Some basic features:
26* Syntax highlighting
27* Code folding
28* Symbol name auto-completion
29* Construct completion/snippets
30* Auto-closing of XML and HTML tags
31* Many supported filetypes including C, Java, PHP, HTML, Python, Perl, Pascal (full list)
32* Symbol lists
33* Code navigation
34* Build system to compile and execute your code
35* Simple project management
36* Plugin interface (see Plugins)
37
38%description -l ja
39Geany は統合開発環境としての基本的機能を備えた、小さくて高速なエディタです。
40
41基本的機能:
42* シンタックスハイライト
43* コードの折り畳み
44* シンボル名の自動補完
45* コンピレーション/スニペットの構築
46* XML と HTML タグを自動で閉じる
47* C、Java、PHP、HTML、Python、Perl、Pascal (full list) など多くのファイル形式をサポート
48* シンボルリスト
49* コードナビゲーション
50* 自分のコードをコンパイル&実行するためのビルドシステム
51* シンプルなプロジェクト管理
52* プラグインインターフェイス
53
54%package devel
55Summary:   Devel files for building Geany plugins
56Summary(ja):   Geany プラグインをビルドするための開発ファイル
57Group:     Development/Libraries
58Requires:  geany = %{version}-%{release}
59
60%description devel
61This package contains the devel files and pkg-config file needed for building
62Geany plugins. You do not need to install this package to use Geany.
63
64%description devel -l ja
65このパッケージには Geany プラグインをビルドするために必要な開発ファイル、
66及び pkg-config ファイルが含まれています。
67Geany を使うためにこのパッケージをインストールする必要はありません。
68
69%prep
70%setup -q
71
72%build
73%configure
74make %{?_smp_mflags}
75
76%install
77%__rm -Rf $RPM_BUILD_ROOT
78%makeinstall
79%__rm $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/icon-theme.cache
80
81desktop-file-install --delete-original --vendor="vine"        \
82        --dir=${RPM_BUILD_ROOT}%{_datadir}/applications         \
83        --mode 0644                                             \
84        $RPM_BUILD_ROOT/%{_datadir}/applications/%{name}.desktop
85
86# Remove libtool library archive (*.la) files
87rm -rf $RPM_BUILD_ROOT%{_libdir}/geany/*.la
88
89%clean
90%__rm -Rf $RPM_BUILD_ROOT
91
92%post
93update-desktop-database %{_datadir}/applications
94touch --no-create %{_datadir}/icons/hicolor
95if [ -x /usr/bin/gtk-update-icon-cache ]; then
96  gtk-update-icon-cache -q %{_datadir}/icons/hicolor ||:
97fi
98
99%postun
100update-desktop-database %{_datadir}/applications
101touch --no-create %{_datadir}/icons/hicolor
102if [ -x /usr/bin/gtk-update-icon-cache ]; then
103  gtk-update-icon-cache -q %{_datadir}/icons/hicolor ||:
104fi
105
106%files
107%defattr(-, root, root, -)
108%doc AUTHORS COPYING ChangeLog HACKING INSTALL NEWS README TODO THANKS
109%{_bindir}/%{name}
110%{_datadir}/%{name}
111%{_libdir}/%{name}
112%{_datadir}/applications/*.desktop
113%{_datadir}/locale/*/LC_MESSAGES/%{name}.mo
114%{_datadir}/icons/hicolor/*
115%{_datadir}/doc/%{name}/
116%{_mandir}/man1/geany.1.gz
117
118%files devel
119%defattr(-, root, root, -)
120%{_includedir}/geany
121%{_libdir}/pkgconfig/geany.pc
122
123%changelog
124* Sun Jan 9 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.20-1
125- new upstream version
126
127* Thu Dec 2 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.19.2-1
128- new upstream version
129
130* Mon Sep 27 2010 Shu KONNO <owa@bg.wakwak.com> 0.19.1-2
131- rebuilt with rpm-4.8.1 for pkg-config
132
133* Sat Aug 21 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.19.1-1
134- new upstream version
135
136* Sun Jun 13 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.19-1
137- new upstream version
138
139* Wed Feb 17 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.18.1-1
140- new upstream version
141
142* Fri Nov 27 2009 Shu KONNO <owa@bg.wakwak.com> 0.18-2
143- rebuilt
144
145* Wed Aug 19 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.18-1vl5
146- new upstream version
147- added update-desktop-database %{_datadir}/applications in %post, %postun
148- run gtk-update-icon-cache in %post, %postun
149
150* Sat Jun 20 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.17-4vl5
151- updated description
152- added desktop-file-install
153- added BuildRequires: desktop-file-utils
154
155* Sun May 10 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.17-3vl5
156- fixed BuildRequires: perl-XML-Parser
157
158* Sun May 10 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.17-2vl5
159- fixed %BuildRoot
160- changed Group to Applications/Development
161  -devel Group to Development/Libraries
162- added BuildRequires: gettext, intltool, perl(XML::Parser)
163- added Requires: vte
164
165* Sun May 3 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.17-1vl5
166- new upstream version
167- spec in UTF-8
168
169* Mon Feb 16 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.16-1vl5
170- new upstream version
171- fixed Requires: gtk2 >= 2.8 (minimum required GTK version 2.8)
172
173* Wed Feb 11 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.15-2vl5
174- fixed License
175- updated Source URL
176- modified %build (use "%{?_smp_mflags}")
177- splited -devel sub-package (for header files)
178- removed *.la files
179
180* Sat Feb 7 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.15-1vl5
181- initial build for VineSeed
Note: See TracBrowser for help on using the repository browser.