source: projects/specs/branches/6/g/gdk-pixbuf2/gdk-pixbuf2-vl.spec @ 10692

Revision 10692, 7.8 KB checked in by tomop, 8 years ago (diff)

gdk-pixbuf2-2.22.1-2

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3# biarch support
4%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
5%define _query_suffix %{nil}
6%if %{build_compat32}
7%define _query_suffix -32
8%endif
9
10Name:           gdk-pixbuf2
11Version:        2.22.1
12Release:        2%{?_dist_release}
13Summary:        An image loading library
14
15Group:          System Environment/Libraries
16License:        LGPLv2+
17URL:            http://www.gt.org
18Source0:        http://download.gnome.org/sources/gdk-pixbuf/2.22/gdk-pixbuf-%{version}.tar.bz2
19
20BuildRequires:  glib2-devel >= 2.26.0
21BuildRequires:  libpng-devel
22BuildRequires:  libjpeg-turbo-devel
23BuildRequires:  libtiff-devel
24BuildRequires:  jasper-devel
25BuildRequires:  libX11-devel
26BuildRequires:  gobject-introspection-devel
27
28# gdk-pixbuf does a configure time check which uses the GIO mime
29# layer; we need to actually have the mime type database.
30BuildRequires:  shared-mime-info
31
32BuildRequires: gtk-doc
33## BuildRequires: libtool >= 2.2.10
34BuildRequires: libtool
35BuildRequires: gettext
36
37# We also need MIME information at runtime
38Requires: shared-mime-info
39
40# gdk-pixbuf was included in gtk2 until 2.21.2
41Conflicts: gtk2 <= 2.21.2
42
43# https://bugzilla.gnome.org/show_bug.cgi?id=624712
44Patch0: 0001-Fix-linking-when-libpng-loader-is-builtin.patch
45
46# security patches
47Patch1000: CVE-2011-2485.patch
48Patch1001: CVE-2012-2370.patch
49Patch1002: CVE-2015-4491-1.patch
50Patch1003: CVE-2015-4491-2.patch
51Patch1004: CVE-2015-7673-1.patch
52Patch1005: CVE-2015-7673-2.patch
53Patch1006: CVE-2015-7673-3.patch
54Patch1007: CVE-2015-7674.patch
55Patch1008: CVE-2015-8875.patch
56
57%description
58gdk-pixbuf is an image loading library that can be extended by loadable
59modules for new image formats. It is used by toolkits such as GTK+ or
60clutter.
61
62%package devel
63Summary: Development files for gdk-pixbuf
64Group: Development/Libraries
65Requires: %{name} = %{version}-%{release}
66Requires: glib2-devel
67Requires: gobject-introspection-devel
68Requires: libpng-devel
69
70# gdk-pixbuf was included in gtk2 until 2.21.2
71Conflicts: gtk2-devel <= 2.21.2
72
73%description devel
74This package contains the libraries and header files that are needed
75for writing applications that are using gdk-pixbuf.
76
77%if %{build_compat32}
78#######################################################################
79# compat32
80%package -n compat32-%{name}
81Summary:        An image loading library
82Group:          System Environment/Libraries
83Requires(post): compat32-glib2 >= %{glib2_version}
84# gdk-pixbuf was included in gtk2 until 2.21.2
85Conflicts: compat32-gtk2 <= 2.21.2
86
87%description -n compat32-%{name}
88gdk-pixbuf is an image loading library that can be extended by loadable
89modules for new image formats. It is used by toolkits such as GTK+ or
90clutter.
91
92%package -n compat32-%{name}-devel
93Summary: Development files for gdk-pixbuf
94Group: Development/Libraries
95Requires: compat32-%{name} = %{version}-%{release}
96Requires: %{name} = %{version}-%{release}
97Requires: compat32-libpng-devel
98
99# gdk-pixbuf was included in gtk2 until 2.21.2
100Conflicts: compat32-gtk2-devel <= 2.21.2
101
102%description -n compat32-%{name}-devel
103This package contains the libraries and header files that are needed
104for writing applications that are using gdk-pixbuf.
105
106%endif
107
108
109%prep
110%setup -q -n gdk-pixbuf-%{version}
111## %patch0 -p1 -b .libpng-linking
112
113%patch1000 -p1 -b .CVE-2011-2485
114%patch1001 -p1 -b .CVE-2012-2370
115%patch1002 -p1 -b .CVE-2015-4491-1
116%patch1003 -p1 -b .CVE-2015-4491-2
117%patch1004 -p1 -b .CVE-2015-7673-1
118%patch1005 -p1 -b .CVE-2015-7673-2
119%patch1006 -p1 -b .CVE-2015-7673-3
120%patch1007 -p1 -b .CVE-2015-7674
121%patch1008 -p1 -b .CVE-2015-8875
122
123%build
124libtoolize --copy --force
125autoreconf -if
126(if ! test -x configure; then NOCONFIGURE=1 ./autogen.sh; CONFIGFLAGS=--enable-gtk-doc; fi;
127 %configure $CONFIGFLAGS \
128        --with-libjasper             \
129        --with-included-loaders=png  \
130        --enable-introspection=yes  )
131make %{?_smp_mflags}
132
133
134%install
135make install DESTDIR=$RPM_BUILD_ROOT    \
136             RUN_QUERY_LOADER_TEST=false
137
138# Remove unpackaged files
139rm $RPM_BUILD_ROOT%{_libdir}/*.la
140rm $RPM_BUILD_ROOT%{_libdir}/gdk-pixbuf-2.0/2.10.0/loaders/*.la
141
142touch $RPM_BUILD_ROOT%{_libdir}/gdk-pixbuf-2.0/2.10.0/loaders.cache
143
144%if %{build_compat32}
145   cp $RPM_BUILD_ROOT%{_bindir}/gdk-pixbuf-query-loaders \
146      $RPM_BUILD_ROOT%{_bindir}/gdk-pixbuf-query-loaders%{_query_suffix}
147%endif
148
149%find_lang gdk-pixbuf
150
151%post
152/sbin/ldconfig
153gdk-pixbuf-query-loaders --update-cache || : > /dev/null 2>&1
154
155%postun
156/sbin/ldconfig
157if [ $1 -gt 0 ]; then
158  gdk-pixbuf-query-loaders --update-cache || : > /dev/null 2>&1
159fi
160
161%if %{build_compat32}
162%post -n compat32-%{name}
163/sbin/ldconfig
164gdk-pixbuf-query-loaders%{_query_suffix} --update-cache || : > /dev/null 2>&1
165
166%postun -n compat32-%{name}
167/sbin/ldconfig
168if [ $1 -gt 0 ]; then
169  gdk-pixbuf-query-loaders%{_query_suffix} --update-cache || : > /dev/null 2>&1
170fi
171%endif
172
173
174%files -f gdk-pixbuf.lang
175%defattr(-,root,root,-)
176%doc AUTHORS COPYING NEWS
177%{_libdir}/libgdk_pixbuf-2.0.so.*
178%{_libdir}/libgdk_pixbuf_xlib-2.0.so.*
179%{_libdir}/girepository-1.0
180%dir %{_libdir}/gdk-pixbuf-2.0
181%dir %{_libdir}/gdk-pixbuf-2.0/2.10.0
182%dir %{_libdir}/gdk-pixbuf-2.0/2.10.0/loaders
183%{_libdir}/gdk-pixbuf-2.0/2.10.0/loaders/*.so
184%ghost %{_libdir}/gdk-pixbuf-2.0/2.10.0/loaders.cache
185%{_bindir}/gdk-pixbuf-query-loaders
186%{_mandir}/man1/gdk-pixbuf-query-loaders.1.gz
187
188%files devel
189%defattr(-,root,root,-)
190%{_includedir}/gdk-pixbuf-2.0
191%{_libdir}/libgdk_pixbuf-2.0.so
192%{_libdir}/libgdk_pixbuf_xlib-2.0.so
193%{_libdir}/pkgconfig/gdk-pixbuf-2.0.pc
194%{_libdir}/pkgconfig/gdk-pixbuf-xlib-2.0.pc
195%{_bindir}/gdk-pixbuf-csource
196%{_datadir}/gtk-doc/html/*
197%{_datadir}/gir-1.0
198%{_mandir}/man1/gdk-pixbuf-csource.1.gz
199
200%if %{build_compat32}
201%files -n compat32-%{name}
202%defattr(-,root,root,-)
203%{_libdir}/libgdk_pixbuf-2.0.so.*
204%{_libdir}/libgdk_pixbuf_xlib-2.0.so.*
205%dir %{_libdir}/gdk-pixbuf-2.0
206%dir %{_libdir}/gdk-pixbuf-2.0/2.10.0
207%dir %{_libdir}/gdk-pixbuf-2.0/2.10.0/loaders
208%{_libdir}/gdk-pixbuf-2.0/2.10.0/loaders/*.so
209%ghost %{_libdir}/gdk-pixbuf-2.0/2.10.0/loaders.cache
210%{_bindir}/gdk-pixbuf-query-loaders%{_query_suffix}
211
212%files -n compat32-%{name}-devel
213%defattr(-,root,root,-)
214%{_libdir}/libgdk_pixbuf-2.0.so
215%{_libdir}/libgdk_pixbuf_xlib-2.0.so
216%{_libdir}/pkgconfig/gdk-pixbuf-2.0.pc
217%{_libdir}/pkgconfig/gdk-pixbuf-xlib-2.0.pc
218%endif
219
220%changelog
221* Wed Jul 27 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.22.1-2
222- added Patch1000-1008 to fix vulnerabilities.
223  - CVE-2011-2485
224  - CVE-2012-2370
225  - CVE-2015-4491
226  - CVE-2015-7673
227  - CVE-2015-7674
228  - CVE-2015-8875
229
230* Sat Nov 20 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.22.1-1
231- new upstream release
232
233* Sat Oct 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.22.0-1
234- new upstream release
235- add configure option (--enable-introspection=yes)
236- drop Patch0
237
238* Sat Oct 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.21.3-1
239- initial build for Vine Linux
240
241
242* Mon Jul 19 2010 Bastien Nocera <bnocera@redhat.com> 2.21.6-3
243- Require libpng for linking
244
245* Thu Jul 15 2010 Colin Walters <walters@verbum.org> - 2.21.6-2
246- Rebuild with new gobject-introspection
247
248* Mon Jul 12 2010 Matthias Clasen <mclasen@redhat.com> - 2.21.6-1
249- Update to 2.21.6
250
251* Fri Jul  2 2010 Colin Walters <walters@verbum.org> - 2.21.5-4
252- Also Require shared-mime-info for same reason
253
254* Fri Jul  2 2010 Colin Walters <walters@verbum.org> - 2.21.5-3
255- BR shared-mime-info; see comment above it
256
257* Tue Jun 29 2010 Colin Walters <walters@pocket> - 2.21.5-2
258- Changes to support snapshot builds
259
260* Mon Jun 28 2010 Matthias Clasen <mclasen@redhat.com> 2.21.5-1
261- Update to 2.21.5
262
263* Sat Jun 26 2010 Matthias Clasen <mclasen@redhat.com> 2.21.4-2
264- Rename to gdk-pixbuf2 to avoid conflict with the
265  existing gdk-pixbuf package
266
267* Sat Jun 26 2010 Matthias Clasen <mclasen@redhat.com> 2.21.4-1
268- Update to 2.21.4
269- Incorporate package review feedback
270
271* Sat Jun 26 2010 Matthias Clasen <mclasen@redhat.com> 2.21.3-1
272- Initial packaging
Note: See TracBrowser for help on using the repository browser.