source: projects/specs/branches/6/g/gdb/gdb-vl.spec @ 3751

Revision 3751, 13.1 KB checked in by Takemikaduchi, 13 years ago (diff)

fix BuildRequires?

Line 
1Summary: A GNU source-level debugger for C, C++ and other languages.
2Summary(ja): C, C++ その他の言語用 GNU ソースレベルデバッガ
3Name: gdb
4Version: 7.2
5Release: 2%{?_dist_release}
6License: GPL
7Group: Development/Debuggers
8Source: ftp://sources.redhat.com/pub/gdb/releases/gdb-%{version}.tar.bz2
9Buildroot: %{_tmppath}/%{name}-%{version}-root
10URL: http://sources.redhat.com/gdb/
11BuildRequires: ncurses-devel glibc-devel gcc make gzip texinfo expat-devel
12BuildRequires: python-devel
13BuildRequires: zlib-devel
14Requires: install-info
15
16Vendor: Project Vine
17Distribution: Vine Linux
18Packager: Takemikaduchi
19
20%description
21GDB, the GNU debugger, allows you to debug programs written in C, C++,
22and other languages, by executing them in a controlled fashion and
23printing their data.
24
25%description -l ja
26GDB (GNU デバッガ) は C, C++ その他の言語で書かれたプログラムのデバッグに
27使うツールです.プログラムの実行を制御し,データを出力することができます.
28
29%prep
30%setup -q
31
32%build
33export CFLAGS="$RPM_OPT_FLAGS"
34rm -fr dejagnu tcl expect
35./configure \
36        --prefix=%{_prefix} \
37        --sysconfdir=%{_sysconfdir} \
38        --mandir=%{_mandir} \
39    --infodir=%{_infodir} \
40        %{_target_platform}
41
42make
43make info
44cp gdb/NEWS .
45
46%install
47rm -rf $RPM_BUILD_ROOT
48%makeinstall infodir=$RPM_BUILD_ROOT%{_infodir} prefix=$RPM_BUILD_ROOT%{_prefix}
49
50# install the gcore script in /usr/bin
51install -m755 $RPM_BUILD_DIR/gdb-%{version}/gdb/gdb_gcore.sh $RPM_BUILD_ROOT%{_bindir}/gcore
52
53# The above is broken, do this for now:
54#mkdir -p $RPM_BUILD_ROOT/%{_infodir}
55#cp `find -name "*.info*"` $RPM_BUILD_ROOT/%{_infodir}
56
57# These are part of binutils
58#rm -f $RPM_BUILD_ROOT%{_infodir}/dir
59#rm -f $RPM_BUILD_ROOT%{_infodir}/dir.info*
60rm -f $RPM_BUILD_ROOT%{_infodir}/bfd*
61rm -f $RPM_BUILD_ROOT%{_infodir}/configure*
62rm -f $RPM_BUILD_ROOT%{_infodir}/standard*
63rm -r $RPM_BUILD_ROOT%{_libdir}/lib{bfd*,iberty*,opcodes*}
64rm -f $RPM_BUILD_ROOT%{_localedir}/*/LC_MESSAGES/{bfd.mo,opcodes.mo}
65rm -rf $RPM_BUILD_ROOT%{_includedir}
66
67%clean
68rm -rf $RPM_BUILD_ROOT
69
70
71%post
72[ -f %{_infodir}/annotate.info ]        && /sbin/install-info %{_infodir}/annotate.info %{_infodir}/dir || :
73[ -f %{_infodir}/annotate.info.gz ]     && /sbin/install-info %{_infodir}/annotate.info.gz %{_infodir}/dir  || :
74[ -f %{_infodir}/gdb.info ]             && /sbin/install-info %{_infodir}/gdb.info %{_infodir}/dir || :
75[ -f %{_infodir}/gdb.info.gz ]          && /sbin/install-info %{_infodir}/gdb.info.gz %{_infodir}/dir  || :
76[ -f %{_infodir}/gdbint.info ]         && /sbin/install-info %{_infodir}/gdbint.info %{_infodir}/dir || :
77[ -f %{_infodir}/gdbint.info.gz ]      && /sbin/install-info %{_infodir}/gdbint.info.gz %{_infodir}/dir  || :
78[ -f %{_infodir}/stabs.info ]           && /sbin/install-info %{_infodir}/stabs.info %{_infodir}/dir  || :
79[ -f %{_infodir}/stabs.info.gz ]        && /sbin/install-info %{_infodir}/stabs.info.gz %{_infodir}/dir  || :
80
81
82%preun
83if [ $1 = 0 ]; then
84        [ -f %{_infodir}/annotate.info ]        && /sbin/install-info --delete %{_infodir}/annotate.info %{_infodir}/dir  || :
85        [ -f %{_infodir}/annotate.info.gz ]     && /sbin/install-info --delete %{_infodir}/annotate.info.gz %{_infodir}/dir  || :
86        [ -f %{_infodir}/gdb.info ]             && /sbin/install-info --delete %{_infodir}/gdb.info %{_infodir}/dir  || :
87        [ -f %{_infodir}/gdb.info.gz ]          && /sbin/install-info --delete %{_infodir}/gdb.info.gz %{_infodir}/dir  || :
88        [ -f %{_infodir}/gdbint.info ]          && /sbin/install-info --delete %{_infodir}/gdbint.info %{_infodir}/dir  || :
89        [ -f %{_infodir}/gdbint.info.gz ]       && /sbin/install-info --delete %{_infodir}/gdbint.info.gz %{_infodir}/dir  || :
90        [ -f %{_infodir}/stabs.info ]           && /sbin/install-info --delete %{_infodir}/stabs.info %{_infodir}/dir  || :
91        [ -f %{_infodir}/stabs.info.gz ]        && /sbin/install-info --delete %{_infodir}/stabs.info.gz %{_infodir}/dir  || :
92fi
93
94
95%files
96%defattr(-,root,root)
97%doc COPYING COPYING.LIB README NEWS
98%{_bindir}/*
99%{_mandir}/*/*
100%{_datadir}/gdb/syscalls
101%{_infodir}/annotate.info*
102%{_infodir}/gdb.info*
103%{_infodir}/gdbint.info*
104%{_infodir}/stabs.info*
105%exclude %{_infodir}/dir
106%ifarch %{ix86} x86_64
107%{_libdir}/libinproctrace.so
108%endif
109## don't include the files in include, they are part of binutils
110#%{_includedir}/*
111#%{_infodir}/bfd.info*
112#%{_infodir}/configure.info*
113#%{_infodir}/standard.info*
114#%{_libdir}/*
115#%{_datadir}/locale/*/LC_MESSAGES/bfd.mo
116#%{_datadir}/locale/*/LC_MESSAGES/opcode.mo
117
118
119%changelog
120* Sat Apr 30 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.2-2
121- add BuildRequires: python-devel, zlib-devel
122- fix %%files
123
124* Thu Apr 28 2011 Shu KONNO <owa@bg.wakwak.com> 7.2-1
125- updated gdb to 7.2
126
127* Wed Feb 17 2010 Shu KONNO <owa@bg.wakwak.com> 7.0.1-1
128- updated gdb to 7.0.1
129- rebuilt with new environment
130
131* Sat Sep 13 2008 Shu KONNO <owa@bg.wakwak.com> 6.7.1-1vl5
132- applied new versioning policy, spec in utf-8
133
134* Mon Feb 25 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.7.1-0vl4
135- rebuild with expat-2.0.1
136- add BuildRequires: expat-devel
137
138* Sun Jan 27 2008 Shu KONNO <owa@bg.wakwak.com> 6.7.1-0vl3
139- dropt %%{_localedir}/*/LC_MESSAGES/*.mo conflicts with binutils
140
141* Fri Jan 04 2008 Shu KONNO <owa@bg.wakwak.com> 6.7.1-0vl2
142- dropt %%{_libdir}/lib{bfd*,iberty*,opcodes*} conflicts with binutils-devel
143
144* Mon Dec 31 2007 Shu KONNO <owa@bg.wakwak.com> 6.7.1-0vl1
145- new upstream release
146
147* Wed Jul 12 2006 Shu KONNO <owa@bg.wakwak.com> 6.4.90-0vl1
148- new upstream release
149
150* Sat Dec 10 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.4.0-0vl1
151- new upstream release
152
153* Thu Nov 28 2002 KAZUKI SHIMURA <rito@pos.to> 5.2.1-4vl2
154- Oops, spec was written in Shift-JIS. Fixed.
155
156* Mon Nov 11 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 5.2.1-4vl1
157- based on 5.2.1-4 from Rawhide and built for Vine Linux
158
159* Fri Aug 23 2002 Florian La Roche <Florian.LaRoche@redhat.de>
160- added mainframe patch from developerworks
161
162* Wed Aug 21 2002 Trond Eivind Glomsr <teg@redhat.com> 5.2.1-3
163- Add changelogs to the previous patch
164
165* Wed Aug 14 2002 Trond Eivind Glomsr <teg@redhat.com> 5.2.1-2
166- Add some patches from Elena Zannoni <ezannoni@redhat.com>
167
168* Tue Jul 23 2002 Trond Eivind Glomsr <teg@redhat.com> 5.2.1-1
169- 5.2.1
170
171* Mon Jul 22 2002 Florian La Roche <Florian.LaRoche@redhat.de>
172- compile on mainframe
173
174* Mon Jul  8 2002 Trond Eivind Glomsr <teg@redhat.com> 5.2-3
175- Rebuild
176
177* Tue May  7 2002 Trond Eivind Glomsr <teg@redhat.com> 5.2-2
178- Rebuild
179
180* Mon Apr 29 2002 Trond Eivind Glomsr <teg@redhat.com> 5.2-1
181- 5.2
182
183* Mon Apr 29 2002 Trond Eivind Glomsr <teg@redhat.com> 5.1.92-1
184- 5.1.92. Hopefully identical to 5.2 final
185
186* Mon Apr 22 2002 Trond Eivind Glomsr <teg@redhat.com> 5.1.91-1
187- 5.1.91. 5.2 expected in a week
188
189* Thu Mar 28 2002 Trond Eivind Glomsr <teg@redhat.com> 5.1.90CVS-5
190- Update to current
191
192* Thu Mar 28 2002 Trond Eivind Glomsr <teg@redhat.com> 5.1.90CVS-4
193- Update to current
194
195* Thu Mar 28 2002 Trond Eivind Glomsr <teg@redhat.com> 5.1.90CVS-3
196- Update to current
197
198* Wed Mar 20 2002 Trond Eivind Glomsr <teg@redhat.com> 5.1.90CVS-2
199- Update to current
200
201* Wed Mar 13 2002 Trond Eivind Glomsr <teg@redhat.com> 5.1.90CVS-1
202- Update to current 5.2 branch
203
204* Thu Jan 24 2002 Trond Eivind Glomsr <teg@redhat.com> 5.1.1-1
205- 5.1.1
206- add URL
207
208* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
209- automated rebuild
210
211* Mon Dec 10 2001 Trond Eivind Glomsr <teg@redhat.com> 5.1-2
212- Fix some thread+fpu problems
213
214* Mon Nov 26 2001 Trond Eivind Glomsr <teg@redhat.com> 5.1-1
215- 5.1
216
217* Mon Nov 19 2001 Trond Eivind Glomsr <teg@redhat.com> 5.0.94-0.71
218- 5.0.94. Almost there....
219
220* Mon Nov 12 2001 Trond Eivind Glomsr <teg@redhat.com> 5.0.93-2
221- Add patch from jakub@redhat.com to improve handling of DWARF
222
223* Mon Nov 12 2001 Trond Eivind Glomsr <teg@redhat.com> 5.0.93-1
224- 5.0.93
225- handle missing info pages in post/pre scripts
226
227* Wed Oct 31 2001 Trond Eivind Glomsr <teg@redhat.com> 5.0.92-1
228- 5.0.92
229
230* Fri Oct 26 2001 Trond Eivind Glomsr <teg@redhat.com> 5.0.91rh-1
231- New snapshot
232- Use the 5.0.91 versioning from the snapshot
233
234* Wed Oct 17 2001 Trond Eivind Glomsr <teg@redhat.com> 5.0rh-17
235- New snapshot
236
237* Thu Sep 27 2001 Trond Eivind Glomsr <teg@redhat.com>
238- New snapshot
239
240* Wed Sep 12 2001 Trond Eivind Glomsr <teg@redhat.com> 5.0rh-16
241- New snapshot
242
243* Mon Aug 13 2001 Trond Eivind Glomsr <teg@redhat.com> 5.0rh-15
244- Don't buildrequire compat-glibc (#51690)
245
246* Thu Aug  9 2001 Trond Eivind Glomsr <teg@redhat.com>
247- New snapshot, from the stable branch eventually leading to gdb 5.1
248
249* Mon Jul 30 2001 Trond Eivind Glomsr <teg@redhat.com>
250- s/Copyright/License/
251- Add texinfo to BuildRequires
252
253* Mon Jun 25 2001 Trond Eivind Glomsr <teg@redhat.com>
254- New snapshot
255
256* Fri Jun 15 2001 Trond Eivind Glomsr <teg@redhat.com>
257- New snapshot
258- Add ncurses-devel to buildprereq
259- Remove perl from buildprereq, as gdb changed the way
260  version strings are generated
261
262* Thu Jun 14 2001 Trond Eivind Glomsr <teg@redhat.com>
263- New snapshot
264
265* Wed May 16 2001 Trond Eivind Glomsr <teg@redhat.com>
266- New snapshot - this had thread fixes for curing #39070
267- New way of specifying version
268
269* Tue May  1 2001 Trond Eivind Glomsr <teg@redhat.com>
270- New tarball
271- Kevin's patch is now part of gdb
272
273* Mon Apr  9 2001 Trond Eivind Glomsr <teg@redhat.com>
274- Add patch from kevinb@redhat.com to fix floating point + thread
275  problem (#24310)
276- remove old workarounds
277- new snapshot
278
279* Thu Apr  5 2001 Trond Eivind Glomsr <teg@redhat.com>
280- New snapshot
281
282* Sat Mar 17 2001 Bill Nottingham <notting@redhat.com>
283- on ia64, there are no old headers :)
284
285* Fri Mar 16 2001 Trond Eivind Glomsr <teg@redhat.com>
286- build with old headers, new compiler
287
288* Wed Mar 16 2001 Trond Eivind Glomsr <teg@redhat.com>
289- new snapshot
290
291* Mon Feb 26 2001 Trond Eivind Glomsr <teg@redhat.com>
292- new snapshot which should fix some more IA64 problems (#29151)
293- remove IA64 patch, it's now integrated
294
295* Wed Feb 21 2001 Trond Eivind Glomsr <teg@redhat.com>
296- add IA64 and Alpha patches from Kevin Buettner <kevinb@redhat.com>
297- use perl instead of patch for fixing the version string
298
299* Tue Feb 20 2001 Trond Eivind Glomsr <teg@redhat.com>
300- don't use kgcc anymore
301- mark it as our own version
302- new snapshot
303
304* Mon Jan 22 2001 Bernhard Rosenkraenzer <bero@redhat.com>
305- Link with ncurses 5.x even though we're using kgcc.
306  No need to drag in requirements on ncurses4 (Bug #24445)
307
308* Fri Jan 19 2001 Trond Eivind Glomsr <teg@redhat.com>
309- new snapshot
310
311* Thu Dec 20 2000 Trond Eivind Glomsr <teg@redhat.com>
312- new snapshot
313
314* Mon Dec 04 2000 Trond Eivind Glomsr <teg@redhat.com>
315- new snapshot
316- new alpha patch - it now compiles everywhere. Finally.
317
318* Fri Dec 01 2000 Trond Eivind Glomsr <teg@redhat.com>
319- new snapshot
320
321* Mon Nov 20 2000 Trond Eivind Glomsr <teg@redhat.com>
322- new CVS snapshot
323- disable the patches
324- don't use %%configure, as it confuses the autoconf script
325- enable SPARC, disable Alpha
326
327
328* Wed Aug 09 2000 Trond Eivind Glomsr <teg@redhat.com>
329- added patch from GDB team for C++ symbol handling
330
331* Mon Jul 25 2000 Trond Eivind Glomsr <teg@redhat.com>
332- upgrade to CVS snapshot
333- excludearch SPARC, build on IA61
334
335* Wed Jul 19 2000 Trond Eivind Glomsr <teg@redhat.com>
336- rebuild
337
338* Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
339- automatic rebuild
340
341* Sun Jul 02 2000 Trond Eivind Glomsr <teg@redhat.com>
342- rebuild
343
344* Fri Jun 08 2000 Trond Eivind Glomsr <teg@redhat.com>
345- use %%configure, %%makeinstall, %%{_infodir}, %%{_mandir},
346  and %%{_tmppath}
347- the install scripts  for info are broken(they don't care about
348  you specify in the installstep), work around that.
349- don't build for IA64
350
351* Mon May 22 2000 Trond Eivind Glomsr <teg@redhat.com>
352- upgraded to 5.0 - dump all patches. Reapply later if needed.
353- added the NEWS file to the %%doc files
354- don't delete files which doesn't get installed (readline, texinfo)
355- let build system handle stripping and gzipping
356- don't delete libmmalloc
357- apply patch from jakub@redhat.com to make it build on SPARC
358
359* Fri Apr 28 2000 Matt Wilson <msw@redhat.com>
360- rebuilt against new ncurses
361
362* Tue Mar  7 2000 Jeff Johnson <jbj@redhat.com>
363- rebuild for sparc baud rates > 38400.
364
365* Tue Feb  8 2000 Jakub Jelinek <jakub@redhat.com>
366- fix core file handling on i386 with glibc 2.1.3 headers
367
368* Fri Jan 14 2000 Jakub Jelinek <jakub@redhat.com>
369- fix reading registers from core on sparc.
370- hack around build problems on i386 with glibc 2.1.3 headers
371
372* Thu Oct 7 1999 Jim Kingdon
373- List files to install in /usr/info specifically (so we don't pick up
374things like info.info from GDB snapshots).
375
376* Thu Oct 7 1999 Jim Kingdon
377- Update GDB to 19991004 snapshot.  This eliminates the need for the
378sigtramp, sparc, xref, and threads patches.  Update sparcmin patch.
379
380* Mon Aug 23 1999 Jim Kingdon
381- Omit readline manpage.
382
383* Tue Aug 7 1999 Jim Kingdon
384- Remove H.J. Lu's patches (they had been commented out).
385- Add sigtramp patch (from gdb.cygnus.com) and threads patch (adapted
386from code fusion CD-ROM).
387
388* Wed Apr 14 1999 Jeff Johnson <jbj@redhat.com>
389- merge H.J. Lu's patches into 4.18.
390
391* Mon Apr 05 1999 Cristian Gafton <gafton@redhat.com>
392- updated the kern22 patch with stuff from davem
393
394* Thu Apr  1 1999 Jeff Johnson <jbj@redhat.com>
395- sparc with 2.2 kernels no longer uses sunos ptrace (davem)
396
397* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
398- auto rebuild in the new build environment (release 3)
399
400* Mon Mar  8 1999 Jeff Johnson <jbj@redhat.com>
401- Sparc fiddles for Red Hat 6.0.
Note: See TracBrowser for help on using the repository browser.