source: projects/specs/branches/6/g/gd21/gd21-vl.spec @ 7918

Revision 7918, 9.0 KB checked in by tomop, 11 years ago (diff)

php5-5.5.5-1

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2Summary: A graphics library for drawing .png files.
3Summary(ja): PNGイメージファイルを描写するためのグラフィックライブラリ
4Name: gd21
5Version: 2.1.0
6Release: 3%{_dist_release}
7Source0: https://bitbucket.org/libgd/gd-libgd/downloads/libgd-%{version}.tar.xz
8Patch0:        gd-2.1.0-multilib.patch
9Patch1:        gd-2.1.0-fonts-vine.patch
10License: BSD-style
11URL: http://www.libgd.org/
12Group: System Environment/Libraries
13
14BuildRoot: %{_tmppath}/%{name}-%{version}-root
15BuildRequires: libjpeg-devel zlib-devel freetype2-devel
16BuildRequires: libpng-devel >= 2:1.2.5
17BuildRequires: libX11-devel libXpm-devel
18
19Vendor: Project Vine
20Distribution: Vine Linux
21Packager: tomop
22
23%description
24Gd is a graphics library for drawing .png files.  Gd allows your code to
25quickly draw images (lines, arcs, text, multiple colors, cutting and
26pasting from other images, flood fills) and write out the result as a
27.png file. Gd is particularly useful in web applications, where .pngs
28are commonly used as inline images.  Note, however, that gd is not a
29paint program.
30
31Install gd if you are developing applications which need to draw .png
32files.  If you install gd, you'll also need to install the gd-devel
33package.
34
35%description -l ja
36GdはPNGファイルを描写するためのグラフックライブラリです。 Gdを使って、
37画像(線や弧, テキスト, カラー, 他の画像からのカット&ペースト等々)を
38簡単に描写して、PNGファイルへ結果を出力することができます。
39Gdは特に、一般にPNG画像を埋め込む必要のあるウェブアプリケーションで
40便利です。ただし、注意して欲しいのは, Gdはペイントツールではありませ
41ん。
42
43PNGファイルを描写する必要のあるアプリケーションを開発する場合、
44Gdをインストールしてください。gdをインストールした場合、gd-devel
45パッケージも必要になります。
46
47%package progs
48Summary: Utility programs that use libgd.
49Summary(ja): libgd を用いたユーティリティプログラム
50Group: Applications/Graphics
51Requires: gd21 = %{version}, perl
52Conflicts: gd-progs < 2.1.0
53
54%description progs
55These are utility programs supplied with gd, the .png graphics library.
56If you install these, you must install gd.
57
58%description progs -l ja
59これは PNG グラフィックライブラリ gd によって提供されるユーティリティ
60プログラムです。これをインストールするには, gdをインストールする必要
61があります。
62
63%package devel
64Summary: The development libraries and header files for gd.
65Summary(ja): gd用の開発ライブラリとヘッダファイル
66Group: Development/Libraries
67Requires: gd21 = %{version}
68Conflicts: gd-devel < 2.1.0
69
70%description devel
71These are the development libraries and header files for gd, the .png
72graphics library.
73
74If you're installing the gd graphics library, you must install gd-devel.
75
76%description devel -l ja
77これらは開発ライブラリです。
78PNGグラフィックライブラリ gd 用の開発ライブラリおよびヘッダファイル
79です。
80
81gdをインストールした場合、gd-develパッケージも必要になります。
82
83
84## to build compat32 for x86_64 architecture support
85%package -n compat32-%{name}
86Summary: A graphics library for drawing .png files.
87Group: System Environment/Libraries
88%description -n compat32-%{name}
89Gd is a graphics library for drawing .png files.  Gd allows your code to
90quickly draw images (lines, arcs, text, multiple colors, cutting and
91pasting from other images, flood fills) and write out the result as a
92.png file. Gd is particularly useful in web applications, where .pngs
93are commonly used as inline images.  Note, however, that gd is not a
94paint program.
95
96Install gd if you are developing applications which need to draw .png
97files.  If you install gd, you'll also need to install the gd-devel
98package.
99
100%package -n compat32-%{name}-devel
101Summary: The development libraries and header files for gd.
102Group: Development/Libraries
103%description -n compat32-%{name}-devel
104These are the development libraries and header files for gd, the .png
105graphics library.
106
107If you're installing the gd graphics library, you must install gd-devel.
108
109
110%prep
111%setup -q -n libgd-%{version}
112%patch0 -p1 -b .mlib
113%patch1 -p1 -b .fonts-vine
114
115%build
116%configure CPPFLAGS="-DHAVE_ICONV -DHAVE_STDARG_H -DHAVE_ERRNO_H"
117make %{?_smp_mflags}
118
119%install
120[ "$RPM_BUILD_ROOT" != "/" ] && rm -fr $RPM_BUILD_ROOT
121make DESTDIR=$RPM_BUILD_ROOT install
122## remove unuse files
123rm -rf $RPM_BUILD_ROOT%{_libdir}/*.{a,la}
124
125%clean
126[ "$RPM_BUILD_ROOT" != "/" ] && rm -fr $RPM_BUILD_ROOT
127
128%post -p /sbin/ldconfig
129%postun -p /sbin/ldconfig
130
131%if %{build_compat32}
132%post -n compat32-%{name} -p /sbin/ldconfig
133%postun -n compat32-%{name} -p /sbin/ldconfig
134%endif
135
136%files
137%defattr(-,root,root)
138%doc COPYING README*
139%{_libdir}/*.so.*
140
141%files progs
142%defattr(-,root,root)
143%{_bindir}/*
144%exclude %{_bindir}/gdlib-config
145
146%files devel
147%defattr(-,root,root)
148%{_bindir}/gdlib-config
149%{_includedir}/*
150%{_libdir}/*.so
151%{_libdir}/pkgconfig/*.pc
152
153%if %{build_compat32}
154%files -n compat32-%{name}
155%defattr(-,root,root)
156%{_libdir}/*.so.*
157%files -n compat32-%{name}-devel
158%defattr(-,root,root)
159%{_libdir}/*.so
160%endif
161
162%changelog
163* Sun Oct 13 2013 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.1.0-3
164- added "Conflicts:".
165
166* Wed Oct 02 2013 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.1.0-2
167- new upstream release.
168
169* Sun Jun 23 2013 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.1.0-1.rc2
170- new upstream release.
171- changed %%name to "gd21" for VinePlus.
172- dropped unnecessary patches.
173
174* Tue Feb 19 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.35-8
175- import patches from fedora package
176- modified font path patch for Vine Linux
177- drop static library
178- remove "-DJISX0208"
179- add "-DHAVE_ICONV -DHAVE_STDARG_H -DHAVE_ERRNO_H""
180
181* Fri Mar 09 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.0.35-7
182- move gdlib-config from gd-progs subpackage to gd-devel subpackage
183
184* Thu Apr 14 2011 IWAI, Masaharu <iwai@alib.jp> 2.0.35-6
185- build on current VineSeed
186
187* Tue Nov  3 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.0.35-5
188- fix build_compat32 if-endif sections
189
190* Sat Oct 31 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.0.35-4
191- add patch2 for fix CVE-2009-3546 (_gdGetColors())
192
193* Wed Apr  8 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.35-3
194- updated URL
195- changed progs Group to Applications/Graphics
196- added %%postun section
197
198* Fri Sep 26 2008 Shu KONNO <owa@bg.wakwak.com> 2.0.35-2
199- removed  *.la
200- spec in utf-8
201
202* Sat Apr 05 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.0.35-1
203- add patch1 from centos5
204- new versioning policy
205
206* Wed Feb 14 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.0.35-0vl1
207- new upstream release with security fix (CVE-2007-2756)
208
209* Wed Feb 14 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.0.34-0vl1
210- new upstream release with security fix
211- change source tarball format gz -> bz2
212
213* Fri Mar 17 2006 Shu KONNO <owa@bg.wakwak.com> 2.0.33-0vl2
214- added compat32-* packages for x86_64 architecture support
215
216* Sat Nov  6 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.0.33-0vl1
217- source upgrade
218
219* Wed Jul 14 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 2.0.27-0vl1
220- source update
221- added -DJISX0208 flag
222
223* Thu Jun 17 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.0.26-0vl1
224- source upgrade
225- BuildPrereq: XOrg-devel instead of XFree86-devel
226
227* Wed Mar 31 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.0.22-0vl1
228- source upgrade
229- remove patch0 (no need for freetype2-2.1.7)
230
231* Wed Nov 19 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.0.15-0vl2
232- add patch0 to build against freetype2-2.1.7
233
234* Sat Jun  7 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.0.15-0vl1
235- source upgrade
236- add URL
237- remove all patches
238- use %%configure script
239- add BuildPrereq: freetype2-devel XFree86-devel
240- remove BuildPrereq: VFlib-devel
241- update %%files
242- update Requires:
243- use License tag instead of Copyright
244
245* Fri Apr 18 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.8.3-0vl4
246- rebuild with libpng-devel-1.2.5-0vl1
247
248* Sun Apr 13 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.3-0vl3
249- rebuild with new toolchain
250
251* Sat Sep 02 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
252- 1.8.3-0vl2
253- symlink to libgd.so.1 (for backward compatibility)
254
255* Tue Jun  6 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
256- first gd 1.8.x release for Vine from rawhide.
257- enable freetype support and defined JISX208 macro.
258
259* Mon May 22 2000 Nalin Dahyabhai <nalin@redhat.com>
260- break out a -progs subpackage
261- disable freetype support
262
263* Fri May 19 2000 Nalin Dahyabhai <nalin@redhat.com>
264- update to latest version (1.8.2)
265- disable xpm support
266
267* Thu Feb 03 2000 Nalin Dahyabhai <nalin@redhat.com>
268- auto rebuild in the new build environment (release 6)
269
270* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
271- auto rebuild in the new build environment (release 5)
272
273* Thu Dec 17 1998 Cristian Gafton <gafton@redhat.com>
274- buiuld for glibc 2.1
275
276* Fri Sep 11 1998 Cristian Gafton <gafton@redhat.com>
277- built for 5.2
Note: See TracBrowser for help on using the repository browser.