source: projects/specs/branches/6/g/gcdemu/gcdemu-vl.spec @ 2235

Revision 2235, 3.5 KB checked in by iwaim, 13 years ago (diff)

gcdemu-1.3.0-2

Line 
1%{!?python_sitelib: %global python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
2%global python_module_name gcdemu
3
4Summary: A GNOME panel applet to control CDEmu daemon
5Summary: CDEmu daemon を制御するための GNOME パネルアプレット
6Name: gcdemu
7Version: 1.3.0
8Release: 2%{?_dist_release}
9License: GPLv2+
10Group: Applications/Accessories
11URL: http://cdemu.sourceforge.net
12Source: http://downloads.sourceforge.net/cdemu/%{name}-%{version}.tar.gz
13BuildRoot: %{_tmppath}/%{name}-%{version}-root
14BuildArch: noarch
15
16BuildRequires: dbus-python-devel
17BuildRequires: gettext
18BuildRequires: intltool >= 0.21
19BuildRequires: gnome-panel-devel
20BuildRequires: gnome-python-devel
21BuildRequires: perl-XML-Parser
22BuildRequires: pygtk2-devel >= 2.6
23BuildRequires: python-devel
24BuildRequires: gnome-doc-utils >= 0.3.2
25
26Requires: dbus-python >= 0.80
27Requires: gnome-python-applet
28Requires: hicolor-icon-theme
29Requires: pygtk2 >= 2.6
30
31Requires(pre): GConf2
32Requires(post): GConf2
33Requires(preun): GConf2
34
35Requires(post): scrollkeeper
36Requires(postun): scrollkeeper
37
38%description
39This is gCDEmu, a GNOME applet for controlling CDEmu daemon. It is part of the
40userspace-cdemu suite, a free, GPL CD/DVD-ROM device emulator for linux.
41
42It provides a graphic interface that allows performing the key tasks related to
43controlling the CDEmu daemon, such as loading and unloading devices, displaying
44devices' status and retrieving/setting devices' debug masks.
45
46In addition, applet listens to the signals emitted by CDEmu daemon and provides
47the notification via libnotify's notifications (provided that python bindings
48are installed).
49
50%prep
51%setup -q
52
53%build
54%{configure} --disable-schemas-install --disable-scrollkeeper
55%{__make} %{?_smp_mflags}
56
57%install
58%{__rm} -rf $RPM_BUILD_ROOT
59export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
60%{__make} install DESTDIR=$RPM_BUILD_ROOT
61unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
62%find_lang gcdemu --with-gnome
63
64%clean
65%{__rm} -rf $RPM_BUILD_ROOT
66
67%pre
68if [ "$1" -gt 1 ]; then
69        export GCONF_CONFIG_SOURCE=$(gconftool-2 --get-default-source)
70        gconftool-2 --makefile-uninstall-rule \
71                %{_sysconfdir}/gconf/schemas/gcdemu.schemas >/dev/null ||:
72fi
73
74%post
75scrollkeeper-update -q
76export GCONF_CONFIG_SOURCE=$(gconftool-2 --get-default-source)
77gconftool-2 --makefile-install-rule \
78        %{_sysconfdir}/gconf/schemas/gcdemu.schemas >/dev/null ||:
79
80%preun
81if [ "$1" -eq 0 ]; then
82        export GCONF_CONFIG_SOURCE=$(gconftool-2 --get-default-source)
83        gconftool-2 --makefile-uninstall-rule \
84                %{_sysconfdir}/gconf/schemas/gcdemu.schemas >/dev/null ||:
85fi
86
87%postun
88scrollkeeper-update -q
89
90%files -f gcdemu.lang
91%defattr(-,root,root,-)
92%doc AUTHORS ChangeLog COPYING NEWS README
93%{_datadir}/pixmaps/*
94#%{_datadir}/omf/gcdemu/gcdemu-C.omf
95%{_libdir}/bonobo/servers/*
96%{_libexecdir}/*
97%dir %{python_sitelib}/%{python_module_name}/
98%{python_sitelib}/%{python_module_name}/*.py*
99%{_sysconfdir}/gconf/schemas/*
100
101
102%changelog
103* Fri Nov 19 2010 IWAI, Masaharu <iwai@alib.jp> - 1.3.0-2
104- add BuildRequires: gnome-doc-utils >= 0.3.2
105
106* Fri Sep 3 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.3.0-1
107- new upstream release
108
109* Sun Feb 7 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.2.0-2
110- rebuilt with python-2.6.4
111
112* Fri Sep 25 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.2.0-1
113- initial build for VineSeed
114
115* Sat Jun 28 2008 Rok Mandeljc <rok.mandeljc@email.si> - 1.1.0-1
116- Updated to 1.1.0
117
118* Thu Dec 20 2007 Rok Mandeljc <rok.mandeljc@email.si> - 1.0.0-1
119- Initial RPM release.
Note: See TracBrowser for help on using the repository browser.