source: projects/specs/branches/6/g/g-wrap/g-wrap-vl.spec @ 6386

Revision 6386, 6.2 KB checked in by Takemikaduchi, 12 years ago (diff)

gob2,g-wrap,hyphen,libdap: new upstream release
others: rebuild

Line 
1%define ver 1.9.14
2%define rel 1%{?_dist_release}
3
4Summary: A tool for creating Scheme interfaces to C libraries.
5Summary(ja): C ライブラリへの Scheme 言語インタフェースを作成するツール
6Name: g-wrap
7Version: %{ver}
8Release: %{rel}
9Group: Development/Libraries
10License: GPL
11URL: http://www.gnucash.org/
12Source: ftp://ftp.gnucash.org/pub/g-wrap/%{name}-%{version}.tar.gz
13Requires: guile
14BuildRequires: guile-devel, libffi-devel
15BuildRequires: glib2-devel, slib
16Requires(pre): /sbin/install-info /sbin/ldconfig
17BuildRoot: %{_tmppath}/%{name}-%{version}-root
18
19Vendor: Project Vine
20Distribution: Vine Linux
21
22
23%description
24g-wrap is a tool for creating Scheme interfaces to C libraries.  At
25the moment it is most heavily focused on providing access to C
26libraries from guile, but it also supports RScheme.
27
28The g-wrap package contains the libraries necessary to run
29applications built with g-wrap.  If you wish to build applications
30that use g-wrap, you should install the g-wrap-devel package.
31
32%description -l ja
33g-wrap は C ライブラリへのScheme言語インタフェースを作成するツールです
34guile から C言語のライブライリへのアクセスを提供することを目的
35としています。 RScheme もサポートしています
36
37g-wrap には g-wrap 使って作成したアプリケーションを動作させるために
38必要なライブラリが含まれています. g-wrap を使ってアプリケーションを
39作成したい場合 g-wrap-devel をinstallしてください.
40
41
42%package devel
43Summary: Include files and libraries needed for g-wrap development.
44Summary(ja): g-wrap を使用した開発に必要なヘッダファイルやライブラリ
45Group: Development/Libraries
46Requires(pre): /sbin/install-info
47Requires: g-wrap = %{version}, guile-devel
48
49
50%description devel
51g-wrap is a tool for creating Scheme interfaces to C libraries.  At
52the moment it is most heavily focused on providing access to C
53libraries from guile, but it also supports RScheme.
54
55You can provide access to a given C API by creating a specification
56file describing the interface you want published at the Scheme level.
57g-wrap will handle generating all the lower level library interface
58code so that the C library shows up as a set of Scheme functions.
59
60You should install g-wrap-devel if you need to compile programs that
61need to use g-wrap C<->Scheme functionality
62
63%description devel -l ja
64g-wrap は C ライブラリへのScheme言語インタフェースを作成するツールです
65guile から C言語のライブライリへのアクセスを提供することを目的
66としています。 RScheme もサポートしています
67
68Schem レベルで表現したいインターフェースを記述を指定したファイルを作成
69することによりC PAI へのアクセスを提供します.
70g-wrap は 低レベルライブラリインターフェースすべての生成を扱うことが
71できます。したがって C ライブラリには Schem 関数の集合としてみえます.
72
73g-wrap のC と Scheme 間の変換機能を必要とするプログラムをコンパイルする
74場合 g-wrap-devel をinstallしておかねかればなりません.
75
76%prep
77%setup -q
78
79%build
80%configure --disable-static
81
82#remove Rpath
83sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
84sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
85
86#Is not parallel-build-safe
87%{__make}
88
89%install
90%{__rm} -rf ${RPM_BUILD_ROOT}
91%{__make} install DESTDIR=${RPM_BUILD_ROOT}
92
93#Remove unneeded file
94find ${RPM_BUILD_ROOT} -name '*.la' -exec rm -f {} ';'
95rm -f ${RPM_BUILD_ROOT}%{_datadir}/info/dir
96mv  ${RPM_BUILD_ROOT}%{_datadir}/guile/site/g-wrap/config.scm ./config.old
97cat config.old > config.scm
98install -p -m 644 config.scm  ${RPM_BUILD_ROOT}%{_datadir}/guile/site/g-wrap/config.scm
99
100
101%clean
102%{__rm} -rf ${RPM_BUILD_ROOT}
103
104
105%post -p /sbin/ldconfig
106
107%post devel
108/sbin/install-info \
109    --info-dir=%{_infodir} %{_infodir}/g-wrap.info.gz
110
111
112%preun -p /sbin/ldconfig
113
114%preun devel
115if [ "$1" = "0" ]; then
116    /sbin/install-info --delete \
117        --info-dir=%{_infodir} %{_infodir}/g-wrap.info.gz
118fi
119
120%files
121%defattr(-,root,root)
122%doc AUTHORS COPYING.LIB ChangeLog INSTALL NEWS README THANKS
123%dir %{_libdir}/%{name}
124%dir %{_libdir}/%{name}/modules
125%{_libdir}/%{name}/modules/*.so.*
126%{_libdir}/*.so.*
127%{_datadir}/guile/site/*
128
129
130%files devel
131%defattr(-,root,root)
132%{_bindir}/*
133%{_libdir}/*.so
134%{_libdir}/%{name}/modules/libgw-guile-gw-glib.so
135%{_libdir}/%{name}/modules/libgw-guile-standard.so
136%{_includedir}/*
137%{_datadir}/aclocal/*
138%{_libdir}/pkgconfig/*
139%{_mandir}/man1/g-wrap-config.1.gz
140%doc %{_infodir}/g-wrap.*
141
142
143%changelog
144* Tue Jun 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.9.14-1
145- update to 1.9.14
146- remove old patches
147
148* Mon Jan 12 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 1.9.1-1
149- new upstream release
150- update BuildRequires: umb-scheme -> slib
151
152* Sat Sep 20 2008 Shu KONNO <owa@bg.wakwak.com> 1.3.4-10vl5
153- applied new versioning policy, spec in utf-8
154- removed *.la
155
156* Tue Oct 25 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.3.4-9vl1
157- added Patches from Fedora
158  * Thu Jul  7 2005 Bill Nottingham <notting@redhat.com> 1.3.4-9
159  - add patch for M4 quoting (#162649, <rc040203@freenet.de>)
160
161* Fri Jan  2 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.3.4-3vl3
162- rebuild with new toolchains
163- s/Copyright/License/
164
165* Thu May 15 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.3.4-3vl2
166- build against new guile 1.6.4
167
168* Wed Feb 19 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.3.4-2vl1
169- based on rawhide 1.3.4-2
170  - update to 1.3.4
171  - move .la files to main package (#79068)
172- rebuild with new guile 1.6.3
173
174* Mon Apr 23 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.10-1vl1
175- updated to 1.1.10
176
177* Mon Mar 26 2001 Kazuhisa TAKEI <takei@vinelinux.org> 1.1.9-1vl4
178- add defattr
179
180* Mon Mar 26 2001 Kazuhisa TAKEI <takei@vinelinux.org> 1.1.9-1vl2
181- japanized spec file ( add %descripsion -l ja Summary(ja)
182
183
184* Wed Nov 08 2000 Derek Atkins <warlord@MIT.EDU>
185- Don't destroy the build directory -- RPM can do that on its own
186- Properly build both g-wrap and g-wrap-devel (info file into -devel)
187- currently only one info file
188
189* Wed Oct 25 2000 Dave Peticolas <dave@krondo.com>
190- use /usr/info/* for automatic gzipping
191
192* Sat May 27 2000 Mark Horning <rip6@rip6.net>
193- Created spec file
Note: See TracBrowser for help on using the repository browser.