source: projects/specs/branches/6/f/fusion-icon/fusion-icon-vl.spec @ 521

Revision 521, 4.3 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
2%define commit 5e2dc9
3%define without_qt 1
4
5Name:           fusion-icon
6Version:        0.1.0
7Release:        3%{?_dist_release}
8Summary:        Compiz Fusion panel applet
9Summary(ja):    Compiz Fusion パネルアプレット
10Group:          User Interface/Desktops
11License:        GPLv2+
12
13# The source for this package was pulled from upstream's vcs.  Use the
14# following commands to generate the tarball:
15# git clone git://anongit.opencompositing.org/users/crdlb/fusion-icon fusion-icon-5e2dc9
16# cd fusion-icon-5e2dc9
17# git checkout 5e2dc9
18# rm -rf .git ; cd ../
19# tar -czvf fusion-icon-5e2dc9.tar.gz fusion-icon-5e2dc9
20
21URL:            http://www.opencompositing.org
22Source0:        %{name}-%{commit}.tar.gz
23Patch0:         %{name}-runpatch.patch
24BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
25BuildRequires:  python-devel
26BuildRequires:  desktop-file-utils
27Requires:       ccsm %{name}-ui=%{version}-%{release}
28BuildArch:      noarch
29ExcludeArch:    ppc64
30
31%description
32The Compiz Fusion Icon is a simple panel applet for starting and controlling
33Compiz Fusion. Upon launch, it will attempt to start Compiz Fusion
34automatically. You may need to select a window decorator, if one does not
35appear.
36
37%package gtk
38Requires:  pygtk2
39Requires:  %{name} = %{version}-%{release}
40Group:     User Interface/Desktops
41Summary:   GTK UI for fusion-icon
42Summary(ja):   GTK UI for fusion-icon
43Provides:  %{name}-ui=%{version}-%{release}
44
45%description gtk
46This package provides the gtk UI for fusion-icon
47
48%package qt
49Requires:  PyQt4
50Requires:  %{name} = %{version}-%{release}
51Group:     User Interface/Desktops
52Summary:   QT UI for fusion-icon
53Summary(ja):   QT UI for fusion-icon
54Provides:  %{name}-ui=%{version}-%{release}
55
56%description qt
57This package provides the qt UI for fusion-icon
58
59%prep
60%setup -q -n %{name}-%{commit}
61%patch0
62
63%build
64
65%install
66rm -rf $RPM_BUILD_ROOT
67make install DESTDIR=$RPM_BUILD_ROOT
68desktop-file-install --vendor=""             \
69  --dir=$RPM_BUILD_ROOT%{_datadir}/applications/   \
70  --delete-original                                \
71        $RPM_BUILD_ROOT%{_datadir}/applications/%{name}.desktop
72
73%post
74touch --no-create %{_datadir}/icons/hicolor
75if [ -x %{_bindir}/gtk-update-icon-cache ]; then
76  %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
77fi
78
79
80%postun
81touch --no-create %{_datadir}/icons/hicolor
82if [ -x %{_bindir}/gtk-update-icon-cache ]; then
83  %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
84fi
85
86%clean
87rm -rf $RPM_BUILD_ROOT
88
89%files
90%defattr(-,root,root,-)
91%{_bindir}/fusion-icon
92%{_datadir}/applications/%{name}.desktop
93%dir %{python_sitelib}/FusionIcon/
94%{python_sitelib}/FusionIcon/*py*
95%{_datadir}/icons/hicolor/*/apps/fusion-icon.png
96%{_datadir}/icons/hicolor/scalable/apps/fusion-icon.svg
97%if "%{fedora}" > "8"
98%{python_sitelib}/fusion_icon-%{version}-py2.5.egg-info
99%endif
100%doc COPYING
101
102%files gtk
103%defattr(-,root,root,-)
104%{python_sitelib}/FusionIcon/interface_gtk/
105
106%if ! %{without_qt}
107%files qt
108%defattr(-,root,root,-)
109%{python_sitelib}/FusionIcon/interface_qt4/
110%endif
111
112%changelog
113* Wed Jul 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.1.0-3
114- remove vendor prefix from desktop file
115
116* Mon Jul 21 2008 Shu KONNO <owa@bg.wakwak.com> 0.1.0-2
117- rebuilt with python-2.5.2
118
119* Sun May 18 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.1.0-1
120- initial build for Vine Linux
121
122* Mon Mar 17 2008 Karol Trzcionka <karlikt at gmail.com> - 0.1.0-0.2.5e2dc9git
123- Fix typo in %%files
124* Mon Mar 17 2008 Karol Trzcionka <karlikt at gmail.com> - 0.1.0-0.1.5e2dc9git
125- Update tarball
126- Change method of releasing
127* Wed Feb 13 2008 Karol Trzcionka <karlikt at gmail.com> - 0-0.5.20080213git
128- Update tarball
129* Tue Jan 22 2008 Karol Trzcionka <karlikt at gmail.com> - 0-0.4.20071206git.1
130- Fix name of egg-info
131* Tue Jan 22 2008 Karol Trzcionka <karlikt at gmail.com> - 0-0.4.20071206git
132- Add egg-info in files section
133* Fri Dec 21 2007 Karol Trzcionka <karlikt at gmail.com> - 0-0.3.20071206git
134- Fix qt interface
135- Add Provides/Requires fusion-icon-ui
136* Thu Dec 06 2007 Karol Trzcionka <karlikt at gmail.com> - 0-0.2.20071206git
137- Set excludearch: ppc64
138- Delete .git directory from tarball
139* Mon Nov 26 2007 Karol Trzcionka <karlikt at gmail.com> - 0-0.1.20071126git
140- Initial release
141
Note: See TracBrowser for help on using the repository browser.