source: projects/specs/branches/6/f/fuse/fuse-vl.spec @ 2587

Revision 2587, 7.0 KB checked in by daisuke, 13 years ago (diff)

fuse: update to 2.8.5

Line 
1Summary:        File System in Userspace (FUSE) utilities
2Summary(ja):    ユーザスペースファイルシステム(FUSE)用のユーティリティ
3Name:           fuse
4Version:        2.8.5
5Release:        1%{?_dist_release}
6
7Group:          System Environment/Base
8License:        GPL
9URL:            http://fuse.sf.net
10
11Source0:        http://dl.sourceforge.net/sourceforge/fuse/%{name}-%{version}.tar.gz
12Source1:        fuse-udev.nodes
13Source2:        fuse-makedev.d-fuse
14Patch0:         fuse-udev_rules.patch
15Patch1:         fuse-openfix.patch
16Patch10:        fuse-2.8.3-chkconfig.patch
17
18BuildRoot:      %{_tmppath}/%{name}-%{version}-root
19Requires(pre):  shadow-utils
20Requires(post): MAKEDEV
21Requires(postun): shadow-utils
22
23Vendor: Project Vine
24Distribution: Vine Linux
25Packager: daisuke, shaolin
26
27
28%description
29With FUSE it is possible to implement a fully functional filesystem in a
30userspace program. This package contains the FUSE userspace tools to
31mount a FUSE filesystem.
32
33%description -l ja
34FUSE を用いることでユーザ空間のプログラムでファイルシステムを実装することが
35可能になります。このパッケージには FUSEファイルシステムをマウントするための
36ユーザ空間ツールが含まれています。
37
38
39%package devel
40Summary:        File System in Userspace (FUSE) devel files
41Group:          Development/Libraries
42Requires:       %{name} = %{version}-%{release}
43Requires:       pkgconfig
44License:        LGPL
45
46%description devel
47With FUSE it is possible to implement a fully functional filesystem in a
48userspace program. This package contains development files (headers,
49pgk-config) to develop FUSE based applications/filesystems.
50
51
52%prep
53%setup -q
54#disable device creation during build/install
55sed -i 's|mknod|echo Disabled: mknod |g' util/Makefile.in
56%patch0 -b .udev-rules
57%patch1 -b .openfix
58%patch10 -p1 -b .chkconfig
59
60%build
61%configure \
62 --bindir=/bin \
63 --libdir=/%{_lib} \
64 --exec-prefix=/ \
65 --disable-static \
66 --disable-kernel-module
67make %{?_smp_mflags}
68
69
70%install
71rm -rf $RPM_BUILD_ROOT
72
73make install DESTDIR=$RPM_BUILD_ROOT
74
75find $RPM_BUILD_ROOT -type f -name "*.la" -exec rm -f {} ';'
76
77# FIXME change from 60 to 99
78install -D -p -m 644 %{SOURCE1} $RPM_BUILD_ROOT/%{_sysconfdir}/udev/makedev.d/99-fuse.nodes
79install -D -p -m 644 %{SOURCE2} $RPM_BUILD_ROOT/%{_sysconfdir}/makedev.d/z-fuse
80# change from 4755 to 0755 to allow stripping -- fixed later in files
81chmod 0755 $RPM_BUILD_ROOT/bin/fusermount
82mkdir -p $RPM_BUILD_ROOT%{_libdir}
83mv $RPM_BUILD_ROOT/%{_lib}/pkgconfig $RPM_BUILD_ROOT%{_libdir}
84
85# copmat symlinks
86mkdir -p $RPM_BUILD_ROOT%{_bindir}
87cd $RPM_BUILD_ROOT%{_bindir}
88ln -s /bin/fusermount fusermount
89ln -s /bin/ulockmgr_server ulockmgr_server
90
91# drop unneeded initscript
92rm -f $RPM_BUILD_ROOT%{_sysconfdir}/init.d/fuse
93
94%clean
95rm -rf $RPM_BUILD_ROOT
96
97
98%preun
99if [ -f /etc/init.d/fuse ] ; then
100    /sbin/service fuse stop >/dev/null 2>&1 ||:
101    /sbin/chkconfig --del fuse ||:
102fi
103       
104%post
105/sbin/ldconfig
106
107%postun
108/sbin/ldconfig
109
110
111%files
112%defattr(-,root,root,-)
113%doc AUTHORS ChangeLog COPYING COPYING.LIB FAQ Filesystems NEWS README README.NFS
114/sbin/mount.fuse
115%attr(4755,root,root) /bin/fusermount
116/bin/ulockmgr_server
117%{_bindir}/fusermount
118%{_bindir}/ulockmgr_server
119%{_sysconfdir}/makedev.d/z-fuse
120%config %{_sysconfdir}/udev/rules.d/99-fuse.rules
121%{_sysconfdir}/udev/makedev.d/99-fuse.nodes
122/%{_lib}/libfuse.so.*
123/%{_lib}/libulockmgr.so.*
124
125%files devel
126%defattr(-,root,root,-)
127/%{_lib}/libfuse.so
128/%{_lib}/libulockmgr.so
129%{_libdir}/pkgconfig/*.pc
130%{_includedir}/fuse.h
131%{_includedir}/ulockmgr.h
132%{_includedir}/fuse
133
134
135%changelog
136* Mon Jan 24 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.5-1
137- new upstream release
138
139* Sat Oct 09 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.4-1
140- new upstream release
141- drop fuse group, change fusermount mode to 4755
142- move fusermount/ulockmgr_server to /bin
143- move libs to /%%{_lib}
144- drop unneeded initscript
145
146* Thu Sep 30 2010 Shu KONNO <owa@bg.wakwak.com> 2.8.3-3
147- rebuilt with rpm-4.8.1 for pkg-config
148
149* Sat May 29 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.8.3-2
150- fix Patch0 to avoid udev warning (NAME="%k" is superfluous etc.)
151- add Patch1 to fix open issue (rhbz #265321)
152- add Patch2 for CVE-2009-3297 (rhbz #558833)
153
154* Wed Apr 14 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.3-1
155- new upstream release
156- remove upstreamed patch10
157- add patch10 to support chkconfig
158
159* Mon Mar  1 2010 IWAI, Masaharu <iwai@alib.jp> 2.7.4-3
160- SECURITY FIX: CVE-2009-3297
161  - patch from Debian 5.0 fuse_2.7.4-1.1+lenny1 (Patch10)
162
163* Mon Jun 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7.4-2
164- update Source2 and Patch0
165  - change udev rules to create /dev/fuse with mode 0666, group root.
166- do not create fuse group in %%pre
167- stop and delete fuse service in %%preun
168
169* Wed Apr 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7.4-1
170- new upstream release
171- spec in utf-8
172
173* Thu Apr 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7.3-1
174- new upstream release
175
176* Tue May 29 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.5-0vl1
177- new upstream release
178
179* Mon Apr 02 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.3-0vl1
180- initial build for Vine Linux based on ATrpms package
181
182* Sun Feb  4 2007 Axel Thimm <Axel.Thimm@ATrpms.net> - 2.6.3-0_3
183- Update to 2.6.3.
184
185* Thu Feb  1 2007 Axel Thimm <Axel.Thimm@ATrpms.net> - 2.6.2-0_2
186- Update to 2.6.2.
187
188* Fri Jan 07 2007 Paulo Roma <roma@lcg.ufrj.br> 2.6.1-1_1
189- Adapted for building kernel module.
190
191* Tue Dec 26 2006 Peter Lemenkov <lemenkov@gmail.com> 2.6.1-1
192- Ver. 2.6.1
193
194* Sat Nov 25 2006 Peter Lemenkov <lemenkov@gmail.com> 2.6.0-2
195- fixed nasty typo (see bug #217075)
196
197* Fri Nov  3 2006 Peter Lemenkov <lemenkov@gmail.com> 2.6.0-1
198- Ver. 2.6.0
199
200* Sun Oct 29 2006 Peter Lemenkov <lemenkov@gmail.com> 2.5.3-5
201- Fixed udev-rule again
202
203* Sat Oct  7 2006 Peter Lemenkov <lemenkov@gmail.com> 2.5.3-4
204- Fixed udev-rule
205
206* Tue Sep 12 2006 Peter Lemenkov <lemenkov@gmail.com> 2.5.3-3%{?dist}
207- Rebuild for FC6
208
209* Wed May 03 2006 Peter Lemenkov <lemenkov@newmail.ru> 2.5.3-1%{?dist}
210- Update to 2.5.3
211
212* Thu Mar 30 2006 Peter Lemenkov <lemenkov@newmail.ru> 2.5.2-4%{?dist}
213- rebuild
214
215* Mon Feb 13 2006 Peter Lemenkov <lemenkov@newmail.ru> - 2.5.2-3
216- Proper udev rule
217
218* Mon Feb 13 2006 Peter Lemenkov <lemenkov@newmail.ru> - 2.5.2-2
219- Added missing requires
220
221* Tue Feb 07 2006 Peter Lemenkov <lemenkov@newmail.ru> - 2.5.2-1
222- Update to 2.5.2
223- Dropped fuse-mount.fuse.patch
224
225* Wed Nov 23 2005 Thorsten Leemhuis <fedora[AT]leemhuis[DOT]info> - 2.4.2-1
226- Use dist
227
228* Wed Nov 23 2005 Thorsten Leemhuis <fedora[AT]leemhuis[DOT]info> - 2.4.2-1
229- Update to 2.4.2 (solves CVE-2005-3531)
230- Update README.fedora
231
232* Sat Nov 12 2005 Thorsten Leemhuis <fedora[AT]leemhuis[DOT]info> - 2.4.1-3
233- Add README.fedora
234- Add hint to README.fedora and that you have to be member of the group "fuse"
235  in the description
236- Use groupadd instead of fedora-groupadd
237
238* Fri Nov 04 2005 Thorsten Leemhuis <fedora[AT]leemhuis[DOT]info> - 2.4.1-2
239- Rename packages a bit
240- use makedev.d/40-fuse.nodes
241- fix /sbin/mount.fuse
242- Use a fuse group to restict access to fuse-filesystems
243
244* Fri Oct 28 2005 Thorsten Leemhuis <fedora[AT]leemhuis[DOT]info> - 2.4.1-1
245- Initial RPM release.
Note: See TracBrowser for help on using the repository browser.