source: projects/specs/branches/6/f/fuse/fuse-vl.spec @ 10690

Revision 10690, 7.3 KB checked in by tomop, 8 years ago (diff)

fuse-2.8.6-1

Line 
1Summary:        File System in Userspace (FUSE) utilities
2Summary(ja):    ユーザスペースファイルシステム(FUSE)用のユーティリティ
3Name:           fuse
4Version:        2.8.6
5Release:        1%{?_dist_release}
6
7Group:          System Environment/Base
8License:        GPL
9URL:            http://fuse.sf.net
10
11Source0:        http://dl.sourceforge.net/sourceforge/fuse/%{name}-%{version}.tar.gz
12Source1:        fuse-udev.nodes
13Source2:        fuse-makedev.d-fuse
14Patch0:         fuse-udev_rules.patch
15Patch1:         fuse-openfix.patch
16Patch10:        fuse-2.8.3-chkconfig.patch
17Patch11:        06-clone_newns.patch
18
19# import from Ubuntu
20Patch1000:      CVE-2015-3202.patch
21
22BuildRoot:      %{_tmppath}/%{name}-%{version}-root
23Requires(pre):  shadow-utils
24Requires(post): MAKEDEV
25Requires(postun): shadow-utils
26
27Vendor: Project Vine
28Distribution: Vine Linux
29Packager: daisuke, shaolin
30
31
32%description
33With FUSE it is possible to implement a fully functional filesystem in a
34userspace program. This package contains the FUSE userspace tools to
35mount a FUSE filesystem.
36
37%description -l ja
38FUSE を用いることでユーザ空間のプログラムでファイルシステムを実装することが
39可能になります。このパッケージには FUSEファイルシステムをマウントするための
40ユーザ空間ツールが含まれています。
41
42
43%package devel
44Summary:        File System in Userspace (FUSE) devel files
45Group:          Development/Libraries
46Requires:       %{name} = %{version}-%{release}
47Requires:       pkgconfig
48License:        LGPL
49
50%description devel
51With FUSE it is possible to implement a fully functional filesystem in a
52userspace program. This package contains development files (headers,
53pgk-config) to develop FUSE based applications/filesystems.
54
55
56%prep
57%setup -q
58#disable device creation during build/install
59sed -i 's|mknod|echo Disabled: mknod |g' util/Makefile.in
60%patch0 -b .udev-rules
61%patch1 -b .openfix
62%patch10 -p1 -b .chkconfig
63%patch11 -p1 -b .clone_newns
64
65%patch1000 -p1 -b .CVE-2015-3202
66
67%build
68%configure \
69 --bindir=/bin \
70 --libdir=/%{_lib} \
71 --exec-prefix=/ \
72 --disable-static \
73 --disable-kernel-module
74make %{?_smp_mflags}
75
76
77%install
78rm -rf $RPM_BUILD_ROOT
79
80make install DESTDIR=$RPM_BUILD_ROOT
81
82find $RPM_BUILD_ROOT -type f -name "*.la" -exec rm -f {} ';'
83
84# FIXME change from 60 to 99
85install -D -p -m 644 %{SOURCE1} $RPM_BUILD_ROOT/%{_sysconfdir}/udev/makedev.d/99-fuse.nodes
86install -D -p -m 644 %{SOURCE2} $RPM_BUILD_ROOT/%{_sysconfdir}/makedev.d/z-fuse
87# change from 4755 to 0755 to allow stripping -- fixed later in files
88chmod 0755 $RPM_BUILD_ROOT/bin/fusermount
89mkdir -p $RPM_BUILD_ROOT%{_libdir}
90mv $RPM_BUILD_ROOT/%{_lib}/pkgconfig $RPM_BUILD_ROOT%{_libdir}
91
92# copmat symlinks
93mkdir -p $RPM_BUILD_ROOT%{_bindir}
94cd $RPM_BUILD_ROOT%{_bindir}
95ln -s /bin/fusermount fusermount
96ln -s /bin/ulockmgr_server ulockmgr_server
97
98# drop unneeded initscript
99rm -f $RPM_BUILD_ROOT%{_sysconfdir}/init.d/fuse
100
101%clean
102rm -rf $RPM_BUILD_ROOT
103
104
105%preun
106if [ -f /etc/init.d/fuse ] ; then
107    /sbin/service fuse stop >/dev/null 2>&1 ||:
108    /sbin/chkconfig --del fuse ||:
109fi
110       
111%post
112/sbin/ldconfig
113
114%postun
115/sbin/ldconfig
116
117
118%files
119%defattr(-,root,root,-)
120%doc AUTHORS ChangeLog COPYING COPYING.LIB FAQ Filesystems NEWS README README.NFS
121/sbin/mount.fuse
122%attr(4755,root,root) /bin/fusermount
123/bin/ulockmgr_server
124%{_bindir}/fusermount
125%{_bindir}/ulockmgr_server
126%{_sysconfdir}/makedev.d/z-fuse
127%config %{_sysconfdir}/udev/rules.d/99-fuse.rules
128%{_sysconfdir}/udev/makedev.d/99-fuse.nodes
129/%{_lib}/libfuse.so.*
130/%{_lib}/libulockmgr.so.*
131
132%files devel
133%defattr(-,root,root,-)
134/%{_lib}/libfuse.so
135/%{_lib}/libulockmgr.so
136%{_libdir}/pkgconfig/*.pc
137%{_includedir}/fuse.h
138%{_includedir}/ulockmgr.h
139%{_includedir}/fuse
140
141
142%changelog
143* Mon Jul 25 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.8.6-1
144- updated to 2.8.6.
145- added Patch11 to fix a complilation error.
146- added Patch1000 to fix CVE-2015-3202.
147
148* Mon Jan 24 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.5-1
149- new upstream release
150
151* Sat Oct 09 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.4-1
152- new upstream release
153- drop fuse group, change fusermount mode to 4755
154- move fusermount/ulockmgr_server to /bin
155- move libs to /%%{_lib}
156- drop unneeded initscript
157
158* Thu Sep 30 2010 Shu KONNO <owa@bg.wakwak.com> 2.8.3-3
159- rebuilt with rpm-4.8.1 for pkg-config
160
161* Sat May 29 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.8.3-2
162- fix Patch0 to avoid udev warning (NAME="%k" is superfluous etc.)
163- add Patch1 to fix open issue (rhbz #265321)
164- add Patch2 for CVE-2009-3297 (rhbz #558833)
165
166* Wed Apr 14 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.3-1
167- new upstream release
168- remove upstreamed patch10
169- add patch10 to support chkconfig
170
171* Mon Mar  1 2010 IWAI, Masaharu <iwai@alib.jp> 2.7.4-3
172- SECURITY FIX: CVE-2009-3297
173  - patch from Debian 5.0 fuse_2.7.4-1.1+lenny1 (Patch10)
174
175* Mon Jun 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7.4-2
176- update Source2 and Patch0
177  - change udev rules to create /dev/fuse with mode 0666, group root.
178- do not create fuse group in %%pre
179- stop and delete fuse service in %%preun
180
181* Wed Apr 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7.4-1
182- new upstream release
183- spec in utf-8
184
185* Thu Apr 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7.3-1
186- new upstream release
187
188* Tue May 29 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.5-0vl1
189- new upstream release
190
191* Mon Apr 02 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.3-0vl1
192- initial build for Vine Linux based on ATrpms package
193
194* Sun Feb  4 2007 Axel Thimm <Axel.Thimm@ATrpms.net> - 2.6.3-0_3
195- Update to 2.6.3.
196
197* Thu Feb  1 2007 Axel Thimm <Axel.Thimm@ATrpms.net> - 2.6.2-0_2
198- Update to 2.6.2.
199
200* Fri Jan 07 2007 Paulo Roma <roma@lcg.ufrj.br> 2.6.1-1_1
201- Adapted for building kernel module.
202
203* Tue Dec 26 2006 Peter Lemenkov <lemenkov@gmail.com> 2.6.1-1
204- Ver. 2.6.1
205
206* Sat Nov 25 2006 Peter Lemenkov <lemenkov@gmail.com> 2.6.0-2
207- fixed nasty typo (see bug #217075)
208
209* Fri Nov  3 2006 Peter Lemenkov <lemenkov@gmail.com> 2.6.0-1
210- Ver. 2.6.0
211
212* Sun Oct 29 2006 Peter Lemenkov <lemenkov@gmail.com> 2.5.3-5
213- Fixed udev-rule again
214
215* Sat Oct  7 2006 Peter Lemenkov <lemenkov@gmail.com> 2.5.3-4
216- Fixed udev-rule
217
218* Tue Sep 12 2006 Peter Lemenkov <lemenkov@gmail.com> 2.5.3-3%{?dist}
219- Rebuild for FC6
220
221* Wed May 03 2006 Peter Lemenkov <lemenkov@newmail.ru> 2.5.3-1%{?dist}
222- Update to 2.5.3
223
224* Thu Mar 30 2006 Peter Lemenkov <lemenkov@newmail.ru> 2.5.2-4%{?dist}
225- rebuild
226
227* Mon Feb 13 2006 Peter Lemenkov <lemenkov@newmail.ru> - 2.5.2-3
228- Proper udev rule
229
230* Mon Feb 13 2006 Peter Lemenkov <lemenkov@newmail.ru> - 2.5.2-2
231- Added missing requires
232
233* Tue Feb 07 2006 Peter Lemenkov <lemenkov@newmail.ru> - 2.5.2-1
234- Update to 2.5.2
235- Dropped fuse-mount.fuse.patch
236
237* Wed Nov 23 2005 Thorsten Leemhuis <fedora[AT]leemhuis[DOT]info> - 2.4.2-1
238- Use dist
239
240* Wed Nov 23 2005 Thorsten Leemhuis <fedora[AT]leemhuis[DOT]info> - 2.4.2-1
241- Update to 2.4.2 (solves CVE-2005-3531)
242- Update README.fedora
243
244* Sat Nov 12 2005 Thorsten Leemhuis <fedora[AT]leemhuis[DOT]info> - 2.4.1-3
245- Add README.fedora
246- Add hint to README.fedora and that you have to be member of the group "fuse"
247  in the description
248- Use groupadd instead of fedora-groupadd
249
250* Fri Nov 04 2005 Thorsten Leemhuis <fedora[AT]leemhuis[DOT]info> - 2.4.1-2
251- Rename packages a bit
252- use makedev.d/40-fuse.nodes
253- fix /sbin/mount.fuse
254- Use a fuse group to restict access to fuse-filesystems
255
256* Fri Oct 28 2005 Thorsten Leemhuis <fedora[AT]leemhuis[DOT]info> - 2.4.1-1
257- Initial RPM release.
Note: See TracBrowser for help on using the repository browser.