source: projects/specs/branches/6/f/foomatic/foomatic-vl.spec @ 4098

Revision 4098, 22.4 KB checked in by tomop, 13 years ago (diff)

foomatic-4.0.7-2

Line 
1%define dbver_rel 4.0
2%define dbver_snap 20110405
3%define enginever 4.0.7
4%define filtersver 4.0.7
5
6Summary: Foomatic printer database.
7Name:           foomatic
8Version:        %{enginever}
9Release:        2%{?_dist_release}
10License:        GPL
11Group: System Environment/Libraries
12
13Vendor: Project Vine
14Distribution: Vine Linux
15Packager: tomop, daisuke, machino
16
17Source0: http://www.linuxprinting.org/download/foomatic/foomatic-db-engine-%{enginever}.tar.gz
18Source1: http://www.linuxprinting.org/download/foomatic/foomatic-filters-%{filtersver}.tar.gz
19Source2: http://www.linuxprinting.org/download/foomatic/foomatic-db-%{dbver_rel}-%{dbver_snap}.tar.gz
20
21# Use libdir.
22Patch1: foomatic-filters-libdir.patch
23Patch2: foomatic-db-engine-libdir.patch
24
25# Handle non-UTF-8 encodings in imported PPD files.
26Patch15: foomatic-bad-utf8.patch
27
28Url:            http://www.linuxprinting.org
29Requires:       perl >= 5.12.3
30Requires:       %(eval `perl -V:version`; echo "perl(:MODULE_COMPAT_$version)")
31Requires:       hplip
32BuildRequires:  perl >= 5.12.3
33BuildRequires:  libxml2-devel
34BuildRequires:  ghostscript-devel
35BuildRequires:  autoconf, automake
36BuildRequires:  mpage
37BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
38Provides:       perl(Foomatic::GrovePath)
39# For 'rm' and '/sbin/service' in post
40Requires(pre):  coreutils initscripts
41Obsoletes: foomatic-db < 4.0.0
42Obsoletes: foomatic-ppd < 4.0.0
43Obsoletes: foomatic-ppd-gimp-print < 4.0.0
44Obsoletes: foomatic-ppd-gimp-print-ijs < 4.0.0
45Obsoletes: foomatic-ppd-omni < 4.0.0
46
47# We need ghostscript to have the gimp-print-4.2.0 driver, and hpijs 1.1.
48Conflicts: ghostscript < 7.05
49
50%description
51Foomatic is a comprehensive, spooler-independent database of printers,
52printer drivers, and driver descriptions. It contains utilities to
53generate driver description files and printer queues for CUPS, LPD,
54LPRng, and PDQ using the database. There is also the possibility to
55read the PJL options out of PJL-capable laser printers and take them
56into account at the driver description file generation.
57
58There are spooler-independent command line interfaces to manipulate
59queues (foomatic-configure) and to print files/manipulate jobs
60(foomatic printjob).
61
62The site http://www.linuxprinting.org/ is based on this database.
63
64%prep
65%setup -q  -c -a 1 -a 2
66
67pushd foomatic-filters-%{filtersver}
68%patch1 -p1 -b .libdir
69popd
70
71pushd foomatic-db-engine-%{enginever}
72chmod a+x mkinstalldirs
73%patch2 -p1 -b .libdir
74%patch15 -p1
75popd
76
77pushd foomatic-db-%{dbver_snap}
78
79cd db/source
80
81# For gutenprint printers, use gutenprint-ijs-simplified.5.2.
82perl -pi -e 's,>gutenprint<,>gutenprint-ijs-simplified.5.2<,' printer/*.xml
83
84# Remove references to foo2zjs, foo2oak, foo2hp and foo2qpdl (bug #208851).
85# Also foo2lava, foo2kyo, foo2xqx (bug #438319).
86for x in zjs oak hp qpdl lava kyo xqx
87do
88  find printer -name '*.xml' |xargs grep -l "<driver>foo2${x}"|xargs rm -vf
89  rm -f driver/foo2${x}.xml opt/foo2${x}-*
90done
91# Same for m2300w/m2400w
92find printer -name '*.xml' |xargs grep -l '<driver>m2[34]00w<'|xargs rm -vf
93rm -f driver/m2300w.xml driver/m2400w.xml opt/m2300w-*
94# Same for all these.
95for x in drv_x125 ml85p pbm2lwxl pbmtozjs bjc800j
96do
97  find printer -name '*.xml' |xargs grep -l "<driver>${x}</driver>"|xargs rm -vf
98  rm -vf driver/${x}.xml opt/${x}-*
99done
100
101popd
102
103%build
104export LIB_CUPS=%{_libdir}/cups
105export CUPS_BACKENDS=%{_libdir}/cups/backend
106export CUPS_FILTERS=%{_libdir}/cups/filter
107export CUPS_PPDS=%{_datadir}/cups/model
108
109pushd foomatic-filters-%{filtersver}
110%configure
111make %{_smp_mflags} PREFIX=%{_prefix} CFLAGS="$RPM_OPT_FLAGS" \
112        INSTALLDIRS=vendor
113popd
114
115pushd foomatic-db-engine-%{enginever}
116%configure --disable-xmltest
117make %{_smp_mflags} PREFIX=%{_prefix} CFLAGS="$RPM_OPT_FLAGS" \
118        INSTALLDIRS=vendor defaults
119make %{_smp_mflags} PREFIX=%{_prefix} CFLAGS="$RPM_OPT_FLAGS" \
120        INSTALLDIRS=vendor
121popd
122
123pushd foomatic-db-%{dbver_snap}
124%configure
125make %{_smp_mflags} PREFIX=%{_prefix} CFLAGS="$RPM_OPT_FLAGS" \
126        INSTALLDIRS=vendor
127popd
128
129%install
130rm -rf %{buildroot}
131
132pushd foomatic-filters-%{filtersver}
133eval `perl '-V:installvendorlib' '-V:installvendorarch'`
134mkdir -p %{buildroot}/$installvendorlib
135
136
137echo %{buildroot}
138
139make    DESTDIR=%{buildroot} PREFIX=%{_prefix} \
140        INSTALLDIRS=vendor \
141        INSTALLVENDORLIB=$installvendorlib \
142        INSTALLVENDORARCH=$installvendorarch \
143        install-main install-cups
144popd
145
146pushd foomatic-db-engine-%{enginever}
147make    DESTDIR=%buildroot PREFIX=%{_prefix} \
148        INSTALLDIRS=vendor \
149        INSTALLVENDORLIB=$installvendorlib \
150        INSTALLVENDORARCH=$installvendorarch \
151        install
152popd
153
154pushd foomatic-db-%{dbver_snap}
155make    DESTDIR=%buildroot PREFIX=%{_prefix} \
156        INSTALLDIRS=vendor \
157        INSTALLVENDORLIB=$installvendorlib \
158        INSTALLVENDORARCH=$installvendorarch \
159        install
160popd
161
162# Remove ghostscript UPP drivers that are gone in 7.07
163rm -f %buildroot%{_datadir}/foomatic/db/source/driver/{bjc6000a1,PM760p,PM820p,s400a1,sharp,Stc670pl,Stc670p,Stc680p,Stc760p,Stc777p,Stp720p,Stp870p}.upp.xml
164
165# Remove drivers with no command line.
166pushd foomatic-db-engine-%{enginever}
167perl -Ilib ./foomatic-cleanupdrivers %buildroot%{_datadir}/foomatic
168popd
169
170# Update any old-style printer IDs still left around.
171echo '#!/usr/bin/perl -pi' > convert-printerids.pl
172sed -e 's|^\(.*\) \(.*\)$|s,printer/\1,printer/\2,g;|' \
173        %{buildroot}%{_datadir}/foomatic/db/oldprinterids \
174        >> convert-printerids.pl
175chmod a+x convert-printerids.pl
176./convert-printerids.pl %{buildroot}%{_datadir}/foomatic/db/source/{opt,driver}/*.xml
177find %{buildroot}%{_datadir}/foomatic/db/source/ -type f | xargs chmod 0644
178
179# Use relative, not absolute, symlink for CUPS filter.
180ln -sf ../../../bin/foomatic-rip %{buildroot}%{_libdir}/cups/filter/foomatic-rip
181
182mkdir %{buildroot}%{_datadir}/foomatic/db/source/PPD/Custom
183mkdir -p %{buildroot}%{_var}/cache/foomatic
184
185echo cups > %{buildroot}%{_sysconfdir}/foomatic/defaultspooler
186
187# Remove things we don't ship.
188rm -rf  %{buildroot}%{_libdir}/perl5/site_perl \
189        %{buildroot}%{_libdir}/ppr \
190        %{buildroot}%{_sysconfdir}/foomatic/filter.conf.sample
191find %{buildroot} -name .packlist -o -name '*.xml.*' | xargs rm -f
192
193
194%post
195/bin/rm -f /var/cache/foomatic/*
196
197# restart the print server if it is running now
198/sbin/service lpd condrestart >/dev/null 2>&1
199/sbin/service cups condrestart >/dev/null 2>&1
200
201exit 0
202
203%clean
204rm -fr %buildroot $RPM_BUILD_DIR/%{name}
205
206%files
207%defattr(-,root,root)
208%doc --parents */README */USAGE */ChangeLog
209%dir %{_sysconfdir}/foomatic
210%config(noreplace) %{_sysconfdir}/foomatic/filter.conf
211%config(noreplace) %{_sysconfdir}/foomatic/defaultspooler
212%{_bindir}/*
213%{_sbindir}/*
214%{perl_vendorlib}/Foomatic
215%{_libdir}/cups/backend/*
216%{_libdir}/cups/driver/*
217%{_libdir}/cups/filter/*
218%{_datadir}/foomatic
219%{_datadir}/cups/model/foomatic-db-ppds
220%{_mandir}/*/*
221%{_var}/cache/foomatic
222
223%changelog
224* Mon Jun 06 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.0.7-2
225- added hplip and coreutils to "Requires:".
226- removed hpijs and fileutils from "Requires:".
227
228* Wed Apr 06 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.0.7-1
229- new upstream release.
230- dropped Source3 (no longer provided by upstream).
231- updated Patch2.
232
233* Thu Mar 24 2011 IWAI, Masaharu <iwai@alib.jp> 4.0.1-3
234- rebuild with perl 5.12.3
235
236* Fri Jul 24 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 4.0.1-2
237- add Requires: hpijs
238
239* Fri May 29 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 4.0.1-1
240- new upstream release
241
242* Sun Mar 22 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.0.0-1
243- new upstream release.
244- applied some patches from Fedora development.
245- remove subpackages.
246
247* Fri Sep 12 2008 Shu KONNO <owa@bg.wakwak.com> 3.0.2-1vl5
248- applied new versioning policy
249- used rpm macros: %%perl_sitelib %%perl_sitearch
250- added foomatic-db-engine-3.1-20050411-combo-xml.patch
251- added foomatic-db-engine-3.1-20050411-perl-data.patch
252- fixed permission of %%{_datadir}/foomatic/db
253
254* Sat Dec 02 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 3.0.2-0vl5
255- add BuildRequires: libxml2-devel, mpage, Omni
256- use %%{_prefix}/lib/{cups,ppr} instead of %%{_libdir}/{cups,ppr}
257- run foomatic-cleanupdrivers, foomatic-compiledb with 'perl -Ilib'
258- not create ppd-omni package if omni support is disabled
259
260* Tue Apr 11 2005 Satoshi MACHINO <machino@vinelinux.org> 3.0.2-0vl4
261- updated foomatic-db to 20050411
262- updated foomatic-db-engine to 3.1-20050411
263- updated foomatic-db-hpijs to 1.5-20050411
264- updated foomatic-filters to 3.1-20050411
265
266* Wed Jan 12 2005 Satoshi MACHINO <machino@vinelinux.org> 3.0.2-0vl3
267- updated foomatic-db to 20050112
268- updated foomatic-db-engine to 3.1-20050112
269- updated foomatic-db-hpijs to 1.5-20050112
270
271* Tue Dec 21 2004 Satoshi MACHINO <machino@vinelinux.org> 3.0.2-0vl2
272- updated foomatic-db to 20041220
273- updated foomatic-db-hpijs to 1.5-20041220
274
275* Sun Sep 19 2004 Satoshi MACHINO <machino@vinelinux.org> 3.0.2-0vl1
276- updated foomatic-db to 20040919
277- updated foomatic-db-engine to 3.0.2
278- updated foomatic-db-hpijs to 1.5-20040919
279- updated foomatic-filters to 3.0.2
280
281* Wed May 26 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 3.0.1-0vl4
282- update foomatic-db to 20040526
283- update foomatic-db-hpijs to 1.5-20040526
284
285* Tue May 25 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 3.0.1-0vl3
286- sprit foomatic-ppd to ppd,ppd-hpijs,ppd-omni,ppd-gimp-print,
287  ppd-gimp-print-ijs
288- add Requires: to ppd-* subpackages.
289
290* Thu Apr 15 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 3.0.1-0vl2
291- new upstream version
292        -- Omni-printers-0.9.1
293        -- gimp-print-foomatic-db-4.2.6
294- foomatic.spec -> foomatic-vl.spec
295
296* Fri Feb 20 2004 Satoshi MACHINO <machino@vinelinux.org> 3.0.1-0vl1
297- new upstream version
298        -- foomatic-filters-3.0.1
299        -- foomatic-db-engine-3.0.1
300        -- foomatic-db-20040219
301        -- foomatic-db-hpijs-1.5-20040219
302
303* Mon Jan 26 2004 Satoshi MACHINO <machino@vinelinux.org> 3.0.0-0vl11
304- new upstream version
305        -- foomatic-filters-3.0.1rc3(bug fix. in configure script)
306        -- defined filterver
307- dropped patch101
308
309* Sun Jan 25 2004 Satoshi MACHINO <machino@vinelinux.org> 3.0.0-0vl10
310- new upstream cvs version(foomatic-3.0.1rc2)
311        -- foomatic-db-20040125
312        -- foomatic-db-engine-3.0.1rc2
313        -- foomatic-db-hpijs-1.5-20040125
314        -- foomatic-filters-3.0.1rc2
315- added patch101
316        -- tests diris null in foomatic-filters-3.0.1rc2
317
318* Fri Jan 23 2004 Satoshi MACHINO <machino@vinelinux.org> 3.0.0-0vl9
319- new upstream cvs version
320        -- foomatic-db-20040123
321        -- foomatic-db-engine-3.0-20040123
322        -- foomatic-db-hpijs-1.5-20040123
323        -- foomatic-filters-3.0-20040123
324- dropped old patches
325
326* Sat Dec 13 2003 Satoshi MACHINO <machino@vinelinux.org> 3.0.0-0vl8
327- built on perl-5.8.2
328
329* Tue Nov 11 2003 Satoshi MACHINO <machino@vinelinux.org> 3.0.0-0vl7
330- separated foomatic-db package included xml files
331
332* Mon Nov 10 2003 Satoshi MACHINO <machino@vinelinux.org> 3.0.0-0vl6
333- added description of ppd sub package
334
335* Sun Nov 09 2003 Satoshi MACHINO <machino@vinelinux.org> 3.0.0-0vl5
336- separated foomatic-ppd package included PPD files
337
338* Sun Nov 09 2003 Satoshi MACHINO <machino@vinelinux.org> 3.0.0-0vl4
339- new upstream version
340        -- foomatic-db-20031109, foomatic-db-engine-3.0-20031109
341        -- foomatic-filters-3.0-20031109, foomatic-db-hpijs-1.4-1
342- dropped patches
343        -- foomatic-filters-path.patch(patch0)
344        -- foomatic-2.0.2-fontpath.patch(patch3)
345- updated patches
346        -- foomatic-filters-3.0-20031109-libdir.patch (patch1)
347        -- foomatic-db-engine-3.0-20031109-libdir.patch (patch2)
348        -- foomatic-filters-3.0-20031109-vine.patch (patch100)
349
350* Thu Nov 06 2003 Satoshi MACHINO <machino@vinelinux.org> 3.0.0-0vl3
351- built on perl-5.8.1
352- fixed install section in spec file
353
354* Sat Aug 30 2003 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 3.0.0-0vl2
355- fix some bugs of foomatic-filters.
356A
357
358* Sat Jun 07 2003 Satoshi MACHINO <machino@vinelinux.org> 3.0.0-0vl1
359- new upstream version
360        -- rewrote spec file
361        -- added some patches from rawhide(foomatic-3.0.0-5)
362- enable cups support
363
364* Sun Apr 20 2003 Satoshi MACHINO <machino@vinelinux.org> 2.0.2-0vl2
365- imported some patches from foomatic-2.0.2-18
366        -- added foomatic-2.0.2-psc2210.patch
367        -- added foomatic-2.0.2-duplex184.patch
368
369* Sun Mar 02 2003 Satoshi MACHINO <machino@vinelinux.org> 2.0.2-0vl1
370- imported foomatic-2.0.2-15
371 
372* Tue Feb  4 2003 Tim Waugh <twaugh@redhat.com> 2.0.2-15
373- Update data-generators to CVS.
374
375* Thu Jan 30 2003 Tim Waugh <twaugh@redhat.com> 2.0.2-14
376- Use hpijs, not hpijs-rss (we don't ship the RSS patch now).
377
378* Thu Jan 23 2003 Tim Waugh <twaugh@redhat.com> 2.0.2-13
379- Pacify printers that don't understand duplex (bug #82385).
380
381* Wed Jan 22 2003 Tim Powers <timp@redhat.com> 2.0.2-12
382- rebuilt
383
384* Thu Jan 21 2003 Tim Waugh <twaugh@redhat.com> 2.0.2-11
385- Add autodetect info for HP DeskJet 656C.  It doesn't really do
386  IEEE 1284 IDs, but since it's a USB device we can figure out it's
387  manufacturer and model anyway.
388
389* Thu Jan  9 2003 Tim Waugh <twaugh@redhat.com> 2.0.2-10
390- Set GS_FONTPATH in gs wrapper (bug #81410).
391
392* Sat Jan  4 2003 Jeff Johnson <jbj@redhat.com> 2.0.2-9
393- use internal dep generator.
394
395* Sun Dec 15 2002 Tim Waugh <twaugh@redhat.com> 2.0.2-8
396- Add several device IDs.
397
398* Sat Dec 14 2002 Tim Waugh <twaugh@redhat.com> 2.0.2-7
399- Update Omni printers to 0.7.2.
400- No longer need Omni badxml patch.
401
402* Sat Dec 14 2002 Tim Powers <timp@redhat.com> 2.0.2-6
403- don't use rpms internal dep generator
404
405* Fri Dec  6 2002 Tim Waugh <twaugh@redhat.com> 2.0.2-5
406- Omni XML wasn't well-formed.
407
408* Wed Nov 20 2002 Tim Waugh <twaugh@redhat.com> 2.0.2-4
409- Update gimp-print data.
410- Add 'generic postscript' model.
411
412* Mon Nov 11 2002 Tim Waugh <twaugh@redhat.com> 2.0.2-3
413- Update Omni printers to 0.7.1.
414
415* Tue Oct 22 2002 Tim Waugh <twaugh@redhat.com> 2.0.2-2
416- Fix file manifest for perl modules.
417- Add autodetect information for HP DeskJet 990C.
418
419* Mon Oct 21 2002 Tim Waugh <twaugh@redhat.com> 2.0.2-1
420- 2.0.2.
421- No longer need 67973, 970c patches.
422- Remove cups-drivers-* packages (no longer needed).
423- Remove files not shipped.  Ship filter.conf.
424- Conditionally restart cups.
425- Use libdir.
426- Don't put things in site_perl; use vendor_perl instead (bug #73528).
427
428* Fri Aug  9 2002 Tim Waugh <twaugh@redhat.com> 1.9-1.20020617.6
429- Fix autodetect information for HPDJ970C.
430
431* Thu Aug  8 2002 Tim Waugh <twaugh@redhat.com> 1.9-1.20020617.5
432- For gimp-print, use the Ghostscript stp driver in preference to the
433  IJS interface.
434
435* Thu Jul 25 2002 Tim Waugh <twaugh@redhat.com> 1.9-1.20020617.4
436- Quieten scriptlets.
437
438* Fri Jul  5 2002 Tim Waugh <twaugh@redhat.com> 1.9-1.20020617.3
439- Fix autodetect information for HPLJ2100/2100M.
440
441* Fri Jun 21 2002 Tim Powers <timp@redhat.com> 1.9-1.20020617.2
442- automated rebuild
443
444* Wed Jun 19 2002 Tim Waugh <twaugh@redhat.com> 1.9-0.20020617.2
445- Omni 0.7.0 printers.
446
447* Mon Jun 17 2002 Tim Waugh <twaugh@redhat.com> 1.9-0.20020617.1
448- Update to CVS.
449- Remove some more explicit perl dependencies that are picked up
450  automatically.
451
452* Wed May 29 2002 Tim Waugh <twaugh@redhat.com> 1.9-0.20020517.3
453- Remove explicit perl-Storable dependency; it should be perl(Storable),
454  and that is picked up automatically.
455
456* Tue May 28 2002 Tim Waugh <twaugh@redhat.com> 1.9-0.20020517.2
457- Fix release number.
458- Drop gen-ppds from the file manifest---use foomatic-compiledb instead
459  (bug #63622).
460
461* Sun May 26 2002 Tim Powers <timp@redhat.com>
462- automated rebuild
463
464* Thu May 23 2002 Tim Waugh <twaugh@redhat.com> 1.9-0.20020517.1
465- Remove ghostscript UPP drivers that are gone in 7.05.
466
467* Sat May 18 2002 Tim Waugh <twaugh@redhat.com> 1.9-0.20020517.0.1
468- Update to CVS.
469- Updated requirements.
470- Updated path and libdir patches.
471- Drop hpijs 1.0.2 patch.
472- foomatic-datafile has moved to %%{_bindir}.
473- Update gimp-print data to 4.2.1.
474- Update Omni printer data to 0.6.1.
475
476* Thu Apr  4 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020313.3
477- Fix the hpijs option data too (bug #62587).
478
479* Wed Apr  3 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020313.2
480- Back off to 1.0.2 for hpijs driver data (bug #62587).
481
482* Thu Mar 14 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020313.1
483- Update to CVS.
484
485* Wed Mar  6 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020306.1
486- Update to CVS.
487- Patches no longer needed: conffile, sys, cachedir, fd0.
488- Adapted path patch.
489
490* Tue Mar  5 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020130.10
491- Fix bug #58319.
492- Drop dbg patch.
493
494* Mon Feb 25 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020130.9
495- Fix file lists.
496
497* Mon Feb 25 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020130.8
498- Fix %post scriplet bug (bug #59942).
499
500* Thu Feb 21 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020130.7
501- Rebuild in new environment.
502
503* Wed Feb 13 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020130.6
504- Merge cups-drivers.  No epoch needed.
505- Require perl-URI.
506
507* Wed Feb 06 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020130.5
508- Cache fix.
509
510* Mon Feb  4 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020130.4
511- Don't ship backup files.
512
513* Mon Feb  4 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020130.3
514- Rebuild to pick up new perl installsitelib.
515
516* Thu Jan 31 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020130.2
517- Fix a thinko in DB.pl.
518
519* Wed Jan 30 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020130.1
520- Update to CVS.
521- No longer need the cachedir patch.
522- Fix config file path.
523- Look in /usr/local/bin last, not first, in lpdomatic (bug #57915).
524
525* Tue Jan 29 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020129.1
526- Update to CVS.
527- Patches no longer needed: prepend, fd3.
528- Use RPM_OPT_FLAGS.
529- Allow non-root users to use foomatic-datafile (bug #58956).
530
531* Sat Jan 26 2002 Jeff Johnson <jbj@redhat.com> 1.1-0.20020124.2
532- added Provides: perl(Foomatic::GrovePath)
533
534* Thu Jan 24 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020124.1
535- Update to CVS.
536- Updated Omni printers to those in Omni 0.5.1.
537- Updated patches: prepend, fd3.
538- Patches no longer needed: utf8, lpdomatic.
539- Added gimp-print (formerly stp) foomatic db info, and removed the old
540  stp.xml file.
541- Conflict with ghostscript if it doesn't have gimp-print-4.2.0 yet.
542
543* Fri Jan 18 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20011218.2
544- REALLY fix PCL fixup code (bug #55909, others).
545- PreReq fileutils, initscripts (bug #56984).
546- Fix prepends in lpdomatic (bug #57371).
547- Run foomatic-cleanupdrivers during install, to remove driver entries
548  with no command line.
549- Put lpdomatic in /usr/sbin again.
550- Fix foomatic-gswrapper's file descriptor manipulations (bug #56871).
551
552* Mon Dec 17 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20011218.1
553- re-imported from upstream to fix some perl fixup code on pcl printers.
554
555* Mon Dec 17 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20011217.2
556- fix the rest of the quoting issues with foomatic-combo-xml with the patch
557- foomatic-1.1-20011217-quotes.patch. This has been sent upstream.
558
559* Mon Dec 17 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20011217.1
560- respin to pull in latest foomatic database, fixes:
561-       properly use the cache in relation to foomatic-combo-xml's output
562-       fix _some_ of the quoting issues with calling foomatic-combo-xml
563
564* Thu Dec  5 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20011205.1
565- respin to pull in latest foomatic database, fixes:
566-       droping half of a large job
567-       -Mutf8 added to the upstream filters
568-       miscelaneous printer db updates
569
570* Mon Nov 29 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20011018.8
571- added Requires: fileutils for the 'rm' in post
572
573* Mon Nov 26 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20011018.7
574- /var/chache => /var/cache, doh!
575
576* Fri Nov 16 2001 Nalin Dahyabhai <nalin@redhat.com> 1.1-0.20011018.6
577- fix %%post scriptlet
578
579* Tue Nov 13 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20011018.5
580- changed the patch to use the -Mutf8 command line option,
581- and to restart the printserver, after rebuilding the settings.
582
583* Fri Nov  9 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20011018.4
584- grumble. Some drivers use inline perl scripts, and need the 'use utf8;'
585- pragma. Without it, they break on _some_ of their options.
586
587* Wed Oct 31 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20011018.3
588- patched lpdomatic to prepend PostScript options in the _right_ place.
589
590* Thu Oct 25 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20011018.2
591- zap the foomatic cache on install
592
593* Thu Oct 18 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20011018.1
594- rolled to pull in latest information.
595- added Omni printers to the printer list.
596
597* Fri Oct 05 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20011005.1
598- rolled to pull in an ia64 fix to foomatic-combo-xml.c
599
600* Mon Oct 01 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20011001.1
601- rolled to pull in foomatic fixes to foomatic-combo-xml.c
602
603* Wed Sep 05 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20010905.1
604- upgraded to latest foomatic, we now have fast overview generation!
605- this means that there is no prebuilt overview file.
606
607* Tue Aug 28 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20010828.1
608- WOW! The latest foomatic uses Till Kamppeter's C based combo compiler.
609- It is now fast enough that there is no real benifit to precompiling.
610- NOTE: this forces the package to stop being noarched.
611
612* Mon Aug 27 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20010827.1
613- fresh pull, maybe it fixes the build errors.
614
615* Sat Aug 25 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20010825.1
616- did a fresh database pull, which contains the old japanese printers as well.
617- removed japanese hack.
618
619* Tue Aug 14 2001 Akira TAGOH <tagoh@redhat.com> 1.1-0.20010717.5
620- Add Japanese printer entry.
621
622* Mon Aug  6 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20010717.4
623- move the cache back to /var, sigh.
624
625* Mon Jul 23 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20010717.2
626- made foomatic pre-compute its db
627
628* Thu Jul 18 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20010717.1
629- imported from mandrake.
630
631* Tue Jul 17 2001 Till Kamppeter <till@mandrakesoft.com> 1.1-0.20010717mdk
632- Added job listing/removal/manipulation and queue control to
633  foomatic-printjob
634- Support for printing multiple copies with PDQ
635
636* Fri Jul 14 2001 Till Kamppeter <till@mandrakesoft.com> 1.1-0.20010714mdk
637- Included the cupsomatic filter script
638- When a queue is set up, default options can be set now
639- Help messages of foomatic-configure and foomatic-printjob cleaned up.
640
641* Fri Jul 13 2001 Till Kamppeter <till@mandrakesoft.com> 1.1-0.20010713mdk
642- Many bugfixes in "foomatic-printjob".
643- "foomatic-configure" adds the Foomatic config file directory automatically
644  to the search paths of PDQ.
645- Printing a help page under PDQ was broken.
646
647* Thu Jul 12 2001 Stefan van der Eijk <stefan@eijk.nu> 1.1-0.20010712mdk
648- BuildRequires:        perl-devel
649
650* Wed Jul 11 2001 Till Kamppeter <till@mandrakesoft.com> 1.1-0.20010711mdk
651- initial release.
652- Deleted the obsolete drivers "stp", "cZ11", and "hpdj".
653- Patch applied which flushes the memory cache regularly, otherwise
654  foomatic-configure would hang when the Foomatic data of GIMP-Print is
655  installed.
Note: See TracBrowser for help on using the repository browser.