source: projects/specs/branches/6/f/fluxbox/fluxbox-vl.spec @ 3390

Revision 3390, 15.7 KB checked in by iwaim, 13 years ago (diff)

fluxbox 1.3.1-2

Line 
1%define FBversion 1.3.1
2%define pversion 1.3.0
3%define patchversion 1.1.0.1
4
5%define fbumenu_version 0.5.5
6%define vinefiles_version 11.2
7
8Summary:        Fluxbox is a windowmanager that is based on Blackbox.
9summary(ja):    Fluxbox は Blackbox から派生したウインドウマネージャです。
10Name:           fluxbox
11Version:        %{FBversion}
12Release:        2%{?_dist_release}
13Group:          User Interface/Desktops
14License:        MIT
15URL:            http://fluxbox.org/
16Vendor:         Project Vine
17Distribution:   Vine Linux
18Source0:        http://sourceforge.net/projects/fluxbox/files/fluxbox/%{version}/fluxbox-%{version}.tar.bz2
19# styles & scripts
20Source1:        %{name}-vinefiles-%{vinefiles_version}.tar.bz2
21Source2:        styles2-2.tar.bz2
22Source3:        fb_libexec.tar.bz2
23Source4:        fb_extend_menu
24
25Patch0:         fluxbox-%{pversion}-2.init-in.patch
26##Patch1:               fluxbox-%{patchversion}.src-clock-tool.patch
27##Patch2:               fluxbox-%{patchversion}.src-Makefile-in.patch
28Patch3:         fluxbox-%{pversion}.nls-ja.patch
29Patch4:         fluxbox-%{pversion}-2.startfb.patch
30Patch5:         fluxbox-%{pversion}.menugen-menu-default.patch
31Patch6:         fluxbox-%{pversion}.menugen-add-app.patch
32Patch8:         fluxbox-%{pversion}.menugen-utf-8.patch
33Patch9:         fluxbox-%{pversion}.menugen-vine-ext.patch
34Patch91:        fluxbox-%{pversion}-2.menugen.patch
35
36Patch10:        fbsetbg_setter_priority.patch
37##Patch20:        fluxbox-1.1.1.Xclients.patch
38##fluxbox-%{patchversion}.Xclients.patch
39##Patch30:      fluxbox-%{patchversion}.nls-hh.patch
40Patch40:        fluxbox-%{patchversion}.nls-ja-make.patch
41Patch41:        fluxbox-%{pversion}.update_cfg.patch
42Patch50:        fluxbox.windowmenu-1.patch
43Patch51:        fluxbox.keys-1.patch
44##Patch100:       fluxbox-%{patchversion}.20080913.patch
45
46BuildRoot:      %{_tmppath}/%{name}-buildroot
47BuildRequires:  libX11-devel libXext-devel
48BuildRequires:  bzip2 imlib2-devel zlib-devel freetype2-devel
49BuildRequires:  libXpm-devel nkf libXft-devel
50BuildRequires:  libICE-devel libSM-devel libXinerama-devel
51BuildRequires:  libXrandr-devel libXrender-devel
52BuildRequires:  fontconfig-devel libtool
53Requires:       imlib2 imlib2-loader ImageMagick nkf xsri task-xorg-x11
54Requires:       zenity bash
55
56%description
57
58Fluxbox is yet another windowmanager for X.
59It's based on the Blackbox 0.61.1 code.
60Fluxbox looks like blackbox and handles styles, colors, window
61placement and similar thing exactly like blackbox
62    (100% theme/style compability).
63So what's the difference between fluxbox and blackbox then?
64The answer is: LOTS!
65Here is a list of features that fluxbox already has, or is in the works...
66
67%description -l ja
68
69fluxbox は X Window System 用の、一味違ったウィンドウマネージャです。
70それは blackbox-0.61.1 のプログラムコードをベースに開発されています。
71fluxbox は blackbox によく似ていて、スタイル、カラーリング、ウィンドウ
72の配置などを blackbox 同様に処理します。(スタイル(テーマ)は 100% 互換)
73では、fluxbox と blackbox の違いは?  ...  その答えは「いっぱい」!
74
75fluxbox に何が出来るか、今後何を計画しているのか?
76詳しくは http://fluxbox.sourceforge.net/ をご覧下さい。
77
78%prep
79%__rm -rf %{buildroot}
80%setup -q -a 1 -a 2 -a 3
81
82## init
83%patch0 -p1
84##%patch1 -p1
85##%patch2 -p1
86## nls
87%patch3 -p1
88## startfluxbox
89%patch4 -p1
90## fluxbox-generete_menu
91%patch5 -p1
92%patch6 -p1
93%patch8 -p1
94%patch9 -p1
95%patch91 -p1
96## fbsetbg_setter_priority
97%patch10 -p1
98##%patch30 -p1
99## nls Makefile.in
100%patch40 -p1
101## fluxbox-update_configs.cc
102%patch41 -p1
103## windowmenu
104%patch50 -p1
105## keys
106%patch51 -p1
107## keys
108##%patch50 -p1
109##%patch100 -p1
110
111%build
112
113CFLAGS="${CFLAGS:-%optflags}" ; export CFLAGS ; \
114    CXXFLAGS="${CXXFLAGS:-%optflags}" ; export CXXFLAGS ; \
115    FFLAGS="${FFLAGS:-%optflags}" ; export FFLAGS ; \
116    ./configure --enable-nls \
117    --prefix=%{_prefix} \
118    --exec-prefix=%{_exec_prefix} \
119    --bindir=%{_bindir} \
120    --sbindir=%{_sbindir} \
121    --sysconfdir=%{_sysconfdir} \
122    --datadir=%{_datadir} \
123    --includedir=%{_includedir} \
124    --libdir=%{_libdir} \
125    --libexecdir=%{_libexecdir} \
126    --localstatedir=%{_localstatedir} \
127    --sharedstatedir=%{_sharedstatedir} \
128    --mandir=%{_mandir} \
129    --infodir=%{_infodir}
130
131%__make
132
133%install
134%__rm -rf  %{buildroot}
135# fluxbox installation
136make "DESTDIR=%{buildroot}" install
137
138# styles
139%__rm data/styles/Makefile*
140%__cp -a data/styles                %{buildroot}%{_datadir}/%{name}/
141%__cp -a data/styles2               %{buildroot}%{_datadir}/%{name}/
142# wallpapers
143%__cp -a data/backgrounds           %{buildroot}%{_datadir}/%{name}/
144# HTML images
145%__cp -a data/images                %{buildroot}%{_datadir}/%{name}/
146# UserMenu samples
147%__cp -a data/UserMenu              %{buildroot}%{_datadir}/%{name}/
148# HTML docs
149%__cp data/*.html                   %{buildroot}%{_datadir}/%{name}/
150# scripts
151%__cp data/fb_welcome               %{buildroot}%{_datadir}/%{name}/
152%__cp data/cng_fbtips               %{buildroot}%{_datadir}/%{name}/
153%__cp data/change-rootcmd           %{buildroot}%{_datadir}/%{name}/
154%__cp data/change-init_rootcmd      %{buildroot}%{_datadir}/%{name}/
155%__cp data/applyoldstyle            %{buildroot}%{_datadir}/%{name}/
156%__cp data/mk-rootcmds              %{buildroot}%{_bindir}/
157%__cp data/fbumenu_gen-%{fbumenu_version} %{buildroot}%{_bindir}/fbumenu_gen
158# changelog
159%__cp ChangeLog                     %{buildroot}%{_datadir}/%{name}/
160
161# xsession desktop entry
162%__mkdir_p %{buildroot}%{_datadir}/xsessions/
163#%__cp data/fluxbox.desktop %{buildroot}%{_datadir}/xsessions/
164%__install -m 644 data/fluxbox.desktop %{buildroot}%{_datadir}/xsessions/
165# logout, reboot, shutdown commands
166%__mkdir_p %{buildroot}%{_libexecdir}/%{name}
167%__install -m 755 fb_libexec/* %{buildroot}%{_libexecdir}/%{name}/
168# extend menu
169%__mkdir_p %{buildroot}%{_datadir}/%{name}/
170%__install -m 755 %{SOURCE4} %{buildroot}%{_datadir}/%{name}/
171
172if [ -z "$DEBUG" ]; then
173    strip   %{buildroot}%{_bindir}/fluxbox \
174        %{buildroot}%{_bindir}/fbsetroot \
175        %{buildroot}%{_bindir}/fbrun
176fi
177
178bzip2 %{buildroot}%{_mandir}/man1/*.1
179
180%post
181
182# New menu-system
183%__rm %{_datadir}/fluxbox/menu*
184%{_bindir}/fluxbox-generate_menu \
185    -in -B \
186    -p %{_prefix} \
187    -o %{_datadir}/fluxbox/menu 2> /dev/null
188
189%clean
190
191%__rm -rf %{buildroot}
192
193%files
194%defattr(-,root,root,755)
195%doc AUTHORS COPYING ChangeLog INSTALL NEWS README TODO
196%{_bindir}/*
197%{_datadir}/*
198%{_libexecdir}/*
199
200
201%changelog
202* Sat Mar 26 2011 KATO Masashi <mkato@par.odn.ne.jp> 1.3.1-2
203- added wide wall paper
204- update documents(flux_news.html)
205
206* Mon Mar  7 2011 KATO Masashi <mkato@par.odn.ne.jp> 1.3.1-1
207- new upstream release.
208
209* Tue Mar  1 2011 KATO Masashi <mkato@par.odn.ne.jp> 1.3.0-1
210- new upstream release.
211- updated patchs.
212- added keys & windowmenu patch.
213- update documents(flux_news.html,styles.html)
214
215* Tue Oct  5 2010 KATO Masashi <mkato@par.odn.ne.jp> 1.1.1-5
216- added BR: libICE-devel libSM-devel libXinerama-devel
217            libXrandr-devel libXrender-devel fontconfig-devel libtool
218- added Requires: task-xorg-x11 bash
219- dropped Requires: xinitrc libXpm
220
221* Mon Oct  4 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.1.1-4
222- add BR: libXft-devel (1.1.1-3.ppc was built w/o libXft-devel)
223
224* Wed May 26 2010 KATO Masashi <mkato@par.odn.ne.jp> 1.1.1-3
225- update & added Vine documents. (apps.html, config_files.html)
226- Combined some of patches.
227- update fbumenu_gen script(usermenu generator).
228- added menu commands. (logout, reboot, shutdown)
229- added extend application menu script. (%{SOURCE4})
230
231* Tue Mar 16 2010 KATO Masashi <mkato@par.odn.ne.jp> 1.1.1-2
232- updated wallpapers.
233- moved desktop-entry to %{_datadir}/xsessions/ .
234
235* Fri Sep 19 2008 KATO Masashi <mkato@par.odn.ne.jp> 1.1.1-1
236- new upstream release.
237- removed upstream patchs.
238- rewrote Vine documents.
239
240* Sat Sep 14 2008 KATO Masashi <mkato@par.odn.ne.jp> 1.1.0.1-3
241- Applied upstream patchs.
242
243* Fri Sep 12 2008 KATO Masashi <mkato@par.odn.ne.jp> 1.1.0.1-2
244- updated mk-rootcmds
245- updated vine documents. (keys.html, flux_news.html)
246
247* Thu Sep 11 2008 KATO Masashi <mkato@par.odn.ne.jp> 1.1.0.1-1
248- new upstream release
249- removed fluxbox-%{FBversion}.nls-hh.patch
250- rewrote documents. (keys.html, flux_news.html)
251- added new default keys file
252
253* Sun Aug 24 2008 KATO Masashi <mkato@par.odn.ne.jp> 1.0.0-6
254- fixed locale problem
255-     rewrote scripts for eucJP and UTF-8
256- revived fluxbox-%{FBversion}.Xclients.patch. (for startx)
257
258* Sun Jun 22 2008 KATO Masashi <mkato@par.odn.ne.jp> 1.0.0-5
259- add new style. (tux)
260
261* Mon Jun 16 2008  KATO Masashi <mkato@par.odn.ne.jp> 1.0.0-3
262- corrected line gap of nls-header
263-   (fluxbox-1.0.0.nls-hh.patch)
264
265* Tue May 27 2008  KATO Masashi <mkato@par.odn.ne.jp> 1.0.0-2
266- adjust startup sequence
267-   (rewrite desktop entry file for dm sessions)
268-   (remove fluxbox-%{FBversion}.Xclients.patch)
269
270* Sun May 25 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.0-1
271- applied new versioning policy
272- rebuilt with xorg-x11 7.3
273- spec in UTF-8
274
275* Tue Dec  4 2007 KATO Masashi <mkato@par.odn.ne.jp> 1.0.0-0vl3, 4
276- retouch patchs for ja_JP.UTF-8 locale
277-     : for root menu & help message
278- rewrite vine documents
279
280* Mon Oct 15 2007 KATO Masashi <mkato@par.odn.ne.jp> 1.0.0-0vl1, 2
281- new upstream 'stable' release
282- add new documents(styles tips, keys tips).
283- add new styles
284- update patch files, vine documents, vine scripts
285
286* Wed Apr 11 2007 KATO Masashi <mkato@par.odn.ne.jp> 1.0-0vl0.rc3.1, 2
287- new upstream release
288- add rewrited system styles
289- update patch files
290- update vine documents
291
292* Sun Dec 24 2006 KATO Masashi <mkato@par.odn.ne.jp> 1.0-0vl0.rc2.3, 4
293- add BuildRequires: zlib-devel freetype2-devel
294- add Requires: xsri
295- Change wpsetter's priority (fbsetbg_setter_priority.patch)
296
297* Thu Jul 20 2006 KATO Masashi <mkato@par.odn.ne.jp> 1.0-0vl0.rc2.1, 2
298- new upstream release
299- update patch files
300- update vine documents
301
302* Thu Jul  6 2006 KATO Masashi <mkato@par.odn.ne.jp> 1.0-0vl0.rc0.1, 2
303- new upstream release
304- update patch files
305- added 'additional applications' extension to fluxbox-generate_menu
306
307* Tue Apr  8 2006 KATO Masashi <mkato@par.odn.ne.jp> 0.9.15.1-0vl1, 2
308- new upstream release
309- add 'init file rewrite' script for back-compatible
310- rewrite documents
311
312* Wed Mar 29 2006 KATO Masashi <mkato@par.odn.ne.jp> 0.9.15-0vl1, 2
313- new upstream release
314- update *tips*
315- update patch files
316- add & update script files
317- update & retouch style files (VineStyle*, BlueStar*)
318- retouch menu structure (Vine tools)
319- add script for back compatible to background-style
320
321* Sun Mar 19 2006 KATO Masashi <mkato@par.odn.ne.jp> 0.9.14-0vl1.1, 2.2
322- update *_tips.html
323    (retouch link errors)
324- retouch ja_JP/Translation.m
325- update menugen patch
326- update style file (VineStyle, BlueStar)
327- add index.html, scripts for 'wellcome'
328
329* Tue Oct 25 2005 KATO Masashi <mkato@par.odn.ne.jp> 0.9.14-0vl1, 2
330- new upstream release
331- update vine patch
332        (retouch init file for new spec.)
333- update vinefiles
334    (update fbumenu_gen(usermenu generator))
335        (update 2 style files for new spec.)
336        (update fluxtips.txt)
337- update fluxbox_menu_tips.html
338
339* Sun Jun  5 2005 KATO Masashi <mkato@par.odn.ne.jp> 0.9.13-0vl3, 4
340- update vine patch
341        (add some menu items to fluxbox-generate_menu)
342            (retouch menu structure)
343                (rewrite 'about menu')
344- update vinefiles
345    (add usermenu generator to x-utilus)
346- update fluxbox_menu_tips.html
347
348* Fri May 27 2005 KATO Masashi <mkato@par.odn.ne.jp> 0.9.13-0vl1
349- new upstream release
350- update vine patch
351        (add some menu items to fluxbox-generate_menu)
352                (extend 'about toolbar')
353- update nls-ja patch
354- update fluxtips.txt
355    (rewrite, add '0.9.13 news')
356
357* Sun Feb  6 2005 KATO Masashi <mkato@par.odn.ne.jp> 0.9.12-0vl1
358- new upstream release
359- update vine patch
360        (add some menu items to fluxbox-generate_menu)
361            (include blackbox styles)
362                (extend 'my_mail')
363                (extend 'about menu')
364- add nls-ja patch
365
366* Sun Dec 12 2004 KATO Masashi <mkato@par.odn.ne.jp> 0.9.11-0vl1
367- new upstream release
368- update vine patch
369    (generate japanese menu)
370        (add some menu items to fluxbox-generate_menu)
371        (retouch menu structure)
372        (fix menu backup problem)
373
374* Wed Nov 24 2004 IWAI, Masaharu <iwai@alib.jp> 0.9.10-0vl1
375- new upstream release
376- update vine patch ( merged vine patches )
377- add font_locale patch ( Patch100 )
378- fix typo: s/buidroot/buildroot/g
379
380* Sun Jun 20 2004 KATO Masashi <mkato@par.odn.ne.jp> 0.9.9-0vl2
381- rewrite 2 styles (VineStyleII, BlueStarII)
382- rewrite fluxtips.txt(for 0.9.x)
383- modifying menu-generator
384    (fix problems of 'can't generates some menus')
385    (add some menu items)
386    (Japanese help messages)
387    - modifying 'init' file(default style, menu-alpha)
388    - append sample of 'keys' file
389
390    * Sun May  2 2004 IWAI, Masaharu <iwai@alib.jp> 0.9.9-0vl1
391    - new upstream release
392
393    * Sun Mar 14 2004 IWAI, Masaharu <iwai@alib.jp> 0.9.8-0vl2
394    - using rpm macros
395    - fix nonexistent directory for styles in postscript
396    - add BuildRequires: bzip2
397    - drop Prefix tag
398
399    * Sat Mar  6 2004 IWAI, Masaharu <iwai@alib.jp> 0.9.8-0vl1
400    - new upstream release
401    - update vine patch (Patch101)
402
403    * Mon Aug 11 2003 IWAI, Masaharu <iwai@alib.jp> 0.1.14-1_0vl2
404    - build for VineSeed
405    - fix Group tag for VineLinux:
406    Graphical desktop/Other -> User Interface/Desktops
407    - add /usr/share/%%{name} directory in %%files section
408
409    * Sat May 31 2003 KATO Masashi <mkato@par.odn.ne.jp> 0.1.14-1_0vl1
410    - fluxbox for Vine Linux. Japanese menu enabled at default.
411    - modified menu-generator patch (x-terminals)
412    - modified init.in patch (date,workspace name,default style)
413    - added 2 styles (VineStyle, BlueStar)
414
415    * Mon Dec  9 2002 Han Boetes <han@mijncomputer.nl> 0.1.14-1
416    - And we have a new release
417
418    * Sun Dec  1 2002 Han Boetes <han@linux-mandrake.com> 0.1.13-4
419    - added only missing patch from bugfixpatch
420
421    * Mon Nov 25 2002 Han Boetes <han@linux-mandrake.com> 0.1.13-3
422    - aa-startup- and openoffice-patch from Rathnor
423
424    * Thu Nov 21 2002 Han Boetes <han@linux-mandrake.com> 0.1.13-2
425    - Fix locales patch
426
427    * Tue Nov 19 2002 Han Boetes <han@linux-mandrake.com> 0.1.13-1
428    - Bump
429
430    * Fri Sep 13 2002 Han Boetes <han@linux-mandrake.com> 0.1.12-1
431    - Bump
432
433    * Tue Sep 10 2002 Han Boetes <han@linux-mandrake.com> 0.1.11-3
434    - Applied bugfix2 patch
435
436    * Tue Sep 10 2002 Han Boetes <han@linux-mandrake.com> 0.1.11-2
437    - Applied bugfix1 patch
438
439    * Tue Sep  3 2002 Han Boetes <han@mijncomputer.nl> 0.1.11-1
440    - Bump
441
442    * Mon Jul 15 2002 Han Boetes <han@mijncomputer.nl> 0.1.10-1
443    - Bump ;kudo's to Kurt Bechstein for recovering the rpm.
444
445* Mon Jun  3 2002 Han Boetes <han@mijncomputer.nl> 0.1.9-2
446- Applied bugfix-patch 2
447
448* Sat May 25 2002 Han Boetes <han@mijncomputer.nl> 0.1.9-1
449- Version Bump
450- New menu-system
451
452* Thu May  9 2002 Han Boetes <han@mijncomputer.nl> 0.1.8-4
453- Esthetic and Profilactic cleanups
454
455* Fri May  3 2002 Han Boetes <han@mijncomputer.nl> 0.1.8-3
456- Applied bugfix-patch 1+2+3
457
458* Sat Apr 27 2002 Han Boetes <han@mijncomputer.nl> 0.1.8-2
459- Applied bugfix-patch 1
460
461* Fri Apr 19 2002 Han Boetes <han@mijncomputer.nl> 0.1.8-1
462- Bump to version 0.1.8
463
464* Sat Mar  9 2002 Han Boetes <han@mijncomputer.nl> 0.1.7-3
465- Applied patch 1
466
467* Wed Mar  6 2002 Han Boetes <han@mijncomputer.nl> 0.1.7-2
468- Added DEBUG flavor
469
470* Fri Mar  1 2002 Han Boetes <han@mijncomputer.nl> 0.1.7-1
471- BUMP!
472
473* Thu Feb 07 2002 Christian Pelealu <chris@nerv-9.net> 0.1.6-3RH
474- Changed a lot of the build spec for RedHat 7.2
475
476* Tue Jan 29 2002 Han Boetes <han@mijncomputer.nl> 0.1.6-3
477- Applied patch 2
478
479* Sun Jan 13 2002 Han Boetes <han@mijncomputer.nl> 0.1.6-2
480- Applied patch.
481
482* Fri Jan 11 2002 Han Boetes <han@mijncomputer.nl> 0.1.6-1
483- Bump version.
484
485* Fri Dec 28 2001 Han Boetes <han@mijncomputer.nl> 0.1.5-1
486- Initial build
487
Note: See TracBrowser for help on using the repository browser.