source: projects/specs/branches/6/f/fluid-soundfont/fluid-soundfont-vl.spec @ 8146

Revision 8146, 7.9 KB checked in by shaolin, 10 years ago (diff)
  • fluid-soundfont, mscore, qtlockedfile, qtsingleapplication
    • new upload
  • gt
    • rebuild; fix spec encoding
Line 
1Name:           fluid-soundfont
2Version:        3.1
3Release:        11%{?_dist_release}
4Summary:        Pro-quality GM/GS soundfont
5Group:          Applications/Multimedia
6License:        MIT
7# The original URL (http://www.powermage.com/fluid) seems dead. Therefore we point
8# to the Hammersound archives:
9URL:            http://www.hammersound.com/cgi-bin/soundlink.pl?action=view_category&category=Collections&ListStart=0&ListLength=20
10# The Hammersound source gives us a soundfont in a linux-unfriendly .sfArk format.
11# In order to convert this to a linux-friendly .sf2 format one needs to use a
12# non-free utility sfarkxtc from
13#    http://www.melodymachine.com
14# This page explains how this conversion is done:
15#    http://vsr.informatik.tu-chemnitz.de/staff/jan/nted/doc/ch01s46.html
16# Debian folks already did this and we will borrow their source tarball:
17Source0:        http://ftp.de.debian.org/debian/pool/main/f/%{name}/%{name}_%{version}.orig.tar.gz
18# Some information about the soundfont that can be found in the Hammersound archive:
19Source1:        Fluid_R3_Readme.pdf
20# Optimized cfg files for fluid usage with timidity, written by Saito, one of
21# the TiMidity++ developers
22Source2:        timidity++.cfg
23Source3:        fluid3gm.cfg
24Source4:        fluid3gs.cfg
25Source5:        fluid_altassign.cfg
26BuildArch:      noarch
27BuildRequires:  soundfont-utils
28
29
30%define common_description \
31FluidR3 is the third release of Frank Wen's pro-quality GM/GS soundfont.\
32The soundfont has lots of excellent samples, including all the GM instruments\
33along side with the GS instruments that are recycled and reprogrammed versions\
34of the GM presets.
35
36%description
37%common_description
38
39%package common
40Summary:        Common files for FluidR3 soundfont
41Group:          Applications/Multimedia
42
43%description common
44%common_description
45
46This package contains common files shared among all FluidR3 soundfont packages.
47
48%package gm
49Summary:        Pro-quality General Midi soundfont
50Group:          Applications/Multimedia
51Requires:       %{name}-common = %{version}-%{release}
52Provides:       soundfont2
53Provides:       soundfont2-default
54# If timidity++ is installed it must understand the trysouce configfile keyword
55Conflicts:      timidity++ <= 2.13.2-30.cvs20111110%{?dist}
56
57%description gm
58%common_description
59
60This package contains Fluid General Midi (GM) soundfont in soundfont 2.0 (.sf2)
61format.
62
63%package gs
64Summary:        Pro-quality General Standard Extension soundfont
65Group:          Applications/Multimedia
66Requires:       %{name}-common = %{version}-%{release}
67Requires:       %{name}-gm = %{version}-%{release}
68Provides:       soundfont2
69
70
71%description gs
72%common_description
73
74This package contains instruments belonging to General Midi's General Standard
75(GS) Extension in soundfont 2.0 (.sf2) format.
76
77%package lite-patches
78Summary:        Pro-quality General Midi soundfont in GUS patch format
79Group:          Applications/Multimedia
80Requires:       %{name}-common = %{version}-%{release}
81Provides:       timidity++-patches = 5
82Obsoletes:      timidity++-patches < 5
83Obsoletes:      PersonalCopy-Lite-patches < 5
84
85%description lite-patches
86%common_description
87
88This package contains Fluid General Midi (GM) soundfont in Gravis Ultrasound
89(GUS) patch (.pat) format.
90
91
92%prep
93%setup -q
94cp -a %{SOURCE1} .
95
96%build
97unsf -v -s -m FluidR3_GM.sf2
98unsf -v -s -m FluidR3_GS.sf2
99
100# Cut the size of the patches subpackage:
101for bank in GM-B{8,9,16} Standard{1,2,3,4,5,6,7} Room{1,2,3,4,5,6,7} Power{1,2,3} Jazz{1,2,3,4} Brush{1,2}; do
102   sed -i "/$bank/d" FluidR3_GM.cfg
103   rm -fr *$bank*
104done
105
106cat FluidR3_GM.cfg FluidR3_GS.cfg > FluidR3.cfg
107
108# The gus patches get used by a lot of different programs and some need the
109# path to the patches to be absolute
110sed -i 's|FluidR3_GM-|%{_datadir}/soundfonts/%{name}-lite-patches/FluidR3_GM-|g' FluidR3.cfg
111sed -i 's|FluidR3_GS-|%{_datadir}/soundfonts/%{name}-lite-patches/FluidR3_GS-|g' FluidR3.cfg
112
113%install
114%{__rm} -rf %{buildroot}
115# The actual soundfonts:
116mkdir -p $RPM_BUILD_ROOT%{_datadir}/soundfonts
117install -p -m 644 FluidR3_GM.sf2 $RPM_BUILD_ROOT%{_datadir}/soundfonts
118install -p -m 644 FluidR3_GS.sf2 $RPM_BUILD_ROOT%{_datadir}/soundfonts
119# Create a symlink to denote that this is the Fedora default soundfont
120ln -s FluidR3_GM.sf2 $RPM_BUILD_ROOT%{_datadir}/soundfonts/default.sf2
121
122# timidity++.cfg files for usage of the sf2 files with the real timidity
123mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}
124install -p -m 644 %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}
125install -p -m 644 %{SOURCE3} %{SOURCE4} %{SOURCE5} \
126    $RPM_BUILD_ROOT%{_datadir}/soundfonts
127
128# Gus patches + timidity.cfg, for programs which want the "old" timidity.cfg
129mkdir -p $RPM_BUILD_ROOT%{_datadir}/soundfonts/%{name}-lite-patches
130cp -a FluidR3_GM-* $RPM_BUILD_ROOT%{_datadir}/soundfonts/%{name}-lite-patches
131cp -a FluidR3_GS-* $RPM_BUILD_ROOT%{_datadir}/soundfonts/%{name}-lite-patches
132install -p -m 644 FluidR3.cfg $RPM_BUILD_ROOT%{_sysconfdir}/timidity.cfg
133
134%clean
135%{__rm} -rf %{buildroot}
136
137%files common
138%doc COPYING README *Readme*
139%dir %{_datadir}/soundfonts/
140
141%files gm
142%{_sysconfdir}/timidity++.cfg
143%{_datadir}/soundfonts/FluidR3_GM.sf2
144%{_datadir}/soundfonts/default.sf2
145%{_datadir}/soundfonts/fluid3gm.cfg
146%{_datadir}/soundfonts/fluid_altassign.cfg
147
148%files gs
149%{_datadir}/soundfonts/FluidR3_GS.sf2
150%{_datadir}/soundfonts/fluid3gs.cfg
151
152%files lite-patches
153%config %{_sysconfdir}/timidity.cfg
154%{_datadir}/soundfonts/%{name}-lite-patches/
155
156
157%changelog
158* Thu Jan  9 2014 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 3.1-11
159- initial build for Vine Linux
160
161* Sat Aug 03 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.1-11
162- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
163
164* Wed Feb 13 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.1-10
165- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
166
167* Thu Jul 19 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.1-9
168- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
169
170* Mon Apr 30 2012 Hans de Goede <hdegoede@redhat.com> - 3.1-8
171- Use trysource for the gs config in timidity++.cfg (rhbz#815611)
172
173* Sat Jan 21 2012 Hans de Goede <hdegoede@redhat.com> - 3.1-7
174- Add timidity++.cfg files tweaked for using FluidR3 with timidity++, written
175  by Saito, one of the TiMidity++ developers
176
177* Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.1-6
178- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
179
180* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.1-5
181- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
182
183* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.1-4
184- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
185
186* Thu Mar 26 2009 Orcan Ogetbil <oget [DOT] fedora [AT] gmail [DOT] com> 3.1-3
187- Add real (non-virtual) Obsoletes: PersonalCopy-Lite-patches < 5
188
189* Mon Mar 23 2009 Orcan Ogetbil <oget [DOT] fedora [AT] gmail [DOT] com> 3.1-2
190- Build lite-patches package by default (remove conditionals)
191- Include only mono banks in the lite-patches package
192- Create a symlink default.sf2 pointing to FluidR3_GM.sf2
193- Add "Provides: soundfont2" to gm and gs packages
194- Add "Provides: soundfont2-default" to gm package
195- Add "Obsoletes/Provides: timidity++-patches (<)= 5" to the lite-patches package
196- Add common subpackage for directory ownership and the doc files
197- Update descriptions
198
199* Sun Feb 01 2009 Orcan Ogetbil <oget [DOT] fedora [AT] gmail [DOT] com> 3.1-1.2
200- Attempt to cut down the size of the (lite-)patches subpackage by extracting only
201  a single layer for each instrument and by removing some banks
202
203* Sat Jan 31 2009 Orcan Ogetbil <oget [DOT] fedora [AT] gmail [DOT] com> 3.1-1.1
204- Mockup for optional GUS-patches subpackages (disabled by default)
205
206* Fri Jan 30 2009 Orcan Ogetbil <oget [DOT] fedora [AT] gmail [DOT] com> 3.1-1
207- Initial Fedora build. SPEC file adapted from PersonalCopy-Lite-soundfont
Note: See TracBrowser for help on using the repository browser.