source: projects/specs/branches/6/f/flim/flim-vl.spec @ 3639

Revision 3639, 6.7 KB checked in by iwaim, 13 years ago (diff)

flim-1.14.9-4

Line 
1%define _noVersionedDependencies        1
2%define emacsen_pkgdir /usr/lib/emacsen-common/packages
3
4
5%define       origver       1.14.9
6%define       origname      flim
7
8Summary:      Library to provide basic features about message for Emacsen
9Summary(ja):  Emacsen 用の message に関する表現形式や符号化のためのライブラリです。
10Name:         %{origname}
11Version:      %{origver}
12Release:      4%{?_dist_release}
13
14Source0:      http://www.kanji.zinbun.kyoto-u.ac.jp/~tomo/comp/emacsen/lisp/flim/flim-1.14/flim-%{origver}.tar.gz
15Source1:      %{origname}-install.sh
16Source2:      %{origname}-remove.sh
17Source3:      %{origname}-init.el
18Patch0:       FLIM-CFG.emacs.patch
19
20License:      1993-1999 Free Software Foundation, Inc., Dan Rich, Morioka Tomohiko, Kobayashi Shuhei
21Group:        Applications/Editors/Emacs
22BuildRoot:    %{_tmppath}/%{name}-%{version}-root
23BuildArch:    noarch
24
25Requires(post,preun): emacsen emacsen-common
26Requires(post): apel
27Requires:     apel
28Obsoletes:    flim-el
29Conflicts:    semi <= 1.14.5-0vl2
30
31Vendor:       Project Vine
32Distribution: Vine Linux
33Packager:     shaolin
34
35
36%description
37FLIM is a library to provide basic features about message
38representation or encoding.
39
40Note: in order to rebuild this SRPM package, you need
41emacsen, emacsen-common and apel installed.
42
43
44%description -l ja
45FLIM は Internet message に関する様々な表現形式や符号化に関する
46基礎的な機能を提供するための汎用部品です.
47
48注意:この SRPM パッケージを rebuild するには、emacsen と emacsen-common
49及び apel がインストールされている必要があります.
50
51
52%prep
53
54rm -rf ${RPM_BUILD_DIR}/%{origname}-%{origver}
55
56
57%setup  -n %{origname}-%{origver}
58
59%patch0 -p1
60
61
62%install
63[ "${RPM_BUILD_ROOT}" != "/" ] && rm -rf ${RPM_BUILD_ROOT}
64[ "${RPM_BUILD_ROOT}" != "/" ] && mkdir -p ${RPM_BUILD_ROOT}
65
66mkdir -p $RPM_BUILD_ROOT/%{_datadir}/emacs/site-lisp/%{origname}
67mkdir -p $RPM_BUILD_ROOT/%{emacsen_pkgdir}/install
68mkdir -p $RPM_BUILD_ROOT/%{emacsen_pkgdir}/remove
69
70#
71# remove unnecessary file
72#
73## upstream is dropped in FLIM-ELS: see ChangeLog file 2002-11-15
74%{__rm} -f mailcap.el
75
76#
77# install el files
78#
79
80cp Makefile FLIM-* *.el %{SOURCE3} \
81   ${RPM_BUILD_ROOT}/usr/share/emacs/site-lisp/%{origname}
82
83#
84# install  script( bytecompile el and install elc , remove )   
85#
86
87%_installemacsenscript %{origname} %{SOURCE1}
88
89%_removeemacsenscript  %{origname} %{SOURCE2}
90
91#
92# install info file
93#
94
95mkdir -p ${RPM_BUILD_ROOT}/usr/info
96
97
98%post
99#
100# bytecompile and install
101#
102
103if [ "$1" = 2 ]; then
104
105%_emacsenPackageRemove %{origname}
106
107fi
108
109
110
111%_addemacsenlist %{origname}
112
113%_emacsenPackageInstall %{origname}
114
115
116%preun
117
118if [ "$1" = 0 ]; then
119
120%_emacsenPackageRemove %{origname}
121
122%_removeemacsenlist %{origname}
123
124fi
125
126
127%triggerpostun -- flim-el
128
129%_emacsenPackageInstall %{origname}
130
131
132%clean
133[ "${RPM_BUILD_ROOT}" != "/" ] && rm -rf ${RPM_BUILD_ROOT}
134
135rm -rf ${RPM_BUILD_DIR}/apel-%{apelver}
136
137
138%files
139%defattr(-,root,root)
140%doc ChangeLog NEWS README* VERSION
141/usr/share/emacs/site-lisp/%{origname}/
142%{emacsen_pkgdir}/install/%{origname}
143%{emacsen_pkgdir}/remove/%{origname}
144
145 
146%changelog
147* Fri Apr 22 2011 IWAI, Masaharu <iwai@alib.jp> 1.14.9-4
148- add Requires: apel
149- add Requires(preun): emacsen emacsen-common: fix 1.14.9-3
150
151* Thu Apr 21 2011 IWAI, Masaharu <iwai@alib.jp> 1.14.9-3
152- drop defining prereq_ge macro
153 - using Requires(post) tag
154
155* Thu Mar  4 2010 IWAI, Masaharu <iwai@alib.jp> 1.14.9-2
156- remove mailcap.el: <BTS:VineLinux:935>
157- update Packager's syntax
158- update description-{en,ja}
159
160* Tue Sep 09 2008 Shu KONNO <owa@bg.wakwak.com> 1.14.9-1vl5
161- applied new versioning policy, spec in utf-8
162- added %%emacsen_pkgdir macro
163
164* Fri Dec  7 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.14.9-0vl1
165- updated to 1.14.9
166
167* Wed Jan 10 2007 Hiroaki Irokawa <irorin@terra.dti.ne.jp> 1.14.8-0vl1
168- updated in sync with 1.14.8 release
169
170* Mon Sep 11 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.14.7-0vl2
171- changed Group to Appliations/Editors/Emacs <BTS:VineLinux:163>
172- s/Copyright/License/
173
174* Mon Dec 13 2004 Hiroaki Irokawa <irorin@terra.dti.ne.jp> 1.14.7-0vl1
175- updated in sync with 1.14.7 release
176
177* Wed Dec 24 2003 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.14.6-0vl1
178- updated in sync with 1.14.6 release
179
180* Mon Jun 09 2003 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.14.5-0vl2
181- increased release number for the new apel release
182
183* Wed May 21 2003 Hiroaki Irokawa <irorin@terra.dti.ne.jp> 1.14.5-0vl1
184- updated in sync with 1.14.5 release
185
186* Mon Jun 03 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.14.4-0vl1
187- updated in sync with 1.14.4 release
188
189* Fri Jan 11 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.14.3-0vl9
190- Obsoletes: flim-el now, instead of Conflicts:
191- added %%triggerpostun -- flim-el
192
193* Fri Dec 28 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.14.3-0vl8
194- package name changed flim-el -> flim again
195- added Source3 for forthcoming site-start mechanism
196
197* Sun Dec 23 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.14.3-0vl7
198- modified Source1 to remove mel-b-ccl.el* if the flavor is xemacs-21.1.x
199  (see http://lists.airs.net/wl/archive/200101/msg00077.html)
200
201* Fri Nov  9 2001 Kazuhisa TAKEI <takei@vinelinux.org>
202- change Patch0( fixed load-path)
203
204* Mon Jul 23 2001 Kazuhisa TAKEI <takei@vinelinux.org>
205- requires: emacsen-common -> prereq
206
207* Wed Jul 18 2001 Kazuhisa TAKEI <takei@vinelinux.org>
208- emacsenize
209
210* Wed Jul 11 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
211- 1.14.3-0vl2
212- back to Requires: emacs = 20.7 -> emacs >= 20.7 (for emacs-beta)
213
214* Wed Jul 11 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
215- 1.14.3-0vl1
216- updated to apel-10.3, flim-1.14.3, semi-1.14.3, emh-1.14.1
217
218* Fri Aug 25 2000 MATSUBAYASHI 'Shaolin' Kohji
219- 1.13.7-8
220- added %define _noVersionedDependencies 1
221
222* Fri Aug 25 2000 MATSUBAYASHI 'Shaolin' Kohji
223- 1.13.7-7
224- modified %files section to handle compressed man page(s)
225
226* Wed May 10 2000 MATSUBAYASHI 'Shaolin' Kohji
227- 1.13.7-6
228- apel updated to 10.2
229
230* Mon Jan 24 2000 MATSUBAYASHI 'Shaolin' Kohji
231- 1.13.7-5
232- added patch (see emacs-mime-ja: 00303) to format texinfo correctly
233
234* Thu Dec 24 1999 MATSUBAYASHI 'Shaolin' Kohji
235- 1.13.7-4
236- updated in sync with apel-10.0 / clime-1.13.6 release
237
238* Wed Dec  1 1999 MATSUBAYASHI 'Shaolin' Kohji
239- 1.13.7-3
240- change Group to Applications/Editors/EmacsLisp
241
242* Mon Nov 29 1999 MATSUBAYASHI 'Shaolin' Kohji
243- 1.13.7-2
244- added patches (see emacs-mime-ja:00183, emacs-mime-ja:00184)
245- now emh-1.10.1 and rmail-mime-1.13.0 are also included
246- documentation files are properly stored under /usr/doc directory
247
248* Wed Nov  3 1999 MATSUBAYASHI 'Shaolin' Kohji
249- 1.13.7-1
250- updated to apel-9.23 / clime-1.13.5 / semi-1.13.7 release
251- added Japanese / English info files to be installed
Note: See TracBrowser for help on using the repository browser.