source: projects/specs/branches/6/f/flac/flac-vl.spec @ 1912

Revision 1912, 8.8 KB checked in by inagaki, 14 years ago (diff)

updated: OpenEXR, openal, exiv2, flac, namazu

Line 
1# set 1 if you want to build input plugin for xmms
2%define build_xmms_plugin 0
3
4%define xmmsinputdir %{_libdir}/xmms/Input
5
6#%%define extraver beta
7
8Name:           flac
9Summary:        FLAC - Free Lossless Audio Codec
10Summary(ja):    FLAC - フリーの可逆音声圧縮コーデック
11Version:        1.2.1
12Release:        2%{?_dist_release}
13
14Group:          Applications/Multimedia
15License:        BSD and GPLv2+
16URL:            http://flac.sourceforge.net/
17
18Source: http://prdownloads.sourceforge.net/flac/%{name}-%{version}%{?extraver:-%extraver}.tar.gz
19Patch1: flac-1.2.1-asm.patch
20Patch2: flac-1.2.1-gcc43.patch
21Patch3: flac-1.2.1-hidesyms.patch
22Patch4: flac-1.2.1-tests.patch
23Patch5: flac-1.2.1-cflags.patch
24Patch6: flac-1.2.1-bitreader.patch
25
26Patch10: flac-xmms-euc-jp-ms.patch
27
28BuildRoot: %{_tmppath}/%{name}-%{version}-root
29BuildRequires: libogg-devel
30BuildRequires: automake autoconf libtool gettext-devel
31%ifarch %ix86
32# 2.0 supports symbol visibility
33BuildRequires:  nasm >= 2.0
34%endif
35
36Vendor:         Project Vine
37Distribution:   Vine Linux
38
39%description
40FLAC stands for Free Lossless Audio Codec. Grossly oversimplified, FLAC is
41similar to MP3, but lossless.
42
43The FLAC project consists of:
44
45  * the stream format
46  * libFLAC  - reference encoders and decoders in library form
47  * flac     - a command-line program to encode and decode FLAC files
48  * metaflac - a command-line metadata editor for FLAC files
49#  * input plugins for various music players (the xmms plugin is in a xmms-
50#    flac package)
51
52%description -l ja
53FLAC (Free Lossless Audio Codec) はフリーの可逆音声圧縮コーデックです。
54MP3 に似ていますが、音質が劣化しません。
55
56FLAC プロジェクトは以下により構成されています。
57
58  * ストリーム形式
59  * libFLAC  - リファレンスエンコーダ/デコーダを実装するライブラリ
60  * flac     - FLAC ファイルのエンコード/デコードに使用するコマンドライン版
61               プログラム。
62  * metaflac - FLAC ファイルのコマンドライン版メタデータエディタ
63#  * 各種音楽再生プログラム用入力プラグイン (XMMS プラグインは xmms-flac パッ
64#    ケージに含まれます)
65
66%package devel
67Summary:        Development libraries and header files from FLAC
68Summary(ja):    FLAC アプリケーション開発用ライブラリ及びヘッダファイル
69Group:          Development/Libraries
70Requires:       %{name} = %{version}
71Requires:       pkgconfig
72
73%description devel
74This package contains all the files needed to develop applications that
75will use the Free Lossless Audio Codec (FLAC).
76
77%description -l ja devel
78このパッケージには FLAC (Free Lossless Audio Codec) を扱うアプリケーションを
79開発するために必要なライブラリ及びヘッダファイルが含まれています。
80
81%if %{build_xmms_plugin}
82%package -n xmms-flac
83Summary:        X MultiMedia System plugin to play FLAC files
84Summary(ja):    FLAC ファイルを再生するための XMMS プラグイン
85Group:          Applications/Multimedia
86Requires:       xmms, %{name} = %{version}
87BuildRequires:  xmms-devel >= 0.9.5.1, gtk+-devel
88
89%description -n xmms-flac
90An input plugin that enables playback of FLAC files in xmms.
91
92%description -l ja -n xmms-flac
93XMMS で FLAC ファイル (*.flac) を再生するための入力プラグインです。
94%endif
95
96
97%prep
98%define srcver %{version}%{?extraver:-%extraver}
99
100%setup -q -n %{name}-%{srcver}
101%patch1 -p1 -b .asm
102%patch2 -p1 -b .gcc43
103%patch3 -p1 -b .hidesyms
104# reduce number of tests
105%patch4 -p1 -b .tests
106%patch5 -p1 -b .cflags
107%patch6 -p0 -b .bitreader
108
109%if %{build_xmms_plugin}
110%patch10 -p1 -b .euc-jp-ms
111%endif
112
113%build
114./autogen.sh -V
115
116%configure \
117    --disable-static \
118%if !%{build_xmms_plugin}
119    --disable-xmms-plugin \
120%endif
121%ifarch ppc
122    --disable-asm-optimizations \
123%endif
124    --disable-thorough-tests
125
126%__make %{?_smp_mflags}
127
128%install
129%__rm -rf %{buildroot}
130%makeinstall \
131%if %{build_xmms_plugin}
132    xmmsinputplugindir=%{buildroot}%{xmmsinputdir}
133%endif
134
135# remove unneeded files
136%{_bindir}/find %{buildroot} -name "*.la" -exec %__rm -f "{}" \;
137%{_bindir}/find doc/ -name "Makefile*" -exec %__rm -f "{}" \;
138
139%check
140make -C test check &> /dev/null
141
142%clean
143%__rm -rf %{buildroot}
144
145%post -p %{_syssbindir}/ldconfig
146
147%postun -p %{_syssbindir}/ldconfig
148
149%files
150%defattr(-,root,root)
151%doc AUTHORS COPYING.* README
152%{_bindir}/*
153%{_libdir}/*.so.*
154%{_mandir}/*/*
155
156%files devel
157%defattr(-,root,root)
158%doc doc/html COPYING.*
159%{_includedir}/*
160%{_libdir}/*.so
161%{_libdir}/pkgconfig/*.pc
162%{_datadir}/aclocal/*.m4
163
164%if %{build_xmms_plugin}
165%files -n xmms-flac
166%defattr(-,root,root)
167%{xmmsinputdir}/*.so
168%endif
169
170
171%changelog
172* Sun Sep 26 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.1-2
173- rebuilt with rpm-4.8.1 for pkg-config
174- added Patch1-6 from Fedora
175
176* Sun Jul 21 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.1-1
177- applied new versioning policy
178- spec in UTF-8
179
180* Sat Sep 22 2007 KAZUKI SHIMURA <ksh753@y5.dion.ne.jp> 1.2.1-0vl1
181- new upstream release
182- drop bmp-plugin.patch (patch1)
183- disable xmms plugin
184
185* Sat Aug 18 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.0-0vl1
186- new upsteram release
187- dropped Patch2 (merged into upstream)
188- do not build beepmp plugin
189
190* Sat May 12 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.1.2-0vl7
191- rebuilt with new toolchain
192
193* Sun Oct 29 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.2-0vl6
194- add '--disable-static' option to %%configure
195- remove *.la
196
197* Wed Jul 26 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.2-0vl5
198- rebuild
199
200* Mon Mar 27 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.1.2-0vl4
201- --disable-asm-optimizations on ppc
202
203* Thu Feb 02 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.2-0vl3
204- rebuild
205
206* Wed Feb 09 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.2-0vl2
207- initialize flac_cfg.stream with NULL to avoid crashing (patch2)
208
209* Sun Feb 06 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.2-0vl1
210- upstream release
211- update bmp-plugin.patch
212
213* Thu Feb 03 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.2-0vl0.0beta
214- upstream release
215- update bmp-plugin.patch
216
217* Fri Jan 14 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.1-0vl5
218- fix typo
219
220* Sat Dec 18 2004 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.1-0vl4
221- move html docs to devel package
222
223* Wed Dec 01 2004 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.1-0vl3
224- add input plugin for beepmp based on for xmms (patch1)
225  - BuildRequires: beepmp-devel >= 0.9.7
226- define build_*_plugin macros to build input plugin sub-packages
227- update description
228
229* Thu Nov 04 2004 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.1-0vl2
230- drop BuildRequires: zlib-devel (was required to build with id3lib)
231
232* Fri Oct 01 2004 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.1-0vl1
233- upstream release
234- drop (Build)Requires: id3lib(-devel)
235
236* Sun Aug 01 2004 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.1-0vl0.1
237- 1.1.1-beta1
238- add BuildRequires: gtk+-devel, zlib-devel
239
240* Mon May 03 2004 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.0-0vl3
241- xmms-flac
242  - enable to convert charset from/to EUC-JP-MS (Patch0)
243  - Requires: glibc >= 2.3.3
244
245* Tue Apr 20 2004 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.0-0vl2
246- fix docs
247
248* Thu Apr 08 2004 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.0-0vl1
249- first build for Vine Linux
250
251* Mon Mar 31 2003 Matthias Saou <matthias.saou@est.une.marmotte.net>
252- Rebuilt for Red Hat Linux 9.
253- Exclude .la files.
254- Updated description.
255
256* Tue Mar 11 2003 Matthias Saou <matthias.saou@est.une.marmotte.net>
257- Fix nasm dep to be only for ix86.
258
259* Mon Jan 27 2003 Matthias Saou <matthias.saou@est.une.marmotte.net>
260- Update to 1.1.0.
261
262* Sun Jan  5 2003 Matthias Saou <matthias.saou@est.une.marmotte.net>
263- Rebuilt against the latest id3lib for the xmms plugin.
264
265* Thu Oct 10 2002 Matthias Saou <matthias.saou@est.une.marmotte.net>
266- Fixed location of include files, doh!
267
268* Sat Sep 28 2002 Matthias Saou <matthias.saou@est.une.marmotte.net>
269- Rebuilt for Red Hat Linux 8.0.
270
271* Thu Sep 25 2002 Matthias Saou <matthias.saou@est.une.marmotte.net>
272- Update to 1.0.4.
273- Removed obsolete build patch, the xmms plugin builds cleanly at last!
274
275* Thu Jul  4 2002 Matthias Saou <matthias.saou@est.une.marmotte.net>
276- Update to 1.0.3.
277
278* Tue Apr 23 2002 Daniel Resare <noa@resare.com>
279- Fixed plugin build when flac is not already installed
280
281* Mon Apr  8 2002 Matthias Saou <matthias.saou@est.une.marmotte.net>
282- Replaced the hard-coded xmms input path with an expansion.
283- Fixed spec (License tag and redundant Group for devel package).
284- Fixed defattr for the xmms plugin.
285
286* Sat Apr  6 2002 Daniel Resare <noa@resare.com>
287- Update to 1.0.2.
288- Splitted out xmms plugin to a separate subpackage.
289
290* Tue Nov 20 2001 Matthias Saou <matthias.saou@est.une.marmotte.net>
291- Update to 1.0.1.
292
293* Sun Oct 21 2001 Matthias Saou <matthias.saou@est.une.marmotte.net>
294- Rebuilt for Red Hat 7.2 and added xmms dependency.
295
296* Thu Aug 16 2001 Matthias Saou <matthias.saou@est.une.marmotte.net>
297- Initial RPM release.
298- You cannot rebuild this SRPM easily if you want the xmms plugin.
299
Note: See TracBrowser for help on using the repository browser.