source: projects/specs/branches/6/f/flac/flac-vl.spec @ 9194

Revision 9194, 9.1 KB checked in by iwamoto, 9 years ago (diff)

flac: fix CVE-2014-8962, CVE-2014-9028

Line 
1# set 1 if you want to build input plugin for xmms
2%define build_xmms_plugin 0
3
4%define xmmsinputdir %{_libdir}/xmms/Input
5
6#%%define extraver beta
7
8Name:           flac
9Summary:        FLAC - Free Lossless Audio Codec
10Summary(ja):    FLAC - フリーの可逆音声圧縮コーデック
11Version:        1.2.1
12Release:        3%{?_dist_release}
13
14Group:          Applications/Multimedia
15License:        BSD and GPLv2+
16URL:            http://flac.sourceforge.net/
17
18Source: http://prdownloads.sourceforge.net/flac/%{name}-%{version}%{?extraver:-%extraver}.tar.gz
19Patch1: flac-1.2.1-asm.patch
20Patch2: flac-1.2.1-gcc43.patch
21Patch3: flac-1.2.1-hidesyms.patch
22Patch4: flac-1.2.1-tests.patch
23Patch5: flac-1.2.1-cflags.patch
24Patch6: flac-1.2.1-bitreader.patch
25Patch10: flac-xmms-euc-jp-ms.patch
26
27# security
28Patch100: flac-1.2.1_CVE-2014-8962.patch
29Patch110: flac-1.2.1_CVE-2014-9028.patch
30
31BuildRoot: %{_tmppath}/%{name}-%{version}-root
32BuildRequires: libogg-devel
33BuildRequires: automake autoconf libtool gettext-devel
34%ifarch %ix86
35# 2.0 supports symbol visibility
36BuildRequires:  nasm >= 2.0
37%endif
38
39Vendor:         Project Vine
40Distribution:   Vine Linux
41
42%description
43FLAC stands for Free Lossless Audio Codec. Grossly oversimplified, FLAC is
44similar to MP3, but lossless.
45
46The FLAC project consists of:
47
48  * the stream format
49  * libFLAC  - reference encoders and decoders in library form
50  * flac     - a command-line program to encode and decode FLAC files
51  * metaflac - a command-line metadata editor for FLAC files
52#  * input plugins for various music players (the xmms plugin is in a xmms-
53#    flac package)
54
55%description -l ja
56FLAC (Free Lossless Audio Codec) はフリーの可逆音声圧縮コーデックです。
57MP3 に似ていますが、音質が劣化しません。
58
59FLAC プロジェクトは以下により構成されています。
60
61  * ストリーム形式
62  * libFLAC  - リファレンスエンコーダ/デコーダを実装するライブラリ
63  * flac     - FLAC ファイルのエンコード/デコードに使用するコマンドライン版
64               プログラム。
65  * metaflac - FLAC ファイルのコマンドライン版メタデータエディタ
66#  * 各種音楽再生プログラム用入力プラグイン (XMMS プラグインは xmms-flac パッ
67#    ケージに含まれます)
68
69%package devel
70Summary:        Development libraries and header files from FLAC
71Summary(ja):    FLAC アプリケーション開発用ライブラリ及びヘッダファイル
72Group:          Development/Libraries
73Requires:       %{name} = %{version}
74Requires:       pkgconfig
75
76%description devel
77This package contains all the files needed to develop applications that
78will use the Free Lossless Audio Codec (FLAC).
79
80%description -l ja devel
81このパッケージには FLAC (Free Lossless Audio Codec) を扱うアプリケーションを
82開発するために必要なライブラリ及びヘッダファイルが含まれています。
83
84%if %{build_xmms_plugin}
85%package -n xmms-flac
86Summary:        X MultiMedia System plugin to play FLAC files
87Summary(ja):    FLAC ファイルを再生するための XMMS プラグイン
88Group:          Applications/Multimedia
89Requires:       xmms, %{name} = %{version}
90BuildRequires:  xmms-devel >= 0.9.5.1, gtk+-devel
91
92%description -n xmms-flac
93An input plugin that enables playback of FLAC files in xmms.
94
95%description -l ja -n xmms-flac
96XMMS で FLAC ファイル (*.flac) を再生するための入力プラグインです。
97%endif
98
99
100%prep
101%define srcver %{version}%{?extraver:-%extraver}
102
103%setup -q -n %{name}-%{srcver}
104%patch1 -p1 -b .asm
105%patch2 -p1 -b .gcc43
106%patch3 -p1 -b .hidesyms
107# reduce number of tests
108%patch4 -p1 -b .tests
109%patch5 -p1 -b .cflags
110%patch6 -p0 -b .bitreader
111
112%if %{build_xmms_plugin}
113%patch10 -p1 -b .euc-jp-ms
114%endif
115
116# security
117%patch100 -p1 -b .CVE-2014-8962
118%patch110 -p1 -b .CVE-2014-9028
119
120%build
121./autogen.sh -V
122
123%configure \
124    --disable-static \
125%if !%{build_xmms_plugin}
126    --disable-xmms-plugin \
127%endif
128%ifarch ppc
129    --disable-asm-optimizations \
130%endif
131    --disable-thorough-tests
132
133%__make %{?_smp_mflags}
134
135%install
136%__rm -rf %{buildroot}
137%makeinstall \
138%if %{build_xmms_plugin}
139    xmmsinputplugindir=%{buildroot}%{xmmsinputdir}
140%endif
141
142# remove unneeded files
143%{_bindir}/find %{buildroot} -name "*.la" -exec %__rm -f "{}" \;
144%{_bindir}/find doc/ -name "Makefile*" -exec %__rm -f "{}" \;
145
146%check
147make -C test check &> /dev/null
148
149%clean
150%__rm -rf %{buildroot}
151
152%post -p %{_syssbindir}/ldconfig
153
154%postun -p %{_syssbindir}/ldconfig
155
156%files
157%defattr(-,root,root)
158%doc AUTHORS COPYING.* README
159%{_bindir}/*
160%{_libdir}/*.so.*
161%{_mandir}/*/*
162
163%files devel
164%defattr(-,root,root)
165%doc doc/html COPYING.*
166%{_includedir}/*
167%{_libdir}/*.so
168%{_libdir}/pkgconfig/*.pc
169%{_datadir}/aclocal/*.m4
170
171%if %{build_xmms_plugin}
172%files -n xmms-flac
173%defattr(-,root,root)
174%{xmmsinputdir}/*.so
175%endif
176
177
178%changelog
179* Fri Dec 26 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.2.1-3
180- add patch100 for fix CVE-2014-8962
181- add patch110 for fix CVE-2014-9028
182
183* Sun Sep 26 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.1-2
184- rebuilt with rpm-4.8.1 for pkg-config
185- added Patch1-6 from Fedora
186
187* Sun Jul 21 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.1-1
188- applied new versioning policy
189- spec in UTF-8
190
191* Sat Sep 22 2007 KAZUKI SHIMURA <ksh753@y5.dion.ne.jp> 1.2.1-0vl1
192- new upstream release
193- drop bmp-plugin.patch (patch1)
194- disable xmms plugin
195
196* Sat Aug 18 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.0-0vl1
197- new upsteram release
198- dropped Patch2 (merged into upstream)
199- do not build beepmp plugin
200
201* Sat May 12 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.1.2-0vl7
202- rebuilt with new toolchain
203
204* Sun Oct 29 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.2-0vl6
205- add '--disable-static' option to %%configure
206- remove *.la
207
208* Wed Jul 26 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.2-0vl5
209- rebuild
210
211* Mon Mar 27 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.1.2-0vl4
212- --disable-asm-optimizations on ppc
213
214* Thu Feb 02 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.2-0vl3
215- rebuild
216
217* Wed Feb 09 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.2-0vl2
218- initialize flac_cfg.stream with NULL to avoid crashing (patch2)
219
220* Sun Feb 06 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.2-0vl1
221- upstream release
222- update bmp-plugin.patch
223
224* Thu Feb 03 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.2-0vl0.0beta
225- upstream release
226- update bmp-plugin.patch
227
228* Fri Jan 14 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.1-0vl5
229- fix typo
230
231* Sat Dec 18 2004 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.1-0vl4
232- move html docs to devel package
233
234* Wed Dec 01 2004 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.1-0vl3
235- add input plugin for beepmp based on for xmms (patch1)
236  - BuildRequires: beepmp-devel >= 0.9.7
237- define build_*_plugin macros to build input plugin sub-packages
238- update description
239
240* Thu Nov 04 2004 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.1-0vl2
241- drop BuildRequires: zlib-devel (was required to build with id3lib)
242
243* Fri Oct 01 2004 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.1-0vl1
244- upstream release
245- drop (Build)Requires: id3lib(-devel)
246
247* Sun Aug 01 2004 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.1-0vl0.1
248- 1.1.1-beta1
249- add BuildRequires: gtk+-devel, zlib-devel
250
251* Mon May 03 2004 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.0-0vl3
252- xmms-flac
253  - enable to convert charset from/to EUC-JP-MS (Patch0)
254  - Requires: glibc >= 2.3.3
255
256* Tue Apr 20 2004 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.0-0vl2
257- fix docs
258
259* Thu Apr 08 2004 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.0-0vl1
260- first build for Vine Linux
261
262* Mon Mar 31 2003 Matthias Saou <matthias.saou@est.une.marmotte.net>
263- Rebuilt for Red Hat Linux 9.
264- Exclude .la files.
265- Updated description.
266
267* Tue Mar 11 2003 Matthias Saou <matthias.saou@est.une.marmotte.net>
268- Fix nasm dep to be only for ix86.
269
270* Mon Jan 27 2003 Matthias Saou <matthias.saou@est.une.marmotte.net>
271- Update to 1.1.0.
272
273* Sun Jan  5 2003 Matthias Saou <matthias.saou@est.une.marmotte.net>
274- Rebuilt against the latest id3lib for the xmms plugin.
275
276* Thu Oct 10 2002 Matthias Saou <matthias.saou@est.une.marmotte.net>
277- Fixed location of include files, doh!
278
279* Sat Sep 28 2002 Matthias Saou <matthias.saou@est.une.marmotte.net>
280- Rebuilt for Red Hat Linux 8.0.
281
282* Thu Sep 25 2002 Matthias Saou <matthias.saou@est.une.marmotte.net>
283- Update to 1.0.4.
284- Removed obsolete build patch, the xmms plugin builds cleanly at last!
285
286* Thu Jul  4 2002 Matthias Saou <matthias.saou@est.une.marmotte.net>
287- Update to 1.0.3.
288
289* Tue Apr 23 2002 Daniel Resare <noa@resare.com>
290- Fixed plugin build when flac is not already installed
291
292* Mon Apr  8 2002 Matthias Saou <matthias.saou@est.une.marmotte.net>
293- Replaced the hard-coded xmms input path with an expansion.
294- Fixed spec (License tag and redundant Group for devel package).
295- Fixed defattr for the xmms plugin.
296
297* Sat Apr  6 2002 Daniel Resare <noa@resare.com>
298- Update to 1.0.2.
299- Splitted out xmms plugin to a separate subpackage.
300
301* Tue Nov 20 2001 Matthias Saou <matthias.saou@est.une.marmotte.net>
302- Update to 1.0.1.
303
304* Sun Oct 21 2001 Matthias Saou <matthias.saou@est.une.marmotte.net>
305- Rebuilt for Red Hat 7.2 and added xmms dependency.
306
307* Thu Aug 16 2001 Matthias Saou <matthias.saou@est.une.marmotte.net>
308- Initial RPM release.
309- You cannot rebuild this SRPM easily if you want the xmms plugin.
310
Note: See TracBrowser for help on using the repository browser.