source: projects/specs/branches/6/f/firstboot/firstboot-vl.spec @ 3656

Revision 3656, 29.9 KB checked in by daisuke, 13 years ago (diff)

firstboot: rebuild for Vine6

Line 
1Summary: Initial system configuration utility
2Summary(ja): 初期システム設定ユーティリティ
3
4Name: firstboot
5Version: 1.4.27.3
6Release: 2%{?_dist_release}
7URL: http://fedoraproject.org/wiki/FirstBoot
8License: GPLv2+
9ExclusiveOS: Linux
10Group: System Environment/Base
11Source0: %{name}-%{version}.tar.bz2
12Patch1: firstboot-vine.patch
13
14BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
15BuildArch: noarch
16Prereq: chkconfig
17BuildRequires: gettext
18Requires: pygtk2
19Requires: metacity
20Requires: rhpl
21Requires: rhpxl
22Requires: system-config-display
23#Requires: system-config-language
24#Requires: system-config-soundcard
25Requires: system-config-securitylevel
26Requires: system-config-network
27Requires: system-config-users
28Requires: system-config-date
29Requires: system-config-keyboard
30Requires: authconfig-gtk
31Requires: libuser
32#Requires: system-logos
33Requires: firstboot-tui = %{version}
34ExcludeArch: s390 s390x ppc64
35
36%description
37The firstboot utility runs after installation.  It guides the
38user through a series of steps that allows for easier
39configuration of the machine.
40
41%package tui
42Summary: A text interface for firstboot
43Summary(ja): fistboot のテキストインタフェース
44Group: System Environment/Base
45Requires(post): chkconfig, /etc/init.d
46BuildRequires: gettext
47Requires: python
48Requires: usermode
49Requires: rhpl
50Requires: system-config-securitylevel-tui
51Requires: system-config-network-tui
52Requires: ntsysv
53Requires: authconfig
54
55%description tui
56firstboot-tui is a text interface for initial system configuration.
57
58%prep
59%setup -q
60%patch1 -p1
61
62sed -i -e 's|/usr/bin/python2|/usr/bin/python|g' \
63    src/firstboot src/xfirstboot.py src/firstboot.py
64
65%build
66make
67
68%install
69make INSTROOT=$RPM_BUILD_ROOT install
70
71mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig
72echo "RUN_FIRSTBOOT=NO" > $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/firstboot
73
74%find_lang %name
75
76%clean
77rm -rf $RPM_BUILD_ROOT
78
79%post tui
80if ! [ -f /etc/sysconfig/firstboot ]
81then
82  chkconfig --add firstboot
83fi
84
85%preun
86if [ $1 = 0 ]; then
87  rm -rf /usr/share/firstboot/*.pyc
88  rm -rf /usr/share/firstboot/modules/*.pyc
89fi
90
91%preun tui
92if [ $1 = 0 ]; then
93  chkconfig --del firstboot
94fi
95
96%files -f %{name}.lang
97%defattr(-,root,root)
98%config %{_sysconfdir}/sysconfig/firstboot
99%dir %{_datadir}/firstboot/
100%dir %{_datadir}/firstboot/modules/
101%dir %{_datadir}/firstboot/pixmaps/
102%{_datadir}/firstboot/exceptionWindow.py*
103%{_datadir}/firstboot/firstbootWindow.py*
104%{_datadir}/firstboot/firstboot_module_window.py*
105%{_datadir}/firstboot/xfirstboot.py*
106%{_datadir}/firstboot/modules/*
107%{_datadir}/firstboot/pixmaps/*
108
109%files -f %{name}.lang tui
110%defattr(-,root,root)
111%config %{_sysconfdir}/rc.d/init.d/firstboot
112%dir %{_datadir}/firstboot/
113%{_sbindir}/firstboot
114%{_datadir}/firstboot/constants_text.py*
115%{_datadir}/firstboot/eula_strings.py*
116%{_datadir}/firstboot/firstboot.py*
117%{_datadir}/firstboot/firstbootBackend.py*
118%{_datadir}/firstboot/functions.py*
119%{_datadir}/firstboot/textWindow.py*
120
121
122%changelog
123* Sat Apr 23 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.27.3-2
124- rebuild for Vine 6
125
126* Thu Oct 02 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.27.3-1
127- initial build for Vine Linux
128
129* Fri Nov  9 2007 Karanbir Singh <kbsingh@centos.org> 1.4.27.3-1.el5.centos
130- Roll in CentOS Branding
131
132* Thu Jun 28 2007 Chris Lumens <clumens@redhat.com> 1.4.27.3-1
133- Iterate over all possible CD drives on the additional CD module (#231612).
134- Enable fullscreen mode again; scale sidebar graphics (#211198).
135
136* Mon Jan 15 2007 Chris Lumens <clumens@redhat.com> 1.4.27.2-1
137- Pull in updated gu_IN translation (#222628).
138- Merge in additional CDs patch so it doesn't get dropped.
139
140* Mon Dec 18 2006 Chris Lumens <clumens@redhat.com> 1.4.27.1-1
141- Allow running on s390 and ppc64 under reconfig mode (#217921).
142
143* Wed Dec 13 2006 Chris Lumens <clumens@redhat.com> 1.4.27-1
144- More translation updates (#212958, #198872).
145
146* Thu Nov 30 2006 Chris Lumens <clumens@redhat.com> 1.4.26-1
147- Update translations (#198872).
148
149* Thu Oct 26 2006 Chris Lumens <clumens@redhat.com> 1.4.25-1
150- Require matching versions of firstboot and firstboot-tui.
151- Fix language in non-rhgb graphical case (notting).
152
153* Wed Oct 25 2006 Chris Lumens <clumens@redhat.com> 1.4.24-1
154- Pick up new si_LK translation (#200532).
155- Support noSidebar value for modules (#210697).
156- Fix release number.
157- Do start up in English on CJKI installs in text mode (#211936).
158
159* Mon Oct 02 2006 Chris Lumens <clumens@redhat.com> - 1.4.23-1
160- runPriority can now be a float.
161- Pick up new translations (#208867).
162- Set window to 800x600 instead of fullscreening (#208331, #208620).
163
164* Wed Sep 20 2006 Chris Lumens <clumens@redhat.com> 1.4.22-1
165- Add help output to /etc/init.d/firstboot (#207043).
166- Fix a window manager warning (#206369).
167- Don't start up in English on CJKI installs (#206600).
168
169* Fri Sep 15 2006 Chris Lumens <clumens@redhat.com> 1.4.21-1
170- Use system-config-network-tui instead of netconfig in the text
171  interface.
172- Remove unused methods in the modules.
173
174* Tue Sep 12 2006 Chris Lumens <clumens@redhat.com> 1.4.20-1
175- Don't specify a default color depth.
176- Pull in new translations (#199090).
177
178* Tue Aug 08 2006 Chris Lumens <clumens@redhat.com> 1.4.19-1
179- Don't fill in the Create User UI with whatever user happens to have
180  UID 500 (#200695).
181
182* Wed Aug 02 2006 Chris Lumens <clumens@redhat.com> 1.4.18-1
183- Remove ddc probe support that rhpxl no longer provides.
184
185* Fri Jul 28 2006 Chris Lumens <clumens@redhat.com> 1.4.17-1
186- Pick up new or_IN translation (#200210).
187- Use new rhpxl X startup code.
188
189* Mon Jul 24 2006 Chris Lumens <clumens@redhat.com> 1.4.16-1
190- Fix system-config-soundcard API change.
191- Make sure firstboot starts after HAL (#199899).
192
193* Thu Jul 20 2006 Chris Lumens <clumens@redhat.com> 1.4.15-1
194- Really disable the display module.
195
196* Wed Jul 19 2006 Chris Lumens <clumens@redhat.com> 1.4.14-1
197- Disable the display module for now.
198
199* Fri Jul 10 2006 Chris Lumens <clumens@redhat.com> 1.4.13-1
200- Better fix for the no display hardware case (#192808).
201
202* Wed Jun 21 2006 Chris Lumens <clumens@redhat.com> 1.4.12-1
203- Update translation files (#195010).
204- Fix traceback on exiting (#196128).
205
206* Mon Jun 12 2006 Chris Lumens <clumens@redhat.com> 1.4.11-1
207- Don't traceback on the display module if there's no display hardware
208  (#142522).
209- Don't forget about reconfig mode if the timer expires (#170609).
210
211* Fri May 26 2006 Chris Lumens <clumens@redhat.com> 1.4.10-1
212- Fix reconfig mode.
213
214* Fri May 19 2006 Chris Lumens <clumens@redhat.com> 1.4.9-1
215- Make /etc/modprobe.conf reading more robust (#191819).
216- Don't try to call readHTML from anaconda's ICS.
217
218* Mon May 15 2006 Chris Lumens <clumens@redhat.com> 1.4.8-2
219- Require system-logos instead of an OS-specific package (#191407).
220
221* Tue Apr 04 2006 Chris Lumens <clumens@redhat.com> 1.4.8-1
222- Allow firstboot to run in kadischi (#186870).
223- Updated for rhpxl changes.
224
225* Mon Mar 20 2006 Martin Stransky <stransky@redhat.com> 1.4.7-1
226- replaced "Play test button" by "Play" button for s-c-s (#185931)
227- Fix soundcard string (#177425).
228- Fix label inconsistency on welcome screen (#183899).
229- Rework "System User" string (#177940).
230- Don't create a user if a homedir with that username already exists
231  (#143150).
232
233* Fri Mar 03 2006 Chris Lumens <clumens@redhat.com> 1.4.6-1
234- Revert UI changes that broke s-c-keyboard (#183718).
235
236* Wed Mar 01 2006 Chris Lumens <clumens@redhat.com> 1.4.5-1
237- Run if RUN_FIRSTBOOT != "NO" (#180520).
238- Don't let dialog windows hide behind the main window.
239- Remove timeout waiting for server to start.
240
241* Wed Feb 08 2006 Chris Lumens <clumens@redhat.com> 1.4.4-1
242- Get rid of chkconfig --off calls.
243- Smarter checking for if we need to reboot or not.
244
245* Mon Feb 06 2006 Chris Lumens <clumens@redhat.com> 1.4.3-1
246- Tweak firstboot-tui requires to not require X (#180046).
247- Wrap left side labels if they're too long.
248- Remove "Click to Finish" module (#178109).
249- Try to prevent running in runlevel 3 if we failed in runlevel 5
250  (#145169).
251
252* Fri Jan 27 2006 Chris Lumens <clumens@redhat.com> 1.4.2-1
253- Layout cleanups and simplification.
254- Use GTK styles to display the new artwork in non-debug mode.
255
256* Wed Jan 25 2006 Chris Lumens <clumens@redhat.com> 1.4.1-1
257- Fix debug mode.
258- Use the new bubbly artwork (#178106).
259
260* Thu Jan 19 2006 Chris Lumens <clumens@redhat.com> 1.4.0-1
261- Split into separate packages for X and no X (#178216).
262
263* Mon Jan 09 2006 Chris Lumens <clumens@redhat.com> 1.3.57-1
264- Use scdMainWindow instead of mainWindow to fix random python import
265  tracebacks.
266
267* Mon Jan 09 2006 Chris Lumens <clumens@redhat.com> 1.3.56-2
268- Remove dependancy on system-config-packages.
269
270* Thu Jan 09 2006 Chris Lumens <clumens@redhat.com> 1.3.56-1
271- Increase timeout on waiting for X to start (#176782).
272- Update translations.
273
274* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
275- rebuilt
276
277* Thu Dec 08 2005 Chris Lumens <clumens@redhat.com> 1.3.55-1
278- Fix grammar problems (#143953).
279- Fix traceback on user screen (#175227).
280
281* Wed Nov 30 2005 Chris Lumens <clumens@redhat.com> 1.3.54-1
282- Use system-config-users for user/group/password validation (#174255).
283
284* Wed Nov 16 2005 Chris Lumens <clumens@redhat.com> 1.3.53-1
285- Disable Additional CDs module for now.
286
287* Fri Oct 28 2005 Chris Lumens <clumens@redhat.com> 1.3.52-1
288- Set a timeout on waiting for the window manager to start.
289- Correct ps output.
290- Move keyboard initialization to after the modules have been loaded
291  (#133074, #157870).
292
293* Mon Oct 17 2005 Chris Lumens <clumens@redhat.com> 1.3.51-1
294- Fix whrandom deprecation warnings.
295- Fix render_to_drawable deprecation warnings.
296- Change "Next" button on last page to "Finish".
297
298* Tue Oct 11 2005 Chris Lumens <clumens@redhat.com> 1.3.50-1
299- Decrease blank space on finished screen (#144496).
300- Fix import of rhpxl.videocard.
301
302* Fri Oct 07 2005 Chris Lumens <clumens@redhat.com> 1.3.49-1
303- Use rhpxl instead of rhpl for X stuff.
304
305* Fri Sep 23 2005 Chris Lumens <clumens@redhat.com> 1.3.48-1
306- Fix autoscreenshot test (#169102).
307- Allow unicode letters in full user names (#169043).
308
309* Thu Sep 15 2005 Jeremy Katz <katzj@redhat.com> - 1.3.47-2
310- exclude arch ppc64 to stop from being included in ppc64 compose where
311  we don't have X
312
313* Thu Sep 15 2005 Chris Lumens <clumens@redhat.com> 1.3.47-1
314- Moved firstboot_gui_window here from rhpl and renamed it to
315  firstboot_module_window.
316- Converted /usr/sbin/firstboot into a python script.
317- Converted the rest of firstboot into a module suitable for importing.
318
319* Tue Sep 13 2005 Chris Lumens <clumens@redhat.com> 1.3.46-1
320- Remove dependancy on up2date (#167663).
321- Use rhpl's X startup code instead of using something different.
322
323* Wed Aug 17 2005 Chris Lumens <clumens@redhat.com> 1.3.45-1
324- Don't fail if no ifcfg script exists for a NIC found in modprobe.conf
325  (#164874).
326- Restore focus after closing dialogs (#143388, #143711).
327
328* Tue Aug 02 2005 Chris Lumens <clumens@redhat.com> 1.3.44-1
329- Allow modules to specify that the system should be rebooted after
330  firstboot has run via the needsReboot module attribute.
331- Enable checking for capital letters in usernames again to be consistent
332  with system-config-users (#164852).
333- Use libuser for adding users again (#164160).
334- Rebuilt translations.
335
336* Thu Jul 07 2005 Chris Lumens <clumens@redhat.com> 1.3.43-1
337- Remove dependancy on xsri (#145807).
338- Fix typo in "additional" (#158435).
339- Tabs vs. spaces consistency (#156456).
340- Don't require system-config-display on ppc64.
341
342* Wed May 25 2005 Jeremy Katz <katzj@redhat.com> - 1.3.42-1
343- Stop using deprecated gtk.{TRUE,FALSE} (#153033)
344
345* Tue May 24 2005 Adrian Likins <alikins@redhat.com> - 1.3.41
346- fix #158095 - Subscription Alert (on first login) on non network installs
347
348* Thu May 19 2005 Adrian Likins <alikins@redhat.com> - 1.3.40
349- fix #154606 - First boot displays "please insert the red hat enterprise linux extras disk"
350
351* Fri Dec 14 2004 Adrian Likins <alikins@redhat.com> - 1.3.39-2
352- really fix #138727 (was looking for cdroms in the wrong place)
353
354* Fri Dec 14 2004 Adrian Likins <alikins@redhat.com> - 1.3.38-1
355- fix #138727 (patch from katzj)
356- latest translations
357
358* Fri Nov 12 2004 Adrian Likins <alikins@redhat.com> - 1.3.37-2
359- fix #139060
360
361* Wed Nov 10 2004 Adrian Likins <alikins@redhat.com> - 1.3.35-1
362- fix #137151
363- fix #138541
364
365* Wed Oct 27 2004 Adrian Likins <alikins@redhat.com> - 1.3.34-1
366- add code to detect if a module wants to be skipped
367  (basically, stuff to me not show RHN modules on fedora)
368
369* Mon Oct 18 2004 Adrian Likins <alikins@redhat.com> - 1.3.33-1
370- #129885 (do the right thing on ia64)
371- #129532 (typo in display file location)
372
373* Fri Oct 15 2004 Adrian Likins <alikins@redhat.com> - 1.3.30-1
374- merge some updates from rhel3 branch
375- try enabling tui stuff again
376
377* Tue Oct 5 2004 Adrian Likins <alikins@redhat.com> - 1.3.28-1
378- text changes for #129885
379- get rid of some deprecation warnings
380
381* Tue Sep 28 2004 Nils Philippsen <nphilipp@redhat.com> - 1.3.27-1
382- let timezone only be configured on --reconfig (#133748)
383- require system-config-date >= 1.7.9
384
385* Thu Sep 23 2004 Adrian Likins <alikins@redhat.com> - 1.3.26-1
386- applied patch from #132736
387
388* Tue Sep 14 2004 Adrian Likins <alikins@redhat.com> - 1.3.25-1
389- change finish screen to not show default "success"
390  message if were also showing errors
391- fix forward/back behaviour
392
393* Fri Sep 10 2004 Adrian Likins <alikins@redhat.com> - 1.3.23-1
394- fix for finish screen
395- ignore modules that throw exceptions on import
396  (#129532 and other variations of "firstboot doesnt start)
397* Fri Sep 3 2004 Adrian Likins <alikins@redhat.com> - 1.3.21-1
398- more fixes for #131308
399
400* Wed Sep 1 2004 Adrian Likins <alikins@redhat.com> - 1.3.20-1
401- better fix for #131308 (works now, but needs some
402  screen resizing)
403
404* Tue Aug 31 2004 Adrian Likins <alikins@redhat.com> - 1.3.19-1
405- #131308 (system-config-date changed, working to not
406  traceback, still needs more fixing)
407
408* Thu Jul 15 2004 Adrian Likins <alikins@redhat.com> - 1.3.17-1
409- allow screens to catch a signal when they are shown
410
411* Wed Jun 30 2004 Adrian Likins <alikins@redhat.com> - 1.3.16-1
412- apply patch to allow modules to go forward/back in
413  the module order
414
415* Mon Jun 21 2004 Brent Fox <bfox@redhat.com> - 1.3.15-1
416- apply patch from mikem in bug #121489
417
418* Wed May 12 2004 Elliot Lee <sopwith@redhat.com> 1.3.14-1
419- Fix initscript (#121489)
420
421* Mon May  3 2004 Brent Fox <bfox@redhat.com> 1.3.13-1
422- fix Norwegian translation bug (bug #122206)
423
424* Thu Apr 22 2004 Brent Fox <bfox@redhat.com> 1.3.12-1
425- look for xorg.conf, not XF86Config (bug #121489)
426
427* Thu Apr 15 2004 Brent Fox <bfox@redhat.com> 1.3.11-1
428- fix bug #120669
429
430* Wed Apr  7 2004 Brent Fox <bfox@redhat.com> 1.3.10-2
431- allow for correct text mode button translations (bug #120087)
432
433* Wed Mar 17 2004 Jeremy Katz <katzj@redhat.com> 1.3.10-1
434- fix password to be encrypted properly
435
436* Wed Mar 17 2004 Jeremy Katz <katzj@redhat.com> 1.3.9-1
437- more workarounds for selinux (don't use libuser at all for create_user.py
438  for right now)
439
440* Wed Mar 17 2004 Brent Fox <bfox@redhat.com> 1.3.8-1
441- workaround selinux - patch from jeremy
442
443* Tue Mar  9 2004 Brent Fox <bfox@redhat.com> 1.3.7-2
444- fix typo (bug #117867)
445
446* Mon Mar  8 2004 Brent Fox <bfox@redhat.com> 1.3.7-1
447- drop the verbose print statements
448
449* Thu Mar  4 2004 Brent Fox <bfox@redhat.com> 1.3.6-1
450- only call chkconfig -add if /etc/sysconfig/firstboot does not exist
451
452* Mon Mar  1 2004 Brent Fox <bfox@redhat.com> 1.3.5-2
453- remove Requires on system-config-mouse
454
455* Tue Feb 17 2004 Brent Fox <bfox@redhat.com> 1.3.5-1
456- call self.win.present() to allow initial keyboard input
457
458* Mon Feb 16 2004 Brent Fox <bfox@redhat.com> 1.3.4-1
459- UTF-8ify fr.po
460- make sure the root window stays on the bottom (bug #105631)
461
462* Tue Jan 27 2004 Tim Powers <timp@ragnarok.devel.redhat.com> 1.3.3-3
463- fedora-logos -> redhat-logos since redhat-logos is a virtual
464  provides (used so that we can switch out redhat-logos with
465  fedora-logos easily). Will change to system-logos once the changes
466  have been made.
467
468* Fri Jan 23 2004 Bill Nottingham <notting@redhat.com> 1.3.3-2
469- some more s/redhat/system/ on requires
470
471* Mon Dec  1 2003 Brent Fox <bfox@redhat.com> 1.3.2-2
472- redhat-logos hasn't been renamed to system-logos yet
473
474* Mon Nov 24 2003 Brent Fox <bfox@redhat.com> 1.3.2-1
475- make changes for Python2.3
476
477* Sun Nov 23 2003 Brent Fox <bfox@redhat.com> 1.3.2-1
478- update Requires for system-config name change
479- make changes for Python2.3
480
481* Mon Oct 27 2003 Brent Fox <bfox@redhat.com> 1.3.1-1
482- fix initscript for text mode
483
484* Fri Oct 24 2003 Brent Fox <bfox@redhat.com> 1.3.1-1
485- bump version
486- use CVS head now for Fedora Core 2
487- made firstboot-cambridge branch for Fedora Core 1
488- first stab at text mode
489
490* Wed Oct 15 2003 Brent Fox <bfox@redhat.com> 1.2.4-1
491- pull lightrays.png from a different location
492
493* Wed Oct  8 2003 Brent Fox <bfox@redhat.com> 1.2.3-1
494- override rhgb's background
495
496* Wed Oct  8 2003 Brent Fox <bfox@redhat.com> 1.2.2-1
497- remove up2date module from Fedora
498
499* Mon Sep 22 2003 Brent Fox <bfox@redhat.com> 1.2.1-1
500- remove some items from the additional cd's screen for now
501- remove some references to Red Hat Linux from welcome.py and up2date.py
502
503* Fri Aug 29 2003 Brent Fox <bfox@redhat.com> 1.1.16-2
504- bump relnum and rebuild
505
506* Fri Aug 29 2003 Brent Fox <bfox@redhat.com> 1.1.16-1
507- call authconfig with --firstboot flag correctly (bug #103367)
508
509* Thu Aug 28 2003 Brent Fox <bfox@bfox.devel.redhat.com> 1.1.15-2
510- bump relnum and rebuild
511
512* Thu Aug 28 2003 Brent Fox <bfox@bfox.devel.redhat.com> 1.1.15-1
513- handle network timeouts better in the date.py screen
514
515* Thu Aug 28 2003 Brent Fox <bfox@bfox.devel.redhat.com> 1.1.14-1
516- handle cds without autorun files better in additional_cds.py
517
518* Thu Aug 21 2003 Brent Fox <bfox@redhat.com> 1.1.13-3
519- bump relnum and rebuild
520
521* Thu Aug 21 2003 Brent Fox <bfox@redhat.com> 1.1.13-2
522- bump relnum and rebuild
523
524* Thu Aug 21 2003 Brent Fox <bfox@redhat.com> 1.1.13-1
525- pass --firstboot flag to authconfig-gtk in create_user.py
526
527* Tue Aug 19 2003 Brent Fox <bfox@redhat.com> 1.1.12-2
528- bump relnum and rebuild
529
530* Tue Aug 19 2003 Brent Fox <bfox@redhat.com> 1.1.12-1
531- fix formatting bug in create_user.py
532
533* Fri Aug 15 2003 Brent Fox <bfox@redhat.com> 1.1.11-2
534- bump relnum and rebuild
535
536* Fri Aug 15 2003 Brent Fox <bfox@redhat.com> 1.1.11-1
537- run 'chkconfig --del firstboot' when it's done
538
539* Thu Aug 14 2003 Brent Fox <bfox@redhat.com> 1.1.10-1
540- allow underscores and dashes in usernames (bug #99115)
541
542* Wed Aug 13 2003 Brent Fox <bfox@redhat.com> 1.1.9-1
543- replace BuildRequires on python-tools with gettext
544
545* Thu Jul 31 2003 Brent Fox <bfox@redhat.com> 1.1.8-2
546- bump relnum and rebuild
547
548* Thu Jul 31 2003 Brent Fox <bfox@redhat.com> 1.1.8-1
549- apply patch from hfuchi@redhat.com for Japanese translation
550
551* Thu Jul 31 2003 Brent Fox <bfox@redhat.com> 1.1.7-2
552- bump relnum and rebuild
553
554* Thu Jul 31 2003 Brent Fox <bfox@redhat.com> 1.1.7-1
555- change runPriority in welcome module
556
557* Tue Jul 22 2003 Brent Fox <bfox@redhat.com> 1.1.6-2
558- bump relnum and rebuild
559
560* Tue Jul 22 2003 Brent Fox <bfox@redhat.com> 1.1.6-1
561- resolve conflict between "Next" and "Forward" (bug #100498)
562
563* Fri Jul 18 2003 Brent Fox <bfox@redhat.com> 1.1.5-2
564- bump relnum and rebuild
565
566* Fri Jul 18 2003 Brent Fox <bfox@redhat.com> 1.1.5-1
567- fix conficting nmemonics (bug #99279)
568
569* Wed Jul  2 2003 Brent Fox <bfox@redhat.com> 1.1.4-2
570- bump relnum and rebuild
571
572* Wed Jul  2 2003 Brent Fox <bfox@redhat.com> 1.1.4-1
573- remove unneeded code from the neworking module
574
575* Thu Jun 26 2003 Brent Fox <bfox@redhat.com> 1.1.3-1
576- first stab at getting locale changing working (#91984)
577
578* Thu Jun 19 2003 Brent Fox <bfox@redhat.com> 1.1.2-2
579- bump number and rebuild
580
581* Thu Jun 19 2003 Brent Fox <bfox@redhat.com> 1.1.2-1
582- implement networking screen for reconfig mode (bug #91984)
583
584* Mon Jun 16 2003 Brent Fox <bfox@redhat.com> 1.1.1-2
585- bump number and rebuild
586
587* Mon Jun 16 2003 Brent Fox <bfox@redhat.com> 1.1.1-1
588- create a timezone module (bug #91984)
589
590* Tue Jun 10 2003 Brent Fox <bfox@redhat.com> 1.0.12-1
591- change "Forward" button to "Next"
592
593* Fri May 30 2003 Brent Fox <bfox@redhat.com> 1.0.11-1
594- fix traceback in username verification
595
596* Thu May 29 2003 Brent Fox <bfox@redhat.com> 1.0.10-1
597- updated deprecated function call in functions.py
598- don't grab the whole screen in debug mode
599
600* Thu May 22 2003 Brent Fox <bfox@redhat.com> 1.0.9-1
601- remove explicit vt7 argument to X (bug #87636)
602
603* Thu May 22 2003 Brent Fox <bfox@redhat.com> 1.0.8-1
604- pass rhgb status into firstbootWindow.py
605- don't draw background if rhgb isn't running
606
607* Mon May 19 2003 Brent Fox <bfox@redhat.com> 1.0.7-1
608- check to see if rhgb is running
609- if rhgb is running, start up metacity and merge X resources
610
611* Fri May 16 2003 Brent Fox <bfox@redhat.com> 1.0.6-2
612- Added a mnemonic for network login button (bug #90636)
613- added more mnemonics create_user.py (bug #90865)
614
615* Mon Mar 24 2003 Brent Fox <bfox@redhat.com> 1.0.6-1
616- add a button to create_user.py to launch authconfig-gtk
617
618* Fri Mar  7 2003 Brent Fox <bfox@redhat.com> 1.0.5-13
619- bump rev for 3.0E
620
621* Fri Feb 28 2003 Brent Fox <bfox@redhat.com> 1.0.5-12
622- fix bug #85358
623
624* Tue Feb 25 2003 Jeremy Katz <katzj@redhat.com> 1.0.5-11
625- background image name changed (#85160)
626- don't traceback if background doesn't exist
627
628* Mon Feb 24 2003 Nalin Dahyabhai <nalin@redhat.com> 1.0.5-10
629- compare text to string.whitespace, not whitespace (#85038)
630
631* Mon Feb 24 2003 Brent Fox <bfox@redhat.com> 1.0.5-9
632- apply initscript patch from mikem@redhat.com.  Avoids calling telinit (bug #84848)
633
634* Fri Feb 21 2003 Brent Fox <bfox@redhat.com> 1.0.5-8
635- call RGB_DITHER_MAX (bug #84850)
636
637* Thu Feb 20 2003 Brent Fox <bfox@redhat.com> 1.0.5-7
638- fix traceback in create_users.py (bug #84722)
639
640* Tue Feb 18 2003 Brent Fox <bfox@redhat.com> 1.0.5-6
641- add mnemonics to up2date.py (bug #84487)
642
643* Wed Feb 12 2003 Brent Fox <bfox@redhat.com> 1.0.5-5
644- only launch r-c-xfree86 if in runlevel 3 and XF86Config does not exist (bug #84135)
645
646* Tue Feb 11 2003 Brent Fox <bfox@redhat.com> 1.0.5-4
647- fix bug #84068
648
649* Wed Feb  5 2003 Brent Fox <bfox@redhat.com> 1.0.5-3
650- check for empty soundcard list, not list = None
651
652* Mon Feb  3 2003 Brent Fox <bfox@redhat.com> 1.0.5-2
653- notting fixed the initscript to pull in the locale
654
655* Fri Jan 31 2003 Brent Fox <bfox@redhat.com> 1.0.5-1
656- new strings in up2date module
657
658* Wed Jan 29 2003 Brent Fox <bfox@redhat.com> 1.0.4-8
659- don't run firstboot in runlevel 3 at all (bug #78239)
660- fix return tuple if no soundcards are found in soundcard_gui.py
661- use backslash instead of forward slash in the init script
662
663* Wed Jan 29 2003 Brent Fox <bfox@redhat.com> 1.0.4-6
664- give the X server 1 second to close before we exit firstboot (bug #81313)
665
666* Tue Jan 28 2003 Brent Fox <bfox@redhat.com> 1.0.4-5
667- don't use Yes/No dialogs in create_user.py (bug #82680)
668- only use root window mode in non-debug mode
669- make module titles consistent with each other
670
671* Fri Jan 24 2003 Brent Fox <bfox@redhat.com> 1.0.4-4
672- better validity checking for user name and password
673
674* Tue Jan 21 2003 Brent Fox <bfox@redhat.com> 1.0.4-3
675- remove print statement that was causing a traceback
676
677* Mon Jan 20 2003 Brent Fox <bfox@redhat.com> 1.0.4-2
678- use the gdm background as the background image
679
680* Fri Jan 17 2003 Brent Fox <bfox@redhat.com> 1.0.4-1
681- make hboxes transparent and use a new background
682
683* Mon Jan 13 2003 Brent Fox <bfox@redhat.com> 1.0.3-6
684- make it so that we can paint the root window
685
686* Thu Jan  9 2003 Brent Fox <bfox@redhat.com> 1.0.3-5
687- sleep .5 sec on exit (bug #81313)
688
689* Mon Dec 23 2002 Brent Fox <bfox@redhat.com> 1.0.3-4
690- enforce 6 char user passwords
691
692* Sun Dec 22 2002 Brent Fox <bfox@redhat.com> 1.0.3-3
693- require an NTP server if NTP selected in date.py
694
695* Tue Dec 17 2002 Brent Fox <bfox@redhat.com> 1.0.3-2
696- don't run x tool if /etc/sysconfig/firstboot exists
697
698* Mon Dec 02 2002 Brent Fox <bfox@redhat.com> 1.0.3-1
699- Create a message for machines that boot in runlevel 3
700
701* Tue Nov 26 2002 Brent Fox <bfox@redhat.com> 1.0.2-4
702- Mark initscript strings as internationalizable (bug 77826)
703
704* Fri Nov 22 2002 Florian La Roche <Florian.LaRoche@redhat.de>
705- exclude mainframe
706
707* Wed Nov 13 2002 Brent Fox <bfox@redhat.com> 1.0.2-3
708- fix soundcard and mouse problem
709
710* Tue Nov 12 2002 Brent Fox <bfox@redhat.com> 1.0.2-2
711- explicitly kill X server pid
712- Latest translations
713
714* Thu Sep 05 2002 Brent Fox <bfox@redhat.com> 1.0.1-10
715- moved some pixmaps to redhat-logos package
716- added a requires for redhat-logos package
717
718* Tue Sep 03 2002 Brent Fox <bfox@redhat.com> 1.0.1-9
719- call dithering magic to make new pixmaps appear correctly
720
721* Tue Sep 03 2002 Brent Fox <bfox@redhat.com> 1.0.1-8
722- get new pixmaps from garrett
723
724* Fri Aug 30 2002 Brent Fox <bfox@redhat.com> 1.0.1-7
725- Wrap umount in a try/except in additional_cds.py
726
727* Fri Aug 30 2002 Brent Fox <bfox@redhat.com> 1.0.1-6
728- run chkconfig on starting/stopping ntpd
729
730* Thu Aug 29 2002 Brent Fox <bfox@redhat.com> 1.0.1-5
731- Make the date screen update the time widgets when the screen is entered
732
733* Thu Aug 29 2002 Brent Fox <bfox@redhat.com> 1.0.1-4
734- Convert po files to UTF-8
735
736* Thu Aug 29 2002 Brent Fox <bfox@redhat.com> 1.0.1-3
737- created a flag so that failed connections to NTP servers don't advance the screens
738- Don't try to display the parent window pixmap gradient
739- Make the parent window background a little darker
740
741* Wed Aug 28 2002 Brent Fox <bfox@redhat.com> 1.0.1-2
742- Fix typo
743
744* Wed Aug 28 2002 Brent Fox <bfox@redhat.com> 1.0.1-1
745- Convert to noarch
746- Add a root window mode for firstbootWindow
747- Use a gtkInvisible dialog to block on up2date and the package screen
748
749* Wed Aug 28 2002 Karsten Hopp <karsten@redhat.de> 1.0.0-5
750- don't require config-mouse, config-keyboard, config-soundcard
751  on S390
752
753* Tue Aug 27 2002 Brent Fox <bfox@redhat.com> 1.0.0-4
754- fix hang on unreponsive ntp servers
755 
756* Thu Aug 22 2002 Brent Fox <bfox@redhat.com> 1.0.0-3
757- Don't draw window decorations
758
759* Wed Aug 21 2002 Brent Fox <bfox@redhat.com> 1.0.0-2
760- pull translation domains from rhpl
761
762* Wed Aug 21 2002 Brent Fox <bfox@redhat.com> 1.0.0-1
763- Implement a lowres mode for 640x480 screens
764
765* Thu Aug 15 2002 Brent Fox <bfox@rehdat.com> 0.9.9-13
766- Don't show up2date screen if machine is already registered
767
768* Wed Aug 14 2002 Brent Fox <bfox@redhat.com> 0.9.9-12
769- fix reconfig mode
770- change pixmap on finished screen
771
772* Tue Aug 13 2002 Brent Fox <bfox@redhat.com> 0.9.9-11
773- pass None into startNtpService
774
775* Tue Aug 13 2002 Brent Fox <bfox@redhat.com> 0.9.9-10
776- If there's no XF86Config file, start redhat-config-xfree86 first
777
778* Tue Aug 13 2002 Brent Fox <bfox@redhat.com> 0.9.9-9
779- only start in runlevel 5
780
781* Tue Aug 13 2002 Brent Fox <bfox@redhat.com> 0.9.9-8
782- include cd.png
783
784* Tue Aug 13 2002 Brent Fox <bfox@redhat.com> 0.9.9-7
785- improved UI on additional cd screen
786
787* Tue Aug 13 2002 Brent Fox <bfox@redhat.com> 0.9.9-6
788- Require redhat-config-packages
789- Change string in finished module
790
791* Mon Aug 12 2002 Brent Fox <bfox@redhat.com> 0.9.9-5
792- Print out a message if user tries to run firstboot again
793- move firstboot to firstboot.py and create a shell script for firstboot
794- applied a patch from dburcaw@terraplex.com to check to see if we're run as root
795
796* Mon Aug 12 2002 Brent Fox <bfox@redhat.com> 0.9.9-4
797- Try to fix race condition
798- Have init script return 0 instead of 1
799- Make Forward button grab the focus
800
801* Wed Aug 07 2002 Brent Fox <bfox@redhat.com> 0.9.9-1
802- Rebuild for Jay, who is being a punk ;)
803 
804* Fri Aug 02 2002 Brent Fox <bfox@redhat.com> 0.9.8-1
805- Make changes for new pam timestamp policy
806
807* Thu Aug 01 2002 Brent Fox <bfox@redhat.com> 0.9.7-1
808- fix typo in finished module
809- create better text in the exception screen
810- save traceback info in /tmp/firstboot.txt
811
812* Tue Jul 30 2002 Brent Fox <bfox@redhat.com> 0.9.6-5
813- merge Xresources on startup.  Fixes bug #68724
814
815* Thu Jul 25 2002 Brent Fox <bfox@redhat.com> 0.9.6-4
816- change background color
817- give some padding to the icon box
818- put new splash and text on welcome and finished modules
819
820* Wed Jul 24 2002 Brent Fox <bfox@redhat.com> 0.9.6-3
821- fix Makefiles and spec files so that translations get installed
822
823* Wed Jul 24 2002 Brent Fox <bfox@redhat.com> 0.9.6-2
824- update spec file for public beta 2
825
826* Tue Jul 23 2002 Brent Fox <bfox@redhat.com> 0.9.6-1
827- removed register module
828- added a finished module
829- pulled in new icons
830
831* Fri Jul 19 2002 Brent Fox <bfox@redhat.com> 0.9.5-1
832- wire up register module
833- wire up up2date module
834- fix pointer pixmap bug
835- create an exceptionWindow to capture tracebacks
836
837* Tue Jul 16 2002 Brent Fox <bfox@redhat.com> 0.9.4-2
838- bump rev num and rebuild
839
840* Sat Jul 13 2002 Brent Fox <bfox@redhat.com> 0.9.4-1
841- fixed preun script to not blow away runlevel symlinks on upgrades
842
843* Thu Jul 11 2002 Brent Fox <bfox@redhat.com> 0.9.3-2
844- Update changelogs and rebuild
845
846* Thu Jul 11 2002 Brent Fox <bfox@redhat.com> 0.9.3-1
847- Update changelogs and rebuild
848
849* Mon Jul 01 2002 Brent Fox <bfox@redhat.com> 0.9.2-1
850- Bump rev number
851
852* Fri Jun 28 2002 Brent Fox <bfox@redhat.com> 0.9.1-4
853- Require metacity
854
855* Fri Jun 28 2002 Brent Fox <bfox@redhta.com> 0.9.1-3
856- Backed out some changes from init script
857- Fixed icon path in date module
858
859* Thu Jun 27 2002 Brent Fox <bfox@redhat.com> 0.9.1-2
860- Popup warning for unimplemented features
861
862* Wed Jun 26 2002 Brent Fox <bfox@redhat.com> 0.9.1-1
863- Only run in runlevel 5
864
865* Tue Jun 25 2002 Brent Fox <bfox@redhat.com> 0.9.0-5
866- Change initscript to not start firstboot on runlevel changes
867
868* Mon Jun 24 2002 Brent Fox <bfox@redhat.com> 0.9.0-4
869- Fix spec file
870
871* Fri Jun 21 2002 Brent Fox <bfox@redhat.com> 0.9.0-3
872- Added snapsrc to makefile
873- Rebuild for completeness
874
875* Wed Jun 12 2002 Brent Fox <bfox@redhat.com> 0.2.0-3
876- Fixed a string error in the welcome module
877
878* Fri May 31 2002 Brent Fox <bfox@redhat.com> 0.2.0-2
879- Some additions to hardware screen
880
881* Fri May 31 2002 Brent Fox <bfox@redhat.com> 0.2.0-1
882- Fix hardare screen's run priority
883
884* Thu May 30 2002 Brent Fox <bfox@redhat.com> 0.1.0-8
885- Created the beginnings of the hardware screen
886
887* Thu May 30 2002 Brent Fox <bfox@redhat.com> 0.1.0-7
888- Fixed Requires to not pull in pygnome
889
890* Tue May 28 2002 Brent Fox <bfox@redhat.com> 0.1.0-6
891- Rebuild for completeness
892- Fix bug in init script
893
894* Sun May 26 2002 Brent Fox <bfox@redhat.com> 0.1.0-4
895- Get startup scripts ready to go
896- Prepare package for placement into newest tree
897- Install init script into correct place
898
899* Tue Nov 28 2001 Brent Fox <bfox@redhat.com>
900- initial coding and packaging
901
Note: See TracBrowser for help on using the repository browser.