source: projects/specs/branches/6/f/finger/finger-vl.spec @ 521

Revision 521, 7.9 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Summary: The finger client.
2Summary(ja): finger クライアント
3Name: finger
4Version: 0.17
5Release: 35%{?_dist_release}
6License: BSD
7Group: Applications/Internet
8Source: ftp://ftp.uk.linux.org/pub/linux/Networking/netkit-devel/bsd-finger-%{version}.tar.gz
9Source1: finger-xinetd
10Patch1: bsd-finger-0.16-pts.patch
11Patch2: bsd-finger-0.17-exact.patch
12Patch3: bsd-finger-0.16-allocbroken.patch
13Patch4: bsd-finger-0.17-rfc742.patch
14Patch5: bsd-finger-0.17-time.patch
15Patch6: bsd-finger-0.17-usagi-ipv6.patch
16Patch7: bsd-finger-0.17-typo.patch
17Patch8: bsd-finger-0.17-strip.patch
18Patch9: bsd-finger-0.17-utmp.patch
19Patch10: bsd-finger-wide-char-support5.patch
20Patch11: bsd-finger-0.17-init-realname.patch
21
22BuildRoot: %{_tmppath}/%{name}-%{version}-root
23BuildRequires: glibc-devel, perl
24
25
26%description
27Finger is a utility which allows users to see information about system
28users (login name, home directory, name, how long they've been logged
29in to the system, etc.).  The finger package includes a standard
30finger client.
31
32You should install finger if you'd like to retreive finger information
33from other systems.
34
35%description -l ja
36finger はシステムを使用しているユーザの情報 (ログイン名,ホームディレクトリ,
37氏名,システムにログインしてからの時間等) を見ることが出来るユーティリティ
38です.finger パッケージには標準的な finger クライアントが含まれます.
39
40他のシステムから finger 情報を見るには finger をインストールして下さい.
41
42
43%package server
44Summary: The finger daemon.
45Summary(ja): finger デーモン
46Group: System Environment/Daemons
47Requires: xinetd
48
49%description server
50Finger is a utility which allows users to see information about system
51users (login name, home directory, name, how long they've been logged
52in to the system, etc.).  The finger-server package includes a standard
53finger server. The server daemon (fingerd) runs from /etc/inetd.conf,
54which must be modified to disable finger requests.
55
56You should install finger-server if your system is used by multiple users
57and you'd like finger information to be available.
58
59%description server -l ja
60finger はシステムを使用しているユーザの情報 (ログイン名,ホームディレクトリ,
61氏名,システムにログインしてからの時間等) を見ることが出来るユーティリティ
62です.finger-server パッケージには標準的な finger サーバが含まれます.
63サーバデーモン (fingerd) は /etc/inetd.conf から起動されますので,
64finger リクエストを無効にするにはこのファイルを編集して下さい.
65
66あなたのシステムが複数のユーザによって使われていて finger 情報を
67提供するには finger-server パッケージをインストールして下さい.
68
69
70%prep
71%setup -q -n bsd-finger-%{version}
72%patch1 -p1 -b .pts
73%patch2 -p1 -b .exact
74%patch3 -p1
75%patch4 -p1 -b .rfc742
76%patch5 -p1 -b .time
77%patch6 -p1 -b .ipv6
78%patch7 -p1 -b .typo
79%patch8 -p1 -b .strip
80%patch9 -p1 -b .utmp
81%patch10 -p1 -b .widechar
82%patch11 -p1
83
84%build
85sh configure --enable-ipv6
86RPM_OPT_FLAGS="$RPM_OPT_FLAGS -fPIC"
87perl -pi -e '
88    s,^CC=.*$,CC=cc,;
89    s,-O2,\$(RPM_OPT_FLAGS),;
90    s,^BINDIR=.*$,BINDIR=%{_bindir},;
91    s,^MANDIR=.*$,MANDIR=%{_mandir},;
92    s,^SBINDIR=.*$,SBINDIR=%{_sbindir},;
93    s,^LDFLAGS=.*$,LDFLAGS=-pie,;
94    ' MCONFIG
95
96make %{?_smp_mflags}
97
98%install
99rm -rf $RPM_BUILD_ROOT
100mkdir -p $RPM_BUILD_ROOT%{_bindir}
101mkdir -p $RPM_BUILD_ROOT%{_mandir}/man{1,8}
102mkdir -p $RPM_BUILD_ROOT%{_sbindir}
103
104mkdir -p $RPM_BUILD_ROOT/etc/xinetd.d
105install -m 644 %{SOURCE1} $RPM_BUILD_ROOT/etc/xinetd.d/finger
106
107make INSTALLROOT=$RPM_BUILD_ROOT install
108
109
110%clean
111rm -rf $RPM_BUILD_ROOT
112
113%files
114%defattr(-,root,root)
115%attr(0711,root,root)   %{_bindir}/finger
116%{_mandir}/man1/finger.1*
117
118%files server
119%defattr(-,root,root)
120%config(noreplace) /etc/xinetd.d/finger
121%attr(0711,root,root)   %{_sbindir}/in.fingerd
122%{_mandir}/man8/in.fingerd.8*
123%{_mandir}/man8/fingerd.8*
124
125
126%changelog
127* Sun Jan 10 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.17-35
128- added Patch11 from Fedora
129  * Mon Sep  7 2009 Radek Vokal <rvokal@redhat.com> - 0.17-39
130  - init realname fix (#520203)
131- Requires: xinetd instead of inetd at server package
132
133* Mon Sep 22 2008 Shu KONNO <owa@bg.wakwak.com> 0.17-34
134- added compile option -fPIC
135
136* Sun Sep 21 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.17-33
137- applied new versioning policy
138- spec in UTF-8
139
140* Sat Jan 14 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.17-32vl1
141- based on Redhat Rawhide 0.17-32
142  * Thu Dec 15 2005 Radek Vokal <rvokal@redhat.com> 0.17-32
143  - another UTF-8 fix
144  * Tue Dec 13 2005 Radek Vokal <rvokal@redhat.com> 0.17-31
145  - real UTF-8 patch by <bnocera@redhat.com>
146  * Mon Nov 28 2005 Radek Vokal <rvokal@redhat.com> 0.17-30
147  - make finger UTF-8 happy (#174352)
148  * Wed Jul 13 2005 Radek Vokal <rvokal@redhat.com> 0.17-29
149  - make finger world readable (#162643)
150  * Tue Jun 15 2004 Alan Cox <alan@redhat.com>
151  - Made finger agree with our other apps about how utmp is managed
152  - Removed dead users from the lists as a result
153  - Fixed random idle time bug
154  * Wed Feb 25 2004 Phil Knirsch <pknirsch@redhat.com> 0.17-21
155  - Made fingerd PIE.
156
157* Sun Sep 21 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.17-18vl1
158- based on Redhat Rawhide 0.17-18.1
159  * Mon Sep 01 2003 Phil Knirsch <pknirsch@redhat.com> 0.17-18
160  - Fixed manpage bug (#75705).
161  * Wed Jun 19 2002 Phil Knirsch <pknirsch@redhat.com> 0.17-13
162  - Don't forcibly strip binaries
163  * Thu Jan 24 2002 Phil Knirsch <pknirsch@redhat.com>
164  - Fixed various typos in manpage/app (#51891, #54916, #57588)
165- rebuilt with new toolchains
166- s/Copyright/License/
167
168* Wed Dec 19 2001 Toru Sagami <sagami@vinelinux.org> 0.17-3vl4
169- added a patch to build on glibc22 system
170
171* Tue Jan 09 2001 Toru Sagami <czs14350@mb.infoweb.ne.jp>
172- 0.17-3vl3
173- Oops, spec was written in SJIS...
174
175* Mon Jan 08 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
176- 0.17-3vl2
177- added Japanese summary and description
178- rebuilt under new %%{_mandir} definitions
179
180* Mon Sep 18 2000 Jun Nishii <jun@vinelinux.org>
181- requires inetd instead of xinetd for Vine Linux 2.1
182
183* Sat Jul 22 2000 Jeff Johnson <jbj@redhat.com>
184- fix RFC742 problem (again) (#6728).
185
186* Tue Jul 18 2000 Bill Nottingham <notting@redhat.com>
187- add description & default to xinetd file
188
189* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
190- automatic rebuild
191
192* Sun Jun 18 2000 Jeff Johnson <jbj@redhat.com>
193- FHS packaging.
194- update to 0.17.
195
196* Wed May 31 2000 Cristian Gafton <gafton@redhat.com>
197- fix the broken malloc code in finger client
198
199* Mon May 22 2000 Trond Eivind Glomsr <teg@redhat.com>
200- converted to use /etc/xinetd.d
201
202* Tue May 16 2000 Chris Evans <chris@ferret.lmh.ox.ac.uk>
203- make some files mode -rwx--x--x as a security hardening measure
204
205* Fri Feb 11 2000 Bill Nottingham <notting@redhat.com>
206- fix description
207
208* Mon Feb  7 2000 Bill Nottingham <notting@redhat.com>
209- handle compressed manpages
210
211* Wed Feb 02 2000 Cristian Gafton <gafton@redhat.com>
212- fix decsription
213- man pages are compressed
214
215* Tue Jan  4 2000 Bill Nottingham <notting@redhat.com>
216- split client and server
217
218* Tue Dec 21 1999 Jeff Johnson <jbj@redhat.com>
219- update to 0.16.
220
221* Wed Jul 28 1999 Jeff Johnson <jbj@redhat.com>
222- exact match w/o -m and add missing pts patch (#2118).
223- recompile with correct PATH_MAILDIR (#4218).
224
225* Thu Apr  8 1999 Jeff Johnson <jbj@redhat.com>
226- fix process table filled DOS attack (#1271)
227- fix pts display problems (#1987 partially)
228
229* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
230- auto rebuild in the new build environment (release 22)
231
232* Mon Mar 15 1999 Jeff Johnson <jbj@redhat.com>
233- compile for 6.0.
234
235* Wed Aug 12 1998 Jeff Johnson <jbj@redhat.com>
236- fix error message typo.
237
238* Tue Aug 11 1998 Jeff Johnson <jbj@redhat.com>
239- build root
240
241* Mon Apr 27 1998 Prospector System <bugs@redhat.com>
242- translations modified for de, fr, tr
243
244* Mon Sep 22 1997 Erik Troan <ewt@redhat.com>
245- added check for getpwnam() failure
Note: See TracBrowser for help on using the repository browser.