source: projects/specs/branches/6/f/findutils/findutils-vl.spec @ 3403

Revision 3403, 5.3 KB checked in by daisuke, 13 years ago (diff)

findutils: update to 4.5.9

Line 
1Summary: The GNU versions of find utilities (find and xargs).
2Summary(ja):  find ユーティリティの GNU バージョン (find および xargs).
3Name: findutils
4Version: 4.5.9
5Release: 1%{?_dist_release}
6License: GPL
7Group: System Environment/Base
8Source0: ftp://ftp.gnu.org/gnu/findutils/findutils-%{version}.tar.gz
9Source1: updatedb.cron
10Requires(post): /sbin/install-info
11Requires(preun): /sbin/install-info
12Buildroot: %{_tmppath}/%{name}-%{version}-root
13BuildRequires: libtool, automake, autoconf
14BuildRequires: dejagnu, gettext, texinfo
15
16%description
17The findutils package contains programs which will help you locate
18files on your system.  The find utility searches through a hierarchy
19of directories looking for files which match a certain set of criteria
20(such as a filename pattern).  The xargs utility builds and executes
21command lines from standard input arguments (usually lists of file
22names generated by the find command).
23
24You should install findutils because it includes tools that are very
25useful for finding things on your system.
26
27%prep
28%setup -q
29
30%build
31%configure
32
33%__make %{?_smp_mflags}
34
35%install
36rm -rf $RPM_BUILD_ROOT
37make install DESTDIR=${RPM_BUILD_ROOT}
38
39%find_lang %{name}
40
41# move find to /bin
42mkdir -p $RPM_BUILD_ROOT/bin
43mv $RPM_BUILD_ROOT%{_bindir}/find $RPM_BUILD_ROOT/bin/
44ln -sf ../../bin/find $RPM_BUILD_ROOT%{_bindir}
45
46# remove unpackaged files
47rm -f $RPM_BUILD_ROOT%{_bindir}/{locate,updatedb}
48rm -f $RPM_BUILD_ROOT%{_libexecdir}/*
49rm -f $RPM_BUILD_ROOT%{_mandir}/man1/{locate,updatedb}*
50rm -f $RPM_BUILD_ROOT%{_mandir}/man5/locatedb*
51rm -f $RPM_BUILD_ROOT%{_infodir}/dir
52
53
54%post
55if [ -f %{_infodir}/find.info.gz ]; then
56  /sbin/install-info %{_infodir}/find.info.gz %{_infodir}/dir
57fi
58
59%preun
60if [ $1 = 0 -a -f %{_infodir}/find.info.gz ]; then
61    /sbin/install-info --delete %{_infodir}/find.info.gz %{_infodir}/dir
62fi
63
64%clean
65rm -rf $RPM_BUILD_ROOT
66
67%files -f %{name}.lang
68%defattr(-,root,root)
69%doc AUTHORS COPYING NEWS README THANKS
70/bin/find
71%{_bindir}/find
72%{_bindir}/oldfind
73%{_bindir}/xargs
74%{_mandir}/man1/find.1*
75%{_mandir}/man1/xargs.1*
76%{_infodir}/find.info*
77%{_infodir}/find-maint.info*
78
79%changelog
80* Mon Apr 11 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 4.5.9-1
81- new upstream release
82
83* Sun Mar 29 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 4.4.0-2
84- move find to /bin
85  - we'd use find in initscripts
86
87* Fri May 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 4.4.0-1
88- new versioning policy
89- new upstream release
90
91* Mon Oct 22 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.2.31-0vl1
92- new upstream release (including security fix for CVE-2007-2452)
93
94* Thu May 04 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 4.2.27-0vl1
95- new upstream release
96- use License instead of Copyright
97- change Group to System Environment/Base
98
99* Tue Jun 21 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 4.2.23-0vl1
100- new upstream release
101- drop unneeded patches
102
103* Sat Jan 20 2001 Lisa Sagami <czs14350@mb.infoweb.ne.jp>
104- 4.1.5-0vl3
105- usr better macros (%%configure/%%makeinstall)
106
107* Tue Nov 21 2000 Jun Nishii <jun@vinelinux.org>
108- 4.1.5-0vl2
109- bug fix for -O002
110
111* Wed Jun  7 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
112- 4.1.5
113- added ja.po
114
115* Mon Apr  3 2000 Bernhard Rosenkraenzer <bero@redhat.com>
116- 4.1.4
117- remove some obsolete patches, adapt others
118- fix build on alpha
119
120* Wed Feb 02 2000 Cristian Gafton <gafton@redhat.com>
121- fix summary
122- ma  pages are compressed
123
124* Wed Jan 12 2000 Preston Brown <pbrown@redhat.com>
125- new description.
126
127* Fri Aug 27 1999 Preston Brown <pbrown@redhat.com>
128- fixed block count bug (# 2141)
129
130* Mon Mar 29 1999 Preston Brown <pbrown@redhat.com>
131- patch to fix xargs out of bounds overflow (bug # 1279)
132
133* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
134- auto rebuild in the new build environment (release 30)
135
136* Fri Mar 19 1999 Jeff Johnson <jbj@redhat.com>
137- strip binaries.
138
139* Mon Feb  8 1999 Jeff Johnson <jbj@redhat.com>
140- remove further updatedb remnants (#1072).
141
142* Thu Dec 03 1998 Cristian Gafton <gafton@redhat.com>
143- added patch for glibc21
144
145* Mon Nov 16 1998 Erik Troan <ewt@redhat.com>
146- removed locate stuff (as we now ship slocate)
147
148* Wed Jun 10 1998 Erik Troan <ewt@redhat.com>
149- updated updatedb cron script to not look for $TMPNAME.n (which was
150  a relic anyway)
151- added -b parameters to all of the patches
152
153* Fri Apr 24 1998 Prospector System <bugs@redhat.com>
154- translations modified for de, fr, tr
155
156* Mon Mar 09 1998 Michael K. Johnson <johnsonm@redhat.com>
157- make updatedb.cron use mktemp correctly
158- make updatedb use mktemp
159
160* Sun Nov 09 1997 Michael K. Johnson <johnsonm@redhat.com>
161- nobody should own tmpfile
162- ignore /net
163
164* Wed Nov 05 1997 Michael K. Johnson <johnsonm@redhat.com>
165- made updatedb.cron do a better job of cleaning up after itself.
166
167* Tue Oct 28 1997 Donald Barnes <djb@redhat.com>
168- fixed 64 bit-ism in getline.c, patch tacked on to end of glibc one
169
170* Thu Oct 23 1997 Erik Troan <ewt@redhat.com>
171- added patch for glibc 2.1
172
173* Fri Oct 17 1997 Donnie Barnes <djb@redhat.com>
174- added BuildRoot support
175
176* Tue Oct 14 1997 Michael K. Johnson <johnsonm@redhat.com>
177- made updatedb.cron work even if "nobody" can't read /root
178- use mktemp in updatedb.cron
179
180* Sun Sep 14 1997 Erik Troan <ewt@redhat.com>
181- added missing info pages
182- uses install-info
183
184* Mon Jun 02 1997 Erik Troan <ewt@redhat.com>
185- built with glibc
186
187* Mon Apr 21 1997 Michael K. Johnson <johnsonm@redhat.com>
188- fixed updatedb.cron
Note: See TracBrowser for help on using the repository browser.