source: projects/specs/branches/6/f/file/file-vl.spec @ 9085

Revision 9085, 12.8 KB checked in by iwamoto, 9 years ago (diff)

file: fix CVE-2014-3710

Line 
1%{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
2%{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
3%define __libtoolize :
4
5Summary: A utility for determining file types.
6Summary(ja): ファイルの種類を判別するユーティリティー
7Name: file
8Version: 5.14
9Release: 7%{?_dist_release}
10License: BSD
11Group: Applications/System
12Obsoletes: file-static
13
14Source0: ftp://ftp.astron.com/pub/file/%{name}-%{version}.tar.gz
15
16# Addtional magic file for Vine
17Source10: magic.printer-j
18
19# Upstream says it's up to distributions to add a way to support local-magic.
20Patch0: file-localmagic.patch
21# sent upstream - should be included in next upstream release
22Patch1: file-5.10-strength.patch
23Patch2: file-5.10-sticky-bit.patch
24Patch3: file-4.17-rpm-name.patch
25Patch4: file-5.04-volume_key.patch
26Patch5: file-5.04-man-return-code.patch
27Patch6: file-5.04-generic-msdos.patch
28Patch7: file-5.14-x86boot.patch
29Patch8: file-5.14-perl.patch
30Patch9: file-5.14-elfspace.patch
31Patch10: file-5.14-bad-fsmagic-space.patch
32Patch11: file-5.14-no-magic.patch
33Patch12: file-5.14-journald.patch
34Patch13: file-5.14-magic_load.patch
35
36#Vine
37Patch100: file-5.14-magicbuild-fix.patch
38Patch110: limit-repetitions-in-awk-detection.patch
39
40#Security
41Patch200: file-5.14_CVE-2014-1943.patch
42Patch210: file-5.14_CVE-2014-2270.patch
43Patch220: DSA-2873-1-regression.patch
44Patch240: CVE-2014-0207.patch
45Patch250: CVE-2014-0237.patch
46Patch260: CVE-2014-0238.patch
47Patch270: file-5.14_CVE-2014-3478.patch
48Patch280: file-5.14_CVE-2014-3479.patch
49Patch290: CVE-2014-3480.patch
50Patch300: CVE-2014-3487.patch   
51Patch310: file-5.14_CVE-2014-3538.patch
52Patch320: file-5.14_CVE-2014-3587.patch
53Patch330: file-5.14_CVE-2014-3710.patch
54
55Buildroot: %{_tmppath}/%{name}-%{version}-root
56#BuildRequires: automake
57#BuildRequires: autoconf
58BuildRequires: zlib-devel
59
60Vendor: Project Vine
61Distribution: Vine Linux
62Packager: daisuke
63
64%description
65The file command is used to identify a particular file according to the
66type of data contained by the file.  File can identify many different
67file types, including ELF binaries, system libraries, RPM packages, and
68different graphics formats.
69
70You should install the file package, since the file command is such a
71useful utility.
72
73%description -l ja
74file コマンドは、ファイルに含まれるデータの種類によって各ファイルが
75どのようなファイルかを判定するために使います。file は ELF バイナリ、シ
76ステムライブラリ、RPM パッケージ、そして様々なグラフィックフォーマット
77を含む、多くの異なるファイルの種類を見分けることができます。
78
79
80%package devel
81Summary:  Libraries and header files for file development
82Summary(ja): libmagic の開発用ファイル
83Group:    Development/Libraries
84Requires: %{name} = %{version}-%{release}
85
86%description devel
87The file-devel package contains the header files and libmagic library
88necessary for developing programs using libmagic.
89
90%package -n python-magic
91Summary: Python bindings for the libmagic API
92Group:   Development/Libraries
93BuildRequires: python-devel
94Requires: %{name} = %{version}-%{release}
95
96%description -n python-magic
97This package contains the Python bindings to allow access to the
98libmagic API. The libmagic library is also used by the familiar
99file(1) command.
100
101
102%prep
103%setup -q
104# Don't use -b -- it will lead to poblems when compiling magic file!
105%patch0 -p1
106%patch1 -p1
107%patch2 -p1
108%patch3 -p1
109%patch4 -p1
110%patch5 -p1
111%patch6 -p1
112%patch7 -p1
113%patch8 -p1
114%patch9 -p1
115%patch10 -p1
116%patch11 -p1
117%patch12 -p1
118%patch13 -p1
119
120#Vine
121%patch100 -p1
122%patch110 -p1 -b .limit-repetitions-in-awk-detection
123
124#Security
125%patch200 -p1 -b .CVE-2014-1943
126%patch210 -p1 -b .CVE-2014-2270
127%patch220 -p1 -b .DSA-2873-1-regression
128%patch240 -p1 -b .CVE-2014-0207
129%patch250 -p1 -b .CVE-2014-0237
130%patch260 -p1 -b .CVE-2014-0238
131%patch270 -p1 -b .CVE-2014-3478
132%patch280 -p1 -b .CVE-2014-3479
133%patch290 -p1 -b .CVE-2014-3480
134%patch300 -p1 -b .CVE-2014-3487
135%patch310 -p1 -b .CVE-2014-3538
136%patch320 -p1 -b .CVE-2014-3587
137%patch330 -p1 -b .CVE-2014-3710
138
139cat %{SOURCE10} >> ./magic/Localstuff
140
141iconv -f iso-8859-1 -t utf-8 < doc/libmagic.man > doc/libmagic.man_
142touch -r doc/libmagic.man doc/libmagic.man_
143mv doc/libmagic.man_ doc/libmagic.man
144
145%build
146autoreconf
147CFLAGS="%{optflags} -D_GNU_SOURCE -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE" \
148%configure --enable-fsect-man5 --disable-rpath
149# remove hardcoded library paths from local libtool
150sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
151sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
152export LD_LIBRARY_PATH=$RPM_BUILD_ROOT/%{name}-%{version}/src/.libs
153make
154
155cd python
156CFLAGS="%{optflags}" %{__python} setup.py build
157
158%install
159rm -rf $RPM_BUILD_ROOT
160mkdir -p $RPM_BUILD_ROOT%{_bindir}
161mkdir -p $RPM_BUILD_ROOT%{_mandir}/man1
162mkdir -p $RPM_BUILD_ROOT%{_mandir}/man3
163mkdir -p $RPM_BUILD_ROOT%{_mandir}/man5
164mkdir -p $RPM_BUILD_ROOT%{_datadir}/misc
165mkdir -p $RPM_BUILD_ROOT%{_datadir}/file
166
167make install DESTDIR=$RPM_BUILD_ROOT
168
169cat magic/Magdir/* > ${RPM_BUILD_ROOT}%{_datadir}/misc/magic
170ln -s misc/magic ${RPM_BUILD_ROOT}%{_datadir}/magic
171##ln -s file/magic.mime ${RPM_BUILD_ROOT}%{_datadir}/magic.mime
172ln -s ../magic ${RPM_BUILD_ROOT}%{_datadir}/file/magic
173
174cd python
175%{__python} setup.py install -O1 --skip-build --root ${RPM_BUILD_ROOT}
176%{__install} -d ${RPM_BUILD_ROOT}%{_datadir}/%{name}
177
178
179# LIBTOOL=/usr/bin/libtool
180#ln -s file/magic ${RPM_BUILD_ROOT}%{_datadir}/magic
181#ln -s file/magic.mime ${RPM_BUILD_ROOT}%{_datadir}/magic.mime
182
183#ln -s ../magic ${RPM_BUILD_ROOT}%{_datadir}/misc/magic
184
185#{ cd ${RPM_BUILD_ROOT}
186#  strip .%{_bindir}/file
187#  cp %SOURCE1 .%{_datadir}/magic.mime
188#}
189
190# remove unuse files
191rm -rf $RPM_BUILD_ROOT%{_libdir}/*.la
192
193%clean
194rm -rf $RPM_BUILD_ROOT
195
196%post -p /sbin/ldconfig
197
198%postun -p /sbin/ldconfig
199
200
201%files
202%defattr(-,root,root)
203%doc COPYING ChangeLog README
204%{_bindir}/*
205%{_libdir}/libmagic.so.*
206%{_datadir}/file/*
207%{_datadir}/magic*
208%{_datadir}/misc/*
209%{_mandir}/man[15]/*
210
211%files devel
212%defattr(-,root,root,-)
213%{_libdir}/*.so
214%{_includedir}/magic.h
215%{_mandir}/man3/*
216
217%files -n python-magic
218%defattr(-, root, root, -)
219%doc python/README COPYING python/example.py
220%{python_sitelib}/magic.py
221%{python_sitelib}/magic.pyc
222%{python_sitelib}/magic.pyo
223%{python_sitelib}/*egg-info
224
225
226%changelog
227* Fri Nov 14 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 5.14-7
228- add patch330 for fix CVE-2014-3710
229
230* Thu Sep 11 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 5.14-6
231- drop patch230 (moved to patch320)
232- add Patch240 for fix CVE-2014-0207
233- add Patch250 for fix CVE-2014-0237
234- add Patch260 for fix CVE-2014-0238
235- add Patch270 for fix CVE-2014-3478
236- add Patch280 for fix CVE-2014-3479
237- add Patch290 for fix CVE-2014-3480
238- add Patch300 for fix CVE-2014-3487
239- add Patch310 for fix CVE-2014-3538
240- add Patch320 for fix CVE-2014-3587
241  These patches are from debian/ubuntu, thanks.
242
243* Thu Aug 28 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 5.14-5
244- add patch230 for fix CVE-2014-3587 (cdf_read_property_info)
245
246* Thu Mar 27 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 5.14-4
247- add patch110,220 for fix regression of CVE-2014-2270
248
249* Wed Mar 12 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 5.14-3
250- add patch210 for fix CVE-2014-2270
251
252* Thu Feb 20 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 5.14-2
253- add patch200 for fix CVE-2014-1943
254
255* Sun Sep 22 2013 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 5.14-1
256- new upstream reelase
257- add patch100 to fix build error
258- remove -static subpackage and add Obs: file-static
259- fix old changelog date...
260
261* Thu Nov 29 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 5.11-1
262- new upstream reelase
263- drop all local patches
264- import fedora patches
265
266* Wed Feb 15 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 5.05-3
267- rebuild with python-2.7.2
268
269* Sun Feb 20 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 5.05-2
270- rebuild package
271- fix Patch100
272
273* Sat Feb 12 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 5.05-1
274- new upstream release
275- updated Vine patches (but Patch100 has not been ported yet...)
276- split to devel and static subpackcages
277
278* Mon Sep 27 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.21-3
279- rebuilt with rpm-4.8.1
280- add environment variable LIBTOOL for make command
281
282* Fri Sep 26 2008 Shu KONNO <owa@bg.wakwak.com> 4.21-2
283- spec in utf-8
284- removed *.la
285
286* Mon May 12 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.21-1
287- applied new versioning policy
288
289* Tue Dec 11 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 4.21-0vl1
290- new upstream release
291- import debian/fedora patches
292- drop obsolete vine magic.
293
294* Thu Jun 14 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.09-0vl3
295- rebuild for VineSeed with new tool chain
296
297* Thu May 31 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.09-0vl2.2
298- add patch110 for fix CVE-2007-2799
299- add zlib-devel to BuildPreReq tag
300
301* Mon Mar 26 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.09-0vl2.1
302- add patch100 for fix CVE-2007-1536
303
304* Sun Sep 10 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.09-0vl2
305- changed Group to Applications/System
306
307* Sun Apr 18 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 4.09-0vl1
308- new upstream release
309- update vine patches
310
311* Wed Sep 10 2003 Tomoya TAKA <taka@vinelinux.org> 4.03-0vl2
312- update Patch10, use 'size_t' in src/jcode.[ch]
313
314* Tue Sep 09 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.03-0vl1
315- update to 4.03
316- update Patch0, 1, 10 for 4.03
317- s/Copyright/License/
318
319* Mon May 12 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.02-1vl1
320- update to 4.02
321- update Vine patches for 4.02
322
323* Sun Mar  9 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 3.41-0vl1
324- new upstream release
325  - fixed security bug (http://www.idefense.com/advisory/03.04.03.txt)
326- remove unneeded patches.
327- update Vine patches for 3.41
328
329* Mon Apr  1 2002 Jun Nishii <jun@vinelinux.org> 3.37-0vl2
330- added NPDL2 data [Vine:02348]
331
332* Fri Feb 08 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.37-0vl1
333- update to 3.37
334
335* Sun Jul 15 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
336- 3.35-0vl3
337- disable some entries in elf for problems on big-endian archs
338
339* Wed Jun  6 2001 Jun Nishii <jun@vinelinux.org>
340- file-3.35-0vl1
341- ver.up
342- added %doc
343
344* Thu Jan 11 2001 Jun Nishii <jun@vinelinux.org>
345- file-3.33-1vl4
346- more fix and clean up jtext patch (file-3.33-vinejtext.patch)
347
348* Thu Jan 11 2001 Jun Nishii <jun@vinelinux.org>
349- file-3.33-1vl3
350- fix again jtext patch (file-3.33-vinejtext.patch)
351- added file-3.33-vinenames.patch to avoid miss-judgement
352
353* Wed Jan 10 2001 Jun Nishii <jun@vinelinux.org>
354- file-3.33-1vl2
355- update jtext patch (file-3.33-vinejtext.patch)
356
357* Mon Jan  8 2001 Jun Nishii <jun@vinelinux.org>
358- file-3.33-1vl1
359- modify description-ja and spec
360
361* Sun Jul 09 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
362- file-3.28-2vl2
363- fixed %files section to handle compressed man pages
364
365* Tue Jun 13 2000 Lisa Sagami <czs14350@nifty.ne.jp>
366- marged RH 3.28-2 and Vine 3.27-3vl3
367
368* Wed Feb 16 2000 Cristian Gafton <gafton@redhat.com>
369- add ia64 patch from rth
370
371* Mon Feb  7 2000 Bill Nottingham <notting@redhat.com>
372- handle compressed manpages
373- update to 3.28
374
375* Mon Sep 6 1999 Norihito Ohmori <ohmori@flatout.org>
376- Japanese Text detection bug fix. (by Toru Hoshina <hoshina@best.com>)
377
378* Fri Aug 27 1999 Norihito Ohmori <ohmori@flatout.org>
379- patch  dues not apply bug.
380
381* Thu Aug 26 1999 Norihito Ohmori <ohmori@flatout.org>
382- not need kcc (Thanks for Toru Hoshina <hoshina@best.com>)
383- ASCII data and Shift JIS data detected in Japanese Text Detection bug fix.
384
385* Mon Aug 23 1999 Jeff Johnson <jbj@redhat.com>
386- identify ELF stripped files correctly (#4665).
387- use SPARC (not sparc) consistently throughout (#4665).
388- add entries for MS Office files (#4665).
389
390* Thu Aug 12 1999 Jeff Johnson <jbj@redhat.com>
391- diddle magic so that *.tfm files are identified correctly.
392
393* Tue Jul  6 1999 Jeff Johnson <jbj@redhat.com>
394- update to 3.27.
395
396* Mon Mar 22 1999 Preston Brown <pbrown@redhat.com>
397- experimental support for realmedia files added
398
399* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
400- auto rebuild in the new build environment (release 5)
401
402* Fri Mar 19 1999 Jeff Johnson <jbj@redhat.com>
403- strip binary.
404
405* Fri Nov 27 1998 Jakub Jelinek <jj@ultra.linux.cz>
406- add SPARC V9 magic.
407
408* Tue Nov 10 1998 Jeff Johnson <jbj@redhat.com>
409- update to 3.26.
410
411* Mon Aug 24 1998 Jeff Johnson <jbj@redhat.com>
412- update to 3.25.
413- detect gimp XCF versions.
414
415* Thu May 07 1998 Prospector System <bugs@redhat.com>
416- translations modified for de, fr, tr
417
418* Wed Apr 08 1998 Erik Troan <ewt@redhat.com>
419- updated to 3.24
420- buildrooted
421
422* Mon Jun 02 1997 Erik Troan <ewt@redhat.com>
423- built against glibc
424
425* Mon Mar 31 1997 Erik Troan <ewt@redhat.com>
426- Fixed problems caused by 64 bit time_t.
427
428* Thu Mar 06 1997 Michael K. Johnson <johnsonm@redhat.com>
429- Improved recognition of Linux kernel images.
Note: See TracBrowser for help on using the repository browser.