source: projects/specs/branches/6/f/file-roller/file-roller-vl.spec @ 4334

Revision 4334, 9.4 KB checked in by kazutaka, 13 years ago (diff)

UI の未約部分修正のために patch を1つ追加して、ja.po を更新

Line 
1%define glib2_version 2.28.6
2%define gtk2_version 2.24.4
3%define gconf2_version 2.32.1
4%define nautilus_version 2.32.1
5%define desktop_file_utils_version 0.16
6%define gnome_doc_utils_version 0.3.2
7
8Summary:        File Roller is a tool for viewing and creating archives.
9Summary(ja):    File Roller - アーカイブの表示・作成ツール
10Name:           file-roller
11Version:        2.32.2
12Release:        2%{?_dist_release}
13
14License:        GPL
15Group:          Applications/Archiving
16Source0:        http://ftp.gnome.org/pub/GNOME/sources/file-roller/2.32/%{name}-%{version}.tar.bz2
17Source1:        file-roller.help.Makefile.am
18Source2:        file-roller.help.gnome-2-30.ja.po
19Source3:        file-roller-ja-figures.tar.bz2
20Source4:        file-roller-2.32.2-ja.po
21# i18n fix for ui strings
22# refer https://bugzilla.gnome.org/show_bug.cgi?id=649159
23# and also http://git.gnome.org/browse/file-roller/commit/src/ui.h?id=c5f7cb8dab9740ff10b46c2dc9a2d2970b2f7cfe
24Patch1:         file-roller-2.32.2-i18n-fix.patch
25URL:            http://ftp.gnome.org/pub/gnome/sources/file-roller/
26BuildRoot:      %{_tmppath}/%{name}-%{version}-root
27
28Requires(post,postun): scrollkeeper >= 0.3.11
29Requires(post,postun): desktop-file-utils >= %{desktop_file_utils_version}
30Requires(post,pre,preun): GConf2
31
32BuildRequires: glib2-devel >= %{glib2_version}
33BuildRequires: gtk2-devel >= %{gtk2_version}
34BuildRequires: GConf2-devel >= %{gconf2_version}
35BuildRequires: nautilus >= %{nautilus_version}
36BuildRequires: nautilus-devel >= %{nautilus_version}
37BuildRequires: desktop-file-utils >= %{desktop_file_utils_version}
38BuildRequires: gnome-doc-utils >= %{gnome_doc_utils_version}
39BuildRequires: libSM-devel
40BuildRequires: docbook-dtds
41
42%description
43File Roller is an application for creating and viewing archives files,
44such as tar files.
45
46%description -l ja
47File Roller は tar ファイルのようなアーカイブの表示や作成をするための
48アプリケーションです。
49
50%prep
51%setup -q
52%patch1 -p1 -b .i18n-fix
53
54## # add Japanese help
55## cp -f %{SOURCE1} help/Makefile.am
56## mkdir help/ja
57## cp -f %{SOURCE2} help/ja/ja.po
58## (cd help/ja && tar jxf %{SOURCE3})
59
60# update Japanese interface
61cp -f %{SOURCE4} po/ja.po
62
63# regenerate to fix path
64rm -f src/fr-enum-types.c
65
66%build
67%configure --disable-scrollkeeper
68export tagname=CC
69make %{?_smp_mflags} LIBTOOL=/usr/bin/libtool
70
71%install
72rm -rf $RPM_BUILD_ROOT
73
74export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
75export tagname=CC
76make install DESTDIR=$RPM_BUILD_ROOT LIBTOOL=/usr/bin/libtool
77unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
78
79# temporary hack to add missing semicolon, fix sent upstream
80#perl -pi -e 's/Categories=Application;Utility$/Categories=Application;Utility;/' $RPM_BUILD_ROOT%{_datadir}/applications/*
81
82desktop-file-install --vendor gnome --delete-original       \
83  --dir $RPM_BUILD_ROOT%{_datadir}/applications             \
84  --add-only-show-in GNOME                                  \
85  $RPM_BUILD_ROOT%{_datadir}/applications/*
86
87rm -rf $RPM_BUILD_ROOT%{_localstatedir}/scrollkeeper
88rm -f $RPM_BUILD_ROOT%{_libdir}/nautilus/extensions-2.0/lib*.*a
89
90rm -f $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/icon-theme.cache
91
92%find_lang %{name} --all-name --with-gnome
93
94%clean
95rm -rf $RPM_BUILD_ROOT
96
97%post
98update-desktop-database %{_datadir}/applications >& /dev/null ||:
99scrollkeeper-update > /dev/null 2>&1 || :
100export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
101gconftool-2 --makefile-install-rule   \
102    %{_sysconfdir}/gconf/schemas/file-roller.schemas > /dev/null
103
104touch --no-create %{_datadir}/icons/hicolor
105if [ -x /usr/bin/gtk-update-icon-cache ]; then
106  /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor ||:
107fi
108
109%pre
110if [ "$1" -gt 1 ]; then
111  export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
112  gconftool-2 --makefile-uninstall-rule   \
113      %{_sysconfdir}/gconf/schemas/file-roller.schemas > /dev/null
114fi
115
116%preun
117if [ "$1" -eq 0 ]; then
118  export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
119  gconftool-2 --makefile-uninstall-rule   \
120      %{_sysconfdir}/gconf/schemas/file-roller.schemas > /dev/null
121fi
122
123%postun
124update-desktop-database %{_datadir}/applications >& /dev/null ||:
125scrollkeeper-update > /dev/null 2>&1 || :
126touch --no-create %{_datadir}/icons/hicolor
127if [ -x /usr/bin/gtk-update-icon-cache ]; then
128  /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor ||:
129fi
130
131%files -f %{name}.lang
132%defattr(-, root, root)
133%doc README COPYING ChangeLog NEWS AUTHORS
134%{_sysconfdir}/gconf/schemas/*.schemas
135%{_bindir}/*
136%{_datadir}/applications/*
137%{_datadir}/file-roller
138%{_datadir}/icons/hicolor/*
139%{_libexecdir}/file-roller
140%{_libdir}/nautilus/extensions-2.0/libnautilus-fileroller.so
141
142%changelog
143* Fri Jul 15 2011 Kazutaka HARADA <kazutaka@vinelinux.org> 2.32.2-2
144- add Patch1 to fix non-translatable string
145- update Source4: file-roller-2-32.2-ja.po
146
147* Thu May 05 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.2-1
148- new upstream release
149
150* Sat Nov 20 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.1-1
151- new upstream release
152
153* Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0-1
154- new upstream release
155- remove Patch
156- drop Source1, Source2, Source3
157
158* Mon Aug 23 2010 Yasumichi Akahoshi <yasumichi@vinelinux.org> 2.30.2-3
159- add Source1-4
160
161* Sat Aug 21 2010 Yasumichi Akahoshi <yasumichi@vinelinux.org> 2.30.2-2
162- add patch from https://bugzilla.gnome.org/show_bug.cgi?id=627387
163
164* Tue Jun 29 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.2-1
165- new upstream release
166- add BuildRequires: docbook-dtds
167
168* Sat May 01 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-1
169- new upstream release
170
171* Sun Apr 18 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
172- new upstream release
173
174* Sat Mar 13 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.2-1
175- new upstream release
176- add BuildRequires: nautilus-devel, gnome-doc-utils, libSM-devel
177
178* Sun Nov  1 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.1-1
179- new upstream release
180
181* Sat Jul 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.3-1
182- new upstream release
183
184* Thu May 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-1
185- new upstream release
186
187* Sat Apr 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.1-1
188- new upstream release
189
190* Mon Mar 23 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
191- new upstream release
192- remove BR: libgnomeprint-devel, libgnomeprintui-devel
193
194* Mon Jan 19 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.24.3-1
195- new upstream release
196
197* Wed Oct 28 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.1-1
198- new upstream release
199
200* Fri Sep 26 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
201- new upstream release
202
203* Tue Apr 15 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.2-1vl5
204- new upstream release
205
206* Sun Apr  6 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.0-1vl5
207- new upstream release
208
209* Sun Dec 16 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.20.2-0vl1
210- new upstream release
211
212* Sun Aug 26 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.18.4-0vl1
213- new upstream release
214
215* Sat Apr 28 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl1
216- new upstream release
217
218* Sat Jun 03 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.3-0vl1
219- new upstream release
220
221* Wed Apr 12 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl1
222- new upstream release
223
224* Tue Mar 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl1
225- new upstream release
226
227* Wed Mar 08 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.92-0vl1
228- new upstream release
229
230* Sat Oct 08 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.1-0vl1
231- new upstream release
232
233* Mon Sep 19 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.0-0vl1
234- new upstream release
235
236* Tue Mar 22 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl1
237- new upstream version
238
239* Sun Feb 27 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.4-0vl1
240- new upsteram release
241
242* Thu Nov 18 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.3-0vl1
243- new upsteram release
244
245* Sun Jul 11 2004 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.4.4-0vl3
246- fix typo
247
248* Sun Feb 15 2004 Tomoya TAKA <taka@vinelinux.org> 2.4.4-0vl2
249- add Patch0 to fix segfaults on 64-bit architectures.
250
251* Sat Jan 31 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.4-0vl1
252- new upstream release
253
254* Wed Dec 24 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-0vl2
255- rebuild with new toolchain
256
257* Tue Dec 09 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-0vl1
258- new upstream release
259
260* Thu Sep 11 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl1
261- new upstream release
262
263* Wed Sep 03 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.6-0vl1
264- new upstream release
265
266* Tue Jun 24 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.4-0vl1
267- revert version to 2.2.4
268
269* Tue Jun 24 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.2-0vl2
270- rebuilt
271
272* Wed Jun 18 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.2-0vl2
273- new upstream release
274
275* Thu Jan 30 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.1-0vl1
276- new upstream release
277
278* Tue Jan 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl1
279- new upstream release
280
281* Fri Jan 10 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl1
282- new upstream release
283
284* Thu Jan  9 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.4-0vl1
285- new upstream release
286
287* Mon Dec  9 2002 Alexander Larsson <alexl@redhat.com> 2.1.3-3
288- fix server file path
289
290* Mon Dec  9 2002 Alexander Larsson <alexl@redhat.com> 2.1.3-2
291- Remove unpackaged files
292
293* Mon Dec  9 2002 Alexander Larsson <alexl@redhat.com> 2.1.3-1
294- Update to 2.1.3
295
296* Fri Dec  6 2002 Havoc Pennington <hp@redhat.com>
297- 2.1.2
298- fix unpackaged files
299
300* Wed Jul 31 2002 Havoc Pennington <hp@redhat.com>
301- fix URL field
302- put icon in file list
303- 2.0.0 stable release
304
305* Fri Jun 21 2002 Havoc Pennington <hp@redhat.com>
306- initial build
307
Note: See TracBrowser for help on using the repository browser.