source: projects/specs/branches/6/f/fcgi/fcgi-vl.spec @ 3281

Revision 3281, 4.8 KB checked in by iwaim, 13 years ago (diff)

fcgi-2.4.0-2vl6

Line 
1Summary:        FastCGI development kit
2Summary(ja):    FastCGI 開発キット
3Name:           fcgi
4Version:        2.4.0
5Release:        2%{?_dist_release}
6
7Group:          Development/Languages
8License:        BSD
9URL:            http://www.fastcgi.com/#TheDevKit
10Source0:        http://fastcgi.com/dist/fcgi-%{version}.tar.gz
11Source1:        fcgi-autogen.sh
12Patch0:         fcgi-2.4.0-autotools.patch
13# Patch0 created with Source1 after patching Patch1 and Patch2
14Patch1:         fcgi-2.4.0-configure.in.patch
15Patch2:         fcgi-2.4.0-Makefile.am-CPPFLAGS.patch
16Patch3:         fcgi-2.4.0-gcc44_fixes.patch
17BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
18
19# for -perl
20BuildRequires:  perl(ExtUtils::MakeMaker)
21
22# don't "provide" private Perl libs
23%global _use_internal_dependency_generator 0
24%global provfind /bin/sh -c "grep -v '%perl_vendorarch.*\\.so$' | %__find_provides"
25%global __find_provides %provfind
26
27%description
28FastCGI is a language independent, scalable, open extension to CGI that
29provides high performance without the limitations of server specific APIs.
30
31
32%package        devel
33Summary:        Development files for %{name}
34Summary(ja):        Development files for %{name}
35Group:          Development/Libraries
36Requires:       %{name} = %{version}-%{release}
37
38
39%description    devel
40The %{name}-devel package contains libraries and header files for
41developing applications that use %{name}.
42
43
44%package perl
45Summary:        Perl bindings for %{name}
46Summary(ja):        Perl bindings for %{name}
47Group:          Development/Libraries
48Requires:       %{name} = %{version}-%{release}
49Requires:  perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
50
51
52%description    perl
53The %{name}-perl package contains the perl bindings for fcgi.
54
55
56%prep
57%setup -q
58%patch0 -p1
59%patch3 -p1 -b .gcc44_fixes
60
61# remove DOS End Of Line Encoding
62sed -i 's/\r//' doc/fastcgi-prog-guide/ch2c.htm
63# fix file permissions
64chmod a-x include/fcgios.h libfcgi/os_unix.c
65
66
67%build
68%configure
69# does not build with parallel make flags
70make
71
72# build the perl bindings
73cd perl
74%{__perl} Makefile.PL INSTALLDIRS=vendor OPTIMIZE="$RPM_OPT_FLAGS"
75make %{?_smp_mflags}
76
77
78%install
79rm -rf $RPM_BUILD_ROOT
80mkdir $RPM_BUILD_ROOT
81
82make install DESTDIR=$RPM_BUILD_ROOT
83rm $RPM_BUILD_ROOT/%{_libdir}/libfcgi{++,}.{l,}a
84install -p -m 0644 -D doc/cgi-fcgi.1 $RPM_BUILD_ROOT%{_mandir}/man1/cgi-fcgi.1
85for manpage in doc/*.3
86do
87install -p -m 0644 -D $manpage $RPM_BUILD_ROOT%{_mandir}/man3/$(basename $manpage)
88done
89rm -f -- doc/*.1
90rm -f -- doc/*.3
91
92# install the perl bindings
93cd perl
94
95make pure_install PERL_INSTALL_ROOT=$RPM_BUILD_ROOT
96
97find $RPM_BUILD_ROOT -type f -name .packlist -exec rm -f {} ';'
98find $RPM_BUILD_ROOT -type f -name '*.bs' -a -size 0 -exec rm -f {} ';'
99find $RPM_BUILD_ROOT -depth -type d -exec rmdir {} 2>/dev/null ';'
100
101chmod -x *.fpl
102%{_fixperms} $RPM_BUILD_ROOT/%{perl_vendorarch}
103
104
105%post -p /sbin/ldconfig
106%postun -p /sbin/ldconfig
107
108
109%check
110# perl tests -- none presently, but that may change
111cd perl && make test
112
113
114%clean
115rm -rf $RPM_BUILD_ROOT
116
117
118%files
119%defattr(-,root,root,-)
120%{_bindir}/cgi-fcgi
121%{_libdir}/libfcgi.so.*
122%{_libdir}/libfcgi++.so.*
123%{_mandir}/man1/*
124%defattr(0644,root,root,0755)
125%doc LICENSE.TERMS README
126
127
128%files devel
129%defattr(-,root,root,-)
130%{_includedir}/*
131%{_libdir}/libfcgi.so
132%{_libdir}/libfcgi++.so
133%{_mandir}/man3/*
134%exclude %{_mandir}/man3/*.3pm*
135%defattr(0644,root,root,0755)
136%doc doc/
137
138
139%files perl
140%defattr(-,root,root,-)
141%{perl_vendorarch}/*
142%exclude %dir %{perl_vendorarch}/auto
143%{_mandir}/man3/*.3pm*
144%defattr(0644,root,root,0755)
145%doc perl/ChangeLog perl/README perl/*.fpl
146
147
148%changelog
149* Sun Apr  3 2011 IWAI, Masaharu <iwai@alib.jp> 2.4.0-2vl6
150- build with perl 5.12.3
151
152* Sat Jul 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-1
153- initial build for Vine Linux
154
155* Sun Mar 01 2009 Chris Weyl <cweyl@alumni.drew.edu> - 2.4.0-9
156- Stripping bad provides of private Perl extension libs
157
158* Tue Feb 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.4.0-8
159- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
160
161* Sun Feb 15 2009 Till Maas <opensource@till.name> - 2.4.0-7
162- Add missing #include <cstdio> to make it compile with gcc 4.4
163
164* Tue Oct 14 2008 Chris Weyl <cweyl@alumni.drew.edu> - 2.4.0-6
165- package up the perl bindings in their own subpackage
166
167* Wed Feb 20 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 2.4.0-5
168- Autorebuild for GCC 4.3
169
170* Thu Aug 23 2007 Till Maas <opensource till name> - 2.4.0-4
171- bump release for rebuild
172
173* Tue Jul 11 2007 Till Maas <opensource till name> - 2.4.0-3
174- remove parallel make flags
175
176* Tue Apr 17 2007 Till Maas <opensource till name> - 2.4.0-2
177- add some documentation
178- add mkdir ${RPM_BUILD_ROOT} to %%install
179- install man-pages
180
181* Mon Mar 5 2007 Till Maas <opensource till name> - 2.4.0-1
182- Initial spec for fedora
Note: See TracBrowser for help on using the repository browser.