source: projects/specs/branches/6/f/farsight2/farsight2-vl.spec @ 1978

Revision 1978, 5.5 KB checked in by owa, 14 years ago (diff)

rebuilt with rpm-4.8.1

Line 
1%{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
2
3%define gst_ver 0.10.23
4%define gst_plugins_base_ver 0.10.23
5%define gst_plugins_good 0.10.7
6%define gst_python 0.10.10
7
8Name:           farsight2
9Version:        0.0.17
10Release:        2%{?_dist_release}
11Summary:        Libraries for videoconferencing
12Summary(ja):    ビデオ会議のためのライブラリ
13
14Group:          System Environment/Libraries
15License:        LGPLv2+
16URL:            http://farsight.freedesktop.org/wiki/
17Source0:        http://farsight.freedesktop.org/releases/%{name}/%{name}-%{version}.tar.gz
18BuildRoot:      %{_tmppath}/%{name}-%{version}-root
19
20BuildRequires:  glib2-devel >= 2.14
21BuildRequires:  gstreamer-devel >= %{gst_ver}
22BuildRequires:  gstreamer-plugins-base-devel >= %{gst_plugins_base_ver}
23BuildRequires:  gstreamer-python >= %{gst_python}
24BuildRequires:  libnice-devel >= 0.0.9
25BuildRequires:  gupnp-devel
26BuildRequires:  gupnp-igd-devel
27BuildRequires:  python-devel
28BuildRequires:  pygobject-devel
29
30Requires:       gstreamer-plugins-good >= %{gst_plugins_good}
31
32
33%description
34%{name} is a collection of GStreamer modules and libraries for
35videoconferencing.
36
37
38%package        python
39Summary:        Python binding for %{name}
40Group:          Development/Libraries
41Requires:       %{name} = %{version}-%{release}
42
43%description    python
44Python bindings for %{name}.
45
46
47%package        devel
48Summary:        Development files for %{name}
49Group:          Development/Libraries
50Requires:       %{name} = %{version}-%{release}
51Requires:       %{name}-python = %{version}-%{release}
52Requires:       gstreamer-devel  >= %{gst_ver}
53Requires:       gstreamer-plugins-base-devel >= %{gst_plugins_base_ver}
54Requires:       pkgconfig
55
56
57%description    devel
58The %{name}-devel package contains libraries and header files for
59developing applications that use %{name}.
60
61%prep
62%setup -q
63
64%build
65%configure                                                              \
66  --with-package-name='Vine Linux farsight2 package'                    \
67  --disable-static
68
69sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
70sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
71make %{?_smp_mflags}
72
73
74%install
75rm -rf $RPM_BUILD_ROOT
76make install DESTDIR=$RPM_BUILD_ROOT INSTALL="install -p"
77find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
78
79%clean
80rm -rf $RPM_BUILD_ROOT
81
82%post -p /sbin/ldconfig
83
84%postun -p /sbin/ldconfig
85
86
87%files
88%defattr(-,root,root,-)
89%doc COPYING
90%{_libdir}/*.so.*
91%dir %{_libdir}/%{name}-0.0
92%{_libdir}/%{name}-0.0/libmulticast-transmitter.so
93%{_libdir}/%{name}-0.0/librawudp-transmitter.so
94%{_libdir}/%{name}-0.0/libnice-transmitter.so
95%{_libdir}/gstreamer-0.10/libfsfunnel.so
96%{_libdir}/gstreamer-0.10/libfsrtpconference.so
97%{_libdir}/gstreamer-0.10/libfsvideoanyrate.so
98%{_libdir}/gstreamer-0.10/libfsrtcpfilter.so
99%{_libdir}/gstreamer-0.10/libfsmsnconference.so
100
101%files python
102%defattr(-,root,root,-)
103%{python_sitearch}/farsight.so
104
105%files devel
106%defattr(-,root,root,-)
107%{_libdir}/libgstfarsight-0.10.so
108%{_libdir}/pkgconfig/%{name}-0.10.pc
109%{_includedir}/gstreamer-0.10/gst/farsight/
110%{_datadir}/gtk-doc/html/%{name}-libs-0.10
111%{_datadir}/gtk-doc/html/%{name}-plugins-0.10
112
113
114%changelog
115* Sat Oct 02 2010 Shu KONNO <owa@bg.wakwak.com> 0.0.17-2
116- rebuilt with rpm-4.8.1 for pkg-config
117- added BR: gupnp-devel
118
119* Sat Feb 06 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 0.0.17-1
120- new upstream release
121
122* Tue Feb 02 2010 Shu KONNO <owa@bg.wakwak.com> 0.0.16-3
123- rebuild with python-2.6
124
125* Sat Nov  7 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 0.0.16-2
126- initial build for Vine Linux
127
128* Tue Oct  6 2009 Brian Pepple <bpepple@fedoraproject.org> - 0.0.16-1
129- Update to 0.0.16.
130
131* Thu Sep 17 2009 Bastien Nocera <bnocera@redhat.com> 0.0.15-2
132- Rebuild for new gupnp
133
134* Thu Sep  3 2009 Brian Pepple <bpepple@fedoraproject.org> - 0.0.15-1
135- Update to 0.0.15.
136
137* Thu Aug 06 2009 Warren Togami <wtogami@redhat.com> - 0.0.14-1
138- 0.0.14
139
140* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.0.12-4
141- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
142
143* Wed Jul 22 2009 Warren Togami <wtogami@redhat.com> - 0.0.12-3
144- rebuild
145
146* Mon Jun 22 2009 Brian Pepple <bpepple@fedoraproject.org> - 0.0.12-2
147- Remove unnecessary requires on gst-plugins-farsight.
148
149* Sat May 30 2009 Brian Pepple <bpepple@fedoraproject.org> - 0.0.12-1
150- Update to 0.0.12.
151
152* Tue May 26 2009 Brian Pepple <bpepple@fedoraproject.org> - 0.0.11-1
153- Update to 0.0.11.
154
155* Wed May 20 2009 Brian Pepple <bpepple@fedoraproject.org> - 0.0.10-1
156- Update to 0.0.10.
157
158* Tue Apr  7 2009 Brian Pepple <bpepple@fedoraproject.org> - 0.0.9-1
159- Update to 0.0.9.
160
161* Tue Mar 17 2009 Brian Pepple <bpepple@fedoraproject.org> - 0.0.8-1
162- Update to 0.0.8.
163- Bump min version of gstreamer needed.
164
165* Tue Feb 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.0.7-3
166- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
167
168* Mon Jan 19 2009 Brian Pepple <bpepple@fedoraproject.org> - 0.0.7-2
169- Add BR on gupnp-igd-devel, pygobject2-devel, and pygtk2-devel.
170
171* Fri Jan  9 2009 Brian Pepple <bpepple@fedoraproject.org> - 0.0.7-1
172- Update to 0.0.7.
173
174* Mon Jan  5 2009 Brian Pepple <bpepple@fedoraproject.org> - 0.0.6-4
175- Add BR on libnice-devel and build libnice transmitter.
176- Set gstreamer package name & origin.
177
178* Fri Jan 02 2009 Brian Pepple <bpepple@fedoraproject.org> - 0.0.6-3
179- Rebuild.
180
181* Wed Dec 31 2008 Brian Pepple <bpepple@fedoraproject.org> - 0.0.6-2
182- Preserve time stamps.
183
184* Tue Dec 16 2008 Brian Pepple <bpepple@fedoraproject.org> - 0.0.6-1
185- Initial Fedora spec.
Note: See TracBrowser for help on using the repository browser.