source: projects/specs/branches/6/e/expect/expect-vl.spec @ 3561

Revision 3561, 8.7 KB checked in by shaolin, 13 years ago (diff)
Line 
1%define tcl_major 8.4
2%define thread_major 2.5
3%define majorver 5.43
4
5Summary: A Tcl/Tk development environment: expect
6Summary(ja): Tcl/Tk 開発環境: expect
7Name: expect
8Version: %{majorver}.0
9Release: 5%{?_dist_release}
10Group: Development/Languages
11URL: http://expect.nist.gov/
12License: BSD
13Source0: http://expect.nist.gov/src/%{name}-%{version}.tar.gz
14Patch0: expect-5.32.2-random.patch
15Patch6: expect-5.38.0-spawn-43310.patch
16Patch8: expect-5.32.2-setpgrp.patch
17Patch10: expect-5.38.0-lib-spec.patch
18Patch11: expect-5.39.0-libdir.patch
19
20Buildroot: %{_tmppath}/%{name}-%{version}-root
21BuildRequires: tcl >= %{tcl_major}
22BuildRequires: thread >= %{thread_major}
23BuildRequires: autoconf213
24BuildRequires: libX11-devel
25
26%description -n expect
27Expect is a tcl extension for automating interactive applications such
28as telnet, ftp, passwd, fsck, rlogin, tip, etc.  Expect is also useful
29for testing the named applications.  Expect makes it easy for a script
30to control another program and interact with it.
31
32Install the expect package if you'd like to develop scripts which interact
33with interactive applications.  You'll also need to install the tcl
34package.
35
36%package devel
37Summary: Development files for expect library.
38Group: Development/Libraries
39Requires: expect = %{version}-%{release}
40Obsoletes: expect <= 5.43-0vl4
41
42%description devel
43This package contains development files for the expect library.
44
45%package -n expectk
46Summary: expectk and some scripts
47Group: Development/Languages
48Requires: expect = %{version}-%{release}
49Obsoletes: expect <= 5.43-0vl4
50
51%description -n expectk
52This package contains expectk and some scripts that use it.
53
54%prep
55%setup -q -n %{name}-%{majorver}
56%patch0 -p1 -b .random
57%patch6 -p2 -b .spawn
58%patch8 -p2 -b .pgrp
59%patch10 -p1 -b .libspec
60%patch11 -p1 -b .libdir
61
62# patch10 touch configure.in
63autoconf-2.13
64
65%build
66%configure --enable-64bit \
67        --with-tcl=%{_libdir} --with-tk=%{_libdir} \
68        --with-tclinclude=%{_includedir}/tcl-private/generic \
69        --with-tkinclude=%{_includedir}/tk-private/generic \
70        --enable-shared --enable-threads --with-x=yes --enable-gcc
71make
72
73%install
74rm -rf ${RPM_BUILD_ROOT}
75mkdir -p ${RPM_BUILD_ROOT}
76make INSTALL_ROOT=%{buildroot} install
77
78# for linking with -lexpect
79ln -s libexpect%{majorver}.so "$RPM_BUILD_ROOT"%{_libdir}/libexpect.so
80
81# remove cryptdir/decryptdir, as Linux has no crypt command (bug 6668).
82rm -f "$RPM_BUILD_ROOT"%{_bindir}/{cryptdir,decryptdir}
83rm -f "$RPM_BUILD_ROOT"%{_mandir}/man1/{cryptdir,decryptdir}.1*
84rm -f "$RPM_BUILD_ROOT"%{_bindir}/autopasswd
85
86%post -p /sbin/ldconfig -n expect
87
88%postun -p /sbin/ldconfig -n expect
89
90%clean
91rm -rf $RPM_BUILD_ROOT
92
93%files
94%%defattr(-,root,root)
95%doc FAQ HISTORY NEWS README
96%{_bindir}/expect
97%{_bindir}/autoexpect
98%{_bindir}/dislocate
99%{_bindir}/ftp-rfc
100%{_bindir}/kibitz
101%{_bindir}/lpunlock
102%{_bindir}/mkpasswd
103%{_bindir}/passmass
104%{_bindir}/rftp
105%{_bindir}/rlogin-cwd
106%{_bindir}/timed-read
107%{_bindir}/timed-run
108%{_bindir}/unbuffer
109%{_bindir}/weather
110%{_bindir}/xkibitz
111%dir %{_libdir}/expect%{majorver}
112%{_libdir}/expect%{majorver}/pkgIndex.tcl
113%{_libdir}/libexpect%{majorver}.so
114%{_mandir}/man1/autoexpect.1.gz
115%{_mandir}/man1/dislocate.1.gz
116%{_mandir}/man1/expect.1.gz
117%{_mandir}/man1/kibitz.1.gz
118%{_mandir}/man1/mkpasswd.1.gz
119%{_mandir}/man1/passmass.1.gz
120%{_mandir}/man1/tknewsbiff.1.gz
121%{_mandir}/man1/unbuffer.1.gz
122%{_mandir}/man1/xkibitz.1.gz
123
124%files devel
125%defattr(-,root,root,-)
126%exclude %{_libdir}/expect%{majorver}/libexpect%{majorver}.a
127%exclude %{_libdir}/libexpect%{majorver}.a
128%{_libdir}/libexpect.so
129%{_mandir}/man3/libexpect.3*
130%{_includedir}/*
131
132%files -n expectk
133%defattr(-,root,root,-)
134%{_bindir}/expectk
135%{_bindir}/multixterm
136%{_bindir}/tknewsbiff
137%{_bindir}/tkpasswd
138%{_bindir}/xpstat
139%{_mandir}/man1/expectk.1*
140%{_mandir}/man1/multixterm.1*
141%{_mandir}/man1/tknewsbiff.1*
142
143
144%changelog
145* Tue Apr 19 2011 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 5.43-5
146- add missing BuildRequires: libX11-devel
147
148* Sat Apr 16 2011 Shu KONNO <owa@bg.wakwak.com> 5.43-4
149- rebuilt with rpm-4.8.1-3
150
151* Tue Jun 29 2010 Shu KONNO <owa@bg.wakwak.com> 5.43-3
152- rebuilt with tcl/tk-8.4.19-2
153
154* Tue May 18 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 5.43-2
155- rebuilt with new toolchain
156- changed devel Group to Development/Libraries
157
158* Sun Jul 27 2008 Shu KONNO <owa@bg.wakwak.com> 5.43-1vl5
159- applied new versioning policy and spec in utf-8
160
161* Sun Feb 17 2008 Shu KONNO <owa@bg.wakwak.com> 5.43-0vl6
162- rebuilt with tcl/tk-8.4.18
163
164* Fri Nov 09 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 5.43-0vl5
165- split to expect-devel and expectk sub package.
166- add libexpect.so to expect-devel (<BTS:wishes:0136>)
167
168* Tue Oct 09 2007 Shu KONNO <owa@bg.wakwak.com> 5.43-0vl4
169- rebuilt with tcl/tk-8.4.16
170
171* Wed Jun 13 2007 Shu KONNO <owa@bg.wakwak.com> 5.43-0vl3
172- rebuilt with new toolchain
173
174* Sun Jan 29 2006 Shu KONNO <owa@bg.wakwak.com> 5.43-0vl2
175- rebuild for tcl/tk-8.4.12
176- added --enable-64bit to configure's option
177
178* Fri Sep 09 2005 Shu KONNO <owa@bg.wakwak.com> 5.43-0vl1
179- updated expect to 5.43.0
180- dropped expect-5.39.0-64bit-82547.patch (for fixed)
181- dropped expect-5.32.2-kibitz.patch (for fixed)
182- dropped expect-5.38.0-autopasswd-9917.patch (for fixed)
183- rebuilt with tcl/tk 8.4.11
184
185* Wed Jun 30 2004 Shu KONNO <owa@bg.wakwak.com> 5.39-95vl2
186- rebuild for tcl/tk-8.4.6
187
188* Mon Jan 12 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 5.39-95vl1
189- update based on fedora
190
191* Mon Mar 31 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 8.4.2-0vl1
192- update based on BitWalk's tcltk-8.4.2-83bw and RawHide tcltk-8.3.5-89
193
194* Thu Nov 15 2001 Kazuhusa TAKEI <takei@linux.or.jp> 8.0.5_jp-10vl3
195- splite source package
196- add include files
197
198* Sun Jul 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 8.0.5_jp-10vl2
199- expand some macros.. (FIXME)
200
201* Sat Jul 14 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 8.0.5_jp-10vl1
202- use %configure macros
203- add Patch 47,50
204
205* Thu May 31 2001 <sagami@vinelinux.org>
206- 8.0.5_jp-10
207- unexpand old %%{configure}, new one causes build failure
208- fixed missing libtkx.so libtclx.so symlink in /usr/lib
209- install manpages into %%{_mandir} and mode 644
210
211* Wed Jul 19 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
212- 8.0.5_jp-9
213- modified %install section to handle compressed man pages
214- fixed /usr/lib/tk8.0jp/demos.jp/images symlink
215
216* Sun Jul  2 2000 Daisuke SUZUKI <daisuke@linux.or.jp>
217- changed default fonts
218
219* Tue Jan 25 2000 Jun Nishii <jun@vinelinux.org>
220- added defattr
221
222* Mon Jan 24 2000 Jun Nishii <jun@vinelinux.org>
223- added some symlinks, such as libtcl8.0.so.
224- obsoletes version number using _jp, now 8.0.5-31vl1
225
226* Wed Jan 5 2000 Norihito Ohmori <nono@vinelinux.org>
227- Apply Tcl/Tk 8.0 Japanese Patch 1.7
228
229* Tue Nov 30 1999 Jakub Jelinek <jakub@redhat.com>
230- fix tclX symlinks.
231- compile on systems where SIGPWR == SIGLOST.
232
233* Sat May  1 1999 Jeff Johnson <jbj@redhat.com>
234- update tcl/tk to 8.0.5.
235- avoid "containing" in Tix (#2332).
236
237* Thu Apr  8 1999 Jeff Johnson <jbj@redhat.com>
238- use /usr/bin/write in kibitz (#1320).
239- use cirrus.sprl.umich.edu in weather (#1926).
240
241* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
242- auto rebuild in the new build environment (release 28)
243
244* Mon Mar 08 1999 Preston Brown <pbrown@redhat.com>
245- whoops, exec-prefix for itcl was set to '/foo', changed to '/usr'.
246
247* Tue Feb 16 1999 Jeff Johnson <jbj@redhat.com>
248- expect does unaligned access on alpha (#989)
249- upgrade tcl/tk/tclX to 8.0.4
250- upgrade expect to 5.28.
251- add itcl 3.0.1
252
253* Tue Jan 12 1999 Cristian Gafton <gafton@redhat.com>
254- call libtoolize to allow building on the arm
255- build for glibc 2.1
256- strip binaries
257
258* Thu Sep 10 1998 Jeff Johnson <jbj@redhat.com>
259- update tcl/tk/tclX to 8.0.3, expect is updated also.
260
261* Mon Jun 29 1998 Jeff Johnson <jbj@redhat.com>
262- expect: mkpasswd needs delay before sending password (problem #576)
263
264* Thu May 07 1998 Prospector System <bugs@redhat.com>
265- translations modified for de, fr, tr
266
267* Sat May 02 1998 Cristian Gafton <gafton@redhat.com>
268- fixed expect binaries exec permissions
269
270* Thu Apr 09 1998 Erik Troan <ewt@redhat.com>
271- updated to Tix 4.1.0.006
272- updated version numbers of tcl/tk to relflect includsion of p2
273
274* Wed Mar 25 1998 Cristian Gafton <gafton@redhat.com>
275- updated tcl/tk to patch level 2
276- updated tclX to 8.0.2
277
278* Thu Oct 30 1997 Otto Hammersmith <otto@redhat.com>
279- fixed filelist for tix... replacing path to the expect binary in scripts
280  was leaving junk files around.
281
282* Wed Oct 22 1997 Otto Hammersmith <otto@redhat.com>
283- added patch to remove libieee test in configure.in for tcl and tk.
284  Shoudln't be needed anymore for glibc systems, but this isn't the "proper"
285  solution for all systems
286- fixed src urls
287
288* Mon Oct 06 1997 Erik Troan <ewt@redhat.com>
289- removed version numbers from descriptions
290
291* Mon Sep 22 1997 Erik Troan <ewt@redhat.com>
292- updated to tcl/tk 8.0 and related versions of packages
293
294* Tue Jun 17 1997 Erik Troan <ewt@redhat.com>
295- built against glibc
296- fixed dangling tclx/tkx symlinks
Note: See TracBrowser for help on using the repository browser.