source: projects/specs/branches/6/e/evolution-data-server/evolution-data-server-vl.spec @ 3801

Revision 3801, 25.1 KB checked in by Takemikaduchi, 13 years ago (diff)

GNOME packages: new upstream release, bogofilter: fix perl requirements, perl-modules: new package

Line 
1%define use_nss 1
2%define ldap_support 1
3%define static_ldap 1
4%define krb5_support 1
5%define nntp_support 1
6
7%define glib2_version 2.28.4
8%define gtk2_version 2.24.3
9%define gtk_doc_version 1.14
10%define intltool_version 0.35.5
11%define orbit2_version 2.14.19
12%define soup_version 2.32.0
13%define libgweather_version 2.30.3
14%define libical_version 0.44
15%define libgdata_version 0.6.5
16
17%define eds_base_version 2.32
18%define eds_api_version 1.2
19
20%define use_gnome_keyring 1
21%define support_imap4_provider 0
22
23%define camel_provider_dir %{_libdir}/evolution-data-server-%{eds_api_version}/camel-providers
24%define eds_extensions_dir %{_libdir}/evolution-data-server-%{eds_api_version}/extensions
25
26# Use stricter build settings than required by upstream.
27%define strict_build_settings 1
28
29### Abstract ###
30
31Summary: Backend data server for evolution
32Summary(ja): Evolution バックエンドデータサーバ
33Name: evolution-data-server
34Version: 2.32.3
35Release: 1%{?_dist_release}
36License: LGPL
37Group: System Environment/Libraries
38URL: http://www.gnome.org/projects/evolution/
39Source0: http://ftp.gnome.org/pub/GNOME/sources/evolution-data-server/2.32/%{name}-%{version}.tar.bz2
40BuildRoot: %{_tmppath}/%{name}-%{version}-root
41
42### Patches ###
43
44# RH bug #215702 / GNOME bug #487988
45Patch10: evolution-data-server-1.8.0-fix-ldap-query.patch
46
47# GNOME bug #373146
48Patch11: evolution-data-server-1.10.1-camel-folder-summary-crash.patch
49
50# RH bug #243296
51Patch12: evolution-data-server-1.11.5-fix-64bit-acinclude.patch
52
53### Dependencies ###
54
55Requires: GConf2
56Requires: ORBit2 >= %{orbit2_version}
57Requires: libsoup >= %{soup_version}
58
59### Build Dependencies ###
60
61BuildRequires: GConf2-devel
62BuildRequires: ORBit2-devel >= %{orbit2_version}
63BuildRequires: bison
64BuildRequires: db4-devel
65BuildRequires: flex
66BuildRequires: gettext
67BuildRequires: glib2-devel
68BuildRequires: gnutls-devel
69BuildRequires: intltool >= %{intltool_version}
70BuildRequires: libsoup-devel >= %{soup_version}
71BuildRequires: libtool
72BuildRequires: libgnome-keyring-devel
73BuildRequires: gtk-doc >= 1.14
74BuildRequires: sqlite3-devel
75BuildRequires: libgweather-devel >= %{libgweather_version}
76BuildRequires: libical-devel >= %{libical_version}
77BuildRequires: gperf
78BuildRequires: libgdata-devel >= %{libgdata_version}
79
80%if %{use_nss}
81BuildRequires: nspr-devel
82BuildRequires: nss-devel
83%else
84BuildRequires: openssl-devel
85%endif
86
87%if %{ldap_support}
88%if %{static_ldap}
89BuildRequires: openldap-evolution-devel
90BuildRequires: openssl-devel
91%else
92BuildRequires: openldap-devel >= 2.0.11
93%endif
94%endif
95
96%if %{krb5_support}
97BuildRequires: krb5-devel
98# tweak for krb5 1.2 vs 1.3
99%define krb5dir /usr/kerberos
100#define krb5dir `pwd`/krb5-fakeprefix
101%endif
102
103%description
104The evolution-data-server package provides a unified backend for
105programs that work with contacts, tasks, and calendar information.
106
107It was originally developed for Evolution (hence the name), but
108is now used by other packages.
109
110%package devel
111Summary: Development files for building against evolution-data-server
112Group: Development/Libraries
113Requires: %{name} = %{version}-%{release}
114Requires: libgnome-devel
115Requires: libgweather-devel
116Requires: libsoup-devel
117Requires: libical-devel >= %{libical_version}
118Requires: sqlite3-devel
119%if %{use_nss}
120Requires: nspr-devel
121Requires: nss-devel
122%endif
123
124%description devel
125Development files needed for building things which link against
126evolution-data-server.
127
128%package doc
129Summary: Documentation files for %{name}
130Group: Applications/Documentation
131
132%description doc
133This package contains developer documentation for %{name}.
134
135%prep
136%setup -q
137
138## %patch10 -p1 -b .fix-ldap-query
139##%patch11 -p1 -b .camel-folder-summary-crash
140%patch12 -p1 -b .fix-64bit-acinclude
141
142mkdir -p krb5-fakeprefix/include
143mkdir -p krb5-fakeprefix/lib
144mkdir -p krb5-fakeprefix/%{_lib}
145
146%build
147%if %{ldap_support}
148
149%if %{static_ldap}
150%define ldap_flags --with-openldap=%{_libdir}/evolution-openldap --with-static-ldap
151# Set LIBS so that configure will be able to link with static LDAP libraries,
152# which depend on Cyrus SASL and OpenSSL.  XXX Is the "else" clause necessary?
153if pkg-config libssl ; then
154        export LIBS="-lsasl2 `pkg-config --libs libssl`"
155else
156        export LIBS="-lsasl2 -lssl -lcrypto"
157fi
158%else
159%define ldap_flags --with-openldap=yes
160%endif
161
162%else
163%define ldap_flags --without-openldap
164%endif
165
166%if %{krb5_support}
167%define krb5_flags --with-krb5=%{krb5dir} --with-krb5-libs=%{_libdir} --with-krb5-includes=%{_includedir}
168%else
169%define krb5_flags --without-krb5
170%endif
171
172%if %{nntp_support}
173%define nntp_flags --enable-nntp=yes
174%else
175%define nntp_flags --enable-nntp=no
176%endif
177
178%if %{use_nss}
179%define ssl_flags --enable-nss=yes --enable-smime=yes
180%else
181%define ssl_flags --enable-openssl=yes
182%endif
183
184%if %{use_nss}
185if ! pkg-config --exists nss; then
186  echo "Unable to find suitable version of nss to use!"
187  exit 1
188fi
189%endif
190
191%if %{use_gnome_keyring}
192%define keyring_flags --enable-gnome-keyring
193%else
194%define keyring flags --disable-gnome-keyring
195%endif
196
197%if %{support_imap4_provider}
198%define imap4_flags --enable-imap4=yes
199%else
200%define imap4_flags --enable-imap4=no
201%endif
202
203export CPPFLAGS="-I%{_includedir}/et"
204export CFLAGS="$RPM_OPT_FLAGS -DLDAP_DEPRECATED -fPIC -I%{_includedir}/et"
205%if ! %{use_nss}
206if pkg-config openssl ; then
207        CFLAGS="$CFLAGS `pkg-config --cflags openssl`"
208        LDFLAGS="$LDFLAGS `pkg-config --libs-only-L openssl`"
209fi
210%endif
211
212# Add stricter build settings here as the source code gets cleaned up.
213# We want to make sure things like compiler warnings and avoiding deprecated
214# functions in the GNOME/GTK+ libraries stay fixed.
215#
216# Please file a bug report at bugzilla.gnome.org if these settings break
217# compilation, and encourage the upstream developers to use them.
218
219%if %{strict_build_settings}
220CFLAGS="$CFLAGS \
221        -DG_DISABLE_DEPRECATED=1 \
222        -DPANGO_DISABLE_DEPRECATED=1 \
223        -DGDK_PIXBUF_DISABLE_DEPRECATED=1 \
224        -DGDK_DISABLE_DEPRECATED=1 \
225        -Wdeclaration-after-statement \
226        -Werror-implicit-function-declaration"
227%endif
228
229# Regenerate configure to pick up configure.in and acinclude.m4 changes.
230aclocal -I m4
231autoheader
232automake
233libtoolize
234intltoolize --force
235autoconf
236
237# See Ross Burton's blog entry for why we want --with-libdb.
238# http://www.burtonini.com/blog//computers/eds-libdb-2006-07-18-10-40
239 
240# need to build with gtk2-2.24.x
241sed -i -e "s:-DGTK_DISABLE_DEPRECATED::" configure
242
243%configure \
244        --with-libdb=/usr \
245        --enable-file-locking=fcntl \
246        --enable-dot-locking=no \
247        --enable-gtk-doc \
248        %ldap_flags %krb5_flags %nntp_flags %ssl_flags %imap4_flags \
249        %keyring_flags
250export tagname=CC
251make %{?_smp_mflags} LIBTOOL=/usr/bin/libtool
252
253%install
254rm -rf $RPM_BUILD_ROOT
255export tagname=CC
256make DESTDIR=$RPM_BUILD_ROOT LIBTOOL=/usr/bin/libtool install
257
258# remove libtool archives for importers and the like
259find $RPM_BUILD_ROOT/%{_libdir} -name '*.la' -exec rm {} \;
260rm -f $RPM_BUILD_ROOT/%{_libdir}/*.a
261rm -f $RPM_BUILD_ROOT/%{_libdir}/evolution-data-server-%{eds_api_version}/camel-providers/*.a
262rm -f $RPM_BUILD_ROOT/%{_libdir}/evolution-data-server-%{eds_api_version}/extensions/*.a
263
264# give the libraries some executable bits
265find $RPM_BUILD_ROOT -name '*.so.*' -exec chmod +x {} \;
266
267%find_lang %{name}-%{eds_base_version}
268
269%clean
270rm -rf $RPM_BUILD_ROOT
271
272%post -p /sbin/ldconfig
273
274%postun -p /sbin/ldconfig
275
276%files -f %{name}-%{eds_base_version}.lang
277%defattr(-,root,root,-)
278%doc README COPYING ChangeLog NEWS AUTHORS
279%{_libdir}/*.so.*
280%{_libexecdir}/e-addressbook-factory
281%{_libexecdir}/e-calendar-factory
282%{_libexecdir}/camel-index-control-%{eds_api_version}
283%{_libexecdir}/camel-lock-helper-%{eds_api_version}
284%{_datadir}/evolution-data-server-%{eds_base_version}
285## %{_datadir}/idl/evolution-data-server-%{eds_api_version}
286%{_datadir}/pixmaps/evolution-data-server
287#{_libdir}/evolution-data-server-%{eds_api_version}
288%{_datadir}/dbus-1/services/*
289
290%dir %{_libdir}/evolution-data-server-%{eds_api_version}
291%dir %{camel_provider_dir}
292%dir %{eds_extensions_dir}
293
294# Camel providers:
295%{camel_provider_dir}/libcamelgroupwise.so
296%{camel_provider_dir}/libcamelgroupwise.urls
297
298%{camel_provider_dir}/libcamelimap.so
299%{camel_provider_dir}/libcamelimap.urls
300
301%if %{support_imap4_provider}
302%{camel_provider_dir}/libcamelimap4.so
303%{camel_provider_dir}/libcamelimap4.urls
304%endif
305
306%{camel_provider_dir}/libcamellocal.so
307%{camel_provider_dir}/libcamellocal.urls
308
309%{camel_provider_dir}/libcamelnntp.so
310%{camel_provider_dir}/libcamelnntp.urls
311
312%{camel_provider_dir}/libcamelpop3.so
313%{camel_provider_dir}/libcamelpop3.urls
314
315%{camel_provider_dir}/libcamelsendmail.so
316%{camel_provider_dir}/libcamelsendmail.urls
317
318%{camel_provider_dir}/libcamelsmtp.so
319%{camel_provider_dir}/libcamelsmtp.urls
320
321%{camel_provider_dir}/libcamelimapx.so
322%{camel_provider_dir}/libcamelimapx.urls
323
324# e-d-s extensions:
325%{eds_extensions_dir}/libebookbackendfile.so
326%{eds_extensions_dir}/libebookbackendgoogle.so
327%{eds_extensions_dir}/libebookbackendgroupwise.so
328%{eds_extensions_dir}/libebookbackendldap.so
329%{eds_extensions_dir}/libebookbackendvcf.so
330%{eds_extensions_dir}/libebookbackendwebdav.so
331%{eds_extensions_dir}/libecalbackendcontacts.so
332%{eds_extensions_dir}/libecalbackendfile.so
333%{eds_extensions_dir}/libecalbackendgroupwise.so
334%{eds_extensions_dir}/libecalbackendhttp.so
335%{eds_extensions_dir}/libecalbackendweather.so
336%{eds_extensions_dir}/libecalbackendcaldav.so
337## %{eds_extensions_dir}/libecalbackendgoogle.so
338
339%files devel
340%defattr(-,root,root,-)
341%{_includedir}/evolution-data-server-%{eds_base_version}
342%{_libdir}/*.so
343%{_libdir}/pkgconfig/*.pc
344
345%files doc
346%defattr(-,root,root,-)
347%{_datadir}/gtk-doc/html/camel
348%{_datadir}/gtk-doc/html/libebackend
349%{_datadir}/gtk-doc/html/libebook
350%{_datadir}/gtk-doc/html/libecal
351%{_datadir}/gtk-doc/html/libedata-book
352%{_datadir}/gtk-doc/html/libedata-cal
353%{_datadir}/gtk-doc/html/libedataserver
354%{_datadir}/gtk-doc/html/libedataserverui
355
356%changelog
357* Thu May 05 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.3-1
358- new upstream release
359
360* Wed Mar 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.2-2
361- rebuild with krb5-libs-1.8.2
362
363* Tue Feb 08 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.2-1
364- new upstream release
365
366* Mon Jan 10 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.1-2
367- rebuild with openssl-1.0.0c
368
369* Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0-1
370- new upstream release
371- remove Requires: gnome-vfs2, libglade2, libgnomeui
372- remove BuildRequires: gnome-vfs2-devel, libglade2-devel, libgnomeui-devel
373- add BuildRequires: libgdata
374- add Requires: nspr-devel, nss-devel (devel package)
375- drop Patch11
376
377* Thu Sep 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.2-2
378- rebuild with rpm-4.8.1 for pkg-config file
379
380* Mon Jun 21 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.2-1
381- new upstream release
382
383* Sat May 01 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-1
384- new upstream release
385
386* Fri Apr 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
387- new upstream release
388- remove BuildRequires: libbonobo-devel
389- remove Requires: libbonobo
390- drop Patch10
391- add configure option (--with-krb5-libs, --with-krb5-includes)
392
393* Thu Feb 11 2010 NAKAMURA Kenta <kenta@vinelinux.org> 2.28.1-2
394- rebuilt with db4-4.8
395
396* Sat Oct 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.1-1
397- new upstream release
398
399* Sat Jul 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.3-1
400- new upstream release
401
402* Thu May 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-1
403- new upstream release
404
405* Sat Apr 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.1.1-1
406- new upstream release
407
408* Sat Apr  4 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.26.0-2
409- added Requires: libical-devel >= 0.43 to devel package
410
411* Sat Mar 21 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
412- new upstream release
413- add BR: libgweather-devel >= 2.26.0
414- add BR: libical-devel >= 0.43
415
416* Sat Mar  7 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.24.5-1
417- new upstream release
418- added BuildRequires: sqlite3-devel
419
420* Mon Jan 19 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.24.2-2
421- enabled krb5 support
422
423* Sun Dec 14 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.24.2-1
424- new upstream release
425
426* Wed Oct 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.1-1
427- new upstream release
428
429* Wed Sep 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
430- new upstream release
431
432* Mon Jun 30 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.3-1
433- new upstream release
434
435* Fri Jun 20 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.2-2
436- rebuilt with db4-4.6.21
437
438* Sat May 31 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.2-1
439- new upstream release
440
441* Sun May  4 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1.1-1vl5
442- new upstream release
443
444* Wed Apr  9 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1-1vl5
445- new upstream release
446
447* Mon Mar 31 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.0-1vl5
448- new upstream release based on Fedora package 2.20.0-3.fc9
449  * Mon Mar 24 2008 Matthew Barnes <mbarnes@redhat.com> - 2.22.0-3.fc9
450  - Add patch for GNOME bug #523023 (EFolder leak in evo-ex-storage).
451  * Tue Mar 11 2008 Matthew Barnes <mbarnes@redhat.com> - 2.22.0-2.fc9
452  - Add patch for RH bug #296671 (GC servers may not support NTLM).
453  * Thu Feb 14 2008 Matthew Barnes <mbarnes@redhat.com> - 2.21.91-3.fc9
454  - Try removing the ancient "ldap-x86_64-hack" patch.
455  * Mon Feb 11 2008 Matthew Barnes <mbarnes@redhat.com> - 2.21.91-1.fc9
456  - Add patch for GNOME bug #516074 (latest glibc breaks Camel).
457- split doc subpackage
458
459* Sat Jul 28 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.10.1-1vl2
460- fixed dependancy
461
462* Sat Jul 14 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.10.1-1vl1
463- updated to 1.10.3.1 based on Fedora package 1.10.1-1.fc7
464  * Wed Apr 04 2007 Matthew Barnes <mbarnes@redhat.com> - 1.10.0-6.fc7
465  - Revise patch for GNOME bug #417999 (another ESourceComboBox goof).
466  * Mon Apr 02 2007 Matthew Barnes <mbarnes@redhat.com> - 1.10.0-5.fc7
467  - Make the new ESourceComboBox widget work properly (RH bug #234760).
468  * Tue Mar 27 2007 Matthew Barnes <mbarnes@redhat.com> - 1.10.0-4.fc7
469  - Link to static evolution-openldap library (RH bug #210126).
470  - Require openssl-devel when statically linking against openldap.
471  - Add -Wdeclaration-after-statement to strict build settings.
472  * Wed Mar 14 2007 Matthew Barnes <mbarnes@redhat.com> - 1.10.0-2.fc7
473  - Modify patch for GNOME bug #376991 to fix RH bug #231994.
474  - Add patch for GNOME bug #417999 (avoid deprecated GTK+ symbols).
475  * Mon Mar 12 2007 Matthew Barnes <mbarnes@redhat.com> - 1.10.0-1.fc7
476  - Update to 1.10.0
477  * Fri Mar 09 2007 Matthew Barnes <mbarnes@redhat.com> - 1.9.92-4.fc7
478  - Add patch for GNOME bug #415922 (support MS ISA Server 2004).
479  - Patch by Kenny Root.
480- rebuilt with nss-devel and nspr-devel
481
482* Fri May 11 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.8.2-0vl2
483- rebuilt with new toolchain and db4-4.3.x
484
485* Sun Nov 26 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.2-0vl1
486- new upstream release
487
488* Sat Nov 11 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.1-0vl1
489- new upstream release
490- dropped Patch16, 17, 19, 20 and 21 (merged into upstream)
491
492* Sat Oct  7 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.0-11vl1
493- new upstream release
494- rebuilt with openssl instead of mozilla-nss
495
496* Mon Aug 28 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.2.1-0vl2
497- rebuilt with openldap-2.3.24-0vl4
498
499* Thu Dec  1 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.2.1-0vl1
500- new upstream release
501- build with libsoap-2.2.7
502
503* Tue Nov  8 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.1.1-0vl1
504- new upstream release
505
506* Sun Sep 25 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.0-2vl1
507- new upstream release
508- added/removed Patches based on Fedora packages
509  * Tue Aug 23 2005 David Malcolm <dmalcolm@redhat.com> - 1.3.8-3
510  - Updated patch 102 to fix further implicit function declarations
511  * Mon Jul 25 2005 David Malcolm <dmalcolm@redhat.com> - 1.3.5-2
512  - Added patch to use nspr rather than mozilla-nspr when doing pkg-config
513    tests (Patch5: evolution-data-server-1.3.5-nspr_fix.patch)
514  * Mon Jul 25 2005 David Malcolm <dmalcolm@redhat.com> - 1.3.5-1
515  - Removed upstreamed patch:
516    evolution-data-server-1.2.0-cope-with-a-macro-called-read.patch
517  * Mon Apr 11 2005 David Malcolm <dmalcolm@redhat.com> - 1.2.2-2
518  - added patch to calendar/libecal/e-cal.c to fix missing declaration
519    of open_calendar
520- rebuilt with mozilla-1.7.12
521
522* Thu May 04 2005 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.2.1-0vl2
523- rebuilt with mozilla-1.7.7
524
525* Tue Apr 12 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.1-0vl1
526- initial build for Vine Linux based on FC package
527- disable krb5 support
528
529* Thu Mar 17 2005 David Malcolm <dmalcolm@redhat.com> - 1.2.1-1
530- 1.2.1
531
532* Thu Mar 10 2005 David Malcolm <dmalcolm@redhat.com> - 1.2.0-3
533- Removed explicit run-time spec-file requirement on mozilla.
534  The Mozilla NSS API/ABI stabilised by version 1.7.3
535  The libraries are always located in the libdir
536  However, the headers are in /usr/include/mozilla-%{mozilla_build_version}
537  and so they move each time the mozilla version changes.
538  So we no longer have an explicit mozilla run-time requirement in the specfile;
539  a requirement on the appropriate NSS and NSPR .so files is automagically generated on build.
540  We have an explicit, exact build-time version, so that we can find the headers (without
541  invoking an RPM query from the spec file; to do so is considered bad practice)
542- Introduced mozilla_build_version, to replace mozilla_version
543- Set mozilla_build_version to 1.7.6 to reflect current state of tree
544
545* Tue Mar  8 2005 David Malcolm <dmalcolm@redhat.com> - 1.2.0-2
546- Added a patch to deal with glibc defining a macro called "read"
547
548* Tue Mar  8 2005 David Malcolm <dmalcolm@redhat.com> - 1.2.0-1
549- 1.2.0
550- Removed patch for GCC 4 as this is now in upstream tarball
551
552* Wed Mar  2 2005 Jeremy Katz <katzj@redhat.com> - 1.1.6-6
553- rebuild to fix library linking silliness
554
555* Tue Mar  1 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.6-5
556- disabling gtk-doc on ia64 and s390x
557
558* Tue Mar  1 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.6-4
559- added macro use_gtk_doc; added missing BuildRequires on gtk-doc; enabled gtk-doc generation on all platforms (had been disabled on ia64)
560
561* Tue Mar  1 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.6-3
562- extended patch to deal with camel-groupwise-store-summary.c
563
564* Tue Mar  1 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.6-2
565- added patch to fix badly-scoped declaration of "namespace_clear" in camel-imap-store-summary.c
566
567* Tue Mar  1 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.6-1
568- 1.1.6
569
570* Tue Feb  8 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.5-3
571- rebuild
572
573* Tue Feb  8 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.5-2
574- forgot to fix sources
575
576* Tue Feb  8 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.5-1
577- 1.1.5
578
579* Thu Jan 27 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.4.2-1
580- Update from unstable 1.1.4.1 to unstable 1.1.1.4.2
581
582* Wed Jan 26 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.4.1-3
583- disable gtk-doc generation on ia64 for now
584
585* Wed Jan 26 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.4.1-2
586- Exclude ppc64 due to missing mozilla dependency
587
588* Wed Jan 26 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.4.1-1
589- Update from 1.0.3 to 1.1.4.1
590- Updated eds_major from 1.0 to 1.2; fixed translation search path.
591- Removed 64-bit patch for calendar backend hash table; upstream now stores pointers to ECalBackendFactory, rather than GType
592- Removed calendar optimisation patch for part of part of bug #141283 as this is now in the upstream tarball
593- Added /usr/lib/evolution-data-server-%{eds_major} to cover the extensions, plus the camel code now in e-d-s, rather than evolution
594- Added /usr/share/pixmaps/evolution-data-server-%{eds_major} to cover the category pixmaps
595- Camel code from evolution is now in evolution-data-server:
596  - Added camel-index-control and camel-lock-helper to packaged files
597  - Added mozilla dependency code from the evolution package
598  - Ditto for LDAP
599  - Ditto for krb5
600  - Ditto for NNTP support handling
601  - Ditto for --enable-file-locking and --enable-dot-locking
602- Added requirements on libbonobo, libgnomeui, gnome-vfs2, GConf2, libglade2
603- Updated libsoup requirement from 2.2.1 to 2.2.2
604- Enabled gtk-doc
605
606* Wed Dec 15 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.3-2
607- fixed packaging of translation files to reflect upstream change to GETTEXT_PACKAGE being evolution-data-server-1.0 rather than -1.5
608
609* Wed Dec 15 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.3-1
610- update from upstream 1.0.2 to 1.0.3:
611  * Address Book
612    - prevent e_book_commit_contact from crashing on multiple calls (Diego Gonzalez)
613    - prevent file backend from crashing if uid of vcard is NULL (Diego Gonzalez)
614
615  * Calendar
616    #XB59904 - Speed up calendar queries (Rodrigo)
617    #XB69624 - make changes in evo corresponding to soap schema changes  (Siva)
618    - fix libical build for automake 1.9 (Rodney)
619    - fix putenv usage for portability (Julio M. Merino Vidal)
620
621  * Updated Translations:
622    - sv (Christian Rose)
623
624- Removed patches to fix build on x86_64 and calendar optimisation for XB59004 as these are in the upstream tarball
625
626* Tue Dec  7 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.2-6
627- Amortize writes to a local cache of a webcal calendar, fixing further aspect of #141283 (upstream bugzilla #70267), as posted to mailing list here:
628http://lists.ximian.com/archives/public/evolution-patches/2004-December/008338.html
629(The groupwise part of that patch did not cleanly apply, so I removed it).
630
631* Thu Dec  2 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.2-5
632- Added fix for #141283 (upstream bugzilla XB 59904), a backported calendar
633optimisation patch posted to upstream development mailing list here:
634http://lists.ximian.com/archives/public/evolution-patches/2004-November/008139.html
635
636* Wed Nov  3 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.2-4
637- Added patch to fix usage of GINT_TO_POINTER/GPOINTER_TO_INT for calendar backend GType hash table, breaking on ia64  (#136914)
638
639* Wed Oct 20 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.2-3
640- added workaround for a backend leak that causes the "contacts" calendar
641backend to hold open an EBook for the local contacts (filed upstream at:
642http://bugzilla.ximian.com/show_bug.cgi?id=68533 ); this was causing e-d-s to
643never lose its last addressbook, and hence never quit.  We workaround this by
644detecting this condition and exiting when it occurs, fixing bug #134851 and #134849.
645
646* Tue Oct 12 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.2-2
647- added patch to fix build on x86_64 (had multiple definitions of mutex code in libdb/dbinc.mutex.h)
648
649* Tue Oct 12 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.2-1
650- update from 1.0.1 to 1.0.2
651- increased libsoup requirement to 2.2.1 to match configuration script
652
653* Tue Sep 28 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.1-1
654- update from 1.0.0 to 1.0.1
655- removed patch that fixed warnings in calendar code (now in upstream tarball)
656
657* Mon Sep 20 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.0-2
658- fixed various warnings in the calendar code
659  (filed upstream here: http://bugzilla.ximian.com/show_bug.cgi?id=66383)
660
661* Tue Sep 14 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.0-1
662- update from 0.0.99 to 1.0.0
663- changed path in FTP source location from 0.0 to 1.0
664
665* Tue Aug 31 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.99-1
666- update from 0.0.98 to 0.0.99
667- increased libsoup requirement to 2.2.0 to match configuration script
668
669* Mon Aug 16 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.98-1
670- updated tarball from 0.0.97 to 0.0.98; updated required libsoup version to 2.1.13
671
672* Thu Aug  5 2004 Warren Togami <wtogami@redhat.com> - 0.0.97-2
673- pkgconfig -devel Requires libbonobo-devel, libgnome-devel
674
675* Wed Aug  4 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.97-1
676- upgraded to 0.0.97; rewrote the package's description
677
678* Mon Jul 26 2004 David Malcolm <dmalcolm@redhat.com>
679- rebuilt
680
681* Tue Jul 20 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.96-2
682- added version numbers to the BuildRequires test for libsoup-devel and ORBit2-devel
683
684* Tue Jul 20 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.96-1
685- 0.0.96; libsoup required is now 2.1.12
686
687* Thu Jul  8 2004 David Malcolm <dmalcolm@redhat.com>
688- rebuilt
689
690* Wed Jul  7 2004 David Malcolm <dmalcolm@redhat.com>
691- rebuilt
692
693* Tue Jul  6 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.95-1
694- 0.0.95
695
696* Thu Jun 17 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.94.1-1
697- 0.0.94.1
698
699* Mon Jun  7 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.94-2
700- rebuilt
701
702* Mon Jun  7 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.94-1
703- 0.0.94
704
705* Wed May 26 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.93-4
706- added ORBit2 requirement
707
708* Fri May 21 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.93-3
709- rebuild again
710
711* Fri May 21 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.93-2
712- rebuilt
713
714* Thu May 20 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.93-1
715- 0.0.93; libsoup required is now 2.1.10
716
717* Wed Apr 21 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.92-1
718- Update to 0.0.92; added a define and a requirement on the libsoup version
719
720* Wed Mar 10 2004 Jeremy Katz <katzj@redhat.com> - 0.0.90-1
721- 0.0.90
722
723* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
724- rebuilt
725
726* Mon Jan 26 2004 Jeremy Katz <katzj@redhat.com> - 0.0.6-1
727- 0.0.6
728
729* Wed Jan 21 2004 Jeremy Katz <katzj@redhat.com> - 0.0.5-2
730- better fix by using system libtool
731
732* Mon Jan 19 2004 Jeremy Katz <katzj@redhat.com> 0.0.5-1
733- add some libdb linkage to make the build on x86_64 happy
734
735* Wed Jan 14 2004 Jeremy Katz <katzj@redhat.com> 0.0.5-0
736- update to 0.0.5
737
738* Sat Jan  3 2004 Jeremy Katz <katzj@redhat.com> 0.0.4-0
739- Initial build.
Note: See TracBrowser for help on using the repository browser.