source: projects/specs/branches/6/e/espeak/espeak-vl.spec @ 6246

Revision 6246, 9.7 KB checked in by inagaki, 12 years ago (diff)

update: espeak, kdepim3, nas, xplanet

Line 
1Name:           espeak
2Summary:        Software speech synthesizer (text-to-speech)
3Version:        1.43
4Release:        4%{?_dist_release}
5
6Group:          Applications/Multimedia
7License:        GPLv3+
8URL:            http://espeak.sourceforge.net
9
10Source0:        http://kent.dl.sourceforge.net/sourceforge/espeak/espeak-%{version}-source.zip
11Source1:        espeak.1
12Patch0:         espeak-1.23-makefile_nostaticlibs.patch
13Patch1:         espeak-1.40.02-gcc_no_libstdc++.patch
14Patch2:         espeak-1.42.04-runtime-detection.patch
15Patch3:         espeak-1.43-ftbs_ld_libm.patch
16
17BuildRoot:      %{_tmppath}/%{name}-%{version}-root
18BuildRequires:  portaudio-devel
19BuildRequires:  pulseaudio-libs-devel
20BuildRequires:  gcc-c++
21
22
23%description
24eSpeak is a software speech synthesizer for English and other languages.
25
26eSpeak produces good quality English speech. It uses a different synthesis
27method from other open source TTS engines, and sounds quite different.
28It's perhaps not as natural or "smooth", but some people may find the
29articulation clearer and easier to listen to for long periods. eSpeak supports
30several languages, however in most cases these are initial drafts and need more
31work to improve them.
32
33It can run as a command line program to speak text from a file or from stdin.
34
35
36%package devel
37Summary: Development files for %{name}
38Summary(ja): %{name} の開発用ファイル
39Group: Development/Libraries
40Requires: %{name} = %{version}-%{release}
41
42%description devel
43Development files for eSpeak, a software speech synthesizer.
44
45
46%prep
47%setup -q -n espeak-%{version}-source
48%patch0 -p1 -b .nostaticlibs
49%patch1 -p1 -b .gcc_no_libstdc++
50%patch2 -p1 -b .runtime-detection
51%patch3 -p1 -b .ftbs_ld_libm
52
53# Fix file permissions
54find . -type f -exec chmod 0644 {} ";"
55# Prepare documentation
56rm -rf docs/images/.svn
57mv docs html
58sed -i 's/\r//' License.txt
59# Compile against portaudio v19 (see ReadMe)
60cp -f src/portaudio19.h src/portaudio.h
61# Don't use the included binary voice dictionaries; we compile these from source
62rm -f espeak-data/*_dict
63
64
65%build
66# Compile espeak
67cd src
68make %{?_smp_mflags} CFLAGS="$RPM_OPT_FLAGS"
69
70# Compile the TTS voice dictionaries
71export ESPEAK_DATA_PATH=$RPM_BUILD_DIR/espeak-%{version}-source
72cd ../dictsource
73for voice in $(../src/speak --voices | awk '{print $2}{print $5}' | egrep -v Language\|File\|/ | uniq); do \
74    ../src/speak --compile=$voice; \
75done
76
77
78%install
79rm -rf $RPM_BUILD_ROOT
80cd $RPM_BUILD_DIR/espeak-%{version}-source/src
81make install DESTDIR=$RPM_BUILD_ROOT BINDIR=%{_bindir} INCDIR=%{_includedir}/espeak LIBDIR=%{_libdir}
82# Install manpage
83mkdir -p $RPM_BUILD_ROOT%{_mandir}/man1
84cp -pf %{SOURCE1} $RPM_BUILD_ROOT%{_mandir}/man1/
85
86%clean
87rm -rf $RPM_BUILD_ROOT
88
89
90%post -p /sbin/ldconfig
91
92%postun -p /sbin/ldconfig
93
94
95%files
96%defattr(-,root,root,-)
97%doc $RPM_BUILD_DIR/espeak-%{version}-source/ReadMe $RPM_BUILD_DIR/espeak-%{version}-source/ChangeLog $RPM_BUILD_DIR/espeak-%{version}-source/License.txt $RPM_BUILD_DIR/espeak-%{version}-source/html/
98%{_mandir}/man1/espeak.1.gz
99%{_bindir}/espeak
100%{_datadir}/espeak-data
101%{_libdir}/libespeak.so.*
102
103%files devel
104%defattr(-,root,root)
105%{_libdir}/*.so
106%{_includedir}/espeak
107
108
109%changelog
110* Sun May 27 2012 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.43-4
111- rebuilt with rpm-4.8.1-3
112
113* Sun Mar 14 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.43-3
114- Initial build for Vine Linux
115
116* Thu Feb 18 2010 Francois Aucamp <faucamp@fedoraproject.org> - 1.43-2
117- Added patch declaring explicit libm linking dependency (RHBZ #565186)
118
119* Sat Feb 13 2010 Francois Aucamp <faucamp@fedoraproject.org> - 1.43-1
120- Update to version 1.43
121- Added patch for runtime detection of pulseaudio, contributed by Kevin Kofler (RHBZ #512190)
122
123* Thu Dec 17 2009 Francois Aucamp <faucamp@fedoraproject.org> - 1.42.04-1
124- Update to version 1.42.04
125- Revert: build against PortAudio instead of native PulseAudio (RHBZ #512190, #532674)
126
127* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.40.02-3
128- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
129
130* Tue Jun 30 2009 Francois Aucamp <faucamp@fedoraproject.org> - 1.40.02-2
131- Compile against pulseaudio instead of portaudio (RHBZ #481651)
132
133* Mon Jun 22 2009 Francois Aucamp <faucamp@fedoraproject.org> - 1.40.02-1
134- Update to version 1.40.02
135- Added patch to compile with GCC and not to link to libstdc++ (not needed)
136- Added manpage (thanks goes to Luke Yelavich from Ubuntu for writing it)
137
138* Tue Feb 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.39-2
139- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
140
141* Tue Oct 21 2008 Francois Aucamp <faucamp@fedoraproject.org> - 1.39-1
142- Update to version 1.39
143
144* Tue Feb 26 2008 Francois Aucamp <faucamp@fedoraproject.org> - 1.31-5
145- Export ESPEAK_DATA_PATH in %%build to allow proper compilation of voice dictionaries
146
147* Tue Jan 29 2008 Francois Aucamp <faucamp@fedoraproject.org> - 1.31-4
148- Removed libjack patches as they are unnecessary
149
150* Tue Jan 29 2008 Francois Aucamp <faucamp@fedoraproject.org> - 1.31-3
151- Added "makefile_libjack" patch to link to libjack
152- Added BuildRequires: jack-audio-connection-kit-devel
153
154* Fri Jan 25 2008 Francois Aucamp <faucamp@fedoraproject.org> - 1.31-2
155- Removed espeakedit (and associated patches and BuildRequires) from package
156  until all phoneme table compilation functions can be moved into espeak (or a
157  separate commandline app without wxGTK dependencies)
158- Voices are still compiled from source, but using pre-compiled phoneme table
159  from upstream until the above issue is resolved
160
161* Thu Jan 24 2008 Francois Aucamp <faucamp@fedoraproject.org> - 1.31-1
162- Update to version 1.31
163- Compile phoneme tables and voice dictionaries from source instead of
164  packaging pre-compiled binary data
165- Added espeakedit as Source1
166- Added BuildRequires: wxGTK-devel for espeakedit
167- Added "makefile_rpmoptflags_wxversion" espeakedit patch to enable
168  RPM_OPT_FLAGS and set the correct wxWidgets version
169- Added "espeak_data_path" espeakedit patch to be able to set control the
170  source directory that espeakedit's compiler uses
171
172* Tue Jan 15 2008 Francois Aucamp <faucamp@fedoraproject.org> - 1.30-1
173- Update to version 1.30
174- Removed local "synthdata_strlen" patch (included upstream)
175
176* Mon Aug 20 2007 Francois Aucamp <faucamp@csir.co.za> - 1.28-1
177- Update to version 1.28
178- Added "synthdata_strlen" patch to fix memory allocation issue on x86_64 (RHBZ #252712)
179- Modified %%prep to build against portaudio v19 for F8 and later
180- Upstream license changed from GPLv2+ to GPLv3+
181
182* Tue Jun 19 2007 Francois Aucamp <faucamp@csir.co.za> - 1.26-1
183- Update to version 1.26
184- Modified %%prep to build against portaudio v19
185
186* Tue Jun 05 2007 Francois Aucamp <faucamp@csir.co.za> - 1.25-1
187- Update to version 1.25
188
189* Tue May 08 2007 Francois Aucamp <faucamp@csir.co.za> - 1.24-1
190- Update to version 1.24
191
192* Tue Apr 24 2007 Francois Aucamp <faucamp@csir.co.za> - 1.23-1
193- Update to version 1.23
194- Added "makefile_nostaticlibs" patch so static libraries aren't installed
195
196* Thu Feb 08 2007 Francois Aucamp <faucamp@csir.co.za> - 1.20-1
197- Update to version 1.20
198- Solves stack smash bug (RHBZ #227316)
199
200* Fri Jan 26 2007 Francois Aucamp <faucamp@csir.co.za> - 1.19-1
201- Update to version 1.19
202- Removed "espeak-1.18-makefile_lpthread" patch as it has been included upstream
203- Removed "espeak-1.18-makefile_smp" patch as it has been included upstream
204- Removed "espeak-1.18-ptr_64bit" patch as it has been solved upstream
205- Fixed espeak-data file permissions
206
207* Tue Jan 16 2007 Francois Aucamp <faucamp@csir.co.za> - 1.18-2
208- Created "espeak-1.18-ptr_64bit" patch to allow compilation on x86_64 (fixes 64-bit pointer issues)
209- Created "espeak-1.18-makefile_smp" patch to allow parallel make ("_smp_mflags")
210- Renamed "makefile_lpthread" patch to "espeak-1.18-makefile_lpthread"
211
212* Mon Jan 15 2007 Francois Aucamp <faucamp@csir.co.za> - 1.18-1
213- Update to version 1.18
214- Dropped statically-linked "speak" executable (replaced by dynamically-linked "espeak" executable)
215- Removed the "espeak program name" patch as it has been included upstream
216- Removed "espeak program name" patch backup file cleanup from %%install
217- Minor modification to "makefile lpthread" patch to account for new lib/executable
218- Removed "BIN_NAME" variable from make in %%build (implemented upstream)
219
220* Mon Nov 20 2006 Francois Aucamp <faucamp@csir.co.za> - 1.17-1
221- Update to version 1.17
222- Removed "makefile install target" patch as it has been included upstream
223- Removed "AMD64 sizeof(char *)" patch as it has been included upstream
224- Minor modification to "espeak program name" patch to allow patching current version
225
226* Tue Nov 07 2006 Francois Aucamp <faucamp@csir.co.za> - 1.16-4
227- Modified patch steps to create backups with different suffixes
228- Renamed patch file extensions to .patch
229- Added step in %%install to remove patch backup files in documentation
230
231* Sat Nov 04 2006 Francois Aucamp <faucamp@csir.co.za> - 1.16-3
232- Fixed source file permissions for -debuginfo package in %%prep
233- Added RPM_OPT_FLAGS to "make" command in %%build; removed RPM_OPT_FLAGS makefile patch
234- Modified makefile install target patch to include general support for setting compiler optimization flags via CXXFLAGS
235- Removed creation of .orig backup files during patching
236- Modified patch files to have different suffixes
237
238* Thu Nov 02 2006 Francois Aucamp <faucamp@csir.co.za> - 1.16-2
239- Added "install" target to makefile (makefile_install_target.patch)
240- Added patch to fix AMD64 sizeof(char *) assumption bug (upstream request ID 1588938)
241- Changed "portaudio" BuildRequires to "portaudio-devel"
242- Added patch to makefile to allow RPM_OPT_FLAGS
243- Added patch to replace all references to "speak" binary with "espeak"
244- Moved header files to /usr/include/espeak
245- Added rmdir command to "install" to remove empty soundicons directory
246
247* Wed Oct 04 2006 Francois Aucamp <faucamp@csir.co.za> - 1.16-1
248- Initial RPM build
Note: See TracBrowser for help on using the repository browser.