source: projects/specs/branches/6/e/esound/esound-vl.spec @ 2767

Revision 2767, 8.5 KB checked in by Takemikaduchi, 13 years ago (diff)

new upstream release

Line 
1# Note that this is NOT a relocatable package
2%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
3
4Summary: Allows several audio streams to play on a single audio device.
5Summary(ja): オーディオストリームを単一デバイスから再生するサーバ
6Name:      esound
7Version:   0.2.41
8Release:   1%{?_dist_release}
9License:   GPL
10Group: System Environment/Daemons
11Source0:   ftp://ftp.gnome.org/pub/GNOME/sources/esound/0.2/esound-%{version}.tar.bz2
12URL:       http://www.tux.org/~ricdude/EsounD.html
13BuildRoot: %{_tmppath}/%{name}-%{version}-root
14BuildRequires: alsa-lib-devel
15BuildRequires: audiofile-devel
16Requires: %{name}-libs = %{version}
17
18%description
19EsounD, the Enlightened Sound Daemon, is a server process that mixes
20several audio streams for playback by a single audio device. For
21example, if you're listening to music on a CD and you receive a
22sound-related event from ICQ, the two applications won't have to
23jockey for the use of your sound card.
24
25Install esound if you'd like to let sound applications share your
26audio device. You'll also need to install the audiofile package.
27
28%description -l ja
29EsounD (the Enlightened Sound Daemon) は複数のオーディオストリームを
30単一のオーディオデバイスから出力するためのサーバです。
31例えば、CD から音楽を聞いている時に ICQ からサウンドイベントを
32受け取った際、EsounD を介することによりこの2つのアプリケーションが
33サウンドカードの取り合いをせずに済むようになります。
34
35
36%package libs
37Summary: Library to talk to the EsounD daemon
38Summary(ja): EsounD 共有ライブラリ
39Group: Development/Libraries
40Obsoletes: %{name} < 0.2.38-2
41
42%description libs
43The esound-libs package includes the libraries required
44for applications to talk to the EsounD daemon.
45
46
47%package devel
48Summary: Development files for EsounD applications.
49Summary(ja): EsounD アプリケーション開発用ファイル
50Group: Development/Libraries
51Requires: %{name}-libs = %{version}
52Requires: audiofile-devel
53Requires: alsa-lib-devel
54
55
56%description devel
57The esound-devel Libraries, include files and other resources you can
58use to develop EsounD applications.
59
60Install esound-devel if you want to develop EsounD applications.
61
62%description devel -l ja
63このパッケージには EsounD アプリケーションを開発するのに必要な
64ライブラリ、include ファイル、その他のリソースが含まれます。
65
66EsounD アプリケーションを開発する場合には esound-devel パッケージを
67インストールしてください。
68
69
70%package -n compat32-%{name}-libs
71Summary: Library to talk to the EsounD daemon
72Summary(ja): EsounD 共有ライブラリ
73Group: System Environment/Daemons
74Requires: %{name}-libs = %{version}
75
76%description -n compat32-%{name}-libs
77The esound-libs package includes the libraries required
78for applications to talk to the EsounD daemon.
79
80
81%package -n compat32-%{name}-devel
82Summary: Development files for EsounD applications.
83Summary(ja): EsounD アプリケーション開発用ファイル
84Group: Development/Libraries
85Requires: %{name}-devel    = %{version}
86Requires: compat32-%{name}-libs = %{version}
87
88
89%description -n compat32-%{name}-devel
90The esound-devel Libraries, include files and other resources you can
91use to develop EsounD applications.
92
93Install esound-devel if you want to develop EsounD applications.
94
95%description -n compat32-%{name}-devel -l ja
96このパッケージには EsounD アプリケーションを開発するのに必要な
97ライブラリ、include ファイル、その他のリソースが含まれます。
98
99EsounD アプリケーションを開発する場合には esound-devel パッケージを
100インストールしてください。
101
102
103%prep
104%setup -q
105
106%build
107%configure --disable-static
108make
109
110
111%install
112rm -rf ${RPM_BUILD_ROOT}
113%makeinstall
114
115#strip ${RPM_BUILD_ROOT}%{_bindir}/* ||:
116#strip ${RPM_BUILD_ROOT}%{_libdir}/*.so.* ||:
117
118#cp -pr $RPM_BUILD_ROOT%{_docdir}/esound docs-to-install
119rm -rf $RPM_BUILD_ROOT%{_docdir}/esound
120rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.la
121
122%clean
123rm -rf ${RPM_BUILD_ROOT}
124
125%post libs -p /sbin/ldconfig
126
127%postun libs -p /sbin/ldconfig
128
129%post -n compat32-%{name}-libs -p /sbin/ldconfig
130
131%postun -n compat32-%{name}-libs -p /sbin/ldconfig
132
133
134%files
135%defattr(-, root, root)
136%{_bindir}/esd
137%{_bindir}/esdcat
138%{_bindir}/esdctl
139%{_bindir}/esddsp
140%{_bindir}/esdfilt
141%{_bindir}/esdloop
142%{_bindir}/esdmon
143%{_bindir}/esdplay
144%{_bindir}/esdrec
145%{_bindir}/esdsample
146%{_mandir}/man1/esd.1*
147%{_mandir}/man1/esdcat.1*
148%{_mandir}/man1/esdctl.1*
149%{_mandir}/man1/esddsp.1*
150%{_mandir}/man1/esdfilt.1*
151%{_mandir}/man1/esdloop.1*
152%{_mandir}/man1/esdmon.1*
153%{_mandir}/man1/esdplay.1*
154%{_mandir}/man1/esdrec.1*
155%{_mandir}/man1/esdsample.1*
156
157%files libs
158%defattr(-, root, root)
159%doc AUTHORS COPYING.LIB ChangeLog docs/esound.sgml docs/html
160%doc INSTALL NEWS README TIPS TODO
161%config(noreplace) %{_sysconfdir}/*
162%{_libdir}/lib*.so.*
163
164%files devel
165%defattr(-, root, root)
166%{_bindir}/esd-config
167%{_includedir}/*
168%{_datadir}/aclocal/*
169%{_libdir}/lib*.so
170%{_libdir}/pkgconfig/*.pc
171%{_mandir}/man1/esd-config.1*
172
173
174%if %{build_compat32}
175%files -n compat32-%{name}-libs
176%defattr(-, root, root)
177%{_libdir}/lib*.so.*
178
179
180%files -n compat32-%{name}-devel
181%defattr(-, root, root)
182%{_libdir}/lib*.so
183%{_libdir}/pkgconfig/*.pc
184%endif
185
186
187%changelog
188* Sat Feb 26 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.2.41-1
189- update to 0.2.41
190- delete Patch0
191
192* Sun Sep 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.2.38-4
193- rebuild with rpm-4.8.1 for pkg-config file
194
195* Mon Jul 13 2009 NAKAMURA Kenta <kenta@vinelinux.org> 0.2.38-3
196- corrected Requires: tag on compat32-esound-devel
197- removed static libraries
198
199* Wed Jul 09 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.2.38-2
200- split shared library to -libs subpackage.
201
202* Mon May 12 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.2.38-1
203- applied new versioning policy
204- removed *.la file from devel package
205
206* Sat May  5 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.2.38-0vl1
207- new upstream release
208
209* Thu Mar 15 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.2.37-0vl1
210- new upstream release
211
212* Sat Dec 23 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.2.36-0vl4
213- add Requires: alsa-lib-devel to -devel package
214
215* Mon May 13 2006 NAKAMURA Kenta <kenta@c.csce.kyushu-u.ac.jp> 0.2.36-0vl3
216- added compat32-* packages for x86_64 architecture support
217
218* Fri Feb 17 2006 Shu KONNO <owa@bg.wakwak.com> 0.2.36-0vl2
219- added BuildRequires: audiofile-devel
220- rebuilt for x86_64 architecture
221
222* Sun Jun 19 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.2.36-0vl1
223- new upstream release
224- build with alsa
225
226* Sat Oct 23 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.2.35-0vl1
227- new upstream release
228- sync manpages to each package
229- added Patch0 from Fedora development 0.2.34-3
230
231* Sun Sep 21 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 0.2.31-0vl2
232- use License tag
233- add .la files to devel package
234
235* Wed Sep 03 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.2.31-0vl1
236- new upstream release
237- add manpages to filelist
238
239* Tue Jan 07 2003 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.2.29-0vl4
240- added missing pkgconfig file
241
242* Sun Jan  5 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.2.29-0vl1
243- new upstream release
244
245* Wed Feb 20 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 0.2.22-0vl3
246- rebuild to remove rpmlib dependancy
247
248* Fri May 25 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
249- remove audio_oss patch
250
251* Thu Dec 14 2000 Yoichi Imai <yoichi@silver-forest.com>
252- 0.2.22-0vl1
253- comment out strip commands
254- changed /var/tmp to %{_tmppath}
255 
256* Thu Oct 26 2000 Jun Nishii <jun@vinelinux.org>
257- 0.2.20-0vl1
258
259* Wed Sep 06 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
260- 0.2.19-0vl2
261- included a patch for audio_oss.c (backed to 0.2.17 style)
262
263* Wed Sep 06 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
264- 0.2.19-0vl1
265- udpated to 0.2.19 release
266- added Japanese Summary and Description
267
268* Sat Jun  3 2000 BIll Nottingham <notting@redhat.com> 0.2.18-2
269- rebuild. Apparently the compiler ate this last time.
270
271* Tue Apr 4 2000 Elliot Lee <sopwith@redhat.com> 0.2.18-1
272- Update to 0.2.18
273
274* Mon Aug 30 1999 Elliot Lee <sopwith@redhat.com> 0.2.13-1
275- Update to 0.2.13
276- Merge in changes from RHL 6.0 spec file.
277
278* Sat Nov 21 1998 Pablo Saratxaga <srtxg@chanae.alphanet.ch>
279
280- added %{_prefix}/share/aclocal/* to %files devel
281- added spanish and french translations for rpm
282
283* Thu Oct 1 1998 Ricdude <ericmit@ix.netcom.com>
284
285- make autoconf do the version updating for us.
286
287* Wed May 13 1998 Michael Fulbright <msf@redhat.com>
288
289- First try at an RPM
Note: See TracBrowser for help on using the repository browser.