source: projects/specs/branches/6/e/empathy/empathy-vl.spec @ 2610

Revision 2610, 15.0 KB checked in by Takemikaduchi, 13 years ago (diff)

empathy,telepathy-salut: new upstream release, others: rebuild with openssl-1.0.0c

Line 
1%define major_ver 2.32
2%define minor_ver 2
3%define rel       1
4
5%{!?python_sitearch: %global python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
6
7## Minimum required versions of GLib, GTK+, libtelepathy, and Mission-Control,
8## respectively.
9%global gtk2_min_version        2.22
10%global glib2_min_version       2.26.0
11%global tp_mc_min_version       5.6.0
12%global tp_glib_min_version     0.13.0
13%global tp_logger_min_version   0.1.5
14#global enchant_version         1.4.0
15%global aspell_version          0.50
16%global libcanberra_version     0.4
17%global gnome_keyring_version   2.32
18%global libnotify_version       0.4.4
19
20Summary:        GNOME Instant Messaging Client
21Summary(ja):    GNOME インスタントメッセージクラアイント
22
23Name:           empathy
24Version:        %{major_ver}.%{minor_ver}
25Release:        %{rel}%{?_dist_release}
26
27Group:          Applications/Communications
28License:        GPLv2+
29URL:            http://live.gnome.org/Empathy
30
31Source0:        http://ftp.gnome.org/pub/GNOME/sources/%{name}/%{majorver}/%{name}-%{version}.tar.bz2
32Source1:        %{name}-README.ConnectionManagers
33
34BuildRoot: %{_tmppath}/%{name}-%{version}-root
35
36#BuildRequires: enchant-devel >= %{enchant_version}
37BuildRequires:  aspell-devel >= %{aspell_version}
38BuildRequires:  iso-codes
39BuildRequires:  desktop-file-utils
40BuildRequires:  evolution-data-server-devel
41BuildRequires:  GConf2-devel
42BuildRequires:  gettext
43BuildRequires:  glib2-devel >= %{glib2_min_version}
44BuildRequires:  gnome-doc-utils >= 0.17.3
45BuildRequires:  gnome-panel
46BuildRequires:  gtk2-devel >= %{gtk2_min_version}
47BuildRequires:  intltool
48BuildRequires:  libxml2-devel
49BuildRequires:  perl(XML::Parser)
50BuildRequires:  pygtk2-devel
51BuildRequires:  telepathy-glib-devel >= %{tp_glib_min_version}
52BuildRequires:  telepathy-mission-control-devel >= %{tp_mc_min_version}
53BuildRequires:  farsight2-devel
54BuildRequires:  telepathy-farsight-devel
55BuildRequires:  libcanberra-devel >= %{libcanberra_version}
56BuildRequires:  libgnome-keyring-devel >= %{gnome_keyring_version}
57BuildRequires:  unique-devel
58BuildRequires:  libnotify-devel >= %{libnotify_version}
59BuildRequires:  libtelepathy-devel
60BuildRequires:  libgnomecanvas-devel
61BuildRequires:  libbonoboui-devel
62BuildRequires:  folks-devel
63BuildRequires:  telepathy-logger-devel >= %{tp_logger_min_version}
64BuildRequires:  gnome-keyring-devel >= %{gnome_keyring_version}
65BuildRequires:  openssl-devel
66BuildRequires:  NetworkManager-glib-devel
67BuildRequires:  WebKit-gtk-devel
68BuildRequires:  geoclue-devel
69BuildRequires:  enchant-devel
70
71Requires:       telepathy-filesystem
72## Empathy is useless without a proper Telepathy connection manager installed.
73## We hardcode dependencies on Salut and Gabble to support XMPP on a default
74## install, in both the link-local and Jabber/GoogleTalk incarnations.
75## (RHBZ: 308871 and 334221)
76## TODO: Perhaps we can configure these to be installed "on demand" with
77##       PackageKit and friends?
78Requires:       telepathy-gabble
79Requires:       telepathy-salut
80## Also hardcode Haze dependency since Empathy is the default IM client in F10+
81## and I'd hate for people to simply disregard it for lack of the "out of the
82## box" protocol support that Pidgin has. (RHBZ: 458935)
83BuildRequires:  telepathy-haze
84# Require this for VOIP support
85Requires:       telepathy-stream-engine
86Requires:       telepathy-mission-control >= %{tp_mc_min_version}
87
88
89Requires(post): GConf2
90Requires(post): scrollkeeper
91
92Requires(postun):       scrollkeeper
93
94## We're using Empathy's upstreamed profiles for Haze-provided stuff now.
95Obsoletes:      telepathy-haze-mission-control < 0.2.0-3
96Provides:       telepathy-haze-mission-control = 0.2.0-3
97## upstream 2.29.1 removed shared libraries: #599086
98Obsoletes: empathy-libs < 2.29.1, empathy-devel < 2.29.1
99## upstream 2.29.1 removed python bindings' #599039
100Obsoletes: empathy-python < 2.29.1
101
102%description
103Empathy provides a powerful multiple protocol instant messaging
104client using the Telepathy framework.
105
106
107%package -n     nautilus-sendto-empathy
108License:        GPLv2+
109Summary:        Nautilus-sendto plugin for empathy
110Summary(ja):    empathy 用 nautilus-sendto プラグイン
111Group:          User Interface/Desktop
112
113Requires:       %{name} = %{version}-%{release}
114Requires:       nautilus-sendto
115BuildRequires:  nautilus-sendto-devel
116
117%description -n nautilus-sendto-empathy
118This package contains nautilus-sendto plugin for the Empathy IM application.
119
120
121%prep
122%setup -q
123
124
125%build
126## GCC complains about some unused functions, so we forcibly show those as
127## simple warnings instead of build-halting errors.
128%configure \
129        --with-compile-warnings=yes \
130        --disable-static \
131        --enable-nautilus-sendto=yes \
132         --with-ca-file=/usr/share/ssl/certs/ca-bundle.crt
133## RPATHs are yucky.
134sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
135sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
136
137##make %{?_smp_mflags}
138## don't use _smp_mflags at empathy-2.18.1
139make
140
141install -m 0644 %{SOURCE1} ./README.ConnectionManagers
142
143
144%install
145rm -rf $RPM_BUILD_ROOT
146make install DESTDIR=$RPM_BUILD_ROOT
147find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
148
149%find_lang %{name}
150
151desktop-file-install --vendor "" --delete-original      \
152        --dir %{buildroot}%{_datadir}/applications      \
153        %{buildroot}%{_datadir}/applications/%{name}.desktop
154
155
156%clean
157rm -rf %{buildroot}
158
159
160%post
161scrollkeeper-update -q -o %{_datadir}/omf/%{name} ||:
162touch --no-create %{_datadir}/icons/hicolor ||:
163%{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor ||:
164
165%postun
166scrollkeeper-update -q || :
167touch --no-create %{_datadir}/icons/hicolor || :
168if [ -x %{_bindir}/gtk-update-icon-cache ]; then
169        %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
170        glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
171fi
172
173%posttrans
174gtk-update-icon-cache %{_datadir}/icons/hicolor >&/dev/null ||:
175glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
176
177
178%files -f %{name}.lang
179%defattr(-,root,root,-)
180%doc AUTHORS COPYING README README.ConnectionManagers NEWS
181%{_bindir}/empathy
182%{_bindir}/empathy-accounts
183%{_bindir}/empathy-debugger
184%{_libexecdir}/empathy-auth-client
185%{_libexecdir}/empathy-av
186%{_datadir}/dbus-1/services/*
187%{_datadir}/empathy
188%{_datadir}/glib-2.0/schemas/*.xml
189%{_datadir}/GConf/gsettings/*
190%{_datadir}/applications/*.desktop
191%{_datadir}/gnome/help/%{name}/
192#{_datadir}/omf/%{name}/
193%{_datadir}/icons/hicolor/*/apps/%{name}*
194#{_datadir}/mission-control/profiles/*.profile
195%{_datadir}/telepathy/clients/*.client
196%{_mandir}/man1/empathy*.1*
197
198%files -n nautilus-sendto-empathy
199%defattr(-,root,root,-)
200%{_libdir}/nautilus-sendto/plugins/libnstempathy.so
201
202
203%changelog
204* Sun Jan 30 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.2-1
205- new upstream release
206- add BuildRequires: openssl-devel, NetworkManager-glib-devel, WebKit-devel
207                     geoclue-devel, enchant-devel
208- add Requires: telepathy-mission-control
209- add configure option: --with-ca-file=/usr/share/ssl/certs/ca-bundle.crt
210
211* Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0.1-1
212- new upstream release
213- add BuildRequires: folks-devel, telepathy-logger-devel, gnome-keyring-devel
214- fix %files
215- fix %post, %postun
216- drop %pre, %preun
217
218* Sat Jun 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0.1-3
219- rebuild with evolution-data-server-2.30.2
220- add nautilus-sendto-empathy package
221  - add configure option (--enable-nautilus-sendto=yes)
222  - add BuildRequires: nautilus-sendto-devel
223
224* Sat Jun 12 2010 IWAI, Masaharu <iwai@alib.jp> 2.30.0.1-2
225- add Obsoletes: empathy-python < 2.29.1
226
227* Tue Apr 13 2010 IWAI, Masaharu <iwai@alib.jp> 2.30.0.1-1
228- new upstream release
229- add new files: %%{_bindir}/empathy-{accounts,debugger}
230- drop -libs, -devel, -python sub packages: upstream removed
231  - Obsoletes: empathy-{libs,devel} < 2.29.1
232  - drop BuildRequires: python-devel
233- drop %%{_bindir}/empathy-logs in %%files: upstream don not install
234- drop applet files in %%files: upstream removed the panel applets
235  - update %%post, %pre and %%preun
236- update BuildRequires version for glib2 and tp_glib
237- defined major_ver, minor_ver and rel
238- fix BuildRequires for gnome-keyring
239
240* Sat Mar 13 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.2-1
241- new upstream release
242- add BuildRequires: libtelepathy-devel, libgnomecanvas-devel, libbonoboui-devel, python-devel
243
244* Wed Feb 03 2010 Shu KONNO <owa@bg.wakwak.com> 2.28.1-4
245- rebuilt with python-2.6.4
246
247* Fri Nov 27 2009 Shu KONNO <owa@bg.wakwak.com> - 2.28.1-3
248- unuse %%{?_smp_mflags} option to make
249
250* Wed Nov 11 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.28.1-2
251- add {gnome-keyring,libcanberra,libnotify,unique}-devel to BuildRequires
252
253* Sat Nov  7 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.1-1
254- new upstream release
255
256* Wed Oct 29 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.1-1
257- new upstream release
258
259* Tue Sep 30 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
260- initial build for Vine Linux
261
262* Tue Sep  9 2008 Matthias Clasen <mclasen@redhat.com> - 2.23.92-1
263- Update to 2.23.92
264
265* Thu Sep  4 2008 Matthias Clasen <mclasen@redhat.com> - 2.23.91-1
266- Update to 2.23.91
267
268* Sun Aug 24 2008 Peter Gordon <peter@thecodergeek.com> - 2.23.90-2
269- Now that Empathy will be the default IM client in F10+, hardcode a dependency
270  on telepathy-haze to keep the same protocol functionality across upgrades,
271  for a much improved "out of the box" experience.
272- Reference: bug 458935.
273
274* Fri Aug 22 2008 Peter Gordon <peter@thecodergeek.com> - 2.23.90-1
275- Update to new upstream release (2.23.90)
276
277* Fri Aug 15 2008 Peter Gordon <peter@thecodergeek.com> - 2.23.6-3
278- Apply patch from Colin Walters to automagically update profile namings for
279  the switch to using Empathy's provided profiles.
280- Drop the upgrade script (no longer needed since it's automatically done).
281  - upgrade-haze-profiles.sh
282
283* Wed Aug 13 2008 Peter Gordon <peter@thecodergeek.com> - 2.23.6-2
284- Use upstream's AIM, ICQ, MSN-Haze, and Yahoo profiles instead of recommending
285  the telepathy-haze-mission-control package. (The Haze-provided ones have grown
286  horribly stale...). This makes for better automagic functionality (if Haze is
287  installed, Empathy/MC will autodetect it) and tracks upstream more closely.
288  + upgrade-haze-profiles.sh
289
290* Mon Aug 04 2008 Peter Gordon <peter@thecodergeek.com> - 2.23.6-1
291- Update to new upstream release (2.23.6)
292- Use the in-tarball libtool scripts instead of the system copy to workaround
293  'make install' errors.
294
295* Wed Jul 16 2008 Brian Pepple <bpepple@fedoraproject.org> - 0.23.4-1
296- Update to 0.23.4.
297- Update source url.
298
299* Mon Jun  2 2008 Brian Pepple <bpepple@fedoraproject.org> - 0.23.3-1
300- Update to 0.23.3.
301- Remove reference to stream-engine in connections managers readme.
302
303* Fri May 16 2008 Brian Pepple <bpepple@fedoraproject.org> - 0.23.2-1
304- Update to 0.23.2.
305- Add man pages.
306- Use enchant-devel, instead of aspell-devel.
307
308* Fri May 16 2008 Brian Pepple <bpepple@fedoraproject.org> - 0.23.1-3
309- Rebuild for new e-d-s.
310
311* Sun May  4 2008 Brian Pepple <bpepple@fedoraproject.org> - 0.23.1-2
312- Drop multiple copies of COPYING file.
313- Drop BR on gnome-vfs2-devel.
314- Require telepathy-stream-engine for VOIP support.
315- Add BR on iso-codes-devel, so spell-checking is enabled.
316
317* Wed Apr 23 2008 Peter Gordon <peter@thecodergeek.com> - 0.23.1-1
318- Update to new upstream release (0.23.1)
319- Drop libtelepathy dependencies; upstream switched fully to telepathy-glib.
320
321* Fri Apr 11 2008 Peter Gordon <peter@thecodergeek.com> - 0.22.1-1
322- Update to new upstream release (0.22.1)
323
324* Mon Mar 10 2008 Peter Gordon <peter@thecodergeek.com> - 0.22.0-1
325- Update to new upstream release (0.22.0)
326
327* Sun Mar 09 2008 Peter Gordon <peter@thecodergeek.com> - 0.21.91-1
328- Update to new upstream release (0.21.91)
329
330* Fri Feb 22 2008 Peter Gordon <peter@thecodergeek.com> - 0.21.90-1
331- Update to new upstream release (0.21.90)
332
333* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.21.4-2
334- Autorebuild for GCC 4.3
335
336* Mon Dec 17 2007 Peter Gordon <peter@thecodergeek.com> - 0.21.4-1
337- Update to new upstream release (0.21.4)
338
339* Tue Nov 13 2007 Peter Gordon <peter@thecodergeek.com> - 0.21.2-1
340- Update to new upstream release (0.21.2)
341- Drop backported drag-and-drop patch (fixed upstream):
342    - svn380-fix-contact-DnD.patch
343- Update README.ConnectionManagers: Include Haze package note, remove Galago
344  note (a feed-only connection manager isn't useful for instant messaging),
345  and fix some wording.
346
347* Fri Oct 19 2007 Peter Gordon <peter@thecodergeek.com> - 0.14-5
348- Backport upstream patch to fixes crashes when using drag-and-drop of a
349  contact from the buddy list to the current conversation window to initiate a
350  conversation:
351    + svn380-fix-contact-DnD.patch
352- Resolves: GNOME bug 483168 (crash in Empathy Instant Messenger: I had
353  dragged a contact ...)
354
355* Tue Oct 16 2007 Peter Gordon <peter@thecodergeek.com> - 0.14-4
356- Depend on Salut and Gabble to enable XMPP by default. Otherwise, Empathy
357  is essentially useless due to the need to install an external connection
358  manager. Also, add a README.ConnectionManagers to the installed
359  documentation which lists other possibilities.
360- Resolves: bug 308871 (Make empathy dependent at least on telepathy-gabble)
361  and bug 334221 (Default empathy install is useless).
362
363* Wed Oct 10 2007 Peter Gordon <peter@thecodergeek.com> - 0.14-3
364- Enable VoIP support for those brave enough to test/break/debug it (F9+
365  only). Though it is functional, it is still deemed rather unstable by
366  upstream. Use it at your own risk. :)
367
368* Tue Oct 02 2007 Peter Gordon <peter@thecodergeek.com> - 0.14-2
369- Disable VoIP support at this time, since it is deemed unstable by upstream
370  for now. (Thanks to Brian Pepple for the notice.)
371 
372* Tue Oct 02 2007 Peter Gordon <peter@thecodergeek.com> - 0.14-1
373- Update to new upstream release (0.14).
374
375* Sun Sep 30 2007 Peter Gordon <peter@thecodergeek.com> - 0.13-1
376- Update to new upstream release (0.13), which adds a panel applet (Megaphone)
377  and python bindings.
378- Split shared libraries into a libs subpackage for easier handling
379  in multi-lib environments.
380
381* Fri Aug 31 2007 Peter Gordon <peter@thecodergeek.com> - 0.12-2
382- Add ldconfig invocations to %%post and %%postun scriptlets.
383
384* Fri Aug 31 2007 Peter Gordon <peter@thecodergeek.com> - 0.12-1
385- Update to new upstream release (0.12).
386- Build against new mission-control stack.
387- Update License tag (GPLv2+).
388- Alphabetize BuildRequires list (aesthetic-only change).
389
390* Wed Aug 29 2007 Fedora Release Engineering <rel-eng at fedoraproject dot org> - 0.8-2
391- Rebuild for selinux ppc32 issue.
392
393* Mon Aug 13 2007 Peter Gordon <peter@thecodergeek.com> - 0.11-1
394- Update to new upstream release (0.11)
395
396* Fri Jun 22 2007 David Nielsen <david@lovesunix.net> - 0.8-1
397- bump to 0.8
398- Now with aspell support (deat to teh speeling mistaks)
399
400* Sat Jun  9 2007 David Nielsen <david@lovesunix.net> - 0.7-1
401- bump to 0.7
402
403* Mon Jun  4 2007 David Nielsen <david@lovesunix.net> - 0.6-3
404- Add telepathy-filesystem to Requires
405- Move .desktop from autostart to applications
406- Nasty hackery to make empathy launch from the menu
407
408* Mon Jun  4 2007 David Nielsen <david@lovesunix.net> - 0.6-2
409- Add gettext to BuildRequires
410
411* Fri Jun  1 2007 David Nielsen <david@lovesunix.net> - 0.6-1
412- Bump to 0.6
413
414* Fri Jun  1 2007 David Nielsen <david@lovesunix.net> - 0.5-2
415- Let Empathy own the directory and not just the files in it
416
417* Tue May 30 2007 David Nielsen <david@lovesunix.net> - 0.5-1
418- Initial package
Note: See TracBrowser for help on using the repository browser.