source: projects/specs/branches/6/e/emacs24/emacs24-vl6.spec @ 6783

Revision 6783, 27.6 KB checked in by munepi, 12 years ago (diff)

new upstream release

Line 
1%define emacsversion 24.2
2#% define bzrdate 20110817
3%define emacsrelease 1%{?bzrdate:.%bzrdate}%{?_dist_release}
4%define vine_default_major_version %(echo %_dist_release|%__sed s/vl//)
5
6%define _noVersionedDependencies 1
7%define prereq_ge()  %(LC_ALL="C" rpm -q --queryformat 'PreReq:%%{NAME} >= %%{VERSION}' %1| grep -v "is not")
8
9%define infodir %{_infodir}/emacs-%{emacsversion}
10
11%define menutreeelversion 0.97
12
13Summary:      GNU Emacs editor
14Summary(ja):  GNU Emacs エディタ
15Name:         emacs24
16Provides:     emacs-snapshot
17Version:      %{emacsversion}
18Release:      %{emacsrelease}
19Source0:      ftp://ftp.gnu.org/pub/gnu/emacs/emacs-%{version}.tar.xz
20#Source0:      ftp://ftp.gnu.org/pub/gnu/emacs/emacs-%{version}%{?bzrdate:.bzr%bzrdate}.tar.xz
21#Source0:      ftp://alpha.gnu.org/gnu/emacs/pretest/emacs-%{emacsversion}.tar.gz
22Source1:      emacs-snapshot.sh
23
24Source10:     site-start.el.emacs24
25
26## local settings for local system
27Source20:     emacs24-local.el
28
29# desktop file
30Source50:     emacs24.desktop.in
31
32## Enable Japanese Menu
33## http://www11.atwiki.jp/s-irie/pages/13.html
34Source100:    menu-tree-el-%{menutreeelversion}.tar.gz
35Source110:    menu-tree-init.el.emacs24
36
37## default settings for Vine Linux
38Source150:    vine-default-base.el
39Source151:    vine-default-faces.el
40
41## Vine Patch(es)
42#Patch10:      emacs-21.1-ppc-nocombreloc.patch
43Patch11:      emacs-23.0.60-locallisppath.patch
44Patch20:      emacs-23.1.90-fixed-resolution.patch
45Patch30:      emacs-24.0.90-libs-termcap.patch
46
47# Fixed in upstream CVS. (from Fedora)
48
49# security patches (from Debian)
50
51# security patches (from Ubuntu)
52
53# patches from Mandrake
54Patch1001:    emacs-21.1-bzip2.patch.bz2
55
56License:      GPLv3+
57Group:        Applications/Editors/Emacs
58
59Distribution: Vine Linux
60Vendor:       Project Vine
61Packager:     munepi, daisuke
62
63BuildRoot:    %{_tmppath}/%{name}-%{version}-root
64# Requires:     tamago >= 4.0.6
65Obsoletes:    mule-base, mule-canna, mule-wnn6, mule, emacs-beta
66Obsoletes:    emacs21 <= 21.2-0vl7
67Obsoletes:    emacs22 <= 22.1
68Obsoletes:    emacs23 <= 23.1
69Provides:     emacs24 = %{version}
70Provides:     emacsen = 0.1
71#% prereq_ge    emacsen-common
72Requires(post):    emacsen-common
73Requires(postun):    emacsen-common
74
75BuildRequires: autoconf
76BuildRequires: xz
77BuildRequires: atk-devel
78BuildRequires: dbus-devel GConf2-devel
79BuildRequires: alsa-lib-devel
80BuildRequires: gnutls-devel
81%if %{?_dist_release} >= "vl7"
82BuildRequires: gtk3-devel
83%else
84BuildRequires: gtk2-devel
85%endif
86BuildRequires: cairo-devel
87BuildRequires: freetype2-devel, fontconfig-devel
88BuildRequires: libpng-devel, libjpeg-devel, libtiff-devel, libungif-devel
89BuildRequires: librsvg2-devel, libotf-devel
90BuildRequires: ImageMagick-devel
91BuildRequires: libxml2-devel > 2.6.17
92BuildRequires: m17n-lib-devel
93BuildRequires: libX11-devel, libXau-devel, libXdmcp-devel, libXrender-devel
94BuildRequires: libSM-devel, libXt-devel, libXpm-devel, ncurses-devel
95BuildRequires: xorg-x11-proto-devel, zlib-devel
96BuildRequires: texinfo
97BuildRequires: nkf
98
99%description
100GNU Emacs is the extensible, customizable, self-documenting real-time
101display editor.
102
103%description -l ja
104GNU Emacs は拡張性が高く、さまざまなカスタマイズが可能な高機能エディタです。
105
106
107%prep
108
109%setup -q -n emacs-%{version}
110
111%ifarch ppc
112#%patch10 -p1
113%endif
114
115%patch11 -p1
116%patch20 -p1
117%patch30 -p1
118
119%patch1001 -p1
120
121#autoconf
122autoreconf -i -I m4
123
124%build
125
126export CFLAGS="-DMAIL_USE_LOCKF $RPM_OPT_FLAGS"
127#to find installinfo
128export PATH="$PATH:/sbin:/usr/sbin"
129
130%configure --with-pop --with-sound \
131    --libexecdir=%{_libdir} --infodir=%{infodir} \
132    --disable-rename \
133%if %{?_dist_release} >= "vl7"
134    --with-x-toolkit=gtk3 \
135%else
136    --with-x-toolkit=gtk \
137%endif
138    --with-freetype --with-xft \
139    --enable-font-backend \
140    --without-gpm \
141    --with-libotf \
142    --with-m17n-flt \
143    --with-dbus --with-gconf \
144    ;
145
146%__make bootstrap
147%__make %{?_smp_mflags}
148
149
150#%define recompile src/emacs -batch --no-init-file --no-site-file -f batch-byte-compile
151
152# recompile patched .el files
153#%{recompile} lisp/mail/mh-utils.el lisp/progmodes/make-mode.el
154
155# bytecompile python-mode, ssl, php-mode and rpm-spec-mode
156#cp %SOURCE12  %SOURCE14 %SOURCE16 %SOURCE17 .
157##%%{recompile} rpm-spec-mode.el php-mode.el ssl.el po-mode.el
158
159
160%install
161[ "${RPM_BUILD_ROOT}" != "/" ] && %__rm -rf ${RPM_BUILD_ROOT}
162
163ARCHDIR=${RPM_ARCH}-vine-linux
164
165%makeinstall libexecdir=$RPM_BUILD_ROOT%{_libdir} \
166        infodir=${RPM_BUILD_ROOT}%{infodir}
167
168## This is a duplicate of the file in FLAVOR/site-lisp
169%__rm -f $RPM_BUILD_ROOT%{_datadir}/emacs/site-lisp/subdirs.el || exit 1
170
171# (cd $RPM_BUILD_ROOT%{_mandir}/man1/; %__mv ctags.1 gctags.1)
172# (cd $RPM_BUILD_ROOT%{_bindir}/; %__mv ctags gctags)
173
174%__mkdir_p  $RPM_BUILD_ROOT%{_datadir}/emacs-%{version}/etc
175%__mkdir_p  $RPM_BUILD_ROOT%{_datadir}/emacs-%{version}/site-lisp
176# cp %{SOURCE100} $RPM_BUILD_ROOT%{_datadir}/emacs-%{version}/site-lisp/menu-tree.el
177# nkf -w %{SOURCE100} > $RPM_BUILD_ROOT%{_datadir}/emacs-%{version}/site-lisp/menu-tree-utf8.el
178%__tar zxvf %{SOURCE100}
179%__cp -a menu-tree-el-%{menutreeelversion}/menu-tree.el $RPM_BUILD_ROOT%{_datadir}/emacs-%{version}/site-lisp/
180nkf -w --overwrite $RPM_BUILD_ROOT%{_datadir}/emacs-%{version}/site-lisp/menu-tree.el
181
182## vine default
183%__cp -a %{SOURCE150} %{SOURCE151} \
184    $RPM_BUILD_ROOT%{_datadir}/emacs-%{version}/site-lisp/
185
186# The elisp reference manual
187#bzcat %{SOURCE13} | tar xf -
188#pushd elisp-manual-21-2.8
189#install -m 644 elisp elisp-? elisp-?? $RPM_BUILD_ROOT/%{infodir}
190#popd
191
192# some modifications of installed files
193
194#rm -f $RPM_BUILD_ROOT%{infodir}/dir
195#gzip -9nf $RPM_BUILD_ROOT%{infodir}/*
196
197%__install -m 644 %{SOURCE10} \
198        $RPM_BUILD_ROOT/%{_datadir}/emacs-%{version}/site-lisp/site-start.el
199%__sed -i -e 's/EMACS_VERSION/%{version}/g' \
200          -e 's/VINE_DEFAULT_MAJOR_VERSION/%{vine_default_major_version}/g' \
201        $RPM_BUILD_ROOT/%{_datadir}/emacs-%{version}/site-lisp/site-start.el
202
203## create site-start.d directory
204%__install -m 755 -d ${RPM_BUILD_ROOT}/etc/emacs-%{version}/site-start.d
205
206# install coding-system init.el
207%__install -m644 %{SOURCE110} \
208    $RPM_BUILD_ROOT/%{_datadir}/emacs-%{version}/site-lisp/menu-tree-init.el
209%__ln_s -f %{_datadir}/emacs-%{version}/site-lisp/menu-tree-init.el \
210    ${RPM_BUILD_ROOT}/etc/emacs-%{version}/site-start.d/60menu-tree-init.el
211
212## install system-wide configure file
213%__install -m755 -d ${RPM_BUILD_ROOT}/etc/emacs
214%__install -m644 %{SOURCE20} ${RPM_BUILD_ROOT}/etc/emacs/emacs24-local.el
215%__sed -i -e 's/EMACS_VERSION/%{version}/g' \
216    ${RPM_BUILD_ROOT}/etc/emacs/emacs24-local.el
217
218## Python mode, php mode and rpm-spec mode
219
220## make file list
221strip $RPM_BUILD_ROOT%{_bindir}/* || :
222
223# install desktop file
224%__mkdir_p $RPM_BUILD_ROOT%{_datadir}/applications
225%__sed -e "s/@@EMACS_VERSION@@/%{emacsversion}/g" %{SOURCE50} > \
226    $RPM_BUILD_ROOT%{_datadir}/applications/$(basename %{SOURCE50} .in)
227[ -f $RPM_BUILD_ROOT%{_datadir}/applications/emacs.desktop ] && \
228    %__rm -f $RPM_BUILD_ROOT%{_datadir}/applications/emacs.desktop || exit 1
229
230# install icons
231%__mkdir_p $RPM_BUILD_ROOT%{_datadir}/icons
232%__cp -a etc/images/icons/hicolor $RPM_BUILD_ROOT%{_datadir}/icons/
233
234## remove man files
235%__rm -f $RPM_BUILD_ROOT/%{_mandir}/man1/* || exit 1
236
237## Remove ctags
238#rm -f $RPM_BUILD_ROOT/usr/bin/ctags
239#rm -f $RPM_BUILD_ROOT/%{_mandir}/man1/*ctags*
240#rm -f $RPM_BUILD_ROOT/%{_datadir}/emacs/%{version}/etc/ctags*
241
242DIR="${RPM_BUILD_ROOT}%{_datadir}/emacs \
243     ${RPM_BUILD_ROOT}%{_datadir}/emacs-%{version}"
244BIN=${RPM_BUILD_ROOT}%{_bindir}
245LIB=${RPM_BUILD_ROOT}%{_libdir}
246EL="*.el"
247
248## prepare file list for emacs
249echo "/usr/bin/ctags
250/usr/bin/ebrowse
251/usr/bin/etags
252/usr/bin/rcs-checkin
253/usr/bin/emacs
254/usr/bin/emacsclient
255/usr/bin/grep-changelog
256/usr/share/icons/hicolor/scalable/apps/emacs.svg
257/usr/share/icons/hicolor/scalable/mimetypes/emacs-document.svg" |
258    %__sed -e "s#[^\n]*#mv ${RPM_BUILD_ROOT}\0 ${RPM_BUILD_ROOT}\0.emacs-%{version}#"|
259    awk '{system($_)}' 
260
261find $DIR $BIN $LIB -type d |
262  %__sed -e "s#^${RPM_BUILD_ROOT}#%dir #" > rpm-files
263
264find $DIR $BIN $LIB -type f |
265  %__sed -e "
266    s#^${RPM_BUILD_ROOT}\(.*movemail\)#%attr(2755, root, mail) \1#
267    s#^${RPM_BUILD_ROOT}##
268  " >> rpm-files
269
270
271%clean
272[ "${RPM_BUILD_ROOT}" != "/" ] && %__rm -rf ${RPM_BUILD_ROOT}
273
274
275%define info_files ccmode cl dired-x ediff emacs forms gnus info message mh-e reftex sc vip viper widget
276
277
278%pre
279
280if [ -L %{_datadir}/emacs-%{version}/site-lisp ] ; then
281    %__rm -f %{_datadir}/emacs-%{version}/site-lisp
282fi
283
284if [ -d %{_datadir}/emacs/%{version}/site-lisp ] ; then
285    find %{_datadir}/emacs/%{version}/site-lisp/* -maxdepth 0 | grep -v subdirs.el | \
286        xargs %__rm -rf
287fi
288
289
290%post
291
292if [ "$1" = 1 ]; then
293
294%_addflavorslist emacs-%{version}
295
296export PRIORITY=50
297
298%_installemacs emacs-%{version}
299
300unset PRIORITY
301fi
302
303if [ "$1" = 2 ]; then
304
305#  export PRIORITY=50
306 
307#  %_installemacs emacs-%{version}
308 
309#  unset PRIORITY
310   
311  echo emacs-%{version} >  /var/lib/emacsen-common/doinstaflavor-emacs
312   
313fi
314
315
316%postun
317
318if [ $1 = 1 ]; then
319# run upgrade install time
320
321# old version uninstall
322
323%_removeflavorslist emacs-%{version}
324
325%_removeemacs emacs-%{version}
326
327#new version install
328if [ -f /var/lib/emacsen-common/doinstaflavor-emacs ] ; then
329
330NEWFLAVOR=$(cat /var/lib/emacsen-common/doinstaflavor-emacs)
331
332%_addflavorslist $NEWFLAVOR
333
334export PRIORITY=50
335
336%_installemacs $NEWFLAVOR
337
338unset PRIORITY
339
340%__rm -rf /var/lib/emacsen-common/doinstaflavor-emacs
341
342fi
343
344fi
345
346
347%preun
348if [ $1 = 0 ]; then
349
350%_removeflavorslist emacs-%{version}
351
352%_removeemacs emacs-%{version}
353
354fi
355
356
357%triggerpostun -- emacs23 < %{version}-%{release}
358
359%_addflavorslist emacs-%{version}
360
361export PRIORITY=50
362
363%_installemacs emacs-%{version}
364
365unset PRIORITY
366
367
368%files -f rpm-files
369%defattr(-,root,root)
370%doc INSTALL README BUGS ChangeLog COPYING
371#%doc INSTALL.BZR
372%dir %{_sysconfdir}/emacs-%{version}
373%dir %{_sysconfdir}/emacs-%{version}/site-start.d
374%{_sysconfdir}/emacs-%{version}/site-start.d/*.el
375%config(noreplace) %{_sysconfdir}/emacs/emacs24-local.el
376%{_infodir}/*
377# %{_mandir}/*/*
378%{_datadir}/applications/emacs24.desktop
379%{_datadir}/icons/hicolor/*
380# %{_datadir}/emacs-%{version}/site-lisp
381%dir %{_localstatedir}/games/emacs
382%{_localstatedir}/games/emacs/*
383
384
385%changelog
386* Mon Aug 27 2012 Munehiro Yamamoto <munepi@vinelinux.org> 24.2-1
387- new upstream release
388
389* Sun Jun 10 2012 Munehiro Yamamoto <munepi@vinelinux.org> 24.1-1
390- new upstream release
391
392* Sat May 19 2012 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.97-1
393- updated to 24.0.97 (24.1 pretest)
394
395* Sun Apr 29 2012 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.96-1
396- updated to 24.0.96 (24.1 pretest)
397
398* Mon Apr  2 2012 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.95-1
399- updated to 24.0.95 (24.1 pretest)
400
401* Sun Mar 11 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 24.0.94-2
402- rebuild with ImageMagick-6.7.5.10
403
404* Mon Feb 27 2012 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.94-1
405- updated to 24.0.94 (24.1 pretest)
406
407* Tue Feb 14 2012 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.93-2
408- use gtk as X toolkit (for vl6)
409
410* Mon Jan 30 2012 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.93-1
411- updated to 24.0.93 (24.1 pretest)
412
413* Thu Dec  1 2011 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.92-1
414- updated to 24.0.92 (24.1 pretest)
415
416* Wed Nov  2 2011 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.91-1
417- updated to 24.0.91 (24.1 pretest)
418
419* Thu Oct  6 2011 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.90-2
420- set --with-x-toolkit=gtk3 (%%configure)
421  - added BuildRequires: gtk3-devel
422
423* Mon Sep 26 2011 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.90-1
424- updated to 24.0.90 (24.1 pretest)
425- applied emacs-24.0.90-libs-termcap.patch
426
427* Sat Jul 09 2011 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.50-10.20110817
428- emacs24 24.0.50 (20110817) snapshot
429- added BuildRequires: ImageMagick-devel, libSM-devel, libxml2-devel > 2.6.17
430
431* Sun Jun 05 2011 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.50-9.20110604
432- emacs24 24.0.50 (20110604) snapshot
433
434* Thu Apr 13 2011 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.50-8.20110413
435- emacs24 24.0.50 (20110413) snapshot
436
437* Tue Apr 05 2011 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.50-7.20110318
438- updated site-start.el
439  - defined vine-default-major-version, vine-default-minor-version,
440    vine-default-version
441  - set "ibus-el" to emacs-ime as default
442  - added ", modified for Vine Linux" to the end of emacs-build-system
443  - set "Vine _at_mark_ vinelinux.org" to report-emacs-bug-address
444
445* Sun Apr 03 2011 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.50-6.20110318
446- fixed site-start.el
447  - do not use the macro loop (contained in the common lisp)
448
449* Tue Feb 22 2011 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.50-5.20110318
450- emacs24 24.0.50 (20110318) snapshot
451
452* Tue Feb 22 2011 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.50-4.20110222
453- emacs24 24.0.50 (20110222) snapshot
454- updated site-start.el
455  - defined the function drop-vine-default-from-load-path (regex)
456
457* Sat Jan 22 2011 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.50-3.20110128
458- emacs24 24.0.50 (20110128) snapshot
459
460* Sun Jan 02 2011 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.50-2.20110101
461- emacs24 24.0.50 (20110101) snapshot
462
463* Sun Dec 05 2010 Munehiro Yamamoto <munepi@vinelinux.org> 24.0.50-1.20101203
464- emacs24 24.0.50 (20101203) snapshot
465- applied new vine-default system
466  - updated site-start.el
467  - updated vine-default-{base,faces}.el
468  - dropped showvdefaultemacs
469    - merged to emacsen-common package as show-vine-default.sh
470  - renamed local wide configration file to emacs24-local.el
471- updated menu-tree.el to version 0.97
472- added Provides: emacs-snapshot
473
474* Sat Oct 30 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.2-4
475- updated vine-default-base.el
476  - changed the variable next-line-add-newlines to nil (default)
477
478* Thu Sep 23 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.2-3
479- updated menu-tree.el to version 0.96
480
481* Sat Jul 03 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.2-2
482- applied some patches from Fedora
483  - Fixed handling of dual spacing fonts rhbz#599437
484  - Add patch to fix rhbz#595546 hideshow library matches wrong parenthesis
485    under certain circumstances
486  - Added a patch fixing m17n and libotf version checking (m17ncheck)
487- updated menu-tree.el to version 0.95
488- merged emacs23-vl.spec of Vine Linux 5.1
489#* Thu Apr 01 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.1-9
490#- applied security fix emacs23-CVE-2010-0825-fix-movemail-race.diff from Ubuntu
491#
492#* Fri Feb 09 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.1-8
493#- added Requires(post): emacsen-common, Requires(postun): emacsen-common
494#
495#* Fri Feb 05 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.1-7
496#- dropped BuildRequires: m17n-lib-devel
497#- added --without-m17n-flt in %%configure
498
499* Mon May 31 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.2-1
500- new upstream release
501- updated menu-tree.el to version 0.94
502- updated menu-tree-init.el.emacs23
503  - used prefer-coding-system
504
505* Wed Apr 21 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.1.96-1
506- updated to 23.1.96 (23.2 pretest)
507
508* Sun Apr 18 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.1.95-2
509- removed /usr/share/emacs/site-lisp/subdirs.el
510
511* Sat Apr 03 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.1.95-1
512- updated to 23.1.95 (23.2 pretest)
513- added BuildRequires:
514  - atk-devel
515  - dbus-devel
516  - GConf2-devel
517  - alsa-lib-devel
518- added some configure options:
519  --with-libotf --with-m17n-flt --with-dbus --with-gconf
520
521* Sun Mar 21 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.1.94-1
522- updated to 23.1.94
523
524* Thu Mar 04 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.1.93-1
525- updated to 23.1.93 alpha
526
527* Sat Feb 13 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.1.92-2
528- added Requires(post): emacsen-common, Requires(postun): emacsen-common
529
530* Tue Feb 02 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.1.92-1
531- update to 23.1.92 alpha
532
533* Sun Jan 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.1-6
534- added BuildRequires:
535  - librsvg2-devel
536  - m17n-lib-devel
537  - libotf-devel
538
539* Sun Jan 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.1-5
540- changed License to GPLv3+
541- renamed emacs23.desktop to emacs23.desktop.in
542- updated vine-default-base.el (See [vine-users:079919])
543- fixed in upstream CVS (from Fedora)
544  - fix #543046 - Using scroll bar in emacs highlights/selects text
545  - fix #542657 - emacs does not display indic text
546  - Fixed rhbz#545398 - ETags messes up filenames
547
548* Tue Sep 01 2009 Munehiro Yamamoto <munepi@vinelinux.org> 23.1-4
549- rebuilt to add signature
550
551* Fri Aug 19 2009 Munehiro Yamamoto <munepi@vinelinux.org> 23.1-3
552- added BuildRequires: nkf
553- updated menu-tree-init.el.emacs23
554  - fixed menu-tree encoding <BTS:VineLinux:766>
555- set Exec=emacs-@@EMACS_VERSION@@ in emacs23.desktop
556
557* Wed Aug 19 2009 Munehiro Yamamoto <munepi@vinelinux.org> 23.1-2
558- replaced BR: libungif-devel with BR: giflib-devel
559
560* Sat Aug 01 2009 Munehiro Yamamoto <munepi@vinelinux.org> 23.1-1
561- new upstream release
562
563* Sat Jul 25 2009 Munehiro Yamamoto <munepi@vinelinux.org> 23.0.96-2.20090714
564- updated vine-default-faces.el to sync with emacs22
565
566* Tue Jul 14 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 23.0.96-1.20090714
567- update to 23.0.96 (20090714) snapshot
568- update vine-default-faces.el
569  - use bash to call gconftool-2
570
571* Sat Jun 27 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 23.0.94-4.20090527
572- update vine-default-faces.el
573  - added \'font in default-frame-alist
574    (if \'font is already in default-frame-alist, overwrited it)
575
576* Wed Jun 10 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 23.0.94-3.20090527
577- update vine-default-faces.el:
578  - use set-frame-font
579    bacause set-default-font function is obsolete since Emacs 23.1
580    (See M-x describe-function RET set-default-font)
581
582* Sun Jun 07 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 23.0.94-2.20090527
583- update vine-default-faces.el:
584  - set desktop-gnome-interface-monospace-font-name
585    from /desktop/gnome/interface/monospace_font_name
586  - automatically set set-default-font
587    with desktop-gnome-interface-monospace-font-name
588
589* Wed May 27 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 23.0.94-1.20090527
590- update to emacs-23.0.94 (20090527) snapshot
591- add --without-gpm to configure
592
593* Thu May 21 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 23.0.92-7.20090422
594- defined show-vine-default function in site-start.el
595  - added showvdefaultemacs script
596
597* Wed May 20 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 23.0.92-6.20090422
598- set PRIORITY=40
599
600* Wed May 06 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 23.0.92-5.20090422
601- changed menu-tree-init.el from hard copy to symbolic link
602  on /etc/emacs-23.0.92/site-start.d
603- added %%{_mandir}/*/* in %%files section
604
605* Sat May 02 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 23.0.92-4.20090422
606- updated menu-tree.el to v0.93
607
608* Fri May 01 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 23.0.92-3.20090422
609- returned alternatives priority to 30
610  (emacs: 30, emacs22: 30)
611
612* Sun Apr 26 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 23.0.92-2.20090422
613- installed system-wide configure file in /etc/emacs
614- updated vine-default-base.el
615- changed alternatives priority from 30 to 50
616  (emacs: 50, emacs22: 30)
617
618* Wed Apr 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 23.0.92-1.20090422
619- update to emacs 23.0.92 (20090422) snapshot
620- add %%triggerpostun to fix alternatives
621
622* Tue Apr 21 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 23.0.91-3.20090325
623- renamed from emacs23 to emacs (emacs-22.x would be renamed to emacs22)
624- updated default settings for Vine Linux
625  - dropped vine-default-mouse.el, vine-default-misc.el
626
627* Sat Apr 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 23.0.91-2.20090325
628- enable default settings for Vine Linux
629  - added site-start.el.emacs23
630  - updated site-start.el
631  - added vine-default-base.el, vine-default-faces.el, vine-default-mouse.el,
632    vine-default-misc.el
633
634* Wed Mar 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 23.0.91-1.20090325
635- emacs23 23.0.91 snapshot
636
637* Tue Sep 09 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 23.0.60-2.20080908
638- drop patch10
639- s/emacsrelese/emacsrelease/
640
641* Mon Sep 08 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 23.0.60-1.20080908
642- emacs23 23.0.60 snapshot
643
644* Sun Sep 07 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 22.3-1
645- new upstream release
646
647* Mon Aug 25 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 22.2-3
648- import security fixes from Debian
649  CVE-2008-2142: fix insecure setting of fast-lock-cache-directories
650  CVE-2008-1694: fix insecure temporary file creation in vcdiff script
651                 leading to possible symlink attacks
652
653* Tue Jun 25 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 22.2-2
654- update menu-tree.el
655- add 60menu-tree-init.el to sed coding-system and load menu-tree
656- build with xorg-x11-7.3
657  - update BuildRequires
658
659* Sun Mar 30 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 22.2-1
660- new upstream release
661
662* Wed Nov 28 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 22.1-0vl2
663- add Patch10000 to fix local variable processing security bypass
664  vulnerability.
665  - http://www.frsirt.com/english/advisories/2007/3715
666  - http://bugs.debian.org/449008
667
668* Mon Jun 04 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 22.1-0vl1
669- new upstream release
670- rename to emacs from emacs22 (emacs-21.x would be renameed to emacs21)
671- drop emcws support
672
673* Sun May 20 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 22.0.50-0.20060403vl3
674- rebuilt with new toolchain
675
676* Sat May 06 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 22.0.50-0.20060403vl2
677- changed Group:
678
679* Mon Apr 03 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 22.0.50-0.20060403vl1
680- update to CVS-20060403
681- update emacs22.desktop
682
683* Wed Sep 28 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 22.0.50-0.20050927vl2
684- fix site-start.el
685
686* Tue Sep 27 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 22.0.50-0.20050927vl1
687- update to CVS-20050927
688
689* Thu Sep  8 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 22.0.50-0.20050907vl1
690- initial build for Vine Linux based on emacs package.
691  - emacs-22.0.50 on CVS-20050907
692
693* Sat Sep  3 2005 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 21.4-0vl3
694- create site-start.d directory on %install
695
696* Thu Feb 17 2005 Hiroaki Irokawa <irorin@terra.dti.ne.jp> 21.4-0vl2
697- included leim-21.4
698- update emcws-21.3-20031213.gz
699
700* Wed Feb 16 2005 Hiroaki Irokawa <irorin@terra.dti.ne.jp> 21.4-0vl1
701- update
702
703* Sat Jul 24 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 21.3-0vl7
704- rebuild with Xaw3d, add BuildRequires: Xaw3d-devel
705
706* Fri Jul 23 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 21.3-0vl6
707- add Patch20 to fix display resolutions. (set to 96dpi)
708  (do not compute dynamically from display's size)
709
710* Tue Mar 16 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 21.3-0vl5
711- rebuilt with new toolchain environment
712
713* Thu Jul 17 2003 Hiroaki Irokawa <irorin@terra.dti.ne.jp> 21.3-0vl4
714- use site-start.el(reading /etc/emacs-21.3/site-start.d/*.el)
715
716* Wed May  7 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 21.3-0vl3
717- add BuildPrereq: libpng >= 1.2.5
718
719* Tue Apr 15 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 21.3-0vl2
720- fixed %%pre script
721
722* Tue Mar 25 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 21.3-0vl1
723- new upstream release
724- remove patch14 whick included in upstream
725
726* Thu Jan 16 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 21.2-0vl11
727- add patch14 to fix frame title text encoding.
728  - http://tsukuba.m17n.org/mule-ja-archive/2002-10/msg00004.html
729
730* Tue Dec 10 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 21.2-0vl10
731- autoconf-2.13, not autoconf in %%setup section
732- BuildPreReq: autoconf213
733
734* Mon Dec  9 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 21.2-0vl9
735- modifiy rpm scripts.
736
737* Mon Dec  9 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 21.2-0vl8
738- rename to emacs
739- obsoletes emacs21 <= 21.2-0vl7, provides emacs21 = %%{version}
740
741* Sun Dec  1 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 21.2-0vl7
742- enable menubar fontset patch (Patch103)
743
744* Sat Nov 30 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 21.2-0vl6
745- add requires/buildprereq tags.
746
747* Sat Nov 30 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 21.2-0vl5
748- add emcws-20021014
749
750* Sun Jul 21 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 21.2-0vl4
751- removed *-mode
752
753* Sat Jul 20 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 21.2-0vl3
754- python-mode was made pending
755- some additional *.el files was moved from "emacs/site-lisp" to
756  "emacs-(version)/site-lisp"
757
758* Sat Jul 13 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 21.2-0vl2
759- added some sources and patches from rawhide 21.2-11 and mandrake 21.2-7mdk
760
761* Sat May 11 2002 Hiroaki Irokawa <irorin@terra.dti.ne.jp> 21.2-0vl1
762- update.
763- Package Name emacs-beta -> emacs21
764- Add Patch100,101,102, Source100(default = Disable)
765- (from http://phe.phyas.aichi-edu.ac.jp/~cyamauch/pl2.html#emacs21)
766- --infodir=%{_infodir}/emacs-21.2(VineSeed-Plus:00723)
767
768* Thu Dec 27 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 21.1-0vl7
769- site-lisp moved under /usr/share/emacs-21.1/ (Patch11 and %%pre section)
770
771* Thu Dec 06 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 21.1-0vl5
772- move /tmp -> /var/lib/emacsen-common (IP(package)C file)
773
774* Fri Nov 02 2001 Tomoya TAKA <tomoya@olive.plala.or.jp> 21.1-0vl4
775- replace patch10 with patch11, posted to gnu.emacs.bug
776  Message-Id: <jebsiza3db.fsf@sykes.suse.de>
777  (reported by ABE Yuji <cbo46560@pop12.odn.ne.jp>)
778
779* Fri Oct 26 2001 Kazuhisa TAKEI <takei@vinelinux.org> 21.1-0vl3
780- fixed build to fail in alpha( only apply patch0 to ppc)
781
782* Tue Oct 23 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 21.1-0vl2
783- added Patch10 (thanks Kitame-san)
784
785* Mon Oct 22 2001 Kazuhisa TAKEI <takei@vinelinux.org> 21.1-0vl1
786- update to 21.1
787
788* Sun Sep 9 2001 Kazuhisa TAKEI <takei@vinelinux.org> 21.0.104-0vl14
789- support  shared installing otheremacsen.
790
791* Mon Jul 23 2001 Kazuhisa TAKEI <takei@vinelinux.org> 21.0.104-0vl3
792- update 21.0.104
793
794* Thu Jul 19 2001 Kazuhisa TAKEI <takei@vinelinux.org> 21.0.103-0vl2
795- support emacsen-common
796
797* Wed May 16 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
798- 21.0.103-0vl1
799- updated to 21.0.103
800- revamped and cleaned up spec file :-)
801- Requires: tamago >= 4.0.6 (...is it reasonable? Mmm...)
802
803* Mon Jan 22 2001 Kazuhisa TAKEI <takei@vinelinux.org> 21.0.95-0vl2
804- fixed .spec bugs( _libdir)
805
806* Fri Jan 12 2001 Kazuhisa TAKEI <takei@vinelinux.org> 21.0.95-0vl1
807- updated to 21.0.95
808
809* Wed Dec 20 2000 Kazuhisa TAKEI <takei@vinelinux.org> 21.0.93-0vl3
810- fixed emacs-beta.spec
811
812* Sat Dec 16 2000 Kazuhisa TAKEI <takei@vinelinux.org> 21.0.93-0vl2
813- 21.0.93 test packaging.
814
815* Fri Jun 30 2000 T.R. Kobayashi <tkoba@ike-dyn.ritsumei.ac.jp>
816- added linespace-patch
817
818* Mon Jun 19 2000 MACHINO, Satoshi <mac@netfort.gr.jp>
819- updated to emacs 20.7
820
821* Thu Apr 20 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
822- updated to emacs 20.6
823
824* Mon Feb 28 2000 kenji KITAYAMA <kenji@gandalf.doshisha.ac.jp>
825- [emacs-20.5a-2]
826- Modified reference of Emacs Info
827
828* Sun Jan 23 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
829- [emacs-20.5a-2]
830- added ppc patch
831
832* Fri Jan  7 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
833- [emacs-20.5a-1]
834- change version from 20.5 to 20.5a
835- added Mule-4.1 patch
836
837* Fri Jan  7 2000 Yasuyuki Furukawa <yasu@on.cs.keio.ac.jp>
838- [emacs-20.5-1]
839- add desktop-link files for desktop menu.
840
841* Thu Dec 24 1999 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
842- [emacs-20.4-16]
843- replaced Y2K savvy timezone.{el,elc} with one from brand-new apel-10.0
844
845* Tue Dec 21 1999 Jun Nishii <jun@vinelinux.org>
846- added documents
847- strip bins
848
849* Wed Dec  1 1999 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
850- [emacs-20.4-14]
851- Change Group to Applications/Editors/Emacs
852
853* Sat Nov  6 1999 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
854- [emacs-20.4-13]
855- included Y2K savvy timezone.{el,elc},
856  modified by Mr. Youichi Teranishi <teranishi@gohome.org>
857
858* Tue Oct 12 1999 Yasuhide OOMORI <dasen@typhoon.co.jp>
859- [emacs-20.4-12]
860- Modified info-dir.
861- Removed -c option from %setup.
862
863* Sun Sep 20 1999 Kazuhisa TAKEI<takei@hh.iij4u.or.jp>
864- fixed XIM support patch
865* Sun Sep 19 1999 Kazuhisa TAKEI<takei@hh.iij4u.or.jp>
866- fixed postinst bug and fontset patch
867* Sun Jul 18 1999 Kazuhisa TAKEI<takei@hh.iij4u.or.jp>
868- first build
Note: See TracBrowser for help on using the repository browser.