source: projects/specs/branches/6/e/emacs/emacs23-vl.spec @ 6835

Revision 6835, 28.6 KB checked in by munepi, 12 years ago (diff)

added patch50 to handle CVE-2012-3479

Line 
1%define emacsversion 23.3
2#% define rcversion rc1
3%define emacsrelease 6%{?rcversion:.%rcversion}%{?_dist_release}
4%define vine_default_major_version %(echo %_dist_release|%__sed s/vl//)
5
6%define _noVersionedDependencies 1
7%define prereq_ge()  %(LC_ALL="C" rpm -q --queryformat 'PreReq:%%{NAME} >= %%{VERSION}' %1| grep -v "is not")
8
9%define infodir %{_infodir}/emacs-%{emacsversion}
10
11%define menutreeelversion 0.97
12
13Summary:      GNU Emacs editor
14Summary(ja):  GNU Emacs エディタ
15Name:         emacs
16Version:      %{emacsversion}
17Release:      %{emacsrelease}
18Source0:      ftp://ftp.gnu.org/pub/gnu/emacs/emacs-%{version}b.tar.bz2
19#Source0:      ftp://alpha.gnu.org/gnu/emacs/pretest/emacs-%{emacsversion}%{?rcversion:-%rcversion}.tar.gz
20
21## Sources from Rawhide 21.2-11
22Source10:     site-start.el.emacs23
23Source11:     python-mode.el
24Source12:     http://www.tihlde.org/~stigb/rpm-spec-mode.el
25Source13:     ftp://ftp.gnu.org/gnu/emacs/elisp-manual-21-2.8.tar.bz2
26# 1.0.2 - http://prdownloads.sourceforge.net/php-mode/php-mode-102.el
27Source14:     php-mode.el
28Source15:     php-mode-init.el
29Source16:     ssl.el
30Source17:     po-mode.el
31Source18:     po-mode-init.el
32
33## local settings for local system
34Source20:     emacs23-local.el
35
36# desktop file
37Source50:     emacs23.desktop.in
38
39## Enable Japanese Menu
40## http://www11.atwiki.jp/s-irie/pages/13.html
41Source100:    menu-tree-el-%{menutreeelversion}.tar.gz
42Source110:    menu-tree-init.el.emacs23
43
44## default settings for Vine Linux
45Source150:    vine-default-base.el
46Source151:    vine-default-faces.el
47
48## Vine Patch(es)
49Patch10:      emacs-21.1-ppc-nocombreloc.patch
50Patch11:      emacs-23.0.60-locallisppath.patch
51Patch20:      emacs-23.1.90-fixed-resolution.patch
52
53# Fixed in upstream CVS. (from Fedora)
54#Patch30:      emacs-23.1-scroll.patch
55#Patch31:      emacs-23.1-indian.patch
56#Patch32:      emacs-23.1-memmove.patch
57# Accepted by upstream.
58#Patch33: emacs-23.2-m17ncheck.patch
59# Fix rhbz#595546
60# Upstream: http://emacsbugs.donarmstrong.com/cgi/bugreport.cgi?bug=6158
61Patch34: emacs-23.2-hideshow-comment.patch
62# Reported upstream http://debbugs.gnu.org/cgi/bugreport.cgi?bug=4129
63#Patch35: emacs-23.2-spacing.patch
64# http://bzr.savannah.gnu.org/lh/emacs/trunk/revision/106247
65Patch36: emacs-23.3-wm-state-hidden.patch
66# rhbz#751154
67Patch37: emacs-23.3-xgselect.patch
68# http://bzr.savannah.gnu.org/lh/emacs/trunk/revision/103228
69Patch38: emacs-23.1-103228_103227.patch
70# Upstream implemented the change in revno. 101105
71Patch40: emacs-23.1-xdg.patch
72# http://lists.gnu.org/archive/html/emacs-devel/2012-01/msg00387.html
73Patch41: emacs-23.3-ede-cve-2012-0035.patch
74
75# GNU bug report logs - #12155
76# 24.1; Potential Security Flaw with `enable-local-eval',
77# `enable-local-variables'
78# http://debbugs.gnu.org/cgi/bugreport.cgi?bug=12155#14
79Patch50: emacs-23.3-CVE-2012-3479.patch
80
81# security patches (from Debian)
82
83# security patches (from Ubuntu)
84# # http://www.vupen.com/english/advisories/2010/0734
85# # https://code.launchpad.net/~ubuntu-branches/ubuntu/karmic/emacs23/karmic-security
86# Patch501:      emacs23-CVE-2010-0825-fix-movemail-race.diff
87
88# patches from Mandrake
89Patch1001:    emacs-21.1-bzip2.patch.bz2
90
91License:      GPLv3+
92Group:        Applications/Editors/Emacs
93
94Distribution: Vine
95Vendor:       Project Vine
96Packager:     munepi, daisuke
97
98BuildRoot:    %{_tmppath}/%{name}-%{version}-root
99# Requires:     tamago >= 4.0.6
100Obsoletes:    mule-base, mule-canna, mule-wnn6, mule, emacs-beta
101Obsoletes:    emacs21 <= 21.2-0vl7
102Obsoletes:    emacs22 <= 22.0.50
103Obsoletes:    emacs23 <= 23.0.91-2.20090325vl5
104Provides:     emacs23 = %{version}
105Provides:     emacsen = 0.1
106#% prereq_ge    emacsen-common
107Requires(post):    emacsen-common
108Requires(postun):    emacsen-common
109
110BuildRequires: autoconf
111%if %{?_dist_release} == "vl6" || %{?_dist_release} == "vl7"
112BuildRequires: atk-devel
113BuildRequires: dbus-devel GConf2-devel
114BuildRequires: alsa-lib-devel
115%endif
116BuildRequires: gtk2-devel, cairo-devel
117BuildRequires: freetype-devel, fontconfig-devel
118BuildRequires: libpng-devel, libjpeg-devel, libtiff-devel, libungif-devel
119##!! For vl5, m17n-lib-devel (plus)
120BuildRequires: librsvg2-devel, libotf-devel
121%if %{?_dist_release} == "vl6" || %{?_dist_release} == "vl7"
122BuildRequires: m17n-lib-devel
123%endif
124BuildRequires: libX11-devel, libXau-devel, libXdmcp-devel, libXrender-devel
125BuildRequires: libXt-devel, libXpm-devel, ncurses-devel
126BuildRequires: xorg-x11-proto-devel, zlib-devel
127BuildRequires: texinfo
128BuildRequires: nkf
129
130%description
131GNU Emacs is the extensible, customizable, self-documenting real-time
132display editor.
133
134%description -l ja
135GNU Emacs は拡張性が高く、さまざまなカスタマイズが可能な高機能エディタです。
136
137
138%prep
139
140%setup -q -n emacs-%{version}
141
142%ifarch ppc
143#%patch10 -p1
144%endif
145
146%patch11 -p1
147%patch20 -p1
148
149#%patch30 -p1 -b .scroll
150#%patch31 -p1
151#%patch32 -p1 -b .memmove
152#%patch33 -p1 -b .m17ncheck
153%patch34 -p0 -b .hideshow-comment
154#%patch35 -p1 -b .spacing
155%patch36 -p1 -b .wm-state-hidden
156%patch37 -p1 -b .xgselect
157%patch38 -p0 -b .svn17
158%patch40 -p1 -b .xdg
159%patch41 -p1 -b .ede-cve-2012-0035
160
161%patch50 -p0 -b .CVE-2012-3479
162
163#%patch501 -p1 -b .movemail
164
165%patch1001 -p1
166
167autoconf
168
169
170%build
171
172export CFLAGS="-DMAIL_USE_LOCKF $RPM_OPT_FLAGS"
173#to find installinfo
174export PATH="$PATH:/sbin:/usr/sbin"
175
176%configure --with-pop --with-sound \
177    --libexecdir=%{_libdir} --infodir=%{infodir} \
178    --disable-rename \
179    --with-toolkit=gtk \
180    --with-freetype --with-xft \
181    --enable-font-backend \
182    --without-gpm \
183        --with-libotf \
184%if %{?_dist_release} == "vl5"
185      --without-m17n-flt \
186%endif
187%if %{?_dist_release} == "vl6" || %{?_dist_release} == "vl7"
188      --with-m17n-flt \
189      --with-dbus --with-gconf \
190%endif
191    ;
192
193%__make bootstrap
194%__make %{?_smp_mflags}
195
196
197#%define recompile src/emacs -batch --no-init-file --no-site-file -f batch-byte-compile
198
199# recompile patched .el files
200#%{recompile} lisp/mail/mh-utils.el lisp/progmodes/make-mode.el
201
202# bytecompile python-mode, ssl, php-mode and rpm-spec-mode
203#cp %SOURCE12  %SOURCE14 %SOURCE16 %SOURCE17 .
204##%%{recompile} rpm-spec-mode.el php-mode.el ssl.el po-mode.el
205
206
207%install
208[ "${RPM_BUILD_ROOT}" != "/" ] && %__rm -rf ${RPM_BUILD_ROOT}
209
210ARCHDIR=${RPM_ARCH}-vine-linux
211
212%makeinstall libexecdir=$RPM_BUILD_ROOT%{_libdir} \
213        infodir=${RPM_BUILD_ROOT}%{infodir}
214
215## This is a duplicate of the file in FLAVOR/site-lisp
216%__rm -f $RPM_BUILD_ROOT%{_datadir}/emacs/site-lisp/subdirs.el || exit 1
217
218(cd $RPM_BUILD_ROOT%{_mandir}/man1/; %__mv ctags.1 gctags.1)
219(cd $RPM_BUILD_ROOT%{_bindir}/; %__mv ctags gctags)
220
221%__mkdir_p  $RPM_BUILD_ROOT%{_datadir}/emacs-%{version}/etc
222%__mkdir_p  $RPM_BUILD_ROOT%{_datadir}/emacs-%{version}/site-lisp
223# cp %{SOURCE100} $RPM_BUILD_ROOT%{_datadir}/emacs-%{version}/site-lisp/menu-tree.el
224# nkf -w %{SOURCE100} > $RPM_BUILD_ROOT%{_datadir}/emacs-%{version}/site-lisp/menu-tree-utf8.el
225%__tar zxvf %{SOURCE100}
226%__cp -a menu-tree-el-%{menutreeelversion}/menu-tree.el $RPM_BUILD_ROOT%{_datadir}/emacs-%{version}/site-lisp/
227nkf -w --overwrite $RPM_BUILD_ROOT%{_datadir}/emacs-%{version}/site-lisp/menu-tree.el
228
229## vine default
230%__cp -a %{SOURCE150} %{SOURCE151} \
231    $RPM_BUILD_ROOT%{_datadir}/emacs-%{version}/site-lisp/
232
233# The elisp reference manual
234#bzcat %{SOURCE13} | tar xf -
235#pushd elisp-manual-21-2.8
236#install -m 644 elisp elisp-? elisp-?? $RPM_BUILD_ROOT/%{infodir}
237#popd
238
239# some modifications of installed files
240
241#rm -f $RPM_BUILD_ROOT%{infodir}/dir
242#gzip -9nf $RPM_BUILD_ROOT%{infodir}/*
243
244%__install -m 644 %{SOURCE10} \
245        $RPM_BUILD_ROOT/%{_datadir}/emacs-%{version}/site-lisp/site-start.el
246%__sed -i -e 's/EMACS_VERSION/%{version}/g' \
247          -e 's/VINE_DEFAULT_MAJOR_VERSION/%{vine_default_major_version}/g' \
248        $RPM_BUILD_ROOT/%{_datadir}/emacs-%{version}/site-lisp/site-start.el
249
250## create site-start.d directory
251%__install -m 755 -d ${RPM_BUILD_ROOT}/etc/emacs-%{version}/site-start.d
252
253# install coding-system init.el
254%__install -m644 %{SOURCE110} \
255    $RPM_BUILD_ROOT/%{_datadir}/emacs-%{version}/site-lisp/menu-tree-init.el
256%__ln_s -f %{_datadir}/emacs-%{version}/site-lisp/menu-tree-init.el \
257    ${RPM_BUILD_ROOT}/etc/emacs-%{version}/site-start.d/60menu-tree-init.el
258
259## install system-wide configure file
260%__install -m755 -d ${RPM_BUILD_ROOT}/etc/emacs
261%__install -m644 %{SOURCE20} ${RPM_BUILD_ROOT}/etc/emacs/emacs23-local.el
262%__sed -i -e 's/EMACS_VERSION/%{version}/g' \
263    ${RPM_BUILD_ROOT}/etc/emacs/emacs23-local.el
264
265## Python mode, php mode and rpm-spec mode
266
267## make file list
268strip $RPM_BUILD_ROOT%{_bindir}/* || :
269
270# install desktop file
271%__mkdir_p $RPM_BUILD_ROOT%{_datadir}/applications
272%__sed -e "s/@@EMACS_VERSION@@/%{emacsversion}/g" %{SOURCE50} > \
273    $RPM_BUILD_ROOT%{_datadir}/applications/$(basename %{SOURCE50} .in)
274[ -f $RPM_BUILD_ROOT%{_datadir}/applications/emacs.desktop ] && \
275    %__rm -f $RPM_BUILD_ROOT%{_datadir}/applications/emacs.desktop || exit 1
276
277# install icons
278%__mkdir_p $RPM_BUILD_ROOT%{_datadir}/icons
279%__cp -a etc/images/icons/hicolor $RPM_BUILD_ROOT%{_datadir}/icons/
280
281## remove man files
282%__rm -f $RPM_BUILD_ROOT/%{_mandir}/man1/* || exit 1
283
284## Remove ctags
285#rm -f $RPM_BUILD_ROOT/usr/bin/ctags
286#rm -f $RPM_BUILD_ROOT/%{_mandir}/man1/*ctags*
287#rm -f $RPM_BUILD_ROOT/%{_datadir}/emacs/%{version}/etc/ctags*
288
289DIR="${RPM_BUILD_ROOT}%{_datadir}/emacs \
290     ${RPM_BUILD_ROOT}%{_datadir}/emacs-%{version}"
291BIN=${RPM_BUILD_ROOT}%{_bindir}
292LIB=${RPM_BUILD_ROOT}%{_libdir}
293EL="*.el"
294
295## prepare file list for emacs
296
297echo "/usr/bin/b2m
298/usr/bin/ebrowse
299/usr/bin/etags
300/usr/bin/rcs-checkin
301/usr/bin/emacs
302/usr/bin/emacsclient
303/usr/bin/gctags
304/usr/bin/grep-changelog
305/usr/share/icons/hicolor/scalable/apps/emacs.svg
306/usr/share/icons/hicolor/scalable/mimetypes/emacs-document.svg"|
307    %__sed -e "s#[^\n]*#mv ${RPM_BUILD_ROOT}\0 ${RPM_BUILD_ROOT}\0.emacs-%{version}#"|
308    awk '{system($_)}' 
309
310
311# find ${RPM_BUILD_ROOT}/%{_mandir} -type f |
312# sed -e "s#\.gz##"|
313# sed -e "s#[^\n]*#mv \0.gz \0-emacs-%{version}.gz#"|
314#    awk '{system($_)}'
315
316
317
318
319#find ${RPM_BUILD_ROOT}/%{_infodir} -type f |
320#sed -e "s#\.gz##"|
321#sed -e "s#[^\n]*#mv \0.gz \0-e21.gz#"|
322#    awk '{system($_)}'
323
324
325
326
327
328find $DIR $BIN $LIB -type d |
329  %__sed -e "s#^${RPM_BUILD_ROOT}#%dir #" > rpm-files
330
331find $DIR $BIN $LIB -type f |
332  %__sed -e "
333    s#^${RPM_BUILD_ROOT}\(.*movemail\)#%attr(2755, root, mail) \1#
334    s#^${RPM_BUILD_ROOT}##
335  " >> rpm-files
336
337
338%clean
339[ "${RPM_BUILD_ROOT}" != "/" ] && %__rm -rf ${RPM_BUILD_ROOT}
340
341
342%define info_files ccmode cl dired-x ediff emacs forms gnus info message mh-e reftex sc vip viper widget
343
344
345%pre
346
347if [ -L %{_datadir}/emacs-%{version}/site-lisp ] ; then
348    %__rm -f %{_datadir}/emacs-%{version}/site-lisp
349fi
350
351if [ -d %{_datadir}/emacs/%{version}/site-lisp ] ; then
352    find %{_datadir}/emacs/%{version}/site-lisp/* -maxdepth 0 | grep -v subdirs.el | \
353        xargs %__rm -rf
354fi
355
356
357%post
358
359if [ "$1" = 1 ]; then
360
361%_addflavorslist emacs-%{version}
362
363export PRIORITY=40
364
365%_installemacs emacs-%{version}
366
367unset PRIORITY
368fi
369
370if [ "$1" = 2 ]; then
371
372#  export PRIORITY=40
373 
374#  %_installemacs emacs-%{version}
375 
376#  unset PRIORITY
377   
378  echo emacs-%{version} >  /var/lib/emacsen-common/doinstaflavor-emacs
379   
380fi
381
382
383%postun
384
385if [ $1 = 1 ]; then
386# run upgrade install time
387
388# old version uninstall
389
390%_removeflavorslist emacs-%{version}
391
392%_removeemacs emacs-%{version}
393
394#new version install
395if [ -f /var/lib/emacsen-common/doinstaflavor-emacs ] ; then
396
397NEWFLAVOR=$(cat /var/lib/emacsen-common/doinstaflavor-emacs)
398
399%_addflavorslist $NEWFLAVOR
400
401export PRIORITY=40
402
403%_installemacs $NEWFLAVOR
404
405unset PRIORITY
406
407%__rm -rf /var/lib/emacsen-common/doinstaflavor-emacs
408
409fi
410
411fi
412
413
414%preun
415if [ $1 = 0 ]; then
416
417%_removeflavorslist emacs-%{version}
418
419%_removeemacs emacs-%{version}
420
421fi
422
423
424%triggerpostun -- emacs23 < %{version}-%{release}
425
426%_addflavorslist emacs-%{version}
427
428export PRIORITY=40
429
430%_installemacs emacs-%{version}
431
432unset PRIORITY
433
434
435%files -f rpm-files
436%defattr(-,root,root)
437%doc INSTALL README BUGS ChangeLog
438%dir %{_sysconfdir}/emacs-%{version}
439%dir %{_sysconfdir}/emacs-%{version}/site-start.d
440%{_sysconfdir}/emacs-%{version}/site-start.d/*.el
441%config(noreplace) %{_sysconfdir}/emacs/emacs23-local.el
442%{_infodir}/*
443# %{_mandir}/*/*
444%{_datadir}/applications/emacs23.desktop
445%{_datadir}/icons/hicolor/*
446# %{_datadir}/emacs-%{version}/site-lisp
447%dir %{_localstatedir}/games/emacs
448%{_localstatedir}/games/emacs/*
449
450%changelog
451* Thu Aug 30 2012 Munehiro Yamamoto <munepi@vinelinux.org> 23.3-6
452- added patch50 to handle CVE-2012-3479
453
454* Sat Jan 21 2012 Munehiro Yamamoto <munepi@vinelinux.org> 23.3-5
455- added patch41 to handle CVE-2012-0035: CEDET global-ede-mode file loading
456  vulnerability (rhbz#773024)
457
458* Fri Jan 06 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 23.3-4
459- update to 23.3b
460- add patch36: Check for _NET_WM_STATE_HIDDEN (rhbz#711739)
461- add patch37: Initialize xgselect in function xg_select when
462  gfds_size == 0 (rhbz#751154)
463- add patch38: Apply upstream Subversion >= 1.7 dir structure
464  fix for vc-svn.el.
465- add patch40: use xdg-open for opening URLs
466
467* Tue Apr 05 2011 Munehiro Yamamoto <munepi@vinelinux.org> 23.3-3
468- updated site-start.el
469  - defined vine-default-major-version, vine-default-minor-version,
470    vine-default-version
471  - set "ibus-el" to emacs-ime as default
472  - added a string ", modified for Vine Linux" to the end of emacs-build-system
473  - set "Vine _at_mark_ vinelinux.org" to report-emacs-bug-address
474
475* Sun Apr 03 2011 Munehiro Yamamoto <munepi@vinelinux.org> 23.3-2
476- fixed site-start.el
477  - do not use the macro loop (contained in the common lisp)
478
479* Fri Mar 11 2011 Munehiro Yamamoto <munepi@vinelinux.org> 23.3-1
480- new upstream release
481
482* Tue Mar 01 2011 Munehiro Yamamoto <munepi@vinelinux.org> 23.3-1.rc1
483- updated to 23.3-rc1 (23.3 release candidate)
484
485* Tue Feb 22 2011 Munehiro Yamamoto <munepi@vinelinux.org> 23.2.94-1
486- updated to 23.2.94 (23.3 pretest)
487- updated site-start.el
488  - defined the function drop-vine-default-from-load-path (regex)
489
490* Wed Feb 02 2011 Munehiro Yamamoto <munepi@vinelinux.org> 23.2.93-1
491- updated to 23.2.93 (23.3 pretest)
492
493* Sat Jan 22 2011 Munehiro Yamamoto <munepi@vinelinux.org> 23.2.92-1
494- updated to 23.2.92 (23.3 pretest)
495- dropped upstreamed patches
496  - emacs-23.2-m17ncheck.patch
497  - emacs-23.2-spacing.patch
498
499* Sun Dec 05 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.2-5
500- applied new vine-default system
501  - updated site-start.el
502  - updated vine-default-{base,faces}.el
503  - dropped showvdefaultemacs
504    - merged to emacsen-common package as show-vine-default.sh
505  - renamed local wide configration file to emacs23-local.el
506- updated menu-tree.el to version 0.97
507- updated emacs23.desktop.in and menu-tree-init.el.emacs23, little
508
509* Sat Oct 30 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.2-4
510- updated vine-default-base.el
511  - changed the variable next-line-add-newlines to nil (default)
512
513* Thu Sep 23 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.2-3
514- updated menu-tree.el to version 0.96
515
516* Sat Jul 03 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.2-2
517- applied some patches from Fedora
518  - Fixed handling of dual spacing fonts rhbz#599437
519  - Add patch to fix rhbz#595546 hideshow library matches wrong parenthesis
520    under certain circumstances
521  - Added a patch fixing m17n and libotf version checking (m17ncheck)
522- updated menu-tree.el to version 0.95
523- merged emacs23-vl.spec of Vine Linux 5.1
524#* Thu Apr 01 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.1-9
525#- applied security fix emacs23-CVE-2010-0825-fix-movemail-race.diff from Ubuntu
526#
527#* Fri Feb 09 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.1-8
528#- added Requires(post): emacsen-common, Requires(postun): emacsen-common
529#
530#* Fri Feb 05 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.1-7
531#- dropped BuildRequires: m17n-lib-devel
532#- added --without-m17n-flt in %%configure
533
534* Mon May 31 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.2-1
535- new upstream release
536- updated menu-tree.el to version 0.94
537- updated menu-tree-init.el.emacs23
538  - used prefer-coding-system
539
540* Wed Apr 21 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.1.96-1
541- updated to 23.1.96 (23.2 pretest)
542
543* Sun Apr 18 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.1.95-2
544- removed /usr/share/emacs/site-lisp/subdirs.el
545
546* Sat Apr 03 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.1.95-1
547- updated to 23.1.95 (23.2 pretest)
548- added BuildRequires:
549  - atk-devel
550  - dbus-devel
551  - GConf2-devel
552  - alsa-lib-devel
553- added some configure options:
554  --with-libotf --with-m17n-flt --with-dbus --with-gconf
555
556* Sun Mar 21 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.1.94-1
557- updated to 23.1.94
558
559* Thu Mar 04 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.1.93-1
560- updated to 23.1.93 alpha
561
562* Sat Feb 13 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.1.92-2
563- added Requires(post): emacsen-common, Requires(postun): emacsen-common
564
565* Tue Feb 02 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.1.92-1
566- update to 23.1.92 alpha
567
568* Sun Jan 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.1-6
569- added BuildRequires:
570  - librsvg2-devel
571  - m17n-lib-devel
572  - libotf-devel
573
574* Sun Jan 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 23.1-5
575- changed License to GPLv3+
576- renamed emacs23.desktop to emacs23.desktop.in
577- updated vine-default-base.el (See [vine-users:079919])
578- fixed in upstream CVS (from Fedora)
579  - fix #543046 - Using scroll bar in emacs highlights/selects text
580  - fix #542657 - emacs does not display indic text
581  - Fixed rhbz#545398 - ETags messes up filenames
582
583* Tue Sep 01 2009 Munehiro Yamamoto <munepi@vinelinux.org> 23.1-4
584- rebuilt to add signature
585
586* Fri Aug 19 2009 Munehiro Yamamoto <munepi@vinelinux.org> 23.1-3
587- added BuildRequires: nkf
588- updated menu-tree-init.el.emacs23
589  - fixed menu-tree encoding <BTS:VineLinux:766>
590- set Exec=emacs-@@EMACS_VERSION@@ in emacs23.desktop
591
592* Wed Aug 19 2009 Munehiro Yamamoto <munepi@vinelinux.org> 23.1-2
593- replaced BR: libungif-devel with BR: giflib-devel
594
595* Sat Aug 01 2009 Munehiro Yamamoto <munepi@vinelinux.org> 23.1-1
596- new upstream release
597
598* Sat Jul 25 2009 Munehiro Yamamoto <munepi@vinelinux.org> 23.0.96-2.20090714
599- updated vine-default-faces.el to sync with emacs22
600
601* Tue Jul 14 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 23.0.96-1.20090714
602- update to 23.0.96 (20090714) snapshot
603- update vine-default-faces.el
604  - use bash to call gconftool-2
605
606* Sat Jun 27 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 23.0.94-4.20090527
607- update vine-default-faces.el
608  - added \'font in default-frame-alist
609    (if \'font is already in default-frame-alist, overwrited it)
610
611* Wed Jun 10 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 23.0.94-3.20090527
612- update vine-default-faces.el:
613  - use set-frame-font
614    bacause set-default-font function is obsolete since Emacs 23.1
615    (See M-x describe-function RET set-default-font)
616
617* Sun Jun 07 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 23.0.94-2.20090527
618- update vine-default-faces.el:
619  - set desktop-gnome-interface-monospace-font-name
620    from /desktop/gnome/interface/monospace_font_name
621  - automatically set set-default-font
622    with desktop-gnome-interface-monospace-font-name
623
624* Wed May 27 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 23.0.94-1.20090527
625- update to emacs-23.0.94 (20090527) snapshot
626- add --without-gpm to configure
627
628* Thu May 21 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 23.0.92-7.20090422
629- defined show-vine-default function in site-start.el
630  - added showvdefaultemacs script
631
632* Wed May 20 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 23.0.92-6.20090422
633- set PRIORITY=40
634
635* Wed May 06 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 23.0.92-5.20090422
636- changed menu-tree-init.el from hard copy to symbolic link
637  on /etc/emacs-23.0.92/site-start.d
638- added %%{_mandir}/*/* in %%files section
639
640* Sat May 02 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 23.0.92-4.20090422
641- updated menu-tree.el to v0.93
642
643* Fri May 01 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 23.0.92-3.20090422
644- returned alternatives priority to 30
645  (emacs: 30, emacs22: 30)
646
647* Sun Apr 26 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 23.0.92-2.20090422
648- installed system-wide configure file in /etc/emacs
649- updated vine-default-base.el
650- changed alternatives priority from 30 to 50
651  (emacs: 50, emacs22: 30)
652
653* Wed Apr 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 23.0.92-1.20090422
654- update to emacs 23.0.92 (20090422) snapshot
655- add %%triggerpostun to fix alternatives
656
657* Tue Apr 21 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 23.0.91-3.20090325
658- renamed from emacs23 to emacs (emacs-22.x would be renamed to emacs22)
659- updated default settings for Vine Linux
660  - dropped vine-default-mouse.el, vine-default-misc.el
661
662* Sat Apr 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 23.0.91-2.20090325
663- enable default settings for Vine Linux
664  - added site-start.el.emacs23
665  - updated site-start.el
666  - added vine-default-base.el, vine-default-faces.el, vine-default-mouse.el,
667    vine-default-misc.el
668
669* Wed Mar 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 23.0.91-1.20090325
670- emacs23 23.0.91 snapshot
671
672* Tue Sep 09 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 23.0.60-2.20080908
673- drop patch10
674- s/emacsrelese/emacsrelease/
675
676* Mon Sep 08 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 23.0.60-1.20080908
677- emacs23 23.0.60 snapshot
678
679* Sun Sep 07 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 22.3-1
680- new upstream release
681
682* Mon Aug 25 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 22.2-3
683- import security fixes from Debian
684  CVE-2008-2142: fix insecure setting of fast-lock-cache-directories
685  CVE-2008-1694: fix insecure temporary file creation in vcdiff script
686                 leading to possible symlink attacks
687
688* Tue Jun 25 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 22.2-2
689- update menu-tree.el
690- add 60menu-tree-init.el to sed coding-system and load menu-tree
691- build with xorg-x11-7.3
692  - update BuildRequires
693
694* Sun Mar 30 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 22.2-1
695- new upstream release
696
697* Wed Nov 28 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 22.1-0vl2
698- add Patch10000 to fix local variable processing security bypass
699  vulnerability.
700  - http://www.frsirt.com/english/advisories/2007/3715
701  - http://bugs.debian.org/449008
702
703* Mon Jun 04 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 22.1-0vl1
704- new upstream release
705- rename to emacs from emacs22 (emacs-21.x would be renameed to emacs21)
706- drop emcws support
707
708* Sun May 20 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 22.0.50-0.20060403vl3
709- rebuilt with new toolchain
710
711* Sat May 06 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 22.0.50-0.20060403vl2
712- changed Group:
713
714* Mon Apr 03 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 22.0.50-0.20060403vl1
715- update to CVS-20060403
716- update emacs22.desktop
717
718* Wed Sep 28 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 22.0.50-0.20050927vl2
719- fix site-start.el
720
721* Tue Sep 27 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 22.0.50-0.20050927vl1
722- update to CVS-20050927
723
724* Thu Sep  8 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 22.0.50-0.20050907vl1
725- initial build for Vine Linux based on emacs package.
726  - emacs-22.0.50 on CVS-20050907
727
728* Sat Sep  3 2005 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 21.4-0vl3
729- create site-start.d directory on %install
730
731* Thu Feb 17 2005 Hiroaki Irokawa <irorin@terra.dti.ne.jp> 21.4-0vl2
732- included leim-21.4
733- update emcws-21.3-20031213.gz
734
735* Wed Feb 16 2005 Hiroaki Irokawa <irorin@terra.dti.ne.jp> 21.4-0vl1
736- update
737
738* Sat Jul 24 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 21.3-0vl7
739- rebuild with Xaw3d, add BuildRequires: Xaw3d-devel
740
741* Fri Jul 23 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 21.3-0vl6
742- add Patch20 to fix display resolutions. (set to 96dpi)
743  (do not compute dynamically from display's size)
744
745* Tue Mar 16 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 21.3-0vl5
746- rebuilt with new toolchain environment
747
748* Thu Jul 17 2003 Hiroaki Irokawa <irorin@terra.dti.ne.jp> 21.3-0vl4
749- use site-start.el(reading /etc/emacs-21.3/site-start.d/*.el)
750
751* Wed May  7 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 21.3-0vl3
752- add BuildPrereq: libpng >= 1.2.5
753
754* Tue Apr 15 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 21.3-0vl2
755- fixed %%pre script
756
757* Tue Mar 25 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 21.3-0vl1
758- new upstream release
759- remove patch14 whick included in upstream
760
761* Thu Jan 16 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 21.2-0vl11
762- add patch14 to fix frame title text encoding.
763  - http://tsukuba.m17n.org/mule-ja-archive/2002-10/msg00004.html
764
765* Tue Dec 10 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 21.2-0vl10
766- autoconf-2.13, not autoconf in %%setup section
767- BuildPreReq: autoconf213
768
769* Mon Dec  9 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 21.2-0vl9
770- modifiy rpm scripts.
771
772* Mon Dec  9 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 21.2-0vl8
773- rename to emacs
774- obsoletes emacs21 <= 21.2-0vl7, provides emacs21 = %%{version}
775
776* Sun Dec  1 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 21.2-0vl7
777- enable menubar fontset patch (Patch103)
778
779* Sat Nov 30 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 21.2-0vl6
780- add requires/buildprereq tags.
781
782* Sat Nov 30 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 21.2-0vl5
783- add emcws-20021014
784
785* Sun Jul 21 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 21.2-0vl4
786- removed *-mode
787
788* Sat Jul 20 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 21.2-0vl3
789- python-mode was made pending
790- some additional *.el files was moved from "emacs/site-lisp" to
791  "emacs-(version)/site-lisp"
792
793* Sat Jul 13 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 21.2-0vl2
794- added some sources and patches from rawhide 21.2-11 and mandrake 21.2-7mdk
795
796* Sat May 11 2002 Hiroaki Irokawa <irorin@terra.dti.ne.jp> 21.2-0vl1
797- update.
798- Package Name emacs-beta -> emacs21
799- Add Patch100,101,102, Source100(default = Disable)
800- (from http://phe.phyas.aichi-edu.ac.jp/~cyamauch/pl2.html#emacs21)
801- --infodir=%{_infodir}/emacs-21.2(VineSeed-Plus:00723)
802
803* Thu Dec 27 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 21.1-0vl7
804- site-lisp moved under /usr/share/emacs-21.1/ (Patch11 and %%pre section)
805
806* Thu Dec 06 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 21.1-0vl5
807- move /tmp -> /var/lib/emacsen-common (IP(package)C file)
808
809* Fri Nov 02 2001 Tomoya TAKA <tomoya@olive.plala.or.jp> 21.1-0vl4
810- replace patch10 with patch11, posted to gnu.emacs.bug
811  Message-Id: <jebsiza3db.fsf@sykes.suse.de>
812  (reported by ABE Yuji <cbo46560@pop12.odn.ne.jp>)
813
814* Fri Oct 26 2001 Kazuhisa TAKEI <takei@vinelinux.org> 21.1-0vl3
815- fixed build to fail in alpha( only apply patch0 to ppc)
816
817* Tue Oct 23 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 21.1-0vl2
818- added Patch10 (thanks Kitame-san)
819
820* Mon Oct 22 2001 Kazuhisa TAKEI <takei@vinelinux.org> 21.1-0vl1
821- update to 21.1
822
823* Sun Sep 9 2001 Kazuhisa TAKEI <takei@vinelinux.org> 21.0.104-0vl14
824- support  shared installing otheremacsen.
825
826* Mon Jul 23 2001 Kazuhisa TAKEI <takei@vinelinux.org> 21.0.104-0vl3
827- update 21.0.104
828
829* Thu Jul 19 2001 Kazuhisa TAKEI <takei@vinelinux.org> 21.0.103-0vl2
830- support emacsen-common
831
832* Wed May 16 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
833- 21.0.103-0vl1
834- updated to 21.0.103
835- revamped and cleaned up spec file :-)
836- Requires: tamago >= 4.0.6 (...is it reasonable? Mmm...)
837
838* Mon Jan 22 2001 Kazuhisa TAKEI <takei@vinelinux.org> 21.0.95-0vl2
839- fixed .spec bugs( _libdir)
840
841* Fri Jan 12 2001 Kazuhisa TAKEI <takei@vinelinux.org> 21.0.95-0vl1
842- updated to 21.0.95
843
844* Wed Dec 20 2000 Kazuhisa TAKEI <takei@vinelinux.org> 21.0.93-0vl3
845- fixed emacs-beta.spec
846
847* Sat Dec 16 2000 Kazuhisa TAKEI <takei@vinelinux.org> 21.0.93-0vl2
848- 21.0.93 test packaging.
849
850* Fri Jun 30 2000 T.R. Kobayashi <tkoba@ike-dyn.ritsumei.ac.jp>
851- added linespace-patch
852
853* Mon Jun 19 2000 MACHINO, Satoshi <mac@netfort.gr.jp>
854- updated to emacs 20.7
855
856* Thu Apr 20 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
857- updated to emacs 20.6
858
859* Mon Feb 28 2000 kenji KITAYAMA <kenji@gandalf.doshisha.ac.jp>
860- [emacs-20.5a-2]
861- Modified reference of Emacs Info
862
863* Sun Jan 23 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
864- [emacs-20.5a-2]
865- added ppc patch
866
867* Fri Jan  7 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
868- [emacs-20.5a-1]
869- change version from 20.5 to 20.5a
870- added Mule-4.1 patch
871
872* Fri Jan  7 2000 Yasuyuki Furukawa <yasu@on.cs.keio.ac.jp>
873- [emacs-20.5-1]
874- add desktop-link files for desktop menu.
875
876* Thu Dec 24 1999 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
877- [emacs-20.4-16]
878- replaced Y2K savvy timezone.{el,elc} with one from brand-new apel-10.0
879
880* Tue Dec 21 1999 Jun Nishii <jun@vinelinux.org>
881- added documents
882- strip bins
883
884* Wed Dec  1 1999 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
885- [emacs-20.4-14]
886- Change Group to Applications/Editors/Emacs
887
888* Sat Nov  6 1999 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
889- [emacs-20.4-13]
890- included Y2K savvy timezone.{el,elc},
891  modified by Mr. Youichi Teranishi <teranishi@gohome.org>
892
893* Tue Oct 12 1999 Yasuhide OOMORI <dasen@typhoon.co.jp>
894- [emacs-20.4-12]
895- Modified info-dir.
896- Removed -c option from %setup.
897
898* Sun Sep 20 1999 Kazuhisa TAKEI<takei@hh.iij4u.or.jp>
899- fixed XIM support patch
900* Sun Sep 19 1999 Kazuhisa TAKEI<takei@hh.iij4u.or.jp>
901- fixed postinst bug and fontset patch
902* Sun Jul 18 1999 Kazuhisa TAKEI<takei@hh.iij4u.or.jp>
903- first build
Note: See TracBrowser for help on using the repository browser.