source: projects/specs/branches/6/e/elfutils/elfutils-vl.spec @ 11345

Revision 11345, 25.5 KB checked in by iwamoto, 6 years ago (diff)

elfutils: update to 0.170 with security fixes.

Line 
1%define eu_version 0.170
2%define eu_release 2
3
4%global nocheck true
5
6Summary: A collection of utilities and DSOs to handle compiled objects
7Summary(ja): コンパイル済みオブジェクトを扱うためのユーティリティ集
8Name: elfutils
9Version: %{eu_version}
10Release: %{eu_release}%{?_dist_release}
11
12License: GPLv3+ and (GPLv2+ or LGPLv3+)
13Group: Development/Tools
14URL: https://sourceware.org/elfutils/
15
16Source: https://sourceware.org/elfutils/ftp/%{version}/%{name}-%{version}.tar.bz2
17
18Requires: elfutils-libelf-%{_arch} = %{version}-%{release}
19Requires: elfutils-libs-%{_arch} = %{version}-%{release}
20
21BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
22BuildRequires: bison >= 1.875
23BuildRequires: flex >= 2.5.4a
24BuildRequires: bzip2
25BuildRequires: bzip2-devel
26BuildRequires: zlib-devel
27BuildRequires: xz-devel
28BuildRequires: gettext
29BuildRequires: m4
30BuildRequires: gcc >= 3.4
31# Need <byteswap.h> that gives unsigned bswap_16 etc.
32BuildRequires: glibc-headers >= 2.3.4-11
33
34Vendor: Project Vine
35Distribution: Vine Linux
36
37%define _gnu %{nil}
38%define _program_prefix eu-
39
40%description
41Elfutils is a collection of utilities, including ld (a linker),
42nm (for listing symbols from object files), size (for listing the
43section sizes of an object or archive file), strip (for discarding
44symbols), readelf (to see the raw ELF file structures), and elflint
45(to check for well-formed ELF files).
46
47
48%package libs
49Summary: Libraries to handle compiled objects
50Summary(ja): コンパイル済オブジェクトを扱うためのライブラリ
51License: GPLv2+ or LGPLv3+
52Group: System Environment/Libraries
53Provides: elfutils-libs-%{_arch} = %{version}-%{release}
54Requires: elfutils-libelf-%{_arch} = %{version}-%{release}
55Conflicts: elfutils < %{version}-%{release}
56Conflicts: elfutils > %{version}-%{release}
57Conflicts: elfutils-devel < %{version}-%{release}
58Conflicts: elfutils-devel > %{version}-%{release}
59
60%description libs
61The elfutils-libs package contains libraries which implement DWARF, ELF,
62and machine-specific ELF handling.  These libraries are used by the programs
63in the elfutils package.  The elfutils-devel package enables building
64other programs using these libraries.
65
66
67%package devel
68Summary: Development libraries to handle compiled objects
69Summary(ja): コンパイル済オブジェクトを扱うための開発用ライブラリ
70License: GPLv2+ or LGPLv3+
71Group: Development/Libraries
72Provides: elfutils-devel-%{_arch} = %{version}-%{release}
73Requires: elfutils-libs-%{_arch} = %{version}-%{release}
74Requires: elfutils-libelf-devel-%{_arch} = %{version}-%{release}
75Conflicts: elfutils-libelf-devel < %{version}-%{release}
76Conflicts: elfutils-libelf-devel > %{version}-%{release}
77
78%description devel
79The elfutils-devel package contains the libraries to create
80applications for handling compiled objects.  libebl provides some
81higher-level ELF access functionality.  libdw provides access to
82the DWARF debugging information.  libasm provides a programmable
83assembler interface.
84
85
86%package devel-static
87Summary: Static archives to handle compiled objects
88Summary(ja): コンパイル済オブジェクトを扱うための静的ライブラリ
89License: GPLv2+ or LGPLv3+
90Group: Development/Libraries
91Provides: elfutils-devel-static-%{_arch} = %{version}-%{release}
92Requires: elfutils-devel-%{_arch} = %{version}-%{release}
93Requires: elfutils-libelf-devel-static-%{_arch} = %{version}-%{release}
94Conflicts: elfutils-libelf-devel < %{version}-%{release}
95Conflicts: elfutils-libelf-devel > %{version}-%{release}
96
97%description devel-static
98The elfutils-devel-static package contains the static archives
99with the code to handle compiled objects.
100
101
102%package libelf
103Summary: Library to read and write ELF files
104Summary(ja): ELF ファイルを読み書きするためのライブラリ
105License: GPLv2+ or LGPLv3+
106Group: System Environment/Libraries
107Provides: libelf = %{version}-%{release}
108Obsoletes: libelf <= 0.8.2-2
109Provides: elfutils-libelf-%{_arch} = %{version}-%{release}
110Conflicts: elfutils < %{version}-%{release}
111Conflicts: elfutils > %{version}-%{release}
112Conflicts: elfutils-libs < %{version}-%{release}
113Conflicts: elfutils-libs > %{version}-%{release}
114Conflicts: elfutils-libelf-devel < %{version}-%{release}
115Conflicts: elfutils-libelf-devel > %{version}-%{release}
116
117%description libelf
118The elfutils-libelf package provides a DSO which allows reading and
119writing ELF files on a high level.  Third party programs depend on
120this package to read internals of ELF files.  The programs of the
121elfutils package use it also to generate new ELF files.
122
123
124%package libelf-devel
125Summary: Development support for libelf
126Summary(ja): libelf の開発用ライブラリ
127License: GPLv2+ or LGPLv3+
128Group: Development/Libraries
129Provides: libelf-devel = %{version}-%{release}
130Obsoletes: libelf-devel <= 0.8.2-2
131Provides: elfutils-libelf-devel-%{_arch} = %{version}-%{release}
132Requires: elfutils-libelf-%{_arch} = %{version}-%{release}
133Conflicts: libelf-devel < %{version}-%{release}
134
135%description libelf-devel
136The elfutils-libelf-devel package contains the libraries to create
137applications for handling compiled objects.  libelf allows you to
138access the internals of the ELF object file format, so you can see the
139different sections of an ELF file.
140
141
142%package libelf-devel-static
143Summary: Static archive of libelf
144Summary(ja): libelf の静的ライブラリ
145License: GPLv2+ or LGPLv3+
146Group: Development/Libraries
147Provides: elfutils-libelf-devel-static-%{_arch} = %{version}-%{release}
148Requires: elfutils-libelf-devel-%{_arch} = %{version}-%{release}
149
150%description libelf-devel-static
151The elfutils-libelf-static package contains the static archive
152for libelf.
153
154%prep
155%setup -q
156
157find . -name \*.sh ! -perm -0100 -print | xargs chmod +x
158
159
160%build
161# Remove -Wall from default flags.  The makefiles enable enough warnings
162# themselves, and they use -Werror.  Appending -Wall defeats the cases where
163# the makefiles disable some specific warnings for specific code.
164# But add -Wformat explicitly for use with -Werror=format-security which
165# doesn't work without -Wformat (enabled by -Wall).
166RPM_OPT_FLAGS="${RPM_OPT_FLAGS/-Wall/}"
167RPM_OPT_FLAGS="${RPM_OPT_FLAGS} -Wformat"
168
169%configure CFLAGS="$RPM_OPT_FLAGS -fexceptions"
170make -s %{?_smp_mflags}
171
172
173%install
174rm -rf ${RPM_BUILD_ROOT}
175make -s install DESTDIR=${RPM_BUILD_ROOT}
176
177chmod +x ${RPM_BUILD_ROOT}%{_prefix}/%{_lib}/lib*.so*
178chmod +x ${RPM_BUILD_ROOT}%{_prefix}/%{_lib}/elfutils/lib*.so*
179
180%find_lang %{name}
181
182# XXX Nuke unpackaged files
183{ cd ${RPM_BUILD_ROOT}
184  rm -f .%{_bindir}/eu-ld
185}
186
187
188
189%check
190make -s %{?_smp_mflags} check || (cat tests/test-suite.log; %{nocheck})
191
192
193%clean
194rm -rf ${RPM_BUILD_ROOT}
195
196%post libs -p /sbin/ldconfig
197
198%postun libs -p /sbin/ldconfig
199
200%post libelf -p /sbin/ldconfig
201
202%postun libelf -p /sbin/ldconfig
203
204%files -f %{name}.lang
205%defattr(-,root,root)
206%doc README TODO
207%{_bindir}/eu-addr2line
208%{_bindir}/eu-ar
209%{_bindir}/eu-elfcmp
210%{_bindir}/eu-elflint
211%{_bindir}/eu-findtextrel
212%{_bindir}/eu-nm
213%{_bindir}/eu-objdump
214%{_bindir}/eu-ranlib
215%{_bindir}/eu-readelf
216%{_bindir}/eu-size
217%{_bindir}/eu-stack
218%{_bindir}/eu-strings
219%{_bindir}/eu-strip
220#%{_bindir}/eu-ld
221%{_bindir}/eu-unstrip
222%{_bindir}/eu-make-debug-archive
223%{_bindir}/eu-elfcompress
224
225%files libs
226%defattr(-,root,root)
227%{_libdir}/libasm-%{version}.so
228%{_libdir}/libasm.so.*
229%{_libdir}/libdw-%{version}.so
230%{_libdir}/libdw.so.*
231%dir %{_libdir}/elfutils
232%{_libdir}/elfutils/lib*.so
233
234
235%files devel
236%defattr(-,root,root)
237%{_includedir}/dwarf.h
238%dir %{_includedir}/elfutils
239%{_includedir}/elfutils/elf-knowledge.h
240%{_includedir}/elfutils/known-dwarf.h
241%{_includedir}/elfutils/libasm.h
242%{_includedir}/elfutils/libebl.h
243%{_includedir}/elfutils/libdw.h
244%{_includedir}/elfutils/libdwelf.h
245%{_includedir}/elfutils/libdwfl.h
246%{_includedir}/elfutils/version.h
247%{_libdir}/libebl.a
248%{_libdir}/libasm.so
249%{_libdir}/libdw.so
250%{_libdir}/pkgconfig/libdw.pc
251
252
253%files devel-static
254%defattr(-,root,root)
255%{_libdir}/libasm.a
256%{_libdir}/libdw.a
257
258
259%files libelf
260%defattr(-,root,root)
261%{_libdir}/libelf-%{version}.so
262%{_libdir}/libelf.so.*
263
264
265%files libelf-devel
266%defattr(-,root,root)
267%{_includedir}/libelf.h
268%{_includedir}/gelf.h
269%{_includedir}/nlist.h
270%{_libdir}/libelf.so
271%{_libdir}/pkgconfig/libelf.pc
272
273
274%files libelf-devel-static
275%defattr(-,root,root)
276%{_libdir}/libelf.a
277
278%changelog
279* Sun Jan  7 2018 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.170-2
280- add Vendor/Distri tags
281
282* Fri Jan  5 2018 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.170-1
283- update to 0.170 (based on VineSeed 0.170-1)
284  fix CVE-2017-7607 - 7613
285
286* Wed Apr 06 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.152-2
287- add BR: zlib-devel, bzip2-devel, xz-devel, m4, gettext
288
289* Tue Apr 05 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.152-1
290- update to 0.152
291
292* Sun Jan 18 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 0.135-2
293- elfutils-libs: changed Group to System Environment/Libraries
294- elfutils-libelf: changed Group to System Environment/Libraries
295- elfutils-devel: changed Group to Development/Libraries
296- elfutils-devel-static: changed Group to Development/Libraries
297- elfutils-libelf-devel: changed Group to Development/Libraries
298- elfutils-libelf-devel-static: changed Group to Development/Libraries
299
300* Mon Sep 29 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.135-1
301- merged with Fedora 9 0.135-1
302
303  - Fri Sep 12 2008 Shu KONNO <owa@bg.wakwak.com> 0.131-1vl5
304  - applied new versioning policy
305  - added elfutils-0.131-readelf_c.patch
306
307  - Thu Nov 29 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.131-0vl1
308  - new upstream release
309  - move libelf/libelf-devel obsoletes tag (<BTS:0568>)
310    - remove Obsoletes: libelf, libelf-devel from elfutils
311    - add Obsoletes: libelf to elfutils-libelf
312    - add Obsoletes: libelf-devel to elfutils-libelf-devel
313
314* Mon May 12 2008 Roland McGrath <roland@redhat.com> - 0.135-1
315- Update to 0.135
316  - libdwfl: bug fixes
317  - eu-strip: changed handling of ET_REL files wrt symbol tables and relocs
318
319* Wed Apr  9 2008 Roland McGrath <roland@redhat.com> - 0.134-1
320- Update to 0.134
321  - elflint: backend improvements for sparc, alpha (#204170)
322  - libdwfl, libelf: bug fixes (#439344, #438867, #438263, #438190)
323- Remove Conflicts: libelf-devel from elfutils-libelf-devel. (#435742)
324
325* Sun Mar  2 2008 Roland McGrath <roland@redhat.com> - 0.133-2
326- Update to 0.133
327  - readelf, elflint, libebl: SHT_GNU_ATTRIBUTE section handling (readelf -A)
328  - readelf: core note handling for NT_386_TLS, NT_PPC_SPE, Alpha NT_AUXV
329  - libdwfl: bug fixes and optimization in relocation handling
330  - elfcmp: bug fix for non-allocated section handling
331  - ld: implement newer features of binutils linker.
332- Install eu-objdump and libasm, now has limited disassembler support.
333
334* Mon Jan 21 2008 Roland McGrath <roland@redhat.com> - 0.132-3
335- Update to 0.132
336  - libelf: Use loff_t instead of off64_t in libelf.h header. (#377241)
337  - eu-readelf: Fix handling of ET_REL files in archives.
338  - libcpu: Implement x86 and x86-64 disassembler.
339  - libasm: Add interface for disassembler.
340  - all programs: add debugging of branch prediction.
341  - libelf: new function elf_scnshndx.
342
343* Sun Nov 11 2007 Roland McGrath <roland@redhat.com> - 0.131-1
344- Update to 0.131
345  - libdw: DW_FORM_ref_addr support; dwarf_formref entry point now deprecated;
346           bug fixes for oddly-formatted DWARF
347  - libdwfl: bug fixes in offline archive support, symbol table handling;
348             apply partial relocations for dwfl_module_address_section on ET_REL
349  - libebl: powerpc backend support for Altivec registers
350
351* Wed Oct 17 2007 Roland McGrath <roland@redhat.com> - 0.130-3
352- Fix ET_REL support.
353- Fix odd indentation in eu-readelf -x output.
354
355* Tue Oct 16 2007 Roland McGrath <roland@redhat.com> - 0.130-1
356- Update to 0.130
357  - eu-readelf -p option can take an argument like -x for one section
358  - eu-readelf --archive-index (or -c)
359  - eu-readelf -n improved output for core dumps
360  - eu-readelf: handle SHT_NOTE sections without requiring phdrs (#249467)
361  - eu-elflint: ditto
362  - eu-elflint: stricter checks on debug sections
363  - eu-unstrip: new options, --list (or -n), --relocate (or -R)
364  - libelf: new function elf_getdata_rawchunk, replaces gelf_rawchunk;
365            new functions gelf_getnote, gelf_getauxv, gelf_update_auxv
366  - libebl: backend improvements (#324031)
367  - libdwfl: build_id support, new functions for it
368  - libdwfl: dwfl_module_addrsym fixes (#268761, #268981)
369  - libdwfl offline archive support, new script eu-make-debug-archive
370
371* Mon Aug 20 2007 Roland McGrath <roland@redhat.com> - 0.129-2
372- Fix false-positive eu-elflint failure on ppc -mbss-plt binaries.
373
374* Tue Aug 14 2007 Roland McGrath <roland@redhat.com> - 0.129-1
375- Update to 0.129
376  - readelf: new options --hex-dump (or -x), --strings (or -p) (#250973)
377  - addr2line: new option --symbols (or -S)
378  - libdw: dwarf_getscopes fixes (#230235)
379  - libdwfl: dwfl_module_addrsym fixes (#249490)
380
381* Fri Jun  8 2007 Roland McGrath <roland@redhat.com> - 0.128-2
382- Update to 0.128
383  - new program: unstrip
384  - elfcmp: new option --hash-inexact
385- Replace Conflicts: with Provides/Requires using -arch
386
387* Wed Apr 18 2007 Roland McGrath <roland@redhat.com> - 0.127-1
388- Update to 0.127
389  - libdw: new function dwarf_getsrcdirs
390  - libdwfl: new functions dwfl_module_addrsym, dwfl_report_begin_add,
391             dwfl_module_address_section
392
393* Mon Feb  5 2007 Roland McGrath <roland@redhat.com> - 0.126-1
394- Update to 0.126
395  - New program eu-ar.
396  - libdw: fix missing dwarf_getelf (#227206)
397  - libdwfl: dwfl_module_addrname for st_size=0 symbols (#227167, #227231)
398- Resolves: RHBZ #227206, RHBZ #227167, RHBZ #227231
399
400* Wed Jan 10 2007 Roland McGrath <roland@redhat.com> - 0.125-3
401- Fix overeager warn_unused_result build failures.
402
403* Wed Jan 10 2007 Roland McGrath <roland@redhat.com> - 0.125-1
404- Update to 0.125
405  - elflint: Compare DT_GNU_HASH tests.
406  - move archives into -static RPMs
407  - libelf, elflint: better support for core file handling
408  - Really fix libdwfl sorting of modules with 64-bit addresses (#220817).
409- Resolves: RHBZ #220817, RHBZ #213792
410
411* Tue Oct 10 2006 Roland McGrath <roland@redhat.com> - 0.124-1
412- eu-strip -f: copy symtab into debuginfo file when relocs use it (#203000)
413- Update to 0.124
414  - libebl: fix ia64 reloc support (#206981)
415  - libebl: sparc backend support for return value location
416  - libebl, libdwfl: backend register name support extended with more info
417  - libelf, libdw: bug fixes for unaligned accesses on machines that care
418  - readelf, elflint: trivial bugs fixed
419
420* Mon Aug 14 2006 Roland McGrath <roland@redhat.com> 0.123-1
421- Update to 0.123
422  - libebl: Backend build fixes, thanks to Stepan Kasal.
423  - libebl: ia64 backend support for register names, return value location
424  - libdwfl: Handle truncated linux kernel module section names.
425  - libdwfl: Look for linux kernel vmlinux files with .debug suffix.
426  - elflint: Fix checks to permit --hash-style=gnu format.
427
428* Mon Jul 17 2006 Roland McGrath <roland@redhat.com> - 0.122-4
429- Fix warnings in elflint compilation.
430
431* Wed Jul 12 2006 Roland McGrath <roland@redhat.com> - 0.122-3
432- Update to 0.122
433  - Fix libdwfl sorting of modules with 64-bit addresses (#198225).
434  - libebl: add function to test for relative relocation
435  - elflint: fix and extend DT_RELCOUNT/DT_RELACOUNT checks
436  - elflint, readelf: add support for DT_GNU_HASH
437  - libelf: add elf_gnu_hash
438  - elflint, readelf: add support for 64-bit SysV-style hash tables
439  - libdwfl: new functions dwfl_module_getsymtab, dwfl_module_getsym.
440
441* Thu Jun 15 2006 Roland McGrath <roland@redhat.com> - 0.121-1
442- Update to 0.121
443  - libelf: bug fixes for rewriting existing files when using mmap (#187618).
444  - make all installed headers usable in C++ code (#193153).
445  - eu-readelf: better output format.
446  - eu-elflint: fix tests of dynamic section content.
447  - libdw, libdwfl: handle files without aranges info.
448
449* Thu May 25 2006 Jeremy Katz <katzj@redhat.com> - 0.120-3
450- rebuild to pick up -devel deps
451
452* Tue Apr  4 2006 Roland McGrath <roland@redhat.com> - 0.120-2
453- Update to 0.120
454  - License changed to GPL, with some exceptions for using
455    the libelf, libebl, libdw, and libdwfl library interfaces.
456    Red Hat elfutils is an included package of the Open Invention Network.
457  - dwarf.h updated for DWARF 3.0 final specification.
458  - libelf: Fix corruption in ELF_C_RDWR uses (#187618).
459  - libdwfl: New function dwfl_version; fixes for offline.
460
461* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 0.119-1.2.1
462- bump again for double-long bug on ppc(64)
463
464* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 0.119-1.2
465- rebuilt for new gcc4.1 snapshot and glibc changes
466
467* Fri Jan 13 2006 Roland McGrath <roland@redhat.com> - 0.119-1
468- update to 0.119
469
470* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
471- rebuilt
472
473* Sun Nov 27 2005 Roland McGrath <roland@redhat.com> - 0.118-1
474- update to 0.118
475  - elflint: more tests.
476  - libdwfl: New function dwfl_module_register_names.
477  - libebl: New backend hook for register names.
478- Make sure -fexceptions is always in CFLAGS.
479
480* Tue Nov 22 2005 Roland McGrath <roland@redhat.com> - 0.117-2
481- update to 0.117
482  - libdwfl: New function dwfl_module_return_value_location (#166118)
483  - libebl: Backend improvements for several CPUs
484
485* Mon Oct 31 2005 Roland McGrath <roland@redhat.com> - 0.116-1
486- update to 0.116
487  - libdw fixes, API changes and additions
488  - libdwfl fixes (#169672)
489  - eu-strip/libelf fix to preserve setuid/setgid permission bits (#167745)
490
491* Fri Sep  9 2005 Roland McGrath <roland@redhat.com> - 0.115-3
492- Update requires/conflicts for better biarch update behavior.
493
494* Mon Sep  5 2005 Roland McGrath <roland@redhat.com> - 0.115-2
495- update to 0.115
496  - New program eu-strings.
497  - libdw: New function dwarf_getscopes_die.
498  - libelf: speed-ups of non-mmap reading.
499  - Implement --enable-gcov option for configure.
500
501* Wed Aug 24 2005 Roland McGrath <roland@redhat.com> - 0.114-1
502- update to 0.114
503  - new program eu-ranlib
504  - libdw: new calls for inlines
505  - libdwfl: new calls for offline modules
506
507* Sat Aug 13 2005 Roland McGrath <roland@redhat.com> - 0.113-2
508- update to 0.113
509  - elflint: relax a bit.  Allow version definitions for defined symbols
510    against DSO versions also for symbols in nobits sections.
511    Allow .rodata section to have STRINGS and MERGE flag set.
512  - strip: add some more compatibility with binutils.
513  - libdwfl: bug fixes.
514- Separate libdw et al into elfutils-libs subpackage.
515
516* Sat Aug  6 2005 Roland McGrath <roland@redhat.com> - 0.112-1
517- update to 0.112
518  - elfcmp: some more relaxation.
519  - elflint: many more tests, especially regarding to symbol versioning.
520  - libelf: Add elfXX_offscn and gelf_offscn.
521  - libasm: asm_begin interface changes.
522  - libebl: Add three new interfaces to directly access machine, class,
523    and data encoding information.
524
525* Fri Jul 29 2005 Roland McGrath <roland@redhat.com> - 0.111-2
526- update portability patch
527
528* Thu Jul 28 2005 Roland McGrath <roland@redhat.com> - 0.111-1
529- update to 0.111
530  - libdwfl library now merged into libdw
531
532* Sun Jul 24 2005 Roland McGrath <roland@redhat.com> - 0.110-1
533- update to 0.110
534
535* Fri Jul 22 2005 Roland McGrath <roland@redhat.com> - 0.109-2
536- update to 0.109
537  - verify that libebl modules are from the same build
538  - new eu-elflint checks on copy relocations
539  - new program eu-elfcmp
540  - new experimental libdwfl library
541
542* Thu Jun  9 2005 Roland McGrath <roland@redhat.com> - 0.108-5
543- robustification of eu-strip and eu-readelf
544
545* Wed May 25 2005 Roland McGrath <roland@redhat.com> - 0.108-3
546- more robustification
547
548* Mon May 16 2005 Roland McGrath <roland@redhat.com> - 0.108-2
549- robustification
550
551* Mon May  9 2005 Roland McGrath <roland@redhat.com> - 0.108-1
552- update to 0.108
553  - merge strip fixes
554  - sort records in dwarf_getsrclines, fix dwarf_getsrc_die searching
555  - update elf.h from glibc
556
557* Sun May  8 2005 Roland McGrath <roland@redhat.com> - 0.107-2
558- fix strip -f byte-swapping bug
559
560* Sun May  8 2005 Roland McGrath <roland@redhat.com> - 0.107-1
561- update to 0.107
562  - readelf: improve DWARF output format
563  - elflint: -d option to support checking separate debuginfo files
564  - strip: fix ET_REL debuginfo files (#156341)
565
566* Mon Apr  4 2005 Roland McGrath <roland@redhat.com> - 0.106-3
567- fix some bugs in new code, reenable make check
568
569* Mon Apr  4 2005 Roland McGrath <roland@redhat.com> - 0.106-2
570- disable make check for most arches, for now
571
572* Mon Apr  4 2005 Roland McGrath <roland@redhat.com> - 0.106-1
573- update to 0.106
574
575* Mon Mar 28 2005 Roland McGrath <roland@redhat.com> - 0.104-2
576- update to 0.104
577
578* Wed Mar 23 2005 Jakub Jelinek <jakub@redhat.com> 0.103-2
579- update to 0.103
580
581* Wed Feb 16 2005 Jakub Jelinek <jakub@redhat.com> 0.101-2
582- update to 0.101.
583- use %%configure macro to get CFLAGS etc. right
584
585* Sat Feb  5 2005 Jeff Johnson <jbj@redhat.com> 0.99-2
586- upgrade to 0.99.
587
588* Sun Sep 26 2004 Jeff Johnson <jbj@redhat.com> 0.97-3
589- upgrade to 0.97.
590
591* Tue Aug 17 2004 Jakub Jelinek <jakub@redhat.com> 0.95-5
592- upgrade to 0.96.
593
594* Mon Jul  5 2004 Jakub Jelinek <jakub@redhat.com> 0.95-4
595- rebuilt with GCC 3.4.x, workaround VLA + alloca mixing
596  warning
597
598* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
599- rebuilt
600
601* Fri Apr  2 2004 Jeff Johnson <jbj@redhat.com> 0.95-2
602- upgrade to 0.95.
603
604* Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
605- rebuilt
606
607* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
608- rebuilt
609
610* Fri Jan 16 2004 Jakub Jelinek <jakub@redhat.com> 0.94-1
611- upgrade to 0.94
612
613* Fri Jan 16 2004 Jakub Jelinek <jakub@redhat.com> 0.93-1
614- upgrade to 0.93
615
616* Thu Jan  8 2004 Jakub Jelinek <jakub@redhat.com> 0.92-1
617- full version
618- macroized spec file for GPL or OSL builds
619- include only libelf under GPL plus wrapper scripts
620
621* Wed Jan  7 2004 Jakub Jelinek <jakub@redhat.com> 0.91-2
622- macroized spec file for GPL or OSL builds
623
624* Wed Jan  7 2004 Ulrich Drepper <drepper@redhat.com>
625- split elfutils-devel into two packages.
626
627* Wed Jan  7 2004 Jakub Jelinek <jakub@redhat.com> 0.91-1
628- include only libelf under GPL plus wrapper scripts
629
630* Tue Dec 23 2003 Jeff Johnson <jbj@redhat.com> 0.89-3
631- readelf, not readline, in %%description (#111214).
632
633* Fri Sep 26 2003 Bill Nottingham <notting@redhat.com> 0.89-1
634- update to 0.89 (fix eu-strip)
635
636* Tue Sep 23 2003 Jakub Jelinek <jakub@redhat.com> 0.86-3
637- update to 0.86 (fix eu-strip on s390x/alpha)
638- libebl is an archive now; remove references to DSO
639
640* Mon Jul 14 2003 Jeff Johnson <jbj@redhat.com> 0.84-3
641- upgrade to 0.84 (readelf/elflint improvements, rawhide bugs fixed).
642
643* Fri Jul 11 2003 Jeff Johnson <jbj@redhat.com> 0.83-3
644- upgrade to 0.83 (fix invalid ELf handle on *.so strip, more).
645
646* Wed Jul  9 2003 Jeff Johnson <jbj@redhat.com> 0.82-3
647- upgrade to 0.82 (strip tests fixed on big-endian).
648
649* Tue Jul  8 2003 Jeff Johnson <jbj@redhat.com> 0.81-3
650- upgrade to 0.81 (strip excludes unused symtable entries, test borked).
651
652* Thu Jun 26 2003 Jeff Johnson <jbj@redhat.com> 0.80-3
653- upgrade to 0.80 (debugedit changes for kernel in progress).
654
655* Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
656- rebuilt
657
658* Wed May 21 2003 Jeff Johnson <jbj@redhat.com> 0.79-2
659- upgrade to 0.79 (correct formats for size_t, more of libdw "works").
660
661* Mon May 19 2003 Jeff Johnson <jbj@redhat.com> 0.78-2
662- upgrade to 0.78 (libdwarf bugfix, libdw additions).
663
664* Mon Feb 24 2003 Elliot Lee <sopwith@redhat.com>
665- debuginfo rebuild
666
667* Thu Feb 20 2003 Jeff Johnson <jbj@redhat.com> 0.76-2
668- use the correct way of identifying the section via the sh_info link.
669
670* Sat Feb 15 2003 Jakub Jelinek <jakub@redhat.com> 0.75-2
671- update to 0.75 (eu-strip -g fix)
672
673* Tue Feb 11 2003 Jakub Jelinek <jakub@redhat.com> 0.74-2
674- update to 0.74 (fix for writing with some non-dirty sections)
675
676* Thu Feb  6 2003 Jeff Johnson <jbj@redhat.com> 0.73-3
677- another -0.73 update (with sparc fixes).
678- do "make check" in %%check, not %%install, section.
679
680* Mon Jan 27 2003 Jeff Johnson <jbj@redhat.com> 0.73-2
681- update to 0.73 (with s390 fixes).
682
683* Wed Jan 22 2003 Tim Powers <timp@redhat.com>
684- rebuilt
685
686* Wed Jan 22 2003 Jakub Jelinek <jakub@redhat.com> 0.72-4
687- fix arguments to gelf_getsymshndx and elf_getshstrndx
688- fix other warnings
689- reenable checks on s390x
690
691* Sat Jan 11 2003 Karsten Hopp <karsten@redhat.de> 0.72-3
692- temporarily disable checks on s390x, until someone has
693  time to look at it
694
695* Thu Dec 12 2002 Jakub Jelinek <jakub@redhat.com> 0.72-2
696- update to 0.72
697
698* Wed Dec 11 2002 Jakub Jelinek <jakub@redhat.com> 0.71-2
699- update to 0.71
700
701* Wed Dec 11 2002 Jeff Johnson <jbj@redhat.com> 0.69-4
702- update to 0.69.
703- add "make check" and segfault avoidance patch.
704- elfutils-libelf needs to run ldconfig.
705
706* Tue Dec 10 2002 Jeff Johnson <jbj@redhat.com> 0.68-2
707- update to 0.68.
708
709* Fri Dec  6 2002 Jeff Johnson <jbj@redhat.com> 0.67-2
710- update to 0.67.
711
712* Tue Dec  3 2002 Jeff Johnson <jbj@redhat.com> 0.65-2
713- update to 0.65.
714
715* Mon Dec  2 2002 Jeff Johnson <jbj@redhat.com> 0.64-2
716- update to 0.64.
717
718* Sun Dec 1 2002 Ulrich Drepper <drepper@redhat.com> 0.64
719- split packages further into elfutils-libelf
720
721* Sat Nov 30 2002 Jeff Johnson <jbj@redhat.com> 0.63-2
722- update to 0.63.
723
724* Fri Nov 29 2002 Ulrich Drepper <drepper@redhat.com> 0.62
725- Adjust for dropping libtool
726
727* Sun Nov 24 2002 Jeff Johnson <jbj@redhat.com> 0.59-2
728- update to 0.59
729
730* Thu Nov 14 2002 Jeff Johnson <jbj@redhat.com> 0.56-2
731- update to 0.56
732
733* Thu Nov  7 2002 Jeff Johnson <jbj@redhat.com> 0.54-2
734- update to 0.54
735
736* Sun Oct 27 2002 Jeff Johnson <jbj@redhat.com> 0.53-2
737- update to 0.53
738- drop x86_64 hack, ICE fixed in gcc-3.2-11.
739
740* Sat Oct 26 2002 Jeff Johnson <jbj@redhat.com> 0.52-3
741- get beehive to punch a rhpkg generated package.
742
743* Wed Oct 23 2002 Jeff Johnson <jbj@redhat.com> 0.52-2
744- build in 8.0.1.
745- x86_64: avoid gcc-3.2 ICE on x86_64 for now.
746
747* Tue Oct 22 2002 Ulrich Drepper <drepper@redhat.com> 0.52
748- Add libelf-devel to conflicts for elfutils-devel
749
750* Mon Oct 21 2002 Ulrich Drepper <drepper@redhat.com> 0.50
751- Split into runtime and devel package
752
753* Fri Oct 18 2002 Ulrich Drepper <drepper@redhat.com> 0.49
754- integrate into official sources
755
756* Wed Oct 16 2002 Jeff Johnson <jbj@redhat.com> 0.46-1
757- Swaddle.
Note: See TracBrowser for help on using the repository browser.