source: projects/specs/branches/6/e/elfio/elfio-vl.spec @ 521

Revision 521, 1.2 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define name elfio
2%define oname ELFIO
3%define version 1.0.3
4%define release 1%{?_dist_release}
5
6Summary: ELF (Executable and Linkable Format) reader and producer implemented as a C++ library
7Name: %{name}
8Version: %{version}
9Release: %{release}
10Source0: http://downloads.sourceforge.net/%{name}/%{oname}-%{version}.tar.bz2
11License: LGPL
12Group: System Environment/Libraries
13Url: http://elfio.sourceforge.net/
14BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
15
16%description
17ELFIO is a C++ library for reading and generating files in the ELF
18binary format. This library is unique and not based on any other
19product. It is also platform independent. The library uses standard
20ANSI C++ constructions and runs on a wide variety of architectures.
21
22%prep
23%setup -q -n %{oname}-%{version}
24
25%build
26%configure
27%__make
28
29%install
30rm -rf %{buildroot}
31%makeinstall
32
33# compat name
34ln -sf libELFIO.a %{buildroot}%{_libdir}/libelfio.a
35
36%clean
37rm -rf %{buildroot}
38
39%files
40%defattr(-,root,root)
41%doc README AUTHORS doc/tutorial.pdf
42%{_bindir}/ELFDump
43%{_includedir}/ELF*.h
44%{_libdir}/*.a
45
46
47%changelog
48* Mon Sep 22 2008 Shu KONNO <owa@bg.wakwak.com> 1.0.3-1vl5
49- applied new versioning policy
50
51* Sat Jun 09 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.3-0vl1
52- initial build for Vine Linux
53
Note: See TracBrowser for help on using the repository browser.