source: projects/specs/branches/6/e/ed/ed-vl.spec @ 3494

Revision 3494, 5.2 KB checked in by inagaki, 13 years ago (diff)

update: ed, sed

Line 
1Summary: The GNU line editor.
2Summary(ja): GNU ラインエディタ
3Name: ed
4Version: 1.5
5Release: 1%{?_dist_release}
6
7License: GPLv3+
8Group: Applications/Text
9URL: http://www.gnu.org/software/ed/
10
11Source: ftp://ftp.gnu.org/gnu/%{name}/%{name}-%{version}.tar.gz
12
13BuildRoot: %{_tmppath}/%{name}-%{version}-root
14Requires(post): /sbin/install-info
15Requires(preun): /sbin/install-info
16
17%description
18Ed is a line-oriented text editor, used to create, display, and modify
19text files (both interactively and via shell scripts).  For most
20purposes, ed has been replaced in normal usage by full-screen editors
21(emacs and vi, for example).
22
23Ed was the original UNIX editor, and may be used by some programs.  In
24general, however, you probably don't need to install it and you probably
25won't use it.
26
27%description -l ja
28ed はラインベースのテキストエディタです.テキストファイルを作成/表示/修正
29するのに使われます (インタラクティブにも,シェルスクリプト経由でも使えます).
30多くのケースで,ed の代わりにフルスクリーンエディタ (emacs や vi 等) が
31使われる様になってきています.
32
33ed は UNIX オリジナルのエディタで,一部のプログラムが ed を使用している
34かもしれません.しかし一般的には ed をインストールする必要はありませんし,
35使うこともないでしょう.
36
37
38%prep
39%setup -q
40rm -f stamp-h.in
41
42%build
43%configure --exec-prefix=/
44make %{?_smp_mflags} CFLAGS="$RPM_OPT_FLAGS"
45
46%install
47rm -rf $RPM_BUILD_ROOT
48mkdir -p $RPM_BUILD_ROOT%{_mandir}/man1
49make install DESTDIR=$RPM_BUILD_ROOT bindir=/bin \
50        mandir=%{_mandir}/man1
51
52rm -f $RPM_BUILD_ROOT%{_infodir}/dir*
53gzip -9qnf  $RPM_BUILD_ROOT%{_infodir}/*
54install -p -m0644 doc/ed.1 $RPM_BUILD_ROOT%{_mandir}/man1
55
56%post
57/sbin/install-info %{_infodir}/ed.info.gz %{_infodir}/dir \
58    --entry="* ed: (ed).                  The GNU Line Editor." || :
59
60%preun
61if [ $1 = 0 ] ; then
62  /sbin/install-info --delete %{_infodir}/ed.info.gz %{_infodir}/dir \
63    --entry="* ed: (ed).                  The GNU Line Editor." || :
64fi
65
66%clean
67rm -rf $RPM_BUILD_ROOT
68
69%files
70%defattr(-,root,root)
71%doc ChangeLog NEWS README TODO AUTHORS COPYING
72/bin/*
73%{_infodir}/ed.info.gz
74%{_mandir}/*/*
75
76
77%changelog
78* Sat Apr 16 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.5-1
79- new upstream release
80
81* Mon Nov 30 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4-1
82- new upstream release
83
84* Sat Nov  8 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.1-1
85- new upstream release
86
87* Sat Aug 23 2008 Shu KONNO <owa@bg.wakwak.com> 1.0-1
88- new upstream release
89- spec in utf-8
90
91* Sat Apr 19 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9-1
92- new upstream release
93
94* Sat Oct 20 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.8-0vl1
95- new upstream release
96- updated URL, License
97
98* Fri Sep 22 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.2-35vl2
99- rebuild to add gpg sign
100
101* Sat Apr 10 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 0.2-35vl1
102- rename spec file to ed-vl.spec
103- added patch2
104  * Tue Dec 17 2002 Karsten Hopp <karsten@redhat.de>ト<8D>
105  - remove regex, use glibc's regex (#79132)
106
107* Wed Dec 04 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.2-28vl1
108- based on 0.2-28 from rawhide and built for Vine Linux
109- BuildPreReq: autoconf253, automake15
110- added Japanese summary and description
111
112* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
113- automated rebuild
114
115* Thu May 23 2002 Tim Powers <timp@redhat.com>
116- automated rebuild
117
118* Mon May  6 2002 Bernhard Rosenkraenzer <bero@redhat.com> 0.2-26
119- Fix build with current toolchain
120
121* Wed Apr 03 2002 Karsten Hopp <karsten@redhat.de>
122- don't use gcc -s
123
124* Fri Feb 22 2002 Karsten Hopp <karsten@redhat.de>
125- bump version
126
127* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
128- automated rebuild
129
130* Mon Oct 15 2001 Karsten Hopp <karsten@redhat.de>
131- add home page (#54602)
132
133* Sat Jul 07 2001 Karsten Hopp <karsten@redhat.de>
134- Copyright -> License
135- fix URL
136
137* Sun Jun 24 2001 Elliot Lee <sopwith@redhat.com>
138- Bump release + rebuild.
139
140* Mon Dec 04 2000 Karsten Hopp <karsten@redhat.de>
141- back out fixes for compiler warnings
142
143* Wed Nov 29 2000 Karsten Hopp <karsten@redhat.de>
144- Security bugfix (mkstemp instead of mktemp) Bugzilla #21470
145
146* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
147- automatic rebuild
148
149* Sun Jun 18 2000 Than Ngo <than@redhat.de>
150- fix typo
151
152* Sat Jun 17 2000 Than Ngo <than@redhat.de>
153- add %%defattr
154- clean up specfile
155
156* Sat May 20 2000 Ngo Than <than@redhat.de>
157- rebuild for 7.0
158- put man pages and infos in right place
159
160* Thu Feb 03 2000 Preston Brown <pbrown@redhat.com>
161- rebuild to gzip man pages.
162
163* Tue Mar 23 1999 Jeff Johnson <jbj@redhat.com>
164- fix %post syntax error (#1689).
165
166* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
167- auto rebuild in the new build environment (release 11)
168
169* Wed Feb 24 1999 Preston Brown <pbrown@redhat.com>
170- Injected new description and group.
171
172* Fri Dec 18 1998 Preston Brown <pbrown@redhat.com>
173- bumped spec number for initial rh 6.0 build
174
175* Mon Apr 27 1998 Prospector System <bugs@redhat.com>
176- translations modified for de, fr, tr
177
178* Fri Oct 17 1997 Donnie Barnes <djb@redhat.com>
179- added install-info support
180- added BuildRoot
181- correct URL in Source line
182
183* Mon Jun 02 1997 Erik Troan <ewt@redhat.com>
184- built against glibc
Note: See TracBrowser for help on using the repository browser.